Руководство JScript

Русская версия.

Следующий перевод не является официальным изданием руководства по языку JScript.

Пользователь применяет полученную информацию на свой страх и риск. Переводчик не несет никакой ответственности за применение языка JScript согласно данному переводу.

Официальная версия находится по адресу http://msdn.microsoft.com/ на английском языке.

© 1998 Microsoft Corporation. Все права защищены.
Перевод © 2000-2004 pauk R-T-F-M.info. Все права защищены.


Справочник языка Microsoft® JScript

Microsoft® JScript™
Справочник языка JScript 		Описание JScript
Информация о версиях

Особая
Информация
Алфавитный список
ключевых слов
Функции
Методы
Объекты
Операторы
Свойства
Инструкции
© 1998 Microsoft Corporation. Все права защищены.


Информация об особенностях

Информация об особенностях 		Справочник языка
Информация о версиях

Преобразование типов данных
Сообщения об ошибках JScript
JScript ECMA-особенности
JScript Non-ECMA-особенности
Microsoft-особенности выполнения сценариев


Алфавитный список

Алфавитный список 		Справочник языка
Информация о версиях

$1...$9 Свойство
abs Метод
acos Метод
ActiveXObject Объект
Add Метод (Dictionary)
Add Метод (Folders)
Addition Оператор (+)
anchor Метод
arguments Свойство
Array Объект
asin Метод
Assignment Оператор (=)
atan Метод
atan2 Метод
atEnd Метод
AtEndOfLine Свойство
AtEndOfStream Свойство
Attributes Свойство
AvailableSpace Свойство
big Метод
Bitwise AND Оператор (&)
Bitwise Left Shift Оператор (<<)
Bitwise NOT Оператор (~)
Bitwise OR Оператор (|)
Bitwise Right Shift Оператор (>>)
Bitwise XOR Оператор (^)
blink Метод
bold Метод
Boolean Объект
break Инструкция
BuildPath Метод
caller Свойство
@cc_on Инструкция
ceil Метод
charAt Метод
charCodeAt Метод
Close Метод
Column Свойство
Comma Оператор (,)
// (Single-line Comment Инструкция)
/*..*/ (Multiline Comment Инструкция)
CompareMode Свойство
Comparison Операторы
compile Метод
Составные Операторы
concat Метод (Array)
concat Метод (String)
Conditional Compilation
Conditional Compilation Variables
Conditional (trinary) Оператор (?:)
constructor Свойство
continue Инструкция
Copy Метод
CopyFile Метод
CopyFolder Метод
cos Метод
Count Свойство
CreateFolder Метод
CreateTextFile Метод
Data Type Conversion
Date Объект
DateCreated Свойство
DateLastAccessed Свойство
DateLastModified Свойство
Decrement Оператор (--)
Delete Метод
delete Оператор
DeleteFile Метод
DeleteFolder Метод
Dictionary Объект
dimensions Метод
Division Оператор (/)
do...while Инструкция
Drive Объект
Drive Свойство
DriveExists Метод
DriveLetter Свойство
Drives Collection
Drives Свойство
DriveType Свойство
E Свойство
Enumerator Объект
Equality Оператор (==)
escape Метод
eval Метод
exec Метод
Exists Метод
exp Метод
File Объект
FileExists Метод
Files Collection
Files Свойство
FileSystem Свойство
FileSystemObject Объект
fixed Метод
floor Метод
Folder Объект
FolderExists Метод
Folders Collection
fontcolor Метод
fontsize Метод
for Инструкция
for...in Инструкция
FreeSpace Свойство
fromCharCode Метод
Function Объект
function Инструкция
GetAbsolutePathName Метод
GetBaseName Метод
getDate Метод
getDay Метод
GetDrive Метод
GetDriveName Метод
GetExtensionName Метод
GetFile Метод
GetFileName Метод
GetFolder Метод
getFullYear Метод
getHours Метод
getItem Метод
getMilliseconds Метод
getMinutes Метод
getMonth Метод
GetObject Function
GetParentFolderName Метод
getSeconds Метод
GetSpecialFolder Метод
GetTempName Метод
getTime Метод
getTimezoneOffset Метод
getUTCDate Метод
getUTCDay Метод
getUTCFullYear Метод
getUTCHours Метод
getUTCMilliseconds Метод
getUTCMinutes Метод
getUTCMonth Метод
getUTCSeconds Метод
getVarDate Метод
getYear Метод
Global Объект
global Свойство
Greater than Оператор (>)
Greater than or equal to Оператор (>=)
Identity Оператор (===)
@if Инструкция
if...else Инструкция
ignoreCase Свойство
Increment Оператор (++)
index Свойство
indexOf Метод
Inequality Оператор (!=)
Infinity Свойство
input Свойство
isFinite Метод
isNaN Метод
IsReady Свойство
IsRootFolder Свойство
italics Метод
item Метод
Item Свойство
Items Метод
join Метод
Key Свойство
Keys Метод
Labeled Инструкция
lastIndex Свойство (RegExp)
lastIndex Свойство (Regular Expression)
lastIndexOf Метод
lastMatch Свойство
lastParen Свойство
lbound Метод
leftContext Свойство
length Свойство (Array)
length Свойство (Function)
length Свойство (String)
Less than Оператор (<)
Less than or equal to Оператор (<=)
Line Свойство
link Метод
LN2 Свойство
LN10 Свойство
log Метод
LOG2E Свойство
LOG10E Свойство
Logical AND Оператор (&&)
Logical NOT Оператор (!)
Logical OR Оператор (||)
match Метод
Math Объект
max Метод
MAX_VALUE Свойство
min Метод
MIN_VALUE Свойство
Modulus Оператор (%)
Move Метод
MoveFile Метод
moveFirst Метод
MoveFolder Метод
moveNext Метод
multiline Свойство
Multiplication Оператор (*)
Name Свойство
NaN Свойство (Global)
NaN Свойство (Number)
NEGATIVE_INFINITY Свойство
new Оператор
Nonidentity Оператор (!==)
Number Объект
Object Объект
OpenAsTextStream Метод
OpenTextFile Метод
Оператор Precedence
ParentFolder Свойство
parse Метод
parseFloat Метод
parseInt Метод
Path Свойство
PI Свойство
POSITIVE_INFINITY Свойство
pow Метод
prototype Свойство
random Метод
Read Метод
ReadAll Метод
ReadLine Метод
RegExp Объект
Regular Expression Объект
Regular Expression Syntax
Remove Метод
RemoveAll Метод
replace Метод
return Инструкция
reverse Метод
rightContext Свойство
RootFolder Свойство
round Метод
ScriptEngine Функция
ScriptEngineBuildVersion Функция
ScriptEngineMajorVersion Функция
ScriptEngineMinorVersion Функция
search Метод
SerialNumber Свойство
@set Инструкция
setDate Метод
setFullYear Метод
setHours Метод
setMilliseconds Метод
setMinutes Метод
setMonth Метод
setSeconds Метод
setTime Метод
setUTCDate Метод
setUTCFullYear Метод
setUTCHours Метод
setUTCMilliseconds Метод
setUTCMinutes Метод
setUTCMonth Метод
setUTCSeconds Метод
setYear Метод
ShareName Свойство
ShortName Свойство
ShortPath Свойство
sin Метод
Size Свойство
Skip Метод
SkipLine Метод
slice Метод (Array)
slice Метод (String)
small Метод
sort Метод
source Свойство
Split Метод
sqrt Метод
SQRT1_2 Свойство
SQRT2 Свойство
strike Метод
String Объект
sub Метод
SubFolders Свойство
substr Метод
substring Метод
Subtraction Оператор (-)
sup Метод
switch Инструкция
tan Метод
test Метод
TextStream Объект
this Инструкция
toArray Метод
toGMTString Метод
toLocaleString Метод
toLowerCase Метод
toString Метод
TotalSize Свойство
toUpperCase Метод
toUTCString Метод
typeof Оператор
Type Свойство
ubound Метод
Unary Negation Оператор (-)
unescape Метод
Unsigned Right Shift Оператор (>>>)
UTC Метод
valueOf Метод
var Инструкция
VBArray Объект
void Оператор
VolumeName Свойство
while Инструкция
with Инструкция
Write Метод
WriteBlankLines Метод
WriteLine Метод


JScript Errors

Microsoft® JScript®
JScript Errors 		JScript Language Reference
Version Information

Run-Time Errors
Syntax Errors


Функции

Функции 		Справочник языка
Информация о версиях

GetObject
ScriptEngine
ScriptEngineBuildVersion
ScriptEngineMajorVersion
ScriptEngineMinorVersion


Методы

Методы 		Справочник языка
Информация о версиях

abs
acos
Add (Dictionary)
Add (Folders)
anchor
asin
atan
atan2
AtEnd
big
blink
bold
BuildPath
ceil
charAt
charCodeAt
Close
compile
concat (Array)
concat (String)
Copy
CopyFile
CopyFolder
cos
CreateFolder
CreateTextFile
Delete
DeleteFile
DeleteFolder
dimensions
DriveExists
escape
eval
exec
Exists
exp
FileExists
fixed
floor
FolderExists
fontcolor
fontsize
fromCharCode
GetAbsolutePathName
GetBaseName
getDate
getDay
GetDrive
GetDriveName
GetExtensionName
GetFile
GetFileName
GetFolder
getFullYear
getHours
getItem
getMilliseconds
getMinutes
getMonth
GetParentFolderName
getSeconds
GetSpecialFolder
GetTempName
getTime
getTimezoneOffset
getUTCDate
getUTCDay
getUTCFullYear
getUTCHours
getUTCMilliseconds
getUTCMinutes
getUTCMonth
getUTCSeconds
getVarDate
getYear
indexOf
isFinite
isNaN
italics
item
Items
join
Keys
lastIndexOf
lbound
link
log
match
max
min
Move
MoveFile
moveFirst
MoveFolder
moveNext
OpenAsTextStream
OpenTextFile
parse
parseFloat
parseInt
pow
random
Read
ReadAll
ReadLine
Remove
RemoveAll
replace
reverse
round
search
setDate
setFullYear
setHours
setMilliseconds
setMinutes
setMonth
setSeconds
setTime
setUTCDate
setUTCFullYear
setUTCHours
setUTCMilliseconds
setUTCMinutes
setUTCMonth
setUTCSeconds
setYear
sin
Skip
SkipLine
slice (Array)
slice (String)
small
sort
split
sqrt
strike
sub
substr
substring
sup
tan
test
toArray
toGMTString
toLocaleString
toLowerCase
toString
toUpperCase
toUTCString
ubound
unescape
UTC
valueOf
Write
WriteBlankLines
WriteLine


Объекты

Объекты 		Справочник языка
Информация о версиях

ActiveXObject
Array
Boolean
Date
Dictionary
Drive
Drives
Enumerator
File
Files Collection
FileSystemObject
Folder
Folders Collection
Global
Function
Math
Number
Object
RegExp
Regular Expression
String
TextStream
VBArray


Операторы

Операторы 		Справочник языка
Информация о версиях

Addition (+)
Assignment (=)
Bitwise AND (&)
Bitwise Left Shift (<<)
Bitwise NOT (~)
Bitwise OR (|)
Bitwise Right Shift (>>)
Bitwise XOR (^)
Comma (,)
Comparison s
Compound Assignment s
Conditional (trinary) (?:)
delete
Decrement (--)
Division (/)
Equality (==)
Greater than (>)
Greater than or equal to (>=)
Identity (===)
Increment (++)
Inequality (!=)
Less than (<)
Less than or equal to (<=)
Logical AND (&&)
Logical NOT (!)
Logical OR (||)
Modulus (%)
Multiplication (*)
new
Nonidentity (!==)
Subtraction (-)
typeof
Unary Negation (-)
Unsigned Right Shift (>>>)
void


Свойства

Свойства 		Справочник языка
Информация о версиях

$1...$9
arguments
AtEndOfLine
AtEndOfStream
Attributes
AvailableSpace
caller
Column
CompareMode
Conditional Compilation Variables
constructor
Count
DateCreated
DateLastAccessed
DateLastModified
Drive
DriveLetter
Drives
DriveType
E
Files
FileSystem
FreeSpace
global
ignoreCase
index
Infinity
input
IsReady
IsRootFolder
Item
Key
lastIndex (RegExp)
lastIndex (Regular Expression)
lastMatch
lastParen
leftContext
length (Array)
length (Function)
length (String)
Line
LN2
LN10
LOG2E
LOG10E
MAX_VALUE
MIN_VALUE
multiline
Name
NaN (Global)
NaN (Number)
NEGATIVE_INFINITY
Path
PI
POSITIVE_INFINITY
prototype
rightContext
RootFolder
SerialNumber
ShareName
ShortName
ShortPath
Size
source
SQRT1_2
SQRT2
SubFolders
TotalSize
Type
VolumeName


Инструкция

Инструкции 		Справочник языка
Информация о версиях

break
@cc_on
Comment
continue
do...while
for
for...in
function
@if
if...else
Labeled
return
@set
switch
this
var
with
while


Описание JScript

Описание JScript
 Справочник языка

Что такое JScript?
Основы JScript
Написание кода на JScript
Переменные JScript
Типы данных JScript
Операторы JScript
Управление ходом программы
Функции JScript
Объекты JScript
Зарезервированные слова JScript
Расширения JScript
Рекурсия
Область видимости переменных
Копирование, прием и сравнение данных
Использование массивов
Расширения создания объектов
Специальные символы
Разрешение проблем в сценариях
Применение JScript в Internet Explorer


Что такое JScript?

Что такое JScript?
 Описание JScript
След.

JScript - реализация спецификации Microsoft ECMA 262 language. Это - полная реализация, плюс некоторые расширения, которые являются преимуществом использования Microsoft Internet Explorer. Эта обучающая программа предназначена, чтобы помочь Вам обучится языку JScript.
Легкий в использовании, легкий в изучении
JScript - интепретируемый, объектно-ориентируемый язык. Хотя JScript имеет меньшее количество возможностей, чем объектно-ориентированные языки C++ и Java, это - достаточно мощный инструмент для предназначенных целей.

JScript - не сокращенная версия другого языка (только отдаленно схож с Java). Однако, возможности языка ограничены. К примеру, нельзя разрабатывать самостоятельные приложения на нем, это несколько ограничивает его применение. Кроме того, сценарии на JScript могут выполняться только при помощи интерпретатора, каковым является Web-браузер.

JScript- язык без строгого контроля типов. Это означает, что Вы не обязаны объявлять типы данных переменных явно. Кроме того, в многих случаях JScript исполняет преобразования автоматически, когда они необходимы. Например, при сложении строки и числа, число будет преобразовано в строку.

Данное описание приводит общие свойства языка. Для получения подробностей следует обратиться к справочнику языка.

Предупреждение Код во многих примерах данного описания языка более прост и менее объемен чем код, который вы найдете в настоящих страницах сети. Объяснить это довольно просто. Цель описания состоит в том, чтобы разъяснить основные концепции, а не выражать оптимальную осмысленность кодирования и стиль.


Написание кода на JScript

Написание кода на JScript
Описание JScript
Пред.
След.

Подобно многим другим языкам программирования, код на Microsoft JScript пишется в текстовом формате, и организован в инструкции, блоки, состоящие из связанных наборов инструкций, и комментариев. В пределах инструкции Вы можете использовать переменные и данные, такие как строки, числа и выражения.
Инструкции
Код JScript инструкции состоит из одного или более символов в строке. Новая строка начинает новую инструкцию, но хорошим стилем является объявление конца инструкции явно. В JScript для этого используется точка с запятой (;).

aBird = "Robin";
var today = new Date();
Группа JScript-инструкций, заключенная в фигурные скобки ({}), называется блоком. Блоки инструкций используются как функции и условные выражения. В следующем примере, первая инструкция определяет функцию, которая состоит из блока пяти инструкций. Последние три инструкции, которые не окружены фигурными скобками - блоком не являются.
function convert(inches)  {
    feet = inches / 12;  //  Эти пять инструкций - блок.
    miles = feet / 5280;
    nauticalMiles = feet / 6080;
    cm = inches * 2.54;
    meters = inches / 39.37;
}
km = meters / 1000;  //  Эти инструкции блоком не являются.
kradius = km;
mradius = miles;
Комментарии
Комментарием в JScript является текст, расположенный после двойного слэша (//) до конца строки. Многострочный комментарий начинается слэшем со знаком умножения (/*), и кончается их обратной комбинацией (*/).
aGoodIdea = "Comment your code thoroughly.";  //  Однострочный комментарий.

/*
Это многострочный комментарий.

Инструкция объявляет значение переменной aGoodIdea.
Значение, которое содержится между кавычками, называется константой. Константа явно и непосредственно содержит информацию.
Кавычки - не являются частью константы.
*/

//  Это еще один вариант многострочного комментария
//  Каждая строка начинается с двойного слэша
//  В некоторых случаях такой комментарий очень удобен

var extendedIdea = aGoodIdea + " You never know when you'll have to figure out what it does.";
Присваивание и равенство
Знак равенства (=) используется в JScript как присваивание. Следующий код

anInteger = 3;
подразумевает "Присвоить значение 3 переменной anInteger," или "anInteger принимает значение 3." При сравнении двух значений на равенство применяется двойной знак равенства (==). Подробнее - в разделе Управление ходом программы.
Выражения
JScript выражения можно разделить на Логические или Числовые. Выражения содержат некоторые особенности, к примеру, символ "+" означает " добавить к...". Любая допустимая комбинация значений, переменных, операторов, и других выражений является выражением.
var anExpression = "3 * (4 / 5)";
var aSecondExpression = "Math.PI * radius * 2";
var aThirdExpression = aSecondExpression + "%" + anExpression;
var aFourthExpression = "(" + aSecondExpression + ") % (" + anExpression + ")";


Переменные JScript

Переменные в JScript
Описание JScript
Пред.
След.

Переменные используются в Microsoft JScript для присваивания значений в сценариях. Для различия переменных, им присваивают имена.
Объявление переменных
Необязательно, но считается хорошим стилем программирования, объявление переменной перед использованием. Это делается с помощью иструкции var. Вы обязаны применять инструкцию var при объявлении локальной ( local )переменной внутри функции. В остальных случаях объявление инструкции var перед применением в сценариях рекомендуется.

Примеры объявления переменных:

var mim = "A man, a plan, a canal, Panama!";  // Строковый тип
var ror = 3;        // Целый числовой тип.
var nen = true;        // Boolean или логический тип.
var fif = 2.718281828        // Числовой тип.
Имя переменной
JScript различает регистр в имени переменной: myCounter отличается от MYCounter. На практике присваивания имен требуется соблюдать следующие правила:
  • Первым символом может быть буква любого регистра, или символ подчеркивания (_), или знак доллара ($).
  • Следующими символами могут быть буквы, символы подчеркивания, цифры и знаки доллара.
  • Именами переменных не могут служить reserved word - зарезервируемые слова.
Несколько примеров правильных имен:
  • _pagecount
  • Part9
  • Number_Items
Некоторые неправильные имена:
  • 99Balloons // Первый символ - цифра.
  • Smith&Wesson // Амперсанд(&) не разрешено применять в именах.
Если необходимо объявить и инициализировать переменную, но без присваивания определенного значения, можно применить значение null.
var zaz = null;
var notalot = 3 * zaz;        // В данном случае notalot равен 0.
Если переменная объявлена, а значение не присвоено, она существует, но значение не определено - undefined.
var godot;
var waitingFor = 1 * godot;  // waitingFor имеет значение NaN, так как значение переменной godot не определено.
Разрешается объявление переменной неявно - без инструкции var. Однако, в выражениях применять необъявленные переменные не допускается.
lel = "";  // Переменная lel объявлена неявно.

var aMess = vyv + zez;  // Ошибка, так как vyv and zez не существуют.
Преобразование типов
Так как JScript - язык с нестрогим контролем типов, переменные в JScript не имеют строго фиксированного типа. Переменные имеют тип, эквивалентный типу значения, которое они содержат. Однако, в некоторых случаях, необходимо принудительное преобразование переменной в определенный тип. Числа могут быть объявлены как строки, а строки необходимо преобразовать в числовой тип. Для этого применяют конверсионные функции parseInt() и parseFloat().
var theFrom = 1;
var theTo = 10;
var doWhat = "Count from ";
doWhat += theFrom + " to " + theTo + ".";
После выполнения кода, переменная doWhat принимает значение "Count from 1 to 10." Числовой тип преобразовывается в строковый тип.
var nowWhat = 0;
nowWhat += 1 + "10";  // В этом случае, "10" является строкой,
            // "+=" - оператор конкатенации.
После исполнения кода, переменная nowWhat принимает значение "0110". Нижеследующее объясняет выполнение кода:
  1. Посмотрите на типы 1 и "10". "10" - строковый, а 1 - числовой, поэтому число было преобразовано в строку.
  2. Оператор + над строками, является оператором конкатенации. Результатом является "110".
  3. Посмотрите на типы по обе стороны оператора +=. nowWhat включает число, и "110" - строку, и поэтому число преобразуется в строку.
  4. В данный момент по обе стороны оператора += находятся строки, происходит конкатенация строк. Результатом является "0110".
  5. Результат хранится в переменной nowWhat.
var nowThen = 0;
nowThen += 1 + parseInt("10");        // В данном случае, "+=" является оператором сложения
После выполнения кода, переменная nowThen принимает значение 11.


Типы данных JScript

Типы данных JScript
 Описание JScript
Пред.
След.

Что такое типы данных в JScript?
В Microsoft JScript используется шесть типов данных. Основные - числа, строки, объекты, логический. Остальные два - null (NULL) undefined (Неопределенный).
.
Строковый тип данных
Строки объявляются при помощи двойных кавычек или апострофов. Строки могут быть объектами JScript, но это - частный случай с особыми свойствами. Несколько примеров строк:
"The cow jumped over the moon."
'"Avast, ye lubbers!" roared the technician.'
"42"
Строка может состоять из нуля или более символов unicode. Когда количество символов равно нулю, это называется пустой строкой ("").
Числовой тип данных
JScript поддерживает числа как целые, так и с плавающей точкой(запятой). Целые могут быть положительные, 0(нуль) и отрицательными; a числа с плавающей точкой(запятой) представляются с десятичной точкой, либо в "e"-формате, означающим "10 в степени" в научном описании. Это соответствует IEEE 754 стандарту для представления чисел. Наконец, существуют специальные представления чисел:
  • NaN, Not A Number или НеЧисло
  • Плюс-Бесконечность
  • Минус-Бесконечность
  • Положительный 0
  • Отрицательный 0
Целые числа могут быть представлены по основанию 10 (decimal-десятичные), 8 (octal-восьмеричные) или 16 (hexadecimal-шестнадцатиричные).

Восьмеричные числа отображаются с первым символом "0", состоят из чисел от 0 до 7. Если число начинается с "0", но содержат числа "8" и(ли) "9", оно является десятичным. Указание в восьмеричном числе символа "e" (или "E") является ошибкой.

Шестнадцатиричные ("hex", 16-ричные) числа начинаются с "0x" (или "0X") и содержат цифры от 0 до 9, буквы от A до F (или от a до f). Символ "e" считается шестнадцатиричной цифрой, и форма числа не является экспоненциальной. Буквы A-F используются как шестнадцатиричные цифры, означаются цифры от 10 до 15 по основанию 10. Так, 0xF означает 15, а 0x10 эквивалентно 16.

8- и 16- ричные числа могут быть отрицательными, но не дробными. Число, начинающееся с "0" и содержащее десятичную точку, является десятичным с плавающей точкой; Если число начинается с "0x" или "00" содержит десятичную точку, все символы, расположенные справа от нее игнорируются.

Примеры чисел:

.0001, 0.0001, 1e-4, 1.0e-4  // Четыре приведенных числа с плавающей точкой равны друг другу.
3.45e2                       // Число с плавающей точкой - равно 345.
42                           // Целое число.
0377                         // Восьмиричное число, эквивалентно 255.
00.0001                      // 8-ричное число не может содержать плавающую точку, эквивалентно 0.
0378                         // 8-ричное число, равное 378.
0Xff                         // 16-ричное, эквивалентное 255.
0x37CF                       // 16-ричное, эквивалентное 14287.
0x3e7                        // 16-ричное, эквивалентное 999.
0x3.45e2                     // 16-ричное число не может содержать дробную часть, эквивалентно 3.
Логический или булев тип
Возможные значения типа - true и false. Это - специальные значения, не равные соответственно 1 и 0.

Предупреждение При сравнении, любое выражение, равное 0, считается ложным - false, а любое выражение, равное числу, отличным от 0 будет правдой(верным) - true. Следующее выражение возвращает true:

(false == 0)

Подробнее об этом - в разделе Управление ходом программы.

Undefined - тип не определен
Значение undefined имеет переменная после ее объявления и до присвоения ей какого-либо определенного значения.
Тип Null
Переменная типа null - не имеет никакого определенного значения.


Операторы JScript

Операторы JScript 		Описание JScript
Пред.
След.

В JScript применяются множество операторов: арифметические, логические, разрядные, присваивания и прочие.

Вычислительные | Логические | Разрядные | Присваивания | Прочие
Название | Символ | Название | Символ | Название | Символ | Название | Символ | Название | Символ
Унарный минус - Логическое НЕ ! Разрядное НЕ ~ Присваивание = Удаление delete
Инкремент ++ Меньше < Поразрядный левый сдвиг << Составное присваивание OP= Тип typeof
Декремент -- Больше > Поразрядный правый сдвиг >> Пусто void
Умножение * Меньше или равно <= Беззнаковый поразрядный правый сдвиг >>>
Деление / Больше или равно >= Разрядное И &
Деление по остатку % Равно == Разрядное ИСКЛЮЧАЮЩЕЕ ИЛИ ^
Сложение + Не равно != Разрядное ИЛИ |
Вычитание - Логическое И &&
Логическое ИЛИ ||
Условное выражение (Тринар) ?:
Запятая ,
Тождественно ===
Нетождественно !==

Приоритет операторов
В JScript операторы выполняются в определенном порядке, называемом приоритет операций. Следующий список отражает приоритет операторов от высшего к низшему. Операторы, указанные в одной строке, выполняются слева направо.

Оператор | Описание
. [] () Точка, индексы массивов, вызов функции
++ -- - ~ ! typeof new void delete | Унарные операции, вывод типов данных, создание объектов, неопределенные значения
* / % Умножение, деление, деление по остатку
+ - + Сложение, вычитание, конкатенация строк
<< >> >>> Поразрядные сдвиги
< <= > >= Меньше, меньше или равно, больше, больше или равно
== != === !== Равно, неравно, тождественно, нетождественно
& Разрядное И
^ Разрядное ИСКЛЮЧАЮЩЕЕ ИЛИ
| Разрядное ИЛИ
&& Логическое И
|| Логическое ИЛИ
?: Условное выражение
= OP= | Операторы присваивания
, Запятая

Круглые скобки используются, чтобы изменить порядок выполнения операторов. Выражение в круглых скобках полностью вычисляется прежде, и его значение используется как остаточный член инструкции. .

Оператор с более высоким приоритетом выполняется ранее оператора с низким приоритетом. Например:

z = 78 * (96 + 3 + 45)
В данном выражении пять операторов: =, *, (), +, and +. Приоритет операторов - следующий: (), *, +, +, =.
  1. Первым вычисляется значение выражения в круглых скобках: К сумме операции 96 и 3 прибавляется 45, общая сумма равна 144.
  2. Далее выполняется умножение: произведение 78 и 144 дает результат 11232.
  3. Переменной z присваивается значение 11232 .


Управление ходом программы

Управление ходом программы
Описание JScript
Пред.
След.

Зачем контролировать ход выполнение программы?
Часто необходимо составить сценарий, выполняющийразличные действия в зависимости от конкретного условия. Например, Вы можете составить сценарий, проверяющий время каждый час, и изменяет некий параметр в зависимости от времени суток. Вы можете написать сценарий, который обрабатывает входные данные, и действует в зависимости от этих значений.

Существует несколько видов проверки условий. Все условные выражения в Microsoft JScript - логические, поэтому результат их проверки равен либо true, либо false. Вы можете проверять значения логического, числового строкового типов данных.

В JScript простейшими структурами управления являются условные выражения.

Использование условных выражений
В JScript поддерживаются условные выражения if и if...else. В выражении if проверяется условие, при соответствии этому условию, выполняется написанный разработчиками JScript-код. (В выражении if...else выполняется при несоответствии условию другой код.) Простейшая форма оператора if может быть написана одной строкой, Но обычно операторы if и if...else записываются в несколько строк.

Следующий пример демонстрирует синтаксис выражений if и if...else. В первом примере - простейшая логическая проверка. Если выражение в круглых скобках равно true, выражение или блок выражений после if выполняется.

// Функция  smash() определена в другом месте кода.
if (newShip)
   smash(champagneBottle,bow);  // Логическая проверка newShip на равенство true.

// В данном примере, условие выполняется, если оба подусловия равны  true.
if (rind.color == "ярко-желтый " && rind.texture == "большие и малые пятна")
{
        theResponse = ("Это тыква? <br> ");
}

// В следующем примере, условие выполнится, если хотя бы одно из подусловий (или оба) равны true.
var theReaction = "";
if ((lbsWeight > 15) || (lbsWeight > 45))
{
    theReaction = ("Неплохо! <br>");
}
else
    theReaction = ("Не очень! <br>");
Условный оператор
В JScript также поддерживается упрощенная форма условия. Это использование вопросительного знака после условия для проверки (подобно if до условия), и двух альтернативных выражений, одно применяется при успешной проверки, другое - при не соответствии условию. Альтернативные выражения разделяются двоеточием.
var hours = "";

// Код для проверки времени
// theHour, or theHour - 12.

hours += (theHour >= 12) ? " PM" : " AM";

Предупреждение Если проверяются несколько условий одновременно, и вам известна вероятность каждого из условий, в зависимости от операторов OR (||) или AND (&&), вы можете изменить порядок проверки условий для ускорения работы сценария.

Например, если три условия должны быть истинными, а второе условие ложно, то третье условие не проверяется.

И наоборот, если хотя бы одно из условий должно быть истинным (при использовании оператора ||), то при истинности одного, проверка остальных не проводится.

Пример побочного эффекта: runsecond не будет проверен, если runfirst() возвращает 0 или false.

if ((runfirst() == 0) || (runsecond() == 0))
// некоторый код
Циклы
Существует несколько вариантов выполнения инструкции или блоков инструкций неоднократно. Повторное выполнение называется циклом. Цикл обычно управляется исходя из значения некоторых условий и(ли) переменных, значения которых меняется в конце каждого цикла. В Microsoft JScript применяется несколько типов циклов: for, for...in, while, do...while и switch.
Применение цикла for
В выражении for определены переменная-счетчик, условие проверки и действие, изменяющее значение счетчика. После каждого выполнения цикла (это называется итерацией цикла), проверяется условие, производится обработка выполнения действий на переменной-счетчиком, и если условия проверки выполнены, выполняется новая итерация цикла.

Если условие для выполнения цикла никогда не будет выполнено, цикл никогда не завершится. Если проверяемое условие всегда выполняется, цикл бесконечен. Поэтому разработчикам следует позаботиться об этом.

/*
Изменение выражения (" icount ++ " в приведенных примерах)
выполняется в конце цикла, после блока инструкций,
прежде, чем условие проверено.
*/

var howFar = 11;  // Ограничение выполнения цикла - 11 итераций.

var sum = new Array(howFar);  // Создание массива размер - 11, индексы от 0 по 10.
var theSum = 0;
sum[0] = 0;

for(var icount = 1; icount < howFar; icount++)  {        // Счетчик  от 1 до 10 в данном случае.
theSum += icount;
sum[icount] = theSum;
}

var newSum = 0;
for(var icount = 1; icount > howFar; icount++)  {        // Цикл не будет выполнен.
newSum += icount;
}

var sum = 0;
for(var icount = 1; icount > 0; icount++)  {        // Бесконечный цикл.
sum += icount;
}
Применение цикла for...in
В JScript используется специальный цикл для пошагового обхода свойств объекта. Счетчик цикла for...in проходит все индексы массива. Это строковый тип, а не числовой.
for (j in tagliatelleVerde)  // tagliatelleVerde является объектом с несколькими свойствами
{
// Код JScript .
}
Применение цикла while
Цикл while напоминает цикл for. Различие в том, что в цикле while отсутствует встроенная переменная-счетчик, а, следовательно, и условия ее изменения. Выражения над условием для выполнения цикла while находятся внутри цикла в блоке инструкций.
var theMoments = "";
var theCount = 42;        // Инициализация переменной-счетчика.
while (theCount >= 1)  {
    if (theCount > 1)  {
        theMoments = "Осталось " + theCount + " секунд!";
}
    else  {
        theMoments = "Осталась одна секунда!";
    }
theCount--;        // изменение счетчика.
}
theMoments = "Время истекло!";

Предупреждение Так как цикл while не имеет встроенных переменных-счетчиков, он более подвержен бесконечному зацикливанию. Условия для выхода из цикла может не случится, и цикл становится бесконечным. Поэтому необходимо чрезвычайно осторожно использовать цикл while.

Применение выражений break и continue в циклах
В Microsoft JScript существует инструкция остановки выполнения цикла. Оператор завершения break может использоваться, чтобы остановить цикл, при выполнении какого-либо условия. Инструкция continue используется, чтобы немедленно перейти к выполнению следующей итерации, пропуская остальную часть выполнения кода текущей итерации, но обновляя переменную-счетчик как в обычных циклах for или for...in.
var theComment = "";
var theRemainder = 0;
var theEscape = 3;
var checkMe = 27;
for (kcount = 1; kcount <= 10; kcount++)
{
    theRemainder = checkMe % kcount;
    if (theRemainder == theEscape)
      {
            break;  // выход при выполнении условия (theRemainder == theEscape).
}
theComment = checkMe + " divided by " + kcount + " leaves a remainder of  " + theRemainder;
}

for (kcount = 1; kcount <= 10; kcount++)
{
   theRemainder = checkMe % kcount;
   if (theRemainder != theEscape)

   {
      continue;  // При неравенстве theRemainder и theEscape переходим к следующей итерации.
}
// JScript код.
}


Функции в JScript

Функции в JScript
 Описание JScript
Пред.
След.

Что такое функция?
Функции в Microsoft JScript выполняют определенные действия. Они могут возвращать некоторый результат, например результат вычислений или сравнения

Функции исполняют при вызове определенный блок инструкций. Это позволяет однажды определить функцию, а в дальнейшем вызывать ее когда потребуется.

Вы передаете данные функции, включая их в круглые скобки после имени функции. Данные в круглых скобках называются параметрами. В некоторых функциях нет параметров вообще; в некоторых - один параметр; иногда параметров несколько.

В JScript имеется два вида функций: встроенные и определяемые.

Специальные встроенные функции
Язык JScript включает несколько встроенных функций. Некоторые из них позволяют обрабатывать выражения и специальные символы, и преобразовывать строки в числовые значения.

Например, escape() и unescape() используются для перевода кода HTML и спецсимволов, то есть символов, которые нельзя непосредственно размещать в тексте. К примеру, символы "<" и ">", применяются для обозначения HTML-тэгов.

Функция escape принимает в параметре спецсимволы, а возвращает ESC-код символа. Каждый код ESC-код начинается со знака процента (%) и последующим двухзначным числом. Функция unescape является инверсионной. В качестве параметра вводится ESC-код, а возвращает символ.

Еще одна встроенная функция - eval(), которая выполняет любое правильное математическое выражение, представленное в виде строки. Функция eval() имеет один аргумент - выражение для выполнения.

var anExpression = "6 * 9 % 7";
var total = eval(anExpression);        // Вычисляет выражение, равно 5.
var yetAnotherExpression = "6 * (9 % 7)";
total = eval(yetAnotherExpression)        // Вычисляет выражение, равно 12.

var totality = eval("Текст.");        // Возвращает ошибку.
В справочнике языка JScript имеется описание других встроенных функций.
Создание собственных функций
Вы можете создавать собственные функции и вызывать их, когда потребуется. Определение функции состоит из объявления параметров и блока инструкций JScript .

Функция checkTriplet в следующем примере принимает в качестве параметров длины трех сторон треугольника, и определяет, является ли треугольник прямоугольным, проверяя согласно Пифагорову правилу(триплету). (Квадрат длины гипотенузы прямоугольного треугольника равен сумме квадратов длин катетов.) Функция checkTriplet в ходе проверки вызывает одну из двух других функций.

При проверке значений при входных значениях чисел с плавающей точкой используется "машинное эпсилон" ("epsilon") - очень маленькое число. Из-за погрешности округления в вычислениях с плавающей точкой, без применения этого числа, функция может возвращать неверный результат. "Машинное эпсилон" является максимальной допустимой погрешностью.

var epsilon = 0.0000000000001;  // "Машинное эпсилон".
var triplet = false;

function integerCheck(a, b, c)  {  // Функция проверки при целых числах.
    if ( (a*a) == ((b*b) + (c*c)) )  {  // Код проверки.
    triplet = true;
    }
}  // Конец функции проверки при целых числах.

function floatCheck(a, b, c)  {  // Функция проверки при числах с плавающей точкой.
var theCheck = ((a*a) - ((b*b) + (c*c)))  // Контрольное число.
    if (theCheck < 0)  {  // Вычисление модуля контрольного числа.
    theCheck *= -1;
    }
    if (epsilon > theCheck)  {  // Сравнение отклонения с допустимой погрешностью!
    triplet = true;
    }
}  // Конец функции проверки при числах с плавающей точкой.

function checkTriplet(a, b, c)  {  // Проверка триплета. Первым делом, присвоим "a" наибольшее значение из трех входных чисел.
var d = 0;  // Временная переменная.
    if (c > b)  {  // При c > b, меняем местами.
    d = c;
    c = b;
    b = d;
    }  // Иначе - не меняем.
    if (b > a)  {  // При b > a, меняем местами.
    d = b;
    b = a;
    a = d;
    }  // Иначе - не меняем.

// Сторона "a" является гипотенузой.

    if (((a%1) == 0) && ((b%1) == 0) && ((c%1) == 0))  {  // Проверка чисел - целые ли они?
    integerCheck(a, b, c);  // Функция для целых чисел.
    }
    else
        floatCheck(a, b, c);  // Иначе вызываем функцию для чисел с плавающей точкой
}  // Окончание проверки правила Пифагора (триплета).

// Практическая проверка - объявляем три переменные.
var sideA = 5;
var sideB = 5;
var sideC = Math.sqrt(50);

checkTriplet(sideA, sideB, sideC);  // Функция проверки на триплет.


Объекты JScript

Объекты JScript
Описание JScript
Пред.
След.

Что такое Объект?
В Microsoft JScript объекты по сути являются совокупностями методов и свойств. Метод - функция, которая выполняется внутри объекта, а свойство - значение или набор значений (в виде матрицы или другого объекта), являющееся частью объекта. В JScript объекты можно разделить на три вида: встроенные, созданные и браузерные.
Объекты и Массивы
В JScript, обработка объектов и массивов идентична. Вы можете обратиться к любой части объекта (его свойствам и методам) либо по имени, либо по индексу. Нумерация индексов в JScript начинается с нуля. Для удобства работы, частям можно присвоить имена.

Существует несколько вариантов обращений. Следующие выражения эквивалентны.

theWidth = spaghetti.width;
theWidth = spaghetti[3];  // [3] является индексом "width".
theWidth = spaghetti["width"];
При использовании числовых индексов, в обращении по имени нельзя использовать точку (.). Следующее выражение вызывает ошибку.
theWidth = spaghetti.3;
В случаях, когда объект является свойством другого объекта, обращение образуется прямым путем.
var init4 = toDoToday.shoppingList[3].substring(0,1);  // массив shoppingList  - свойство toDoToday.
Так как объекты могут быть свойствами других объектов, возможно создание массивов с более чем одним измерением, которые непосредственно не поддерживаются. Следующий код создает таблицу умножения для значений от 0 до 16.
var multTable = new Array(17);  // Создание оболочки для таблицы
for (var j = 0; j < multTable.length; j++)  {  // Подготовка к заполнению строками
    var aRow = new Array(17);  // Создание строки
    for (var i = 0; i < aRow.length; i++)  {  // Подготовка к заполнению строки
    aRow[i] = (i + " times " + j + " = " + i*j);  // Создание и размещение одного значения
    }
multTable[j] = aRow;  // Заполнение таблицы строкой
}
Обращение к каждому элементу производится указанием нескольких индексов
var multiply3x7 = multTable[3][7];
Следующее выражение вызовет ошибку.
var multiply3x7 = multTable[3, 7];


Зарезервированные слова JScript

Зарезервированные слова JScript
Описание JScript
Пред.
След.

В JScript имеется ряд зарезервированных ключевых слов. Эти слова разделяются на три типа: зарезервированные ключевые слова JScript, слова, зарезервированные для будущих версий, и слова, которые следует избегать.

Ключевые слова JScript
break | false | in | this | void
continue | for | new | true | while
delete | function | null | typeof | with
else | if | return | var

Зарезервированные слова для будущих версий JScript
case | debugger | export | super
catch | default | extends | switch
class | do | finally | throw
const | enum | import | try

К словам, которых следует избегать относятся имена уже существующих встроенных объектов и функций. Например, в языке уже применяются слова String и parseInt.

Применение любого из ключевых слов первых двух типов вызовет ошибку трансляции, когда ваш сценарий начнет выполняться. Использование зарезервированных слов третьего вида может вызвать непредсказуемое исполнение сценария, если Вы попытаетесь применить вашу переменную и вызвать объект с тем же именем в одном сценарие. Например, следующий сценарий не выполняет того, что нужно:

var String = "Новая строка";
var text = new String("Эта строка - новый экземпляр объекта");
В этом случае получим ошибку, выводящую информацию о том, что строка не является объектом.


Recursion

Рекурсия
 Описание JScript
Пред.
След.

Рекурсия - важнейшая методика программирования. Она используется, чтобы иметь обращение к функции непосредственно изнутри себя. Наглядный пример - вычисление факториалов. Факториалы 0 и 1 оба определены заранее, оба равны 1. Факториалы больших чисел рассчитываются так: умножаются 1 * 2 * ..., увеличивая множитель на каждый цикл на единицу, пока не достигнет номера, для которого вычисляется факториал.

В данном параграфе опишем фукцию, вычисляющую факториал.

"Если число - меньше чем нуль, выход. Если это не целое число, округляем до меньшего целого числа. Если число - нуль или единица, факториал - 1. Если число больше единицы, умножаем его на факториал числа, меньшего на единицу".

Чтобы вычислить факториал любого числа, которое больше единицы, необходимо вычислить факториал по крайней мере одного другого числа. Функция, которую Вы используете, должна вызвать саму себя для вычисления факториала меньшего числа, до тех пор, пока факториал какого либо числа не будет вычислен. Это - пример рекурсии

Понятно, этот способ имеет недостатки. Вы можете легко создать рекурсивную функцию, которая никогда не примет конечный или определенный результат, и не достигнет конечной точки. Такая рекурсия заставляет компьютер выполнять так называемый "бесконечный" цикл. Пример: удалим первое правило (относительно вычисления факториала отрицательных чисел) из описания вычисления факториала, и попробуем вычислить факториал любого отрицательного числа. Эта попытка потерпит неудачу, потому что, чтобы вычислять факториал, скажем, -24 Вы сначала должны вычислить факториал -25; но чтобы делать это Вы сначала должны вычислить факториал -26; и так далее. Очевидно, что функция никогда не достигнет промежуточного определенного результата.

Таким образом, чрезвычайно важно определять рекурсивные функции с большой осторожностью. Если Вы подозреваете, что возможен случай бесконечной рекурсии, можно задать функцию, вызывающую себя определенное количество раз, то есть если обращений к функции слишком много, автоматически происходит выход из нее.

Ниже приведена функция, написанная на JScript.

function factorial(aNumber)  {
aNumber = Math.floor(aNumber);  // Если число не цело, "откинем" дробную часть.
if (aNumber < 0)  {  // Если число меньше нуля, выход.
    return "Значение не определено.";
    }
      if ((anumber == 0) || (anumber == 1))  {  // Если число 0 или 1, факториал равен 1.
      return 1;
      }
        else return (anumber * factorial(anumber - 1));  // Вычисляем до выполнения
}


Область видимости переменных

Область видимости переменных
 Описание JScript
Пред.
След.

В Microsoft JScript область видимости переменных может быть представлена в двух контекстах: глобальном (global) и локальном (local). Если объявление переменной (variable) находится вне определения функции, это - глобальная переменная, значение которой доступно и изменяемо в любом месте программы. Если переменная объявляется в определении функции, то она является локальной. Такая переменная создается и уничтожается каждый раз при вызове функции; она не доступна вне функции.

Локальная и глобальная переменные могут иметь одно и то же имя, но сами переменные - различны. Следовательно, изменение одной переменной не влечет изменения другой. Внутри функции, в которой объявлена локальная переменная , только локальная версия имеет значение.

var aCentaur = "a horse with rider,";  // Глобальное определение aCentaur.

// JScript код опущен для краткости.
function antiquities()  // Локальная переменная aCentaur объявляется в этой функции.
{

// JScript код опущен для краткости.
var aCentaur = "A centaur is probably a mounted Scythian warrior";

// JScript код опущен для краткости.
  aCentaur += ", misreported; that is, ";  // Конкатенация локальной переменной.

// JScript код опущен для краткости.
}  // Конец функции.

var nothinginparticular = antiquities();
aCentaur += " as seen from a distance by a naive innocent.";

/*
Внутри функции переменная содержит: "A centaur is probably a mounted
Scythian warrior, misreported; that is, ";
вне функции переменная содержит остаток предложения:
"a horse with rider, as seen from a distance by a naive innocent."
*/
Важно заметить, что переменные действуют, как будто они были объявлены в начале контекста. Часто это может привести к непредсказуемому результату.
var aNumber = 100;
var withAdditive = 0;

withAdditive += aNumber;  // withAdditive сейчас 100.
tweak();
withAdditive += aNumber;  // withAdditive сейчас 200.

function tweak()  {
var newThing = 0;  // Явное объявление переменной newThing.
// Следующая инструкция, если ее не закомментировать, выдаст ошибку.
// newThing = aNumber;
// Следующая инструкция присваивает значение 42 локальной переменной aNumber, явно объявляя ее.
aNumber = 42;
if (false)  {
    var aNumber;  // Эта инструкция никогда не будет выполнена.
    aNumber = "Hello!";  // Эта инструкция никогда не выполнена.
    }  // Конец условного выражения.
}  // Конец определения функции.
Закомментированная инструкция пытается присвоить значение aNumber локальной переменной newThing. Попытка неудачна, несмотря на то, что локальная переменная aNumber определена в функции, и поэтому существует. Переменная aNumber не имеет определенного значения в момент, когда вызвана инструкция, поэтому ее значение равно undefined.


Копирование, прием и сравнение данных

Копирование, прием и сравнение данных
 Описание JScript
Пред.
След.

В Microsoft JScript обработка данных зависит от типа данных.

Значение и ссылка
Числовые и логические значения (true и false) копируются, принимаются и сравниваются значениями. При копировании или приеме значения, определяется место в памяти компьютера и в него помещается значение оригинала. Если оригинал меняется, на значение копии это не влияет (и наоборот), так как копия и оригинал являются двумя различными объектами.

Объекты, массивы и функции копируются, принимаются и сравниваются в большинстве случаев по ссылке. При копировании или приеме по ссылке, вы по существу создаете указатель на оригинал, применяя указатель как копию. При изменении оригинала, вы изменяете и копию, и оригинал. Это только один объект; "копия" на самом деле не является копией, это всего лишь еще одна ссылка на данные.

Предупреждение Вы можете изменить такое поведение для объектов и массивов, определив метод assign( ) для них.

И наконец, строки копируются и принимаются по ссылке, а сравниваются по значению.

Предупреждение Создается множество ASCII и ANSI символов, заглавные буквы предшествуют прописным, сравнение происходит последовательно по символам. Например, "Zoo" при сравнении меньше чем "aardvark".

Прием параметров к функциям
Когда прием параметров к функциям происходит по значению, создается отдельная копия параметра, которая существует внутри функции. С другой стороны, при приеме параметра по ссылке, если функция изменяет значение этого параметра, он изменяет значение во всем сценарии.
Проверка данных
При проверке элементов по значению, происходит сравнение на равенство друг другу. Обычно, сравнение происходит поразрядно, байт к байту. При проверке по ссылке, определяется, являются ли оба элемента указателями на один оригинальный элемент. Если являются, то они равны; если нет (даже при поразрядном равенстве), то они не являются равными.

Скопированные и принятые по ссылке строки сохраняются в памяти; но невозможно изменить строки, как только они созданы, это становится возможным при их сравнении по значению. Это позволяет проверять, имеют ли две строки то же самое содержание, даже если каждая из них была создана отдельно от другой.


Использование массивов

Использование массивов
 Описание JScript
Пред.
След.

Индексация массивов
Массивы в JScript разряжены. Так, если в массиве три значения пронумерованы как 0, 1 и 2, вы можете создать элемент 50, не волнуясь об элементах от 3 до 49. Если массив имеет автоматическую переменную размера (смотрите встроенные объекты (Intrinsic Objects) для определения размера массива), переменная размера установлена как 51, несмотря на размер 4. Конечно, можно создавать массивы без разрывов в нумерации элементов, но это не обязательное условие. Фактически в JScript, массивы вообще могут не иметь нумерации.

В JScript объекты и массивы идентичны друг другу. Настоящая разница не в данных, а скорее в адресации элементов массива или свойств (properties) и методов объекта.

Адресация массивов
Существует два основных способа для адресации элементов массива. Обычно, для адресации используют индексы. Индексы содержат числовое значение или выражение (expression), которое оценивается как неотрицательное целое. В следующем примере предполагается, что переменная entryNum определена, и ей присвоено значение в другом месте в сценарие.
theListing = addressBook[entryNum];
theFirstLine = theListing[1];
Метод адресации эквивалентен методу адресации объектов, хотя при адресации объекта, индекс должен быть именем существующего свойства. Если такого свойства нет, возникает ошибка при исполнении кода.

Второй способ адресации массива состоит в том, чтобы создать объект (массив), который содержит свойства, которые пронумерованы числами в цикле. В следующем примере создается два массива, один для имени, второй для адреса, внесенных в список addressBook. Каждый из них содержит четыре свойства. Образец theName, например, формируется от [Name1] до [Name4] свойств theListing, может содержать "G." "Edward" "Heatherington" "IV" или "George" "" "Sand" "".

theListing = addressBook[entryNum];
for (i = 1; i < 4; i++)  {
theName[i] = theListing["Name" + i];
theAddress[i] = theListing["Address" + i];
}
В то же время код мог бы легко быть написан в "dot"-стиле системы обозначений (то есть адресуя theListing, theName и theAddress скорее как объекты, чем матрицы, через точку), но подобное не всегда возможно. Иногда какое-либо свойство не может существовать до времени выполнения, или нельзя его узнать заранее. Например, если массив addressBook упорядочен по фамилии вместо нумерации, пользователь будет вероятно вводить названия " на лету", в то время как сценарий функционирует, просматривая людей. Следующий пример показывает применение определений функций в другом месте сценария.
theListing = addressBook[getName()];
theIndivListing = theListing[getFirstName()];
Это ассоциативная адресация массива, то есть адресация посредством полностью произвольных строк. Объекты в JScript являются ассоциативными массивами. Хотя чаще всего используется "dot"-стиль, это не всегда требуется.


Расширения создания объектов

Расширения создания объектов
 Описание JScript
Пред.
След.

Применение конструкторов при создании объектов
В Microsoft JScript для создания классов объектов используются конструкторы. Вызывается конструктор с помощью инструкции new.

Особый случай конструктора - создание анонимных функций. Анонимная функция - функция, не имеющая имени. Вы можете применять конструктор для создания функций "на лету", например, как инструкцию внутри другой функции. Такая функция, которая вызывается только из одного расположения, не нуждается в имени.

В следующем примере такая анонимная функция генерирует одну строку списка "Имя-Электронный адрес". Она проверяет значение переменной firstNameFirst , чтобы решить, разместить сначала имя или фамилию, а также значение переменной emailNameFirst , чтобы решить, разместить сначала имя или адрес электронной почты. В примере предполагается, что значения firstNameFirst и emailNameFirst определены в другом месте.

for (j = 1; j < addressList[length]; j++)
{
oneListingLine = new Function(emailNameFirst, firstNameFirst, addressList, j, theName = new Function(firstNameFirst, addressList, j, var theName=(addressList[j].firstName + addressList[j].lastName);
if(firstNameFirst)
      {
      theName=(addressList[j].firstName + addressList[j].lastName);
      },) ;
if (emailNameFirst)
      {
theListing = addressList[j].emailName+ ":\t" + theName
      } else theListing = theName + ":\t" + addressList[j].emailName; return theListing;)
document.write(oneListingLine + "<br>");
}
Запись конструкторов
Для написания собственного конструктора используется ключевое слово this в пределах конструктора для обращения к только что созданному объекту. Конструктор инициализирует объект.

В следующем примере конструктора индекс начинается с нуля, но это не обязательно. Нумерация индексов может начинаться и с единицы, например, если вы желаете указывать параметр, который указывает размер массива или объекта. Это называется степенью для отличия от автоматически поддерживаемого параметра длины объекта Array( ). Если вы записываете код, который добавляет свойства к массиву, то вы должны обновить параметр степени (или его эквивалент), так как этот параметр не поддерживается в JScript. Обратите внимание, что даже в таком чрезвычайно простом примере используются и объектные (точечные), и индекс-стили (для массивов) системы обозначений, для того, чтобы обратиться к текущему объекту.

function MakeStringArray(length) {
this.extent = length;
for (iNum = 0; iNum < length; i++) {
this[iNum] = "";
}
}

// Применение конструктора для создания и инициализации массива.
myStringArray = new MakeStringArray(63);
Применение прототипов при создании объектов
При записи определения объекта можно использовать свойства прототипа для создания свойств, которые обычно поддерживаются всеми объектами, созданными по определению. Свойства прототипа копируются по ссылке в каждый объект класса, они имеют одни и те же значения для всех объектов класса. Однако, можно изменить значения свойств прототипа в одном объекте, новые значения переопределяются по умолчанию, но лишь в одном экземпляре объекта. На другие объекты этого класса это изменение не действует.

В принципе, Вы можете определять дополнительные свойства для объектов, которые являются частью JScript. Например, если необходима особая постоянная для вычислений, отсутствующая среди свойств объектов Math и Number, можно определить ее непосредственно и затем назначать в соответствующие прототипы объекта или свойство прототипа объекта.

Math.prototype.Avogadro = 6.0232E23;
function howManyMolecules(wtGrams,molWt) {
return ((wtGrams/molWt)*Math.prototype.Avogadro);
}
document.write("Всего " + howManyMolecules(window.prompt("Масса в  граммах?",0),window.prompt
("Каков молекулярный вес?",0)) +
 " молекул.");
По сути, можно определить функцию, назначив как метод String.prototype, и использовать его в любой строке в любом месте сценария. Следующий пример принимает массив Периодической системы элементов, называемый "theElements" и определенный в другом месте сценария, содержащий символы элементов, их названия, атомный вес и некоторую другую информацию.

function atomName(theSymbol) {
return(theElements[theSymbol].fullName);
}

String.prototype.atomName = atomName;

function decodeFormula(theFormula) {
var theCurrentPiece = "";
var theDecodedFormula = "";
for (i = 1; i = theFormula.length ; i++);
if (theFormtheCurrentPiece)
// Инструкции кода для разделения строки в массив символов и чисел.
// Цикл для трансляции декодированной строки. Условия:
theDecodedFormula += formula[n].number
theDecodedFormula += " ";
theDecodedFormula += formula[n].symbol.prototype.atomName;
theDecodedFormula += " "
// Конец цикла.

return theDecodedFormula;
}

decodeFormula(window.prompt("Формула?","Al2O3"));


Специальные символы
 Описание JScript
Пред.
След.

Специальные символы
JScript позволяет использовать специальные символы, которые включаются в строки, но их невозможно напечатать непосредственно. Каждый из этих символов начинается с наклонной черты влево. Наклонная черта влево - ESC-символ, применяемый для того, чтобы сообщить интерпретатору, что следующий символ является специальным.

Обозначение | Описание
\b | Удаление одного символа слева
\f | Конец страницы
\n | Перевод строки (новая строка)
\r | Возврат каретки
\t | Табуляция (Ctrl-I)
\' Одинарная кавычка - апостроф
\" Двойная кавычка
\\ Наклонная черта влево - обратный слэш

Обратите внимание, что, потому что обратный слэш непосредственно означает ESC-символ, и его одиночный символ в сценариях не допустим. Если Вы хотите вывести обратный слэш, используйте два его символа вместе (\\).

document.write('Путь к файлу  C:\\webstuff\\mypage\\gifs\\garden.gif.');
document.write('The caption reads, "After the snow of \'97. Grandma\'s house is covered."');
Вы можете использовать эти управляющие последовательности, чтобы управлять форматированием текста внутри тэгов <PRE> и <XMP>, а иногда в всплывающих окнах alert, prompt и confirm.


Разрешение проблем в сценариях

Разрешение проблем в сценариях
 Описание JScript
Пред.
След.

В любом языке программирования имеются специфические особенности, и необходимо быть особо внимательным для избежания ошибок. Например, значение null: в Microsoft JScript имеет отличия от значения null в языках C or C++.

Ниже перечислены некоторые виды ошибок при разработке JScript сценариев.

Синтаксические ошибки
В языках программирования синтаксис более строг, чем в естественных языках, поэтому важно внимательно следит за правилами при разработке сценариев. Например, при задании параметра строкового типа, необходимо заключить его в кавычки, иначе произойдет ошибка.
Порядок выполнения сценария
JScript сценарии для браузера являются частью HTML-кода. Поэтому порядок выполнения зависит от места его размещения. Так, сценарий, помещенный между <HEAD>-тэгами, выполняется ранее, чем сценарий в <BODY>-части документа. Если объект создан в <BODY>-части, он не выполнится при вызове в <HEAD>-части.
Автоматическое преобразование типов
JScript - язык с нестрогим контролем типов с автоматическим присваиванием. Следовательно, несмотря на то, что значения, имеющие различные типы не равны, выражения в следующем примере, возвращают true.
"100" == 100
false == 0
Приоритет операций
Порядок выполнения операций в выражениях(expression) происходит согласно установленному порядку, который называется приоритет операций. Так, в следующем примере, умножение производится ранее вычитания, хотя вычитание в выражении встречается ранее.
theRadius = aPerimeterPoint - theCenterpoint * theCorrectionFactor;
Применение цикла for...in в объектах
При пошаговом обхождении свойств объекта при помощи цикла for...in, вы не можете управлять порядком обхода свойств. Кроме того, этот порядок различен в разных реализациях языка.
Ключевое слово with
Инструкция with удобна для указания свойств, уже существующих в данном объекте, но не может использоваться, чтобы добавить свойство объекту. Чтобы создать новые свойства в объекте, необходимо обратиться к объекту явно.
Ключевое слово this
Хотя ключевое слово this позволяет обратиться к объекту непосредственно, нельзя применять this или подобные инструкции при выполнении функции, где объект не определен. Если функция назначена методом объекта, тогда возможно применение this.
Чтение и запись сценария
Тэг </SCRIPT> завершает обработку записи сценария. Запись "</SCRIPT>", разделенного пробелом, либо записаного в две строки, например, "</SCR" и "IPT>", не является эквивалентной </SCRIPT>.
Явное описание окон
Существует возможность открыть одно или несколько окон. Любое неявное описание подразумевает текущее окно. Для других окон требуется явное описание.


Вывод информации в браузер

Вывод информации в браузер
Описание JScript
Пред.
След.

В Microsoft JScript существует два варианта вывода данных в окно браузера. Для этого применяются write( ) и writeln( ), являющиеся методами document-объекта. Так же возможен вывод информации при помощи всплывающих окон alert, prompt или confirm.
Применение document.write( ) и document.writeln( )
В большинстве случаев для вывода данных в браузер применяется метод write( ), имеющий один аргумент, это - строка, которую необходимо вывести на экран. Строка может быть формата plain text или HTML.

Строки заключаются в двойные или одинарные кавычки. Это позволяет чередовать кавычки с апострофами.

document.write("Число ПИ приблизительно равно " + Math.PI);
document.write( );

Предупреждение Следующая простая функция позволяет подобно "document.write" вывести данные в окне браузера. Если аргумент не определен - "w()" - печатается пустая строка..
function w(m)  {		// Функция w().
m = "" + m + "";        //  Переменной m присвоен строковый тип.
if ("undefined" != m)  {    //  Проверка на неопределенное значение.
    document.write(m);
    }
document.write("<br>");
}

w('<IMG SRC="horse.gif">');
w();
w("Это - лошадь.");
w();

Метод writeln( ) практически идентичен write( ), за исключением перевода на новую строку после вывода данных. Однако, если Вы используете <PRE> и <XMP>, то тэги и символы новой строки выводятся в экран браузера.

Очистка текущего документа
Метод clear() document-объекта делает текущий документ пустым. Этот метод также наряду с остальной частью документа, очищает и ваш сценарий (), так что следует быть очень осторожным при его использовании.
document.clear();


Всплывающие окна

Всплывающие окна
 Описание JScript
Пред.

Использование alert, prompt и confirm
Существует три вида всплывающих окон: alert, confirm и prompt. Всплывающие окна имеют интерфейс window-объектов. Так как window-объекты имеют объектную иерархию, поэтому обращаться к ним возможно по полному имени (например, "window.alert()"), это помогает определить их принадлежность к чему-либо.

Alert - предупреждение
Метод alert имеет один аргумент - строку, которую всплывающее окно выводит на экран пользователя. Строка не использует HTML. Единственная кнопка OK позволяет пользователю закрыть alert для продолжения работы со страницей.
window.alert("Привет! Нажми OK для продолжения.");
Confirm - подтверждение
Окно confirm позволяет задать пользователю альтернативный вопрос, на который можно ответить "Да-Нет" с помощью кнопок OK и Cancel соответственно. Метод confirm возвращает одно из двух значений: true или false. Окно message - так же является модальным: для продолжения работы, пользователь обязан нажать на одну из двух кнопок.
var truthBeTold = window.confirm("Нажми OK для продолжения или Cancel для выхода.");
if (truthBeTold) {
window.alert("Добро пожаловать на Web-страницу!");
}  else  window.alert("До свидания!");
Prompt - запрос
Всплывающее окно prompt позволяет пользователю ввести текстовой ответ на ваш запрос. Окно имеет кнопки OK и Cancel. Если Вы примените второй аргумент, то он будет являться ответом по умолчанию. Иначе ответ по умолчанию будет не определен: "<undefined>".

Как alert( ) и confirm( ) окна, prompt также является модальным окном. Пользователь для продолжения работы должен закрыть окно.

var theResponse = window.prompt("Привет!","Введите здесь свое имя");


Встроенные объекты

Встроенные объекты
 Описание JScript
Пред

В Microsoft JScript девять встроенных объектов. Это Array, Boolean, Date, Function, Global, Math, Number, Object и String. Каждый из объектов имеет свои методы и свойства, подробно описанные в справочнике языка. Здесь приводится описание объектов.
Объект Array - Массив
В JScript обработка массивов происходит подобно обработки объектов. Индекс в массиве, эквивалентный свойству объекта, может быть вызван по порядковому номеру (или по имени, ассоциированному с ним). Создания нового массива происходит с помощью оператора new и конструктора Array() (constructor), подобно приведенному ниже примеру.
var theMonths = new Array(12)  {
theMonths[0] = "Jan";
theMonths[1] = "Feb";
theMonths[2] = "Mar";
theMonths[3] = "Apr";
theMonths[4] = "May";
theMonths[5] = "Jun";
theMonths[6] = "Jul";
theMonths[7] = "Aug";
theMonths[8] = "Sep";
theMonths[9] = "Oct";
theMonths[10] = "Nov";
theMonths[11] = "Dec";
}
При создании массива, JScript включает в объект Array свойство размера (length), которое характеризует количество элементов массива. Если массив не имеет элементов, то его размер равен нулю. Если задан номер индекса, размер массива равно ему. В следующем примере

var theMonths = new Array("Jan", "Feb", "Mar", "Apr", "May", "Jun",
"Jul", "Aug", "Sep", "Oct", "Nov", "Dec");

var l = theMonths.length;
document.write(l);
размер массива равен 12.
Объект String - Строка
В JScript строки являются объектами. Это означает, что в любой можно объявить переменную строкового типа, либо применить строку-константу, что фактически и происходит при создании нового объекта String. Объект String имеет встроенные методы, которые можно применить при работе со строками. Одним из методов является substring, возвращающий часть строки. Он содержит два аргумента числового типа.
aString = "0123456789";
var aChunk = aString.substring(4, 7);  // aChunk равно "456".
var aNotherChunk = aString.substring(7, 4);  // aNotherChunk равно "456".

// Применение метода в созданном ранее массиве:
firstLetter = theMonths [5].substring(0,1);  // переменной firstLetter присвоено значение "J".
Еще одно свойство объекта String - свойство длины (length) строки, значение которого соответствует количеству символов в строке, значение 0 соответствует пустой строке. Это значение может быть использовано в вычислениях.
var howLong = "Hello World".length  // Возвращает значение 11, которое присваивается переменной howLong.
Объект Math - Математические вычисления
Объект Math включает ряд предопределенных свойств и методов. Свойствами являются определенные числа. Например, число ПИ (приблизительно 3.14159...). Свойство Math.PI используется в приведенном ниже примере.
// Переменная  radius является числовым значением.
var circleArea = Math.PI * radius * radius;  // Вычисление площади круга.
Пример встроенного метода объекта Math: вычисление возведения в степень числа (pow). Приведенный пример использует число ПИ и метод возведения в степень.
// Вычисление объема сферы в зависимости от радиуса.
volume = (4/3)*(Math.PI*Math.pow(radius,3));
Объект Date - Дата
Объект Date применяется для вывода текущей даты, а также для определения разницы между датами. Все значения методов и свойств предопределены. Вообще объект Date позволяет определить день недели; день, месяц, год; а также время в часах, минутах и секундах. Основанием является количество миллисекунд, прошедших с 1-го января 1970 года, 00 ч,00 мин,00.000 сек по GMT. GMT означает "Среднее Время По Гринвичу"; условно UTC, или "Универсальная Координата Времени", являющееся Международным Эталоном Времени.

Предупреждение В JScript для обработки временных величин до полуночи 1-го января 1970 года нельзя применять объект Date. Для работы с временными данными до 1970 года необходимо написать собственные функции.

Для создания нового объекта Date используется оператор new. В следующем примере для текущего года определяется количество прошедших и оставшихся дней.

/*
В переменной thisIsToday содержится массив для текущего момента.
*/
var thisIsToday = new Date();

var toDay = new Date();  // Текущая дата.

// Определение года, месяца и дня.
var thisYear = toDay.getYear() + 1900;
var thisMonth = theMonths[toDay.getMonth()];
var thisDay = thisMonth  + " " + toDay.getDate() + "," + (parseInt(toDay.getYear()) + 1900);

// Определение количества дней.
thisDay = Math.round(Date.parse(thisDay)/8.64e7);

// То же самое для дня начала текущего года.
var firstDay = "Jan 1, " + thisYear;
firstDay = Math.floor(Date.parse(firstDay)/8.64e7);

// То же самое для дня конца текущего года.
var lastDay = "Dec 31, " + thisYear;
lastDay = Math.floor(Date.parse(lastDay)/8.64e7);

// Количество дней в году.
var daysInYear = (lastDay - firstDay) + 1;

// Определение количество прошедших и оставшихся дней.
var daysElapsed = thisDay - firstDay;
var daysLeft = daysInYear - daysElapsed;

// Комментарии.
var comment1 = daysElapsed+ " days have elapsed in the year.";
var comment2 = "That means there are " + daysLeft + " days left in " + thisYear + ".";

// Особые случаи.
if (daysElapsed == 0)  {
comment1 = "Первого Января " + thisYear + " года.";
}
if (daysElapsed == 1) {
comment1 = "Прошел один день.";
}
if(daysElapsed == daysInYear) {
comment1 = thisYear + " закончен.";
}

if (daysLeft == 0)  {
comment2 = "Наилучшие пожелания в Новом Году!";
}
if (daysLeft == 1)  {
comment2 = "Остался один день в " + thisYear + " году.";
}
if (daysLeft == daysInYear)  {
comment2 = "С Новым Годом!";
}
Объект Number - Число
В дополнение к особым числовым свойствам (PI, например), доступным в объекте Math, в Microsoft JScript доступ к некоторым свойствам происходит через объект Number.

Свойство | Описание
MAX_VALUE Наибольшее доступное число - примерно 1.79E+308; положительное или отрицательное. (Значение может изменяться в зависимости от системы.)
MIN_VALUE | Наименьшее доступное число - примерно 2.22E-308; положительное или отрицательное. (Значение может изменяться в зависимости от системы.)
NaN | Специальное нечисловое значение, "not a number" - НеЧисло.
POSITIVE_INFINITY | Любое положительное число, большее Number.MAX_VALUE конвертируется в это значение; представляется как "Inf".
NEGATIVE_INFINITY | Любое отрицательное число, меньшее -Number.MAX_VALUE конвертируется в это значение; представляется как "-Inf".

Предупреждение Number.NaN - особое свойство, означающее нечисловое значение - "not a number." Например, деление на нуль возвращает NaN. Попытка использовать строку как число также возвращает Number.NaN. При сравнении NaN не равно ни какому-либо числу, ни самому себе. Следовательно, для проверки на результат NaN, не следует использовать сравнение с Number.NaN; для этого применяется функция isNaN().


Создание собственных объектов

Создание собственных объектов
 Описание JScript
Пред.

Для создания нового объекта, необходимо сначала определить его, присвоить ему свойства и, если необходимо, методы. Следующий пример создает объект pasta (макароны). Существует ключевое слово this, используемое для обращения к текущему объекту.
function pasta( grain, grain2, width, shape, shapenum, extent, egg )
{
  this.length = 7;   // Размер, количество свойств объекта, это свойство не включает само себя в размерность.
  this.grain = grain;   // Какие гранулы включены? (Строка)
  this.grain2 = grain2;   // Добавление другой муки? (Строка)
  this.width = width;     // Длина? (Число)
  this.shape = shape;   // Форма изделия? (Строка)
  this.shapenum = shapenum;  // Количество видов фигур? (Число)
  this.extent = extent;    // Количество штук? (Число)
  this.egg = egg;  // Применение яичного порошка? (Булево значение)
}
Однажды объявив объект, можно создавать новые экземпляры с помощью оператора new.
var spaghetti = new pasta("wheat", "", 0.2, "circle", 9, 30, true);
var linguine = new pasta("wheat", "", 0.3, "oval", 17, 30, true);
Можно добавлять свойства к одному экземпляру объекта, изменять экземпляр, но эти свойства не являются свойствами объекта, и не обнаруживаются в других экземплярах, если они не добавлены явно. Если требуется добавить свойства объекту для всех экземпляров, следует объявить их в определении объекта.
// Дополнительные свойства spaghetti.
spaghetti.color = "соломенный";
spaghetti.drycook = 7;
spaghetti.freshcook = 0.5;

var chowFun = new pasta("rice", "", 3, "flat", , 12, false);
/*
Ни объект chowFun, ни объект linguine, ни объект pasta
не содержат трех дополнительных свойств объекта spaghetti.
*/
Включение методов при определении
При определении объекта, в него можно включать методы. В следующем примере создается объект, содержащий массив строк и метод. Метод добавляет строку в массив, увеличивая размер объекта.
function addItem(newItem)  // Определение функции расширения списка
{
    this.length += 1;  // Увеличение размера массива.
    this[(this.length-1)] = newItem;  // Добавление нового элемента, сохраняя нумерацию.
}

function shoppingList(firstItem) // Объявление объекта "Список покупок".
{
    this.length = 2;  // Количество свойств объекта, исключая само свойство размера.
    this.addItem = addItem;   // Включение функции addItem как метода.
    this[(this.length-1)] = firstItem;  // Первому элементу присвоен номер 1.
}

var myList = new shoppingList("Молоко");
myList.addItem("Яйцо");  // Применение метода для добавления "Яйцо", элементу присвоен номер 2.
myList.addItem("Крупа");  // "Крупа" получает номер 3.
В данном случае, содержание массива следующее:
  • myList[length] равно 4
  • myList[addItem] является функцией addItem
  • myList[1] is Молоко
  • myList[2] is Яйцо
  • myList[3] is Крупа
Обратите внимание, что индексирование не так точно, как Вы могли бы ожидать. Если выполняется цикл for...in в этом массиве, цикл выполняет итерации в порядке, приведенном здесь, и переменная цикла имеет первоначальное значение "длиной" 0.


FileSystemObject Glossary

Microsoft® Scripting Library - FileSystemObject
FileSystemObject Glossary 		Scripting Run-Time Reference

array
A set of sequentially indexed elements having the same type of data. Each element of an array has a unique identifying index number. Changes made to one element of an array do not affect the other elements.

collection
An object that contains a set of related objects. An object's position in the collection can change whenever a change occurs in the collection; therefore, the position of any specific object in the collection may vary.

run-time error
An error that occurs when code is running. A run-time error results when a statement attempts an invalid operation.

string expression
Any expression that evaluates to a sequence of contiguous characters. Elements of a string expression can include a function that returns a string, a string literal, a string constant, or a string variable.

type library
A file or component within another file that contains standard descriptions of exposed objects, properties, and methods.


СЛОВАРЬ JScript

СЛОВАРЬ JScript 		Справочник языка

ASCII Character Set
American Standard Code for Information Interchange (ASCII) - Американский Стандартный Код Обмена Информацией - 7-разрядное представление букв и символов стандартной U.S.-клавиатуры. ASCII содержит коды 128 символов (0–127).

Automation object
Объект, выставленный другим приложениям и инструментариям через автоматический интерфейс.

bitwise comparison
Поразрядное сравнение - сравнение значений позиций битов двух числовых выражений.

Boolean expression
Выражение, принимающее значение либо true, либо false. Нелогическое выражение преобразовывается в булево согласно следующим правилам:
  • Все объекты принимаются за true.
  • Строки принимают значение false, только если они пустые.
  • null и undefined возвращают false.
  • Числа принимают значение false, только если равны нулю.

character code
Числовой код представления символов, например, ASCII-стандарт.

class
Формальное определение объекта. Класс действует как шаблон объекта, во время выполнения программы.

comment
Комментарий - текстовой блок, игнорируется интепретатором, предназначен для пояснения кода. В JScript строка комментария начинается с //. Многострочный комментарий имеет вид: /* текст комментария */.

comparison operator
Операторы сравнения - определяют отношение двух выражений. К ним относятся МЕНЬШЕ (<), МЕНЬШЕ ИЛИ РАВНО (<=), БОЛЬШЕ (>), БОЛЬШЕ ИЛИ РАВНО (>=), НЕРАВНО (!=) и РАВНО (==).

compound statement
Составная инструкция. Последовательность выражений, заключенная в фигурные скобки({}). Несколько инструкций выполняются последовательно как одна.

constructor
Конструктор - функция JScript с двумя особыми свойствами:
  • Вызывается оператором new.
  • Пропускают адрес нового объекта через ключевое слово this.
Конструкторы применяются для инициализации нового объекта.

expression
Выражение - комбинация слов, операторов, переменных, символов, чисел или объектов. Выражения применяются для вычислений, обработки символов, вызова функции или проверки данных.

intrinsic object
Встроенный объект - объект, определенный в стандарте языка JScript. Такие объекты могут применятся в любых сценариях. Встроенными объектами языка JScript являются: Array, Boolean, Date, Function, Global, Math, Number, Object, RegExp, Regular Expression и String.

local time
Время, установленное на компьютере клиента или сервера, в зависимости от того, где исполняется сценарий.

locale
Набор информации, соответствующий данному языку и стране. Локаль воздействует на язык предопределенных терминов программирования и установок, специфических для установленных страны и языка. Отметим два момента, где установки локали важны:
  • Локаль воздействует на язык терминов типа ключевых слов и определяет региональные установки типа десятичного числа и разделителей элементов списка, форматов даты и порядка сортировки символов.
  • Локаль воздействует на порядок и способы преобразования типов данных, например, на вывод чисел при преобразовании строк. Вы можете установить региональные установки, используя утилиты Панели Управления, включенные в операционную систему.

null
Значение указывает на то, что переменная не содержит достоверного значения. Значение null может быть результатом:
  • Явного назначения переменной значения null.
  • Операции между выражениями, содержащих значение null.

numeric expression
Любое выраженние, которое можно оценить в качестве числа. При некоторых обстоятельствах, если возможно, строки могут преобразовываться в числовые выражения.

primitive
Примитив - тип данных языка JScript, который управляется значениями. Типы данных в JScript, рассматриваемые как примитивы - числовой, логический, строковый и функция. Объекты и массивы - не примитивные типы данных.

property
Именованный атрибут объекта. Свойства определяют характеристики объекта - размер, цвет или состояние объекта, например, enabled или disabled.

run-time error
Ошибка, возникающая во время выполнения программы. Ошибка run-time error является результатом попытки выполнения инструкцией недопустимой операции.

scope
Область видимости - определяет видимость переменной, процедуры или объекта. Переменные, объявленные в функциях, видимы только в пределах функции.

string comparison
Сравнение строк - сравнение двух символьных последовательностей. Если не определена функция для сравнения, сравнение строк происходит поразрядно (побитово). В английских строках, бинарное сравнение - регистро-чувствительное, а текстовое сравнение - нет.

string expression
Строковое выражение - выражение, состоящее из последовательности символов. Элементы строковых выражений могут включать возвращающие строки функции, строковые литералы, объекты String или переменные строкового типа.

undefined
Неопределенное значение - особый случай, когда переменная объявлена, но значение ей еще не присвоено.

Universal Coordinated Time (UTC)
Универсальная координата времени, является Международным эталоном времени. Упоминается как Среднее время по Гринвичу или GMT.

user-defined object
Пользовательский объект - объект, созданный пользователем при помощи своего кода.

variable
Переменная - определенная именованная порция информации. В JScript нет строго контроля типа данных, переменная может быть разных типов в зависимости от условий сценария.

wrapper
Объект, созданный для обеспечения объектно-ориентированного интерфейса к некоторым другим типам данных. Объекты Number и Boolean являются примерами wrapper-объектов.


Поведение операторов

Поведение операторов 		Справочник языка
Версия 1

Следующая таблица описывает поведение большинства операторов Microsoft JScript. Столбцы и строки представляют различные типы выражений по обе стороны оператора JScript, поведение оператора указано на пересечении столбца и строки.

Символ E означает ошибку типа run-time error. Символ N означает числовой или логический результат.

obj | as | ns | num | bool | undef | null
obj | N | E | N | N | N | E | E
as | E | E | E | E | E | E | E
ns | N | E | N | N | N | E | E
num | N | E | N | N | N | E | E
bool | N | E | N | N | N | E | E
undef | E | E | E | E | E | E | E
null | E | E | E | E | E | E | E

obj = объект, as = символьно-цифровая строка, ns = числовая строка, num = число, bool = логическое(булево) значение, undef = неопределенное значение, null = значение null.


Метод concat (Массив)

Метод concat (Массив) 		Справочник языка
Версия 3

См. также Применение

Описание
Слияние двух массивов с созданием одного массива.
Синтаксис
array1.concat(array2)

Синтаксис метода concat состоит из частей:

Часть | Описание
array1 | Требуется. Объект Array, соединяемый с array2.
array2 | Требуется. Объект Array, присоединяемый к концу array1.

Примечание
Метод concat возвращает объект Array, состоящий из массивов array1 и array2.

Если ссылка объекта копируется с array1 или array2, результатом является тот же самый объект.

В следующем примере применяется метод concat:

function ConcatArrayDemo()
{
  var a, b, c;
  a = new Array(0,1,2,3,4);
  b = new Array(5,6,7,8,9);
  c = a.concat(b);
  return(c);
}


Метод concat (Массив)

Метод concat (Массив)
Применение 		Справочник языка

Объект Array
Объект String


Метод concat (Массив)

Метод concat (Массив)
См. также 		Справочник языка

Метод concat (Строка)
Метод join


Метод join

Метод join 		Справочник языка
Версия 2

См. также Применение

Описание
Преобразование всех элементов массива в объект String и соединяет их.
Синтаксис

arrayobj.join(separator)

Параметр separator - объект String, используемый для соединения одного элемента массива arrayobj со следующим при создании нового объекта String. Если он опущен, элементы массива разделены пустой строкой.

Примечание
Метод join возвращает объект String, содержащий все элементы, преобразованные в строку и соединенные вместе.

В следующем примере применяется метод join:

function JoinDemo()
{
  var a, b;
  a = new Array(0,1,2,3,4);
  b = a.join("-");
  return(b);
}


Метод join

Метод join
Применение 		Справочник

Объект Array


Метод join

Метод join
См. также 		Справочник языка

Методы объекта Array
Объект String


Свойство length (Массивы)

Свойство length (Массивы) 		Справочник языка
Версия 2

См. также Применение

Описание
Определяет целое число, большее на единицу чем самый большой индекс, определенный в массиве.
Синтаксис

numVar = arrayObj.length

Примечание
Поскольку нумерация индексов в массиве не должна быть непрерывной, свойство length необязательно равно количеству элементов массива. Например, в следующем примере, my_array.length содержит 7, а не 2:
var my_array = new Array( );
my_array[0] = "Тест";
my_array[6] = "Еще один тест";
Если значение, меньшее чем предыдущее значение назначено на свойство length, массив будет обрезан, а все элементы с индексами, равными или большими чем новое значение свойства length будут утеряны.

Если значение, большее чем предыдущее значение назначено на свойство length, массив будет расширен, а всем новым элементам будет присвоено значение undefined.

В следующем примере иллюстрируется применение свойства length:

function LengthDemo()
{
  var a, l;
  a = new Array(0,1,2,3,4);
  l = a.length;
  return(l);
}


Свойство length (массив)

Свойство length (массив)
Применение 		Справочник языка

Объект Array


length Property (Array)

length Property (Array)
См. также 		Справочник языка

Свойство length (Функция)
Свойство length (Строка)


Метод reverse

Метод reverse 		Справочник языка
Версия 2

См. также Применение

Описание
Меняет элементы объекта Array в обратном порядке.
Синтаксис
arrayobj.reverse( )
Примечание
Метод reverse размещает элементы в объекте Array в обратном порядке. Во время выполнения новый объект Array не создается.

Если массив не непрерывен, метод reverse создает элементы в массиве, заполняя разрывы в массиве. Каждый из таких элементов имеет неопределенное значение (undefined).

В следующем примере используется метод reverse:

function ReverseDemo()
{
  var a, l;
  a = new Array(0,1,2,3,4);
  l = a.reverse();
  return(l);
}


Метод reverse

Метод reverse
Применение 		Справочник языка

Объект Array


Метод reverse

Метод reverse
См. также 		Справочник языка

Методы объекта Array


Метод slice (Массив)

Метод slice (Массив) 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает часть массива.
Синтаксис
arrayObj.slice(start, [end])

Синтаксис метода slice состоит из частей:

Часть | Описание
arrayObj | Требуется. Объект Array.
start | Требуется. Номер индекса массива arrayObj (начиная с нуля).
end | Необязательно. Конечный индекс arrayObj (начиная с нуля).

Примечание
Метод slice возвращает объект Array, содержащий часть массива arrayObj.

Метод slice копирует, но не включает элементы указанные за end. Если end отрицательно, указывается смещение с конца arrayObj. Кроме того, в данном случае, отсчитывание начинается не с нуля. Если опущено, извлечение происходит до конца массива arrayObj.

В следующем примере последний элемент myArray копируется в newArray:

newArray = myArray.slice(0, -1)
Если ссылка объекта arrayObj копируется в результат, она указывает на тот же самый объект.


Метод slice

Метод slice
Применение 		Справочник языка

Объект Array
Объект String


Метод slice (Массив)

Метод slice
См. также 		Справочник языка

Метод slice (Строка)


Метод sort

Метод sort 		Справочник языка
Версия 2

См. также Применение

Описание

Сортировка элементов объекта Array.

Синтаксис
arrayobj.sort(sortfunction)

Параметр sortfunction является именем функции, используемой для установки порядка элементов. Если опущен, элементы сортируются по возрастанию, в порядке ASCII.

Примечание
Метод sort сортирует объект Array с размещением; никакой новый объект Array при выполнении не создается.

Если применяется аргумент sortfunction, возвращается одно из следующих значений:

  • Отрицательное значение, если первый параметр меньше чем второй параметр.
  • Нуль, если оба элемента эквивалентны.
  • Положительное значение, если первый параметр больше чем второй параметр.

В следующем примере применен метод sort:

function SortDemo()
{
  var a, l;
  a = new Array("X" ,"y" ,"d", "Z", "v","m","r");
  l = a.sort();
  return(l);
}


Метод sort

Метод sort
Применение 		Справочник языка

Объект Array


Drives Collection

Совокупность дисков 		Справочник языка
Версия 3

См. также Свойства Методы

Описание
Совокупность всех доступных дисков. Только для чтения.
Примечание
Для того, чтобы появиться в совокупности Drives, съемные устройства должны быть вставлены.

Следующий пример показывает, как совкупность Drives использует свойство Drives и выполняет итерации в объекте Enumerator:

function ShowDriveList()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[Устройство не готово]";
    s +=  n + "<br>";
  }
  return(s);
}


Drives Collection

Совокупность дисков
См. также 		Справочник языка

Объект Drive
Свойства дисков
Объект File
Совокупность файлов
Объект Folder
Совокупность папок


Совокупность дисков

Совокупность дисков
Методы 		Справочник языка

Совокупность дисков не содержит методов.


Drives Collection

Совокупность дисков
Свойства 		Справочник языка

Свойство Count
Свойство Item


Совокупность файлов

Совокупность файлов 		Справочник языка
Версия 3

См. также Свойства Методы

Описание
Совокупность всех объектов File в пределах папки.
Примечание
В следующем примере показано получение совокупности файлов, применяя объект Enumerator и инструкцию for:
function ShowFolderFileList(folderspec)
{
  var fso, f, f1, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(folderspec);
  fc = new Enumerator(f.files);
  s = "";
  for (; !fc.atEnd(); fc.moveNext())
  {
      s += fc.item();
      s += "<br>";
  }
  return(s);
}


Совокупность файлов

Совокупность файлов
См. также 		Справочник языка

Объект Drive
Совокупность дисков
Объект File
Объект Folder
Совокупность папок


Совокупность файлов

Совокупность файлов
Методы 		Справочник языка

Совокупность файлов не имеет методов.


Совокупность файлов

Совокупность файлов
Свойства 		Справочник языка

Свойство Count
Свойство Item


Folders Collection

Совокупность папок 		Справочник языка
Версия 3

См. также Свойства Методы

Описание
Совокупность всех объектов Folder, содержащихся в указанном объекте Folder.
Примечание
Следующий пример показывает, как получить совокупность папок с помощью проведения итераций в объекте Enumerator, применяя инструкцию for:
function ShowFolderList(folderspec)
{
  var fso, f, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(folderspec);
  fc = new Enumerator(f.SubFolders);
  s = "";
  for (; !fc.atEnd(); fc.moveNext())
  {
    s += fc.item();
    s += "<br>";
  }
  return(s);
}


Folders Collection

Совокупность папок
См. также 		Справочник языка

Объект Drive
Совокупность дисков
Объект File
Совокупность файлов
Объект Folder
Свойство SubFolders


Folders Collection

Совокупность папок
Методы 		Справочник языка

Метод Add (Folders)


Folders Collection

Совокупность папок
Свойства 		Справочник языка

Свойство Count
Свойство Item


Трансляция условных выражений

Трансляция условных выражений 		Справочник языка
Версия 3

См. также

Описание
Позволяет использовать новые особенности языка JScript без проблем совместимости с браузерами, не поддерживающими такие выражения.
Примечание
Для активации трансляции условных выражений применяется инструкция @cc_on или инструкции @if или @set вне комментария. Некоторые применения трансляции условных выражений являются новыми особенностями JScript.

Строго рекомендуется код трансляции условных выражений размещать в комментариях:

/*@cc_on @*/
/*@if (@_jscript_version == 4)
   alert("JScript Версия 4");
   @else @*/
   alert("Необходима более поздняя версия обработчика JScript.");
/*@end @*/
Этот пример использует специальные разделители комментария, которые используются только лишь при трансляции условных выражений с помощью инструкции @cc_on. Обработчик сценария, не понимающий трансляцию условных выражений, выдаст сообщение о необходимости обновления.


Трансляция условных выражений

Трансляция условных выражений
См. также 		Справочник языка

Переменные условных выражений
Инструкция @cc_on
Инструкция @if
Инструкция @set


Переменные условных выражений

Переменные условных выражений 		Справочник языка
Версия 3

См. также

Следующие переменные предопределены и применяются при трансляции условных выражений. Если переменная не равна true, она не определена и при обращении к ней ведет как значение NaN.

Переменная | Описание
@_win32 | true при работе Win32 системы.
@_win16 | true при работе Win16 системы.
@_mac | true при работе на Apple Macintosh.
@_alpha | true при работе на DEC Alpha процессоре.
@_x86 | true при работе на процессорах Intel.
@_mc680x0 | true при работе на процессоре Motorola 680x0.
@_PowerPC | true при работе на процессоре Motorola PowerPC.
@_jscript | Всегда true.
@_jscript_build | Содержит build-номер обработчика сценариев JScript.
@_jscript_version | Содержит версию JScript в формате major.minor.


Переменные условных выражений

Переменные условных выражений
См. также 		Справочник языка

Трансляция условных выражений
Инструкция @cc_on
Инструкция @if
Инструкция @set


jscopy

Copyright

Microsoft® JScript®

Information in this document is subject to change without notice. The names of companies, products, people, characters, and/or data mentioned herein are fictitious and are in no way intended to represent any real individual, company, product, or event, unless otherwise noted. Complying with all applicable copyright laws is the responsibility of the user. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 1991-2000 Microsoft Corporation. All rights reserved.

Microsoft, MS, MS-DOS, ActiveX, JScript, Microsoft Press, Visual Basic, Windows, Windows NT, Win32, and Win32s are either registered trademarks or trademarks of Microsoft Corporation in the U.S.A. and/or other countries.

Other product and company names mentioned herein may be the trademarks of their respective owners.


Метод getDate

Метод getDate 		Справочник языка
Версия 1

См. также Применение

Описание

Возвращает день месяца, сохраненный в объекте Date согласно локальному времени (local time).

Синтаксис
objDate.getDate()
Примечание
Для получения значения даты согласно UTC применяется метод getUTCDate.

Возвращаемое значение является целым числом от 1 до 31 и представляетс сохраненную в объекте Date дату.

В следующем примере применен метод getDate:

function DateDemo()
{
  var d, s = "Сегодня: ";
  d = new Date();
  s += (d.getMonth() + 1) + "/";
  s += d.getDate() + "/";
  s += d.getYear();
  return(s);
}


Метод getDate

Метод getDate
Применение 		Справочник языка

Объект Date


Метод getDate

Метод getDate
См. также 		Справочник языка

Методы объекта Date
Метод getUTCDate
Метод setDate
Метод setUTCDate


Метод getDay

Метод getDay 		Справочник языка
Версия 1

См. также Применение

Описание
Представляет день недели, сохраненный в объекте Date согласно локальному времени (local time).
Синтаксис
objDate.getDay()
Применение
Дня получения даты согласно UTC применяется метод getUTCDay.

Возвращаемое значение из метода getDay является целым числом между 0 и 6 и обозначает день недели (воскресенье-суббота):

0 = Sunday
1 = Monday
2 = Tuesday
3 = Wednesday
4 = Thursday
5 = Friday
6 = Saturday

В следующем примере используется метод getDay:

function DateDemo()
{
  var d, day, x, s = "Сегодня: ";
  var x = new Array("Sunday", "Monday", "Tuesday");
  var x = x.concat("Wednesday","Thursday", "Friday");
  var x = x.concat("Saturday");
  d = new Date();
  day = d.getDay();
  return(s += x[day]);
}


Метод getDay

Метод getDay
Применение 		Справочник языка

Объект Date


Метод getDay

Метод getDay
См. также 		Справочник языка

Методы объекта Date
Метод getUTCDay


Метод getFullYear

Метод getFullYear 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает значение года, хранящееся в объекте Date согласно локальному времени (local time).
Синтаксис
objDate.getFullYear()
Примечание
Для получения года согласно UTC применяется метод getUTCFullYear.

Метод getFullYear возвращает абсолютное значение года. Например, 1976 год возвращается как 1976. Это позволяет избегать некоторых проблем представления дат ("Проблема-2000").

Метод GetFullYear применен в следующем примере:

function DateDemo()
{
  var d, s = "Today's UTC date is: ";
  d = new Date();
  s += (d.getMonth() + 1) + "/";
  s += d.getDate() + "/";
  s += d.getFullYear();
  return(s);
}


Метод getFullYear

Метод getFullYear
Применение 		Справочник языка

Объект Date


Метод getFullYear

Метод getFullYear
См. также 		Справочник языка

Методы объекта Date
Метод getUTCFullYear
Метод setFullYear
Метод setUTCFullYear


Метод getHours

Метод getHours 		Справочник языка
Версия 1

См. также Применение

Описание
Возвращает значение часов, сохраненное в объекте Date согласно локальному времени (local time).
Синтаксис
objDate.getHours()
Примечание
Для получения значения часов согласно UTC, необходимо применять метод getUTCHours.

Метод getHours возвращает целое значение от 0 до 23, сообщающее от количестве часов, прошедших после полуночи. Нуль означает два случая: время до 1:00:00 am или время не сохранено в объекте Date при его создании. Единственный способ определить случай, это проверить минуты и секунды для нулевых значений часа. Если все эти значения равны нулю, то скорей всего, время не сохранено в объекте Date.

В следующем примере используется метод getHours:

function TimeDemo()
{
  var d, s = "Текущее локальное время: ";
  var c = ":";
  d = new Date();
  s += d.getHours() + c;
  s += d.getMinutes() + c;
  s += d.getSeconds() + c;
  s += d.getMilliseconds();
  return(s);
}


Метод getHours

Метод getHours
Применение 		Справочник языка

Объект Date


Метод getHours

Метод getHours
См. также 		Справочник языка

Методы объекта Date
Метод getUTCHours
Метод setHours
Метод setUTCHours


Метод getMilliseconds

Метод getMilliseconds 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает количество миллисекунд, прошедших от последней секунды согласно локальному времени (local time).
Синтаксис
objDate.getMilliseconds()
Примечание
Для получения числа миллисекунд согласно UTC следует использовать метод getUTCMilliseconds.

Возвращается значение миллисекунд в диапазоне 0-999.

Метод getMilliseconds применен в следующем примере:

function TimeDemo()
{
  var d, s = "Текущее локальное время: ";
  var c = ":";
  d = new Date();
  s += d.getHours() + c;
  s += d.getMinutes() + c;
  s += d.getSeconds() + c;
  s += d.getMilliseconds();
  return(s);
}


Метод getMilliseconds

Метод getMilliseconds
Применение 		Справочник языка

Объект Date


Метод getMilliseconds

Метод getMilliseconds
См. также 		Справочник языка

Методы объекта Date
Метод getUTCMilliseconds
Метод setMilliseconds
Метод setUTCMilliseconds


Метод getMinutes

Метод getMinutes 		Справочник языка
Версия 1

См. также Применение

Описание
Возвращает количество полных минут, прошедших по окончании последнего часа согласно локальному времени (local time).
Синтаксис
objDate.getMinutes()
Применение
Для получения минут согласно UTC необходимо применять метод getUTCMinutes.

Мeтод getMinutes возвращает целое число от 0 до 59, равное значению минут, хранящемуся в объекте Date. Ноль возвращается в двух случаях: после окончание часа прошло менее одной минуты, или время не сохранено в объекте Date, когда объект быть создан. Единственный способ определить причину - проверить на нулевые значения часы и секунды. Если все равно нулю, то скорей всего, время не хранится в объекте Date.

В следующем примере используется метод getMinutes:

function TimeDemo()
{
  var d, s = "Текущее локальное время: ";
  var c = ":";
  d = new Date();
  s += d.getHours() + c;
  s += d.getMinutes() + c;
  s += d.getSeconds() + c;
  s += d.getMilliseconds();
  return(s);
}


Метод getMinutes

Метод getMinutes
Применение 		Справочник языка

Объект Date


Метод getMinutes

Метод getMinutes
См. также 		Справочник языка

Методы объекта Date
Метод getUTCMinutes
Метод setMinutes
Метод setUTCMinutes


Метод getMonth

Метод getMonth 		Справочник языка
Версия 1

См. также Применение

Описание
Возвращает значение месяца из объекта Date согласно локальному времени (local time).
Синтаксис
objDate.getMonth()
Примечание
Для получения значения месяца согласно UTC применяется метод getUTCMonth.

Метод getMonth возвращает целое число в диапазоне 0-11, указывает на месяц, хранящийся в объекте Date. Значение месяца меньше на единицу его порядкового номера. Например, если дата "Jan 5, 1996 08:47:00" хранится в объекте Date, метод getMonth возвращает 0.

Метод getMonth применен в следующем примере:

function DateDemo()
{
  var d, s = "Сегодня: ";
  d = new Date();
  s += (d.getMonth() + 1) + "/";
  s += d.getDate() + "/";
  s += d.getYear();
  return(s);
}


Метод getMonth

Метод getMonth
Применение 		Справочник языка

Объект Date


Метод getMonth

Метод getMonth
См. также 		Справочник языка

Методы объекта Date
Метод getUTCMonth
Метод setMonth
Метод setUTCMonth


Метод getSeconds

Метод getSeconds 		Справочник языка
Версия 1

См. также Применение

Описание
Возвращает количество секунд, прошедших по окочании последней минуты из объекта Date согласно локальному времени (local time).
Синтаксис
objDate.getSeconds()
Примечание
Для получения значения секунд согласно UTC, необходимо использовать метод getUTCSeconds.

Метод getSeconds возвращает целое значение в диапазоне 0-59, указывает на значение секунд объекта Date. Ноль возвращается в двух случаях. Первый - когда прошло менее одной секунды в текущей минуте. Второк - когда время не сохранено в объекте Date при его создании. Для определения причины следует проверить часы и минуты на нулевое значение. Если все значения равны нулю, то, скорее всего, время не хранится в объекте Date.

Метод getSeconds применен в следующем примере:

function TimeDemo()
{
  var d, s = "Текущее локальное время: ";
  var c = ":";
  d = new Date();
  s += d.getHours() + c;
  s += d.getMinutes() + c;
  s += d.getSeconds() + c;
  s += d.getMilliseconds();
  return(s);
}


Метод getSeconds

Метод getSeconds
Применение 		Справочник языка

Объект Date


Метод getSeconds

Метод getSeconds
См. также 		Справочник языка

Методы объекта Date
Метод getUTCSeconds
Метод setSeconds
Метод setUTCSeconds


Метод getTime

Метод getTime 		Справочник языка
Версия 1

См. также Применение

Описание
Возвращает время, хранящееся в объекте Date.
Синтаксис
objDate.getTime()
Примечание
Метод getTime возвращает целое значение, равное числу миллисекунд, прошедших с полуночи 01/01/1970 до времени, сохраненном в объекте Date. Диапазон дат равен примерно 285,616 лет от 01/01/1970 - в прошлое или будущее. Отрицательные числа указывают на дату до 1970 года.

При вычислении дат и времени часто необходимо определить переменные, равные количеству миллисекунд, выраженных через дни, часы или минуты. Например:

var MinMilli = 1000 * 60
var HrMilli = MinMilli * 60
var DyMilli = HrMilli * 24
В следующем примере применен метод getTime:
function GetTimeTest()
{
  var d, s, t;
  var MinMilli = 1000 * 60;
  var HrMilli = MinMilli * 60;
  var DyMilli = HrMilli * 24;
  d = new Date();
  t = d.getTime();
  s = "Прошло "
  s += Math.round(t / DyMilli) + " дней с 01/01/1970";
  return(s);
}


Метод getTime

Метод getTime
Применение 		Справочник языка

Объект Date


Метод getTime

Метод getTime
См. также 		Справочник языка

Методы объекта Date
Метод setTime


Метод getTimezoneOffset

Метод getTimezoneOffset 		Справочник языка
Версия 1

См. также Применение

Описание

Определяет разность в минутах между временем на хосте и UTC.

Синтаксис
objDate.getTimezoneOffset()
Примечание
Метод getTimezoneOffset возвращает целое значение, представляющее собой количество минут разницы между локальной машиной и UTC. Это значение соответствует компьютеру, на котором выполняется сценарий. Если вызван серверный сценарий, возвращается значение для сервера. Если вызван клиентский сценарий, возвращается значение для клиента.

Значение может быть как положительным, так и отрицательным.

Например, сервер в New York City входит в контакт с клиентом в Los Angeles 1 декабря. getTimezoneOffset возвращает 480 при выполнении клиентом и 300 при выполнении сервером.

Метод getTimezoneOffset применен в следующем примере:

function TZDemo()
{
  var d, tz, s = "Текущее локальное время ";
  d = new Date();
  tz = d.getTimezoneOffset();
  if (tz < 0)
    s += tz / 60 + " часов до GMT";
  else if (tz == 0)
    s += "GMT";
  else
    s += tz / 60 + " часов после GMT";
  return(s);
}


Метод getTimezoneOffset

Метод getTimezoneOffset
Применение 		Справочник языка

Объект Date


Метод getTimezoneOffset

Метод getTimezoneOffset
См. также 		Справочник языка

Методы объекта Date


Метод getUTCDate

Метод getUTCDate 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает значение числа месяца, сохраненное в объекте Date согласно UTC.
Синтаксис
objDate.getUTCDate()
Примечание
Дня получения даты согласно локальному времени (local time) следует применять метод getDate.

Возвращаемое значение является целым числом в диапазоне 1-31, хранящееся в объекте Date.

В следуещем примере применяется метод getUTCDate:

function UTCDateDemo()
{
  var d, s = "Сегодня по UTC: ";
  d = new Date();
  s += (d.getUTCMonth() + 1) + "/";
  s += d.getUTCDate() + "/";
  s += d.getUTCFullYear();
  return(s);
}


Метод getUTCDate

Microsoft® JScriptJScript
Метод getUTCDate
Применение 		Справочник языка

Объект Date


Метод getUTCDay

Метод getUTCDay 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает значение дня недели, сохраненное в объекте Date согласно UTC.
Синтаксис
objDate.getUTCDay()
Примечание
Для получения дня недели согласно локального времени (local time) следует использовать метод getDate.

Возвращаемое значение метода getUTCDay - целое число в диапазоне 0-6, обозначающее день недели (воскресенье-суббота):

0 = Sunday
1 = Monday
2 = Tuesday
3 = Wednesday
4 = Thursday
5 = Friday
6 = Saturday
В следующем примере используется метод getUTCDay:
function DateDemo()
{
  var d, day, x, s = "Сегодня ";
  var x = new Array("Sunday", "Monday", "Tuesday");
  x = x.concat("Wednesday","Thursday", "Friday");
  x = x.concat("Saturday");
  d = new Date();
  day = d.getUTCDay();
  return(s += x[day]);
}


Метод getUTCDay

Метод getUTCDay
Применение 		Справочник языка

Объект Date


Метод getUTCDay

Метод getUTCDay
См. также 		Справочник языка

Методы объекта Date
Метод getDay


Метод getUTCFullYear

Метод getUTCFullYear 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает год из объекта Date согласно UTC.
Синтаксис
objDate.getUTCFullYear()
Примечание
Для получения года согласно локальному времени (local time) следует применять метод getFullYear.

Мeтод getUTCFullYear возвращает абсолютное значение года. Это позволяет избежать проблем с датами ("Проблема-2000").

Применение метода getUTCFullYear показано в следующем примере:

function UTCDateDemo()
{
  var d, s = "Сегодня (согласно UTC): ";
  d = new Date();
  s += (d.getUTCMonth() + 1) + "/";
  s += d.getUTCDate() + "/";
  s += d.getUTCFullYear();
  return(s);
}


Метод getUTCFullYear

Метод getUTCFullYear
Применение 		Справочник языка

Объект Date


Метод getUTCFullYear

Метод getUTCFullYear
См. также 		Справочник языка

Методы объекта Date
Метод getFullYear
Метод setFullYear
Метод setUTCFullYear


Метод getUTCHours

Метод getUTCHours 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает значение часа, хранящееся в объекте Date согласно UTC.
Синтаксис
objDate.getUTCHours()
Примечание
Для получения количества часов, прошедших после полуночи локального времени (local time), следует применять метод getHours.

Метод getUTCHours возвращает целое значение в диапазоне 0-23, являющееся количеством часов, прошедших после полуночи. Значение, равное нулю, возможно в двух случаях: либо время до 1:00:00 A.M., либо время не сохранено в объекте Date при его создании. Для определения причины следует проверить минуты и секунды на нулевые значения. Если все эти значения равны нулю, то скорее всего время не хранится в объекте Date.

В следующем примере применен метод getUTCHours:

function UTCTimeDemo()
{
  var d, s = "Текущее время по UTC: ";
  var c = ":";
  d = new Date();
  s += d.getUTCHours() + c;
  s += d.getUTCMinutes() + c;
  s += d.getUTCSeconds() + c;
  s += d.getUTCMilliseconds();
  return(s);
}


Метод getUTCHours

Метод getUTCHours
Применение 		Справочник языка

Объект Date


Метод getUTCHours

Метод getUTCHours
См. также 		Language Reference

Методы объекта Date
Метод getHours
Метод setHours
Метод setUTCHours


Метод getUTCMilliseconds

Метод getUTCMilliseconds 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает значение количество миллисекунд, прошедших с окончания последней секунды, хранящееся в объекте Date согласно UTC.
Синтаксис
objDate.getUTCMilliseconds()
Примечание
Для получения количества миллисекунд по локальному времени (local time) необходимо использовать метод getMilliseconds.

Значение миллисекунд возвращается в диапазоне 0-999.

В приведенном ниже примере применен метод getUTCMilliSeconds:

function UTCTimeDemo()
{
  var d, s = "Текущее время UTC: ";
  var c = ":";
  d = new Date();
  s += d.getUTCHours() + c;
  s += d.getUTCMinutes() + c;
  s += d.getUTCSeconds() + c;
  s += d.getUTCMilliseconds();
  return(s);
}


Метод getUTCMilliseconds

Метод getUTCMilliseconds
Применение 		Справочник языка

Объект Date


Метод getUTCMilliseconds

Метод getUTCMilliseconds
См. также 		Справочник языка

Методы объекта Date
Метод getMilliseconds
Метод setMilliseconds
Метод setUTCMilliseconds


Метод getUTCMinutes

Метод getUTCMinutes 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает количество минут, прошедших в текущем часе. Значение минут хранится в объекте Date согласно UTC.
Синтаксис
objDate.getUTCMinutes()
Примечание
Для получения количества минут согласно локальному времени (local time) следует использовать метод getMinutes.

Метод getUTCMinutes возвращает целое значение диапазона 0-59, равное значению минут, хранящемуся в объекте Date. Нулевое значение возможно в двух случаях: либо по окончании предыдущего часа прошло менее одной минуты, либо время не сохранено в объекте Date при его создании. Для определения причины необходимо проверить на нулевые значения часы и секунды. Если все значения - нулевые, то скорей всего время не было сохранено в объекте Date.

Метод getUTCMinutes применен в следующем примере:

function UTCTimeDemo()
{
  var d, s = "Время по UTC: ";
  var c = ":";
  d = new Date();
  s += d.getUTCHours() + c;
  s += d.getUTCMinutes() + c;
  s += d.getUTCSeconds() + c;
  s += d.getUTCMilliseconds();
  return(s);
}


Метод getUTCMinutes

Метод getUTCMinutes
Применение 		Справочник языка

Объект Date


Метод getUTCMinutes

Метод getUTCMinutes
См. также 		Справочник языка

Методы объекта Date
Метод getMinutes
Метод setMinutes
Метод setUTCMinutes


Метод getUTCMonth

Метод getUTCMonth 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает значение месяца, хранящееся в объекте Date согласно UTC.
Синтаксис
objDate.getUTCMonth()
Примечание
Для получения значения месяца согласно локальному времени (local time) следует применять метод getMonth.

Метод getUTCMonth возвращает целое значение в диапазоне 0-11, указывающее на значение месяца, сохраненное в объекте Date. Значение равно порядковому номеру месяца, уменьшенного на единицу.

Метод getUTCMonth применен в следующем примере:

function UTCDateDemo()
{
  var d, s = "Сегодня по UTC: ";
  d = new Date();
  s += (d.getUTCMonth() + 1) + "/";
  s += d.getUTCDate() + "/";
  s += d.getUTCFullYear();
  return(s);
}


Метод getUTCMonth

Метод getUTCMonth
Применение 		Справочник языка

Объект Date


Метод getUTCMonth

Метод getUTCMonth
См. также 		Справочник языка

Методы объекта Date
Метод getMonth
Метод setMonth
Метод setUTCMonth


Метод getUTCSeconds

Метод getUTCSeconds 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает количество секунд, прошедших по окончанию последней минуты, значение хранится в объекте Date согласно UTC.
Синтаксис
objDate.getUTCSeconds()
Примечание
Для получения количества секунд согласно локальному времени (local time) необходимо использовать метод getSeconds.

Метод getUTCSeconds возвращает целое значение в диапазоне 0-59, указывающее на значение секунд из указанного объекта Date. Нуль возможен в двух случаях: либо в текущей минуте прошло менее одной секунды, либо время не было сохранено в объекте Date при его создании. Для определения причины следует проверить на нулевые значения минуты и часы. Если все значения равны нулю, то скорей всего время не было сохранено в объекте Date.

Применение метода getUTCSeconds приведено в следующем примере:

function UTCTimeDemo()
{
  var d, s = "Текущее время UTC: ";
  var c = ":";
  d = new Date();
  s += d.getUTCHours() + c;
  s += d.getUTCMinutes() + c;
  s += d.getUTCSeconds() + c;
  s += d.getUTCMilliseconds();
  return(s);
}


Метод getUTCSeconds

Метод getUTCSeconds
Применение 		Справочник языка

Объект Date


Метод getUTCSeconds

Метод getUTCSeconds
См. также 		Справочник языка

Методы объекта Date
Метод getSeconds
Метод setSeconds
Метод setUTCSeconds


Метод getVarDate

Метод getVarDate 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает значение VT_DATE, сохраненное в объекте Date.
Синтаксис
dateobj.getVarDate( )

Аргумент dateobj является объектом Date.

Примечание
Метод getVarDate применяется при взаимодействии с объектом ActiveX® или другими объектами, принимающими и возвращающими значение даты в формате VT_DATE.


Метод getVarDate

Метод getVarDate
Применение 		Справочник языка

Объект Date


Метод getVarDate

Метод getVarDate
См. также 		Справочник языка

Метод getDate
Метод parse


Метод getYear

Метод getYear 		Справочник языка
Версия 1

См. также Применение

Описание

Возвращает значение года, хранящееся в указанном объекте Date.

Синтаксис

objDate.getYear( )
Примечание
Этот метод - устаревший, поддерживается для совместимости со старыми версиями. Вместо него необходимо использовать метод getFullYear.

Для дат ХХ века, год представлен двумя цифрами, как разница с 1900 годом. Для других дат значение - четырехзначное. Например, 1996 возвращается как 96, а 1825 и 2025 возвращаются как есть.

Метод getYear используется в приведенном ниже примере:

function DateDemo()
{
  var d, s = "Сегодня: ";
  d = new Date();
  s += (d.getMonth() + 1) + "/";
  s += d.getDate() + "/";
  s += d.getYear();
  return(s);
}


Метод getYear

Метод getYear
Применение 		Справочник языка

Объект Date


Метод getYear

Метод getYear
См. также 		Справочник языка

Методы объекта Date
Метод getFullYear
Метод getUTCFullYear
Метод setFullYear
Метод setUTCFullYear
Метод setYear


Метод parse

Метод parse 		Справочник языка
Версия 1

См. также Применение

Описание

Анализирует строку, содержащую дату, и возвращает количество миллисекунд, прошедших с полуночи 01/01/1970 до указанной даты.

Синтаксис
Date.parse(dateVal)

Аргумент dateVal - строка, содержащую дату формата "Jan 5, 1996 08:47:00" или значение VT_DATE, полученное от ActiveX® объекта (или иного объекта).

Примечание
Анализирует строку, содержащую дату, и возвращает количество миллисекунд, прошедших с полуночи 01/01/1970 до указанной даты dateVal.

Метод parse является статическим методом объекта Date. По этой причине объект Date не нужно объявлять явно.

var datestring = "November 1, 1997 10:15 AM";
Date.parse(datestring)
Для успешного анализа с помощью метода parse, необходимо соблюдать следующие правила:
  • Для ввода коротких дат применяют разделители "/" или "-", но необходимо соблюдать формат "month/day/year", например, "7/20/96".
  • В длинной форме представления дат типа "July 10 1995" можно указать год, месяц и день в любом порядке, год может быть указан в 2-х и 4-х значном виде. Если год указан двумя цифрами, число должно быть больше или равно 70.
  • Любой текст внутри круглых скобок обрабатывается как комментарий. Круглые скобки могут быть вложенными.
  • Запятые и пробелы обрабатываются как разделители. Разрешено использовать несколько разделителей.
  • Месяцы и дни должны иметь два или более символа. Неуникальное имя из двух символов принимается за последний возможный вариант. Например, "Ju" равен "July", а не "June".
  • Объявленный день недели игнорируется, если он неправильный остаток от указанной даты. Например, "Tuesday November 9 1996" будет принят и обработан, даже несмотря на то, что правильное значение даты равно "Friday". В результате объект Date будет содержать "Friday November 9 1996".
  • JScript обрабатывает все стандарты временных зон, такие как Универсальная координата времени (UTC) и Среднее время по Гринвичу (GMT).
  • Часы, минуты и секунды разделяются двоеточием, хотя необязательно все указывать. Например, записи "10:", "10:11" и "10:11:12" являются допустимыми.
  • Если часы указаны по 24-значной шкале, является ошибкой указывать "PM" для времени больше чем 12. Например, "23:15 PM" является ошибкой.
  • Строка, содержащая неправильную дату, является ошибкой. Например, строка, содержащая значение двух дат или двух месяцев.
В следующем примере показано применение метода parse:
function GetTimeTest(testdate)
{
  var d, s, t;
  var MinMilli = 1000 * 60;
  var HrMilli = MinMilli * 60;
  var DyMilli = HrMilli * 24;
  d = new Date();
  t = Date.parse(testdate);
  s = "Прошло "
  s += Math.round(Math.abs(t / DyMilli)) + " дней "
  s += "между " + testdate + " и 01/01/1970";
  return(s);
}


Метод parse

Метод parse
Применение 		Справочник языка

Объект Date


Метод parse

Метод parse
См. также 		Справочник языка

Методы объекта Date


Метод setDate

Метод setDate 		Справочник языка
Версия 1

См. также Применение

Описание
Умтанавливает числовое значение дня месяца в объекте Date согласно локальному времени (local time).
Синтаксис
objDate.setDate(numDate)

Аргумент numDate является числовым значением, равным дню месяца.

Примечание
Дня установки значения дня месяца согласно UTC следует использовать метод setUTCDate.

Если значение numDate превышает количество дней месяца, хранящегося в объекте Date, либо отрицательно, другие значения даты меняются соответственно. Например, если сохраненное значение даты - 5 января 1996, то при вызове setDate(32) новое значение даты будет 1 февраля 1996. При отрицательном значении дата устанавливается аналогично.

В следующем примере применяется метод setDate:

function SetDateDemo(newdate)
{
  var d, s;
  d = new Date();
  d.setDate(newdate);
  s = "Установленное время ";
  s += d.toLocaleString();
  return(s);
}


Метод setDate

Метод setDate
Применение 		Справочник языка

Объект Date


Метод setDate

Метод setDate
См. также 		Справочник языка

Методы объекта Date
Метод getDate
Метод getUTCDate
Метод setUTCDate


Метод setFullYear

Метод setFullYear 		Справочник языка
Версия 3

См. также Применение

Описание
Устанавливает значение года в объекте Date согласно локальному времени (local time).
Синтаксис
objDate.setFullYear(numYear[, numMonth[, numDate]])

Синтаксис метода setFullYear состоит из частей:

Часть | Описание
numYear | Требуется. Числовое значение года.
numMonth | Необязательно. Числовое значение месяца. Должно быть указано, если указывается numDate.
numDate | Необязательно. Числовое значение дня месяца.

Примечание
Все методы set устанавливают необязательные параметры по значениям соответствующих методов get в случае, если эти параметры не указаны. Например, Если параметр numMonth необязателен и не указан, JScript использует значение, возвращаемое методом getMonth.

Кроме того, если значения параметров больше допустимых или отрицательные, другие параметры меняются соответственно.

Для установки значения года согласно UTC следует применять метод setUTCFullYear.

Диапазон значений года - 285,616 лет от 1970 года - в прошлое или будущее.

Метод setFullYear применен в следующем примере:

function SetFullYearDemo(newyear)
{
  var d, s;
  d = new Date();
  d.setFullYear(newyear);
  s = "Current setting is ";
  s += d.toLocaleString();
  return(s);
}


Метод setFullYear

Метод setFullYear
Применение 		Справочник языка

Объект Date


Метод setFullYear

Метод setFullYear
См. также 		Справочник языка

Методы объекта Date
Метод getFullYear
Метод getUTCFullYear
Метод setUTCFullYear


Метод setHours

Метод setHours 		Справочник языка
Версия 1

См. также Применение

Описание
Изменяет значение часа, хранящееся в объекте Date согласно локальному времени.
Синтаксис
objDate.setHours(numHours[, numMin[, numSec[, numMilli]]])

Синтаксис метода setHours состоит из частей:

Часть | Описание
numHours | Требуется. Числовое значение, равное значению часов.
numMin | Необязательно. Числовое значение, равное значению минут.
numSec | Необязательно. Числовое значение, равное значению секунд.
numMilli | Необязательно. Числовое значение, равное значению миллисекунд.

Примечание
Все set-методы берут необязательные значения, возвращаемые аналогичными get-методам, если они не были указаны явно. Например, если аргумент numMonth необязателен, но не указан, то JScript использует значение, возвращаемое методом getMonth.

Для установки значения часа согласно Универсальной координате времени (UTC) следует применять метод setUTCHours.

Если значение аргумента находится вне диапазона, другие значения меняются соответственно. Например, если сохраненное значение даты "Jan 5, 1996 00:00:00", a вызвано setHours(30), то дата изменяется на to "Jan 6, 1996 06:00:00". Отрицательные значения меняются аналогично.

Следующий пример иллюстрирует применение метода setHours:

function SetHoursDemo(nhr, nmin, nsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setHours(nhr, nmin, nsec);
  s = "Текущие установки: " + d.toLocaleString()
  return(s);
}


Метод setHours

Метод setHours
Применение 		Справочник языка

Объект Date


Метод setHours

Метод setHours
См. также 		Справочник языка

Методы объекта Date
Метод getHours
Метод getUTCHours
Метод setUTCHours


Метод setMilliseconds

Метод setMilliseconds 		Справочник языка
Версия 3

См. также Применение

Описание
Устанавливает значение миллисекунд, хранящееся в объекте Date согласно локальному времени.
Синтаксис
objDate.setMilliseconds(numMilli)

Аргумент numMilli является числовым значением, равным значению миллисекунд.

Примечание
Все set-методы, имеющие необязательные аргументы, используют значения, возвращаемые соответствующими get-методами, в случае, если эти аргументы не были указаны явно. Например, если параметр numMonth является необязательным, и он не был указан, то JScript использует значение, возвращенное методом getMonth.

Для установки значения миллисекунд согласно Универсальной координаты времени (UTC) следует использовать метод setUTCMilliseconds.

Если значение numMilli больше 999 или отрицательно, то значение секунд (минут, часов и т.д. при необходимости) меняется соответственно.

Следующий пример иллюстрирует применение метода setMilliseconds:

function SetMSecDemo(nmsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setMilliseconds(nmsec);
  s = "Текущие установки ";
  s += d.toLocaleString() + sep + d.getMilliseconds();
  return(s);
}


Метод setMilliseconds

Метод setMilliseconds
Применение 		Справочник языка

Объект Date


Метод setMilliseconds

Метод setMilliseconds
См. также 		Справочник языка

Методы объекта Date
Метод getMilliseconds
Метод getUTCMilliseconds
Метод setUTCMilliseconds


Метод setMinutes

Метод setMinutes 		Справочник языка
Версия 1

См. также Применение

Описание
Устанавливает значение минут, хранящееся в объекте Date согласно локальному времени.
Синтаксис
objDate.setMinutes(numMinutes[, numSeconds[, numMilli]])

Синтаксис метода setMinutes состоит из частей:

Часть | Описание
numMinutes | Требуется. Число, равное значению минут.
numSeconds | Необязательно. Число, равное значению секунд. Должно быть указано, если используется аргумент numMilli.
numMilli | Необязательно. Число, равное значению миллисекунд.

Примечание
Все set-методы, имеющие необязательные аргументы, используют значения, возвращаемые соответствующими get-методами, в случае, если эти аргументы не были указаны явно. Например, если параметр numMonth является необязательным, и он не был указан, то JScript использует значение, возвращенное методом getMonth.

Для установки значения минут согласно Универсальной координате времени (UTC) следует применять метод setUTCMinutes.

Если значение параметра находится вне диапазона или отрицательно, другие сохраняемые значения меняются соответственно. Например, если сохраненная дата равна "Jan 5, 1996 00:00:00", и был вызван метод setMinutes(90), то значение даты равно "Jan 5, 1996 01:30:00." Подобное поведение метода происходит при использовании отрицательных значений.

Следующий пример иллюстрирует применение метода setMinutes:

function SetMinutesDemo(nmin, nsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setMinutes(nmin, nsec);
  s = "Текущие установки " + d.toLocaleString()
  return(s);
}


Метод setMinutes

Метод setMinutes
Применение 		Справочник языка

Объект Date


Метод setMinutes

Метод setMinutes
См. также 		Справочник языка

Методы объекта Date
Метод getMinutes
Метод getUTCMinutes
Метод setUTCMinutes


setMonth Method

Метод setMonth 		Справочник языка
Версия 1

См. также Применение

Описание
Устанавливает значение месяца, хранящееся в объекте Date, согласно локальному времени.
Синтаксис
objDate.setMonth(numMonth[, dateVal])

Синтаксис метода setMonth состоит из частей:

Часть | Описание
numMonth | Требуется. Числовое значение, равное месяцу.
dateVal | Необязательно. Числовое значение, представляющее день месяца. Если не указано, применяется значение, вызываемое методом getDate.

Примечание
Для установки значения месяца согласно Универсальной координате времени (UTC) следует использовать метод setUTCMonth.

Если значение numMonth больше 11 (значение Января равно 0) или является отрицательным, то значение года может меняться соответственно. Например, если установлена дата "Jan 5, 1996" и вызван метод setMonth(14), то значение даты равно "Mar 5, 1997."

Следующий пример иллюстрирует применение метода setMonth:

function SetMonthDemo(newmonth)
{
  var d, s;
  d = new Date();
  d.setMonth(newmonth);
  s = "Текущие установки:  ";
  s += d.toLocaleString();
  return(s);
}


setMonth Method

Метод setMonth
Применение 		Справочник языка

Объект Date


setMonth Method

Метод setMonth
См. также 		Справочник языка

Методы объекта Date
Метод getMonth
Метод getUTCMonth
Метод setUTCMonth


Метод setSeconds

Метод setSeconds 		Справочник языка
Версия 1

См. также Применение

Описание
Устанавливает значение секунд, сохраняемое в объекте Date согласно локальному времени.
Синтаксис
objDate.setSeconds(numSeconds[, numMilli])

Синтаксис метода setSeconds состоит из частей:

Часть | Описание
numSeconds | Требуется. Число, равное значению секунд.
numMilli | Необязательно. Число, равное значению миллисекунд.

Примечание
Все set-методы, имеющие необязательные аргументы, используют значения, возвращаемые соответствующими get-методами, в случае, если эти аргументы не были указаны явно. Например, если параметр numMonth является необязательным, и он не был указан, то JScript использует значение, возвращенное методом getMonth.

Для установки значения секунд согласно Универсальной координате времени (UTC) следует использовать метод setUTCSeconds.

Если значение аргумента больше его диапазона или отрицательно, другие сохраняемые значения изменяются соответственно. Например, если сохраненная дата равна "Jan 5, 1996 00:00:00" и вызван метод setSeconds(150), то дата изменится на "Jan 5, 1996 00:02:30."

Следующий пример иллюстрирует применение метода setSeconds:

function SetSecondsDemo(nsec, nmsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setSeconds(nsec, nmsec);
  s = "Текущие установки ";
  s += d.toLocaleString() + sep + d.getMilliseconds();
  return(s);
}


Метод setSeconds

Метод setSeconds
Применение 		Справочник языка

Объект Date


Метод setSeconds

Метод setSeconds
См. также 		Справочник языка

Методы объекта Date
Метод getSeconds
Метод getUTCSeconds
Метод setUTCSeconds


Метод setTime

Метод setTime 		Справочник языка
Версия 1

См. также Применение

Описание
Устанавливает значение даты и времени непосредственно в объект Date.
Syntax
objDate.setTime(milliseconds)

Аргумент milliseconds является целым числом, представляющим собой количество миллисекунд, прошедших после полуночи 01/01/1970 GMT.

Примечание
Если milliseconds отрицательно, то это означает дату до 1970 года. Диапазон доступных значений - приблизительно 285,616 лет от 1970 года - в прошлое или будущее.

Установленные методом setTime время и дата не зависят от временной зоны.

Метод setTime применен в следующем примере:

function SetTimeTest(newtime)
{
  var d, s;
  d = new Date();
  d.setTime(newtime);
  s = "Текущие установки: ";
  s += d.toUTCString();
  return(s);
}


Метод setTime

Метод setTime
Применение 		Справочник языка

Объект Date


Метод setTime

Метод setTime
См. также 		Справочник языка

Методы объекта Date
Метод getTime


Метод setUTCDate

Метод setUTCDate 		Справочник языка
Версия 3

См. также Применение

Описание
Установка дня месяца в объекте Date согласно Универсальной координате времени (UTC).
Синтаксис
objDate.setUTCDate(numDate)

Аргумент numDate является числом, означающим день месяца.

Примечание
Для установки значения дня месяца согласно локальному времени следует использовать метод setDate.

Если значение numDate превышает количество дней в месяце, хранящееся в объекте Date или является отрицательным числом, то значение устанавливается равным numDate за минусом количества дней в данном месяце. Например, если текущая дата равна January 5, 1996, и вызван метод setUTCDate(32), то дата изменится на to February 1, 1996. Аналогичное поведение метода наблюдается при применении отрицательных значений.

Следующий пример иллюстрирует применение метода setUTCDate:

function SetUTCDateDemo(newdate)
{
  var d, s;
  d = new Date();
  d.setUTCDate(newdate);
  s = "Текущие установки ";
  s += d.toUTCString();
  return(s);
}


Метод setUTCDate

Метод setUTCDate
Применение 		Справочник языка

Объект Date


Метод setUTCDate

Метод setUTCDate
См. также 		Справочник языка

Методы объекта Date
Метод getDate
Метод getUTCDate
Метод setDate


Метод setUTCFullYear

Метод setUTCFullYear 		Справочник языка
Версия 3

См. также Применение

Описание
Устанавливает значение года в объекте Date согласно Универсальной координаты времени (UTC).
Синтаксис
objDate.setUTCFullYear(numYear[, numMonth[, numDate]])

Синтаксис метода setUTCFullYear состоит из частей:

Часть | Описание
numYear | Требуется. Число, равное значению года.
numMonth | Необязательно. Число, равное значению месяца. Должно быть указано при использовании параметра numDate.
numDate | Необязательно. Число, равное дню месяца.

Примечание
Все set-методы, имеющие необязательные аргументы, используют значения, возвращаемые соответствующими get-методами, в случае, если эти аргументы не были указаны явно. Например, если параметр numMonth является необязательным, и он не был указан, то JScript использует значение, возвращенное методом getMonth.

Вообще, если значение аргумента находится вне диапазона или является отрицательным, то сохраняемые значения изменяются соответственно.

Для установки значения года согласно локальному времени следует применять метод setFullYear.

Диапазон значений года, поддерживаемый объектом Date, приблизительно равен 285,616 годам по обе стороны от 1970 года.

Следующий пример иллюстрирует применение метода setUTCFullYear:

function SetUTCFullYearDemo(newyear)
{
  var d, s;
  d = new Date();
  d.setUTCFullYear(newyear);
  s = "Текущие установки ";
  s += d.toUTCString();
  return(s);
}


Метод setUTCFullYear

Метод setUTCFullYear
Применение 		Справочник языка

Объект Date


Метод setUTCFullYear

Метод setUTCFullYear
См. также 		Справочник языка

Методы объекта Date
Метод getFullYear
Метод getUTCFullYear
Метод setFullYear


Метод setUTCHours

Метод setUTCHours 		Справочник языка
Версия 3

См. также Применение

Описание
Устанавливает значение часов, сохраняемое в объекте Date согласно Универсальной координаты времени (UTC).
Синтаксис
objDate.setUTCHours(numHours[, numMin[, numSec[, numMilli]]])

Синтаксис метода setUTCHours состоит из частей:

Часть | Описание
numHours | Требуется. Число, равное значению часа.
numMin | Необязательно. Число, равное значению минут. Должно быть указано, если используется значениеr numSec или numMilli.
numSec | Необязательно. Число, равное значению секунд. Должно быть указано, если применяется параметр numMilli.
numMilli | Необязательно. Число, равное значению миллисекунд.

Примечание
Все set-методы, имеющие необязательные аргументы, используют значения, возвращаемые соответствующими get-методами, в случае, если эти аргументы не были указаны явно. Например, если параметр numMonth является необязательным, и он не был указан, то JScript использует значение, возвращенное методом getMonth.

Для установки значения часа согласно локальному времени следует использовать метод setHours.

Если значение аргумента превышает диапазон или отрицательно, то другие значения изменяются соответственно. Например, если установленная дата равна "Jan 5, 1996 00:00:00.00", и вызван метод setUTCHours(30), то дата изменится на "Jan 6, 1996 06:00:00.00."

Следующий пример иллюстрирует применение метода setUTCHours:

function SetUTCHoursDemo(nhr, nmin, nsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setUTCHours(nhr, nmin, nsec);
  s = "Текущие установки: " + d.toUTCString()
  return(s);
}


Метод setUTCHours

Метод setUTCHours
Применение 		Справочник языка

Объект Date


Метод setUTCHours

Метод setUTCHours
См. также 		Справочник языка

Методы объекта Date
Метод getHours
Метод getUTCHours
Метод setHours


Метод setUTCMilliseconds

Метод setUTCMilliseconds 		Справочник языка
Версия 3

См. также Применение

Описание
Устанавливает значение миллисекунд, сохраняемое в объекте Date, согласно Универсальной координате времени (UTC).
Синтаксис
objDate.setUTCMilliseconds(numMilli)

Аргумент numMilli является значением, равным количеству миллисекунд.

Примечание
Для установки значения миллисекунд согласно локальному времени следует использовать метод setMilliseconds.

Если значение numMilli больше чем 999 или отрицательно, то значение секунд (минут, часов и т.д. если необходимо) изменяется соответственно.

Следующий пример иллюстрирует применение метода setUTCMilliseconds:

function SetUTCMSecDemo(nmsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setUTCMilliseconds(nmsec);
  s = "Текущие установки ";
  s += d.toUTCString() + sep + d.getUTCMilliseconds();
  return(s);
}


Метод setUTCMilliseconds

Метод setUTCMilliseconds
Применение 		Справочник языка

Объект Date


Метод setUTCMilliseconds

Метод setUTCMilliseconds
См. также 		Справочник языка

Методы объекта Date
Метод getMilliseconds
Метод getUTCMilliseconds
Метод setMilliseconds


Метод setUTCMinutes

Метод setUTCMinutes 		Справочник языка
Версия 3

См. также Применение

Описание
Устанавливает значение минут в объекте Date согласно Универсальной координате времени (UTC).
Синтаксис
objDate.setUTCMinutes(numMinutes[, numSeconds[, numMilli]])

Синтаксис метода setUTCMinutes состоит из частей:

Часть | Описание
numMinutes | Требуется. Число, равное значению минут.
numSeconds | Необязательно. Число, равное значению секунд. Должно быть указано при использовании numMilli.
numMilli | Необязательно. Число, равное значению миллисекунд.

Примечание
Все set-методы, имеющие необязательные аргументы, используют значения, возвращаемые соответствующими get-методами, в случае, если эти аргументы не были указаны явно. Например, если параметр numMonth является необязательным, и он не был указан, то JScript использует значение, возвращенное методом getMonth.

Для изменения значения минут согласно локальному времени следует применять метод setMinutes.

Если значение параметра превышает диапазон или отрицательно, тo сохраняемые значения изменяются соответственно. Например, если установленная дата равна "Jan 5, 1996 00:00:00.00", и вызван метод setUTCMinutes(70), дата изменится на to "Jan 5, 1996 01:10:00.00."

Следующий пример иллюстрирует применение метода setUTCMinutes:

function SetUTCMinutesDemo(nmin, nsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setUTCMinutes(nmin,nsec);
  s = "Текущие установки " + d.toUTCString()
  return(s);
}


Метод setUTCMinutes

Метод setUTCMinutes
Применение 		Справочник языка

Объект Date


Метод setUTCMinutes

Метод setUTCMinutes
См. также 		Справочник языка

Методы объекта Date
Метод getMinutes
Метод getUTCMinutes
Метод setMinutes


Метод setUTCMonth

Метод setUTCMonth 		Справочник языка
Версия 3

См. также Применение

Описание
Устанавливает значение месяца в объекте Date согласно Универсальной координате времени (UTC).
Синтаксис
objDate.setUTCMonth(numMonth[, dateVal])

Синтаксис метода setUTCMonth состоит из частей:

Часть | Описание
numMonth | Требуется. Число, равное значению месяца.
dateVal | Необязательно. Число, представляющее значение дня месяца. Если не указано, значение вызывается методом getUTCDate.

Примечание
Для установки значения месяца согласно локальному времени следует применять метод setMonth.

Если значение numMonth более 11 (значение January равно 0) или отрицательно, сохраняемое значение года изменяется соответственно. Например, если значение даты равно "Jan 5, 1996 00:00:00.00", и вызван метод setUTCMonth(14), то значение даты изменится на "Mar 5, 1997 00:00:00.00."

Следующий пример иллюстрирует применение метода setUTCMonth:

function SetUTCMonthDemo(newmonth)
{
  var d, s;
  d = new Date();
  d.setUTCMonth(newmonth);
  s = "Текущие установки ";
  s += d.toUTCString();
  return(s);
}


Метод setUTCMonth

Метод setUTCMonth
Применение 		Справочник языка

Объект Date


Метод setUTCMonth

Метод setUTCMonth
См. также 		Справочник языка

Методы объекта Date
Метод getMonth
Метод getUTCMonth
Метод setMonth


Метод setUTCSeconds

Метод setUTCSeconds 		Справочник языка
Версия 3

См. также Применение

Описание
Устанавливает значение секунд, хранящееся в объекте Date согласно Универсальной координаты времени (UTC).
Синтаксис
objDate.setUTCSeconds(numSeconds[, numMilli])

Синтаксис метода setUTCSeconds состоит из частей:

Часть | Описание
numSeconds | Требуется. Числовое значение, равное значению секунд.
numMilli | Необязательно. Числовое значение, равное значению миллисекунд.

Примечание
Все set-методы, имеющие необязательные аргументы, используют значения, возвращаемые соответствующими get-методами, в случае, если эти аргументы не были указаны явно. Например, если параметр numMonth является необязательным, и он не был указан, то JScript использует значение, возвращенное методом getMonth.

Для установки значения секунд согласно локальному времени следует применять метод setSeconds.

Если значение параметра вне диапазона или отрицательно, другие сохраняемые значения изменяются соответственно. Например, если хранящееся значение равно "Jan 5, 1996 00:00:00.00", а метод setSeconds(150) был вызван, то дата меняется на "Jan 5, 1996 00:02:30.00."

Следующий пример иллюстрирует применение метода setSeconds:

function SetUTCSecondsDemo(nsec, nmsec)
{
  var d, s;
  var sep = ":";
  d = new Date();
  d.setUTCSeconds(nsec, nmsec);
  s = "Текущие установки: ";
  s += d.toUTCString() + sep + d.getUTCMilliseconds();
  return(s);
}


Метод setUTCSeconds

Метод setUTCSeconds
Применение 		Справочник языка

Объект Date


Метод setUTCSeconds

Метод setUTCSeconds
См. также 		Справочник языка

Методы объекта Date
Метод getSeconds
Метод getUTCSeconds
Метод setSeconds


Метод setYear

Метод setYear 		Справочник языка
Версия 1

См. также Применение

Описание
Устанавливает значение года в объекте Date.
Синтаксис
objDate.setYear(numYear)

Аргумент numYear равен значению года минус 1900.

Применение
Метод - устаревший, используется для совместимости с предыдущими версиями. Вместо него необходимо использовать метод setFullYear.

Для установки в объекте Date значения 1997 вызывается setYear(97). Для установки значения 2010 вызывается setYear(2010). В настоящее время рекомендуется применять метод setFullYear.

В следующем примере применен метод setYear:

function SetYearDemo(newyear)
{
  var d, s;
  d = new Date();
  d.setYear(newyear);
  s = "Текущие установки ";
  s += d.toLocaleString();
  return(s);
}


Метод setYear

Метод setYear
Применение 		Справочник языка

Объект Date


Метод setYear

Метод setYear
См. также 		Справочник языка

Методы объекта Date
Метод getFullYear
Метод getUTCFullYear
Метод getYear
Метод setFullYear
Метод setUTCFullYear


Метод toGMTString

Метод toGMTString 		Справочник языка
Версия 1

См. также Применение

Описание
Преобразование даты в строку, используя Соглашение GMT.
Синтакис
objDate.toGMTString()
Примечание
Метод toGMTString в JScript считается устаревшим, поддерживается для совместимости с ранними версиями. Вместо него рекомендуется применять метод toUTCString.

Метод toGMTString возвращает объект String, содержащий дату в строковом представлении согласно соглашениям GMT. Формат даты - следующий: "05 Jan 1996 00:00:00 GMT."

Применение метода toGMTString показано в примере:

function toGMTStrDemo()
{
  var d, s;
  d = new Date();
  s = "Текущая установка: ";
  s += d.toGMTString();
  return(s);
}


Метод toGMTString

Метод toGMTString
Применение 		Справочник языка

Объект Date


Метод toGMTString

Метод toGMTString
См. также 		Справочник языка

Методы объекта Date
Метод toUTCString


Метод toLocaleString

Метод toLocaleString 		Справочник языка
Версия 1

См. также Применение

Описание
Преобразовывает формат даты в соответствие с текущей локалью (locale).
Синтаксис
dateObj.toLocaleString( )
Примечание
Метод toLocaleString возвращает объект String, содержащий дату в формате установленной локали. Формат возвращаемого значения зависит от текущей локали. Например, в США toLocaleString возвращает "01/05/96 00:00:00" для 5 января, но в Европе для этой даты возвращаемое значение будет равным "05/01/96 00:00:00", так как по Европейскому Соглашению дни месяца указываются ранее месяца.

В следующем примере применен метод toLocaleString:

function toLocaleStrDemo()
{
  var d, s;
  d = new Date();
  s = "Current setting is ";
  s += d.toLocaleString();
  return(s);
}


Метод toLocaleString

Метод toLocaleString
См. также 		Справочник языка

Методы объекта Date


Метод toUTCString

Метод toUTCString 		Справочник языка
Версия 3

См. также Применение

Описание
Преобразовывает дату в формат Универсальной координаты времени (UTC).
Синтаксис
objDate.toUTCString()
Примечание
Метод toUTCString возвращает объект String, содержащий дату, в формате Соглашения UTC, легко читаемую форму.

В следующем примере показано применение метода toUTCString:

function toUTCStrDemo()
{
  var d, s;
  d = new Date();
  s = "Текущая установка: ";
  s += d.toUTCString();
  return(s);
}


Метод toUTCString

Метод toUTCString
Применение 		Справочник языка

Объект Date


Метод toUTCString

Метод toUTCString
См. также 		Справочник языка

Методы объекта Date
Метод toGMTString


Метод UTC

Метод UTC 		Справочник языка
Версия 1

См. также Применение

Описание

Вычисление количества миллисекунд между полуночью 01/01/1970 по UTC (или GMT) и указанной датой.

Синтаксис
Date.UTC(year, month, day[, hours[, minutes[, seconds[,ms]]]])

Синтаксис метода UTC состоит из частей:

Часть | Описание
year | Требуется. Абсолютное значение года. Если год представлен в диапазоне 0-99, к значению прибавляется 1900.
month | Требуется. Месяц в диапазоне 0-11 (январь-декабрь). Значение равно порядковому номеру месяца, уменьшенного на единицу.
date | Требуется. День месяца в диапазоне 1-31.
hours | Необязательно. Должен быть указан, если должно быть указано minutes. Целое значение в диапазоне 0-23, указывает на часы.
minutes | Необязательно. Должен быть указан, если должно быть указано seconds. Целое значение в диапазоне 0-59, указывает на минуты.
seconds | Необязательно. Должен быть указан, если должно быть указано milliseconds. Целое значение в диапазоне 0-59, указывает на секунды.
ms | Необязательно. Целое значение в диапазоне 0-999, указывает на миллисекунды.

Примечание

Метод UTC возвращает количество милливекунд между 01/01/1970 по UTC и указанной датой. Это значение может применяться в методе setTime и в конструкторе (constructor) объекта Date. Если значения параметров находятся вне диапазона, другие значения меняются соответственно. Например, если указано 150 секунд, JScript переопределяет это значение как 2 минуты и 30 секунд.

Разница между методом UTC и конструктором объекта Date заключается в том, что метод UTC принимает время по UTC, a конструктор объекта Date принимает локальное время (local time).

Метод UTC вызывается следующим образом:

var datestring = "November 1, 1997 10:15 AM";
Date.UTC(datestring)
Предупреждение Если year указан в диапазоне 0-99, применяется формула year = 1900 + year для определения года.

В следующем примере применен метод UTC для определения прошедшего времени между двумя датами:

function DaysBetweenDateAndNow(yr, mo, dy)
{
  var d, r, t1, t2, t3;
  var MinMilli = 1000 * 60
  var HrMilli = MinMilli * 60
  var DyMilli = HrMilli * 24
  t1 = Date.UTC(yr, mo, dy)
  d = new Date();
  t2 = d.getTime();
  if (t2 >= t1)
    t3 = t2 - t1;
  else
    t3 = t1 - t2;
  r = Math.round(t3 / DyMilli);
  return(r);
}


Метод UTC

Метод UTC
Применение 		Справочник языка

Объект Date


Метод UTC

Метод UTC
См. также 		Справочник языка

Методы объекта Date
Метод setTime


Метод Add (Dictionary)

Метод Add (Dictionary) 		Справочник языка
Версия 2

См. также Применение

Описание
Добавляет пару ключ-значение в объект Dictionary.
Синтаксис
object.Add (key, item)

Синтаксис метода Add состоит из частей:

Часть | Описание
object | Требуется. Всегда имя объекта Dictionary.
key | Требуется. Ключ key, ассоциируемый с добавляемым значением item.
item | Требуется. Добавляемое значение item, ассоциируемое с ключом key.

Примечание
Если key уже существует, то возникает ошибка.

Следующий пример иллюстрирует применение метода Add:

var d;
d = new ActiveXObject("Scripting.Dictionary");
d.Add("a", "Athens");
d.Add("b", "Belgrade");
d.Add("c", "Cairo");


Метод Add (Dictionary)

Метод Add (Dictionary)
Применение 		Справочник языка

Объект Dictionary


Метод Add (Dictionary)

Метод Add (Dictionary)
См. также 		Справочник языка

Метод Add (Folders)
Метод Exists
Метод Items
Метод Keys
Метод Remove
Метод RemoveAll


Свойство CompareMode

Свойство CompareMode 		Справочник языка
Версия 2

См. также Применение

Описание
Устанавливает и возвращает режим сравнения строковых ключей в объекте Dictionary.
Синтаксис
object.CompareMode[ = compare]

Синтаксис свойства CompareMode состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта Dictionary.
compare | Необязательно. Если указано, compare представляет значение режима сравнения. Допустимые значения - 0 (бинарный), 1 (текстовой), 2 (базы данных). Значения, большие 2 допустимы для использования в некоторых локальных установках (LCID).

Примечание
Если попытаться изменить режим сравнения объекта Dictionary , уже содержащего данные, то происходит ошибка.

Следующий пример иллюстрирует применение свойства CompareMode:

function TestCompareMode(key)
{
  //Создание некоторых переменных.
  var a, d;
  var BinaryCompare = 0, TextCompare = 1;
  d = new ActiveXObject("Scripting.Dictionary");
  //Установка режима сравнения текста
  d.CompareMode = TextCompare;
  //Добавление пар ключ-значение.
  d.Add("a", "Athens");
  d.Add("b", "Belgrade");
  d.Add("c", "Cairo");
  return(d.Item(key));
}


Свойство CompareMode

Свойство CompareMode
Применение 		Справочник языка

Объект Dictionary


Свойство CompareMode

Свойство CompareMode
См. также 		Справочник языка

Свойство Key


Свойство Count

Свойство Count 		Справочник языка
Версия 2

См. также Применение

Описание
Возвращает количество значений в совокупности или объекте Dictionary. Только для чтения.
Синтаксис
object.Count

Параметр object является именем объекта или совокупности.

Примечание
Следующий пример иллюстрирует применение свойства Count:
function CountDemo()
{
  var a, d, i, s;                 // Создание переменных.
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add ("a", "Athens");          // Добавление пар ключ-значение
  d.Add ("b", "Belgrade");
  d.Add ("c", "Cairo");
  a = (new VBArray(d.Keys()));    // Получение ключей.
  s = "";
  for (i = 0; i < d.Count; i++)   //Итерирование объектов.
  {
    s += a.getItem(i) + " - " + d(a.getItem(i)) + "<br>";
  }
  return(s);              // Возвращение результатов.
}


Свойство Count

Свойство Count
Применение 		Справочник языка

Объект Dictionary
Совокупность дисков
Совокупность папок
Совокупность файлов


Свойство Count

Свойство Count
См. также 		Справочник языка

Свойство CompareMode
Свойство Item
Свойство Key


Метод Exists

Метод Exists 		Справочник языка
Версия 2

См. также Применение

Описание
Возвращает true, если указанный ключ существует в объекте Dictionary, и false - если не существует.
Синтаксис
object.Exists(key)

Синтаксис метода Exists состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта Dictionary.
key | Требуется. Значение key, искомое в объекте Dictionary.

Следующий пример иллюстрирует применение метода Exists:

function keyExists(k)
{
  var fso, s = "";
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add("a", "Athens");
  d.Add("b", "Belgrade");
  d.Add("c", "Cairo");
  if (d.Exists(k))
    s += "Указанный ключ существует.";
  else
    s += "Указанный ключ не существует.";
  return(s);
}


Метод Exists

Метод Exists
Применение 		Справочник языка

Объект Dictionary


Метод Exists

Метод Exists
См. также 		Справочник языка

Метод Add (Dictionary)
Метод Items
Метод Keys
Метод Remove
Метод RemoveAll


Свойство Item

Свойство Item 		Справочник языка
Версия 2

См. также Применение

Описание
Устанавливает или возвращает значение item для указанного ключа key в объекте Dictionary или совокупности.
Синтаксис
object.Item(key)[ = newitem]

Синтаксис свойства Item состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта Dictionary или совокупности.
key | Требуется. Key ассоциируется с item для поиска или добавления.
newitem | Необязательно. Используется исключительно в объектах Dictionary; в совокупностях не применяется. Если указано, то newitem новым значением, ассоциируемым с указанным ключем key.

Примечание
Если key не был найден при измененииn item, то создается новый ключ key с указанным newitem. Если key не найден при попытке возвратить существующее значение, то создается новый ключ key с пустым значением.

Следующий пример иллюстрирует применение свойства Item.

function DicTest(keyword)
{
  var a, d;
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add("a", "Athens");
  d.Add("b", "Belgrade");
  d.Add("c", "Cairo");
  a = d.Item(keyword);
  return(a);
}


Свойство Item

Свойство Item
Применение 		Справочник языка

Объект Dictionary
Совокупность дисков
Совокупность файлов
Совокупность папок


Свойство Item

Свойство Item
См. также 		Справочник языка

Свойство CompareMode
Свойство Count
Свойство Key


Метод Items

Метод Items 		Справочник языка
Версия 2

См. также Применение

Описание
Возвращает массив всех значений, содержащихся в объекте Dictionary.
Синтаксис
object.Items( )

Параметр object всегда является именем объекта Dictionary.

Примечание
Следующий пример иллюстрирует применение метода Items:
function ItemsDemo()
{
  var a, d, i, s;              // Создание переменных.
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add ("a", "Athens");       // Добавление пар ключ-значение
  d.Add ("b", "Belgrade");
  d.Add ("c", "Cairo");
  a = (new VBArray(d.Items())).toArray();    // Получение значений.
  s = "";
  for (i in a)               //Итерирование объекта.
  {
    s += a[i] + "<br>";
  }
  return(s);           // Возвращение результатов.
}


Метод Items

Метод Items
Применение 		Справочник языка

Объект Dictionary


Метод Items

Метод Items
См. также 		Справочник языка

Метод Add (Dictionary)
Метод Exists
Метод Keys
Метод Remove
Метод RemoveAll


Свойство Key

Свойство Key 		Справочник языка
Версия 2

См. также Применение

Описание
Устанавливает ключ в объекте Dictionary.
Синтаксис
object.Key(key) = newkey

Синтаксис свойства Key состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта Dictionary.
key | Требуется. Key - значение, которое будет изменено.
newkey | Требуется. Новое значение, изменяющее указанное значение key.

Примечание

Следующий пример иллюстрирует применение свойства Key:

var d;
d = new ActiveXObject("Scripting.Dictionary");

function AddStuff()
{
  var a;
  d.Add("a", "Athens");
  d.Add("b", "Belgrade");
  d.Add("c", "Cairo");
}

function ChangeKey(oldkey, newkey)
{
  var s;
  d.Key("c") = "Ca";
  s = "Ключ " + oldkey + " изменен на " + newkey;
  return(s);
}


Свойство Key

Свойство Key
Применение 		Справочник языка

Объект Dictionary


Свойство Key

Свойство Key
См. также 		Справочник языка

Свойство CompareMode
Свойство Count
Свойство Item


Метод Keys

Метод Keys 		Справочник языка
Версия 2

См. также Применение

Описание
Возвращает массив всех ключей, содержащихся в объекте Dictionary.
Синтаксис
object.Keys( )

Параметр object всегда является именем объекта Dictionary.

Примечание
Следующий пример иллюстрирует применение метода Keys:
function KeysDemo()
{
  var a, d, i, s;              // Создание переменных.
  d = new ActiveXObject("Scripting.Dictionary");
  d.Add ("a", "Athens");       // Добавление пар ключ-значение
  d.Add ("b", "Belgrade");
  d.Add ("c", "Cairo");
  a = (new VBArray(d.Keys())).toArray();    // Получение ключей.
  s = "";
  for (i in a)                 //Итерирование объекта.
  {
    s += a[i] + " - " + d(a[i]) + "<br>";
  }
  return(s);           // Возвращение результатов.
}


Метод Keys

Метод Keys
Применение 		Справочник языка

Объект Dictionary


Метод Keys

Метод Keys
См. также 		Справочник языка

Метод Add (Dictionary)
Метод Exists
Метод Items
Метод Remove
Метод RemoveAll


Метод Remove

Метод Remove 		Справочник языка
Версия 2

См. также Применение

Описание
Удаляет пару "ключ-значение" в объекте Dictionary.
Синтаксис
object.Remove(key)

Синтаксис метода Remove состоит из частей:

Часть | Описание
object | Требуется. Всегда имя объекта Dictionary.
key | Требуется. Key ассоциируется с парой "ключ-значение", которая удаляется из объекта Dictionary.

Примечание
Выдает ошибку, если указанный ключ не существует.

В следующем примере показано применение метода Remove:

var a, d, i, s;              // Создание переменных.
d = new ActiveXObject("Scripting.Dictionary");
d.Add ("a", "Athens");       // Добавление ключей и значений
d.Add ("b", "Belgrade");
d.Add ("c", "Cairo");
...
d.Remove("b");               // Удаление второй пары.


Метод Remove

Метод Remove
Применение 		Справочник языка

Объект Dictionary


Метод RemoveAll

Метод RemoveAll 		Справочник языка
Версия 2

См. также Применение

Описание
Метод RemoveAll удаляет все пары ключ-значение из объекта Dictionary.
Синтаксис
object.RemoveAll( )

Аргумент object всегда является именем объекта Dictionary.

Примечание
Следующий пример иллюстрирует применение метода RemoveAll:
var a, d, i;             // Создание переменных.
d = new ActiveXObject("Scripting.Dictionary");
d.Add ("a", "Athens");   // Добавление пар ключ-значение.
d.Add ("b", "Belgrade");
d.Add ("c", "Cairo");
...
d.RemoveAll( );           // Очистка объекта.


Метод RemoveAll

Метод RemoveAll
Применение 		Справочник языка

Объект Dictionary


Метод RemoveAll

Метод RemoveAll
См. также 		Справочник языка

Метод Add (Dictionary)
Метод Exists
Метод Items
Метод Keys
Метод Remove


Метод Remove

Метод Remove
См. также 		Справочник языка

Метод Add (Dictionary)
Метод Exists
Метод Items
Метод Keys
Метод RemoveAll


Свойство AvailableSpace

Свойство AvailableSpace 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает общее количество доступного для пользователя места на указанном устройстве или сетевом ресурсе.
Синтаксис
object.AvailableSpace

Аргумент object всегда является именем объекта Drive.

Примечание
Значение, возвращаемое свойством AvailableSpace обычно равно значению, возвращаемому свойством FreeSpace. Различия могут быть для компьютерных систем с поддержкой квот.

Следующий пример иллюстрирует применение свойства AvailableSpace:

function ShowAvailableSpace(drvPath)
{
  var fso, d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(drvPath));
  s = "Устройство " + drvPath.toUpperCase() + " - ";
  s += d.VolumeName + "<br>";
  s += "Доступно: " + d.AvailableSpace/1024 + " Kb";
  return(s);
}


Свойство AvailableSpace

Свойство AvailableSpace
Применение 		Справочник языка

Объект Drive


Свойство AvailableSpace

Свойство AvailableSpace
См. также 		Справочник языка

Свойство DriveLetter
Свойство DriveType
Свойство FileSystem
Свойство FreeSpace
Свойство IsReady
Свойство Path
Свойство RootFolder
Свойство SerialNumber
Свойство ShareName
Свойство TotalSize
Свойство VolumeName


Свойство DriveLetter

Свойство DriveLetter 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает символ физического (логического) диска или сетевого ресурса. Только для чтения.
Синтаксис
object.DriveLetter

Аргумент object всегда является именем объект Drive.

Примечание
Свойство DriveLetter возвращает строку нулевой длины (""), если указанный диск не ассоциируется с символом диска,

Следующий пример иллюстрирует применение свойства DriveLetter:

function ShowDriveLetter(drvPath)
{
  var fso, d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(drvPath));
  s = "Устройство " + d.DriveLetter.toUpperCase( ) + ": - ";
  s += d.VolumeName + "<br>";
  s += "Доступно: " + d.AvailableSpace/1024 + " Kb";
  return(s);
}


Свойство DriveLetter

Свойство DriveLetter
Применение 		Справочник языка

Объект Drive


Свойство DriveLetter

Свойство DriveLetter
См. также 		Справочник языка

Свойство DriveType
Свойство FileSystem
Свойство SerialNumber
Свойство ShareName
Свойство VolumeName


Свойство DriveType

Свойство DriveType 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает значение типа указанного устройства.
Синтаксис
object.DriveType

Параметр object всегда является именем объекта Drive.

Примечание
Следующий пример иллюстрирует применение свойства DriveType:
function ShowDriveType(drvpath)
{
  var fso, d, s, t;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(drvpath);
  switch (d.DriveType)
  {
    case 0: t = "Unknown"; break;
    case 1: t = "Removable"; break;
    case 2: t = "Fixed"; break;
    case 3: t = "Network"; break;
    case 4: t = "CD-ROM"; break;
    case 5: t = "RAM Disk"; break;
  }
  s = "Тип устройства " + d.DriveLetter + ": - " + t;
  return(s);
}


Свойство DriveType

Свойство DriveType
Применение 		Справочник языка

Объект Drive


Свойство DriveType

Свойство DriveType
См. также 		Справочник языка

AvailableSpace Property
DriveLetter Property
FileSystem Property
FreeSpace Property
IsReady Property
SerialNumber Property
ShareName Property
TotalSize Property
VolumeName Property


Свойство FileSystem

Свойство FileSystem 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает тип файловой системы указанного устройства.
Синтаксис
object.FileSystem

Параметр object всегда является именем объекта Drive.

Примечание
Возможные возвращаемые значения: FAT, NTFS и CDFS.

Следующий пример иллюстрирует применение свойства FileSystem:

function ShowFileSystemType(drvPath)
{
  var fso,d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(drvPath);
  s = d.FileSystem;
  return(s);
}


Свойство FileSystem

Свойство FileSystem
Применение 		Справочник языка

Объект Drive


Свойство FileSystem

Свойство FileSystem
См. также 		Справочник языка

Свойство DriveType
Свойство IsReady


Свойство FreeSpace

Свойство FreeSpace 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает общее количество свободного места на указанном устройстве или сетевом ресурсе. Только для чтения.
Синтаксис
object.FreeSpace

Параметр object всегда является объектом Drive.

Примечание
Значение, возвращаемое свойством FreeSpace, обычно такое же, как и значение, возвращаемое свойством AvailableSpace. Различия могут быть для компьютерных систем с поддержкой квот.

Следующий пример иллюстрирует применение свойства FreeSpace:

function ShowFreeSpace(drvPath)
{
  var fso, d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(drvPath));
  s = "Устройство " + drvPath.toUpperCase( ) + " - ";
  s += d.VolumeName + "<br>";
  s += "Свободно: " + d.FreeSpace/1024 + " Kbytes";
  return(s);
}


Свойство FreeSpace

Свойство FreeSpace
Применение 		Справочник языка

Объект Drive


Свойство FreeSpace

Свойство FreeSpace
См. также 		Справочник языка

Свойство AvailableSpace
Свойство FileSystem
Свойство IsReady
Свойство TotalSize


Свойство IsReady

Свойство IsReady 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает True, если указанное устройство готово, и False - если не готово.
Синтаксис
object.IsReady

Параметр object - всегда объект a Drive.

Примечание
Для съемных медиа-устройств (например, CD-ROM), IsReady возвращает True только тогда, когда соответствующее средство вставлено и свободно для доступа.

Следующий пример иллюстрирует применение свойства IsReady:

function ShowDriveInfo(drvpath)
{
  var fso, d, s, t;
  fso = new ActiveXObject("Scripting.FileSystemObject")
  d = fso.GetDrive(drvpath)
  switch (d.DriveType)
  {
    case 0: t = "Unknown"; break;
    case 1: t = "Removable"; break;
    case 2: t = "Fixed"; break;
    case 3: t = "Network"; break;
    case 4: t = "CD-ROM"; break;
    case 5: t = "RAM Disk"; break;
  }
  s = "Drive " + d.DriveLetter + ": - " + t;
  if (d.IsReady)
    s += "<br>" + " Устройство готово.";
  else
    s += "<br>" + " Устройство не готово.";
  return(s);
}


Свойство IsReady

Свойство IsReady
Применение 		Справочник языка

Объект Drive


Свойство IsReady

Свойство IsReady
См. также 		Справочник языка

Свойство AvailableSpace
Свойство DriveLetter
Свойство DriveType
Свойство FileSystem
Свойство FreeSpace
Свойство SerialNumber
Свойство TotalSize
Свойство VolumeName


Свойство Path

Свойство Path 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает путь к указанным файлу, папки или диску.
Синтаксис
object.Path

Параметр object всегда является объектом File, Folder или Drive.

Примечание
Для символов дисков корневой каталог не включается. Например, путь к диску C означается как C:, а не C:\.

Следующий пример иллюстрирует применение свойства Path для объекта File:

function ShowFileAccessInfo(filespec)
{
  var fso, d, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec);
  s = f.Path.toUpperCase() + "<br>";
  s += "Создан: " + f.DateCreated + "<br>";
  s += "Последний доступ: " + f.DateLastAccessed + "<br>";
  s += "Последнее изменение: " + f.DateLastModified
  return(s);
}


Свойство Path

Свойство Path
Применение 		Справочник языка

Объект Drive
Объект File
Объект Folder


Свойство Path

Свойство Path
См. также 		Справочник языка

Свойства объекта Drive
Свойства объекта File
Свойства объекта Folder


Свойство RootFolder

Свойство RootFolder 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает объект Folder, представляющий собой корневую папку указанного диска. Только для чтения.
Синтаксис
object.RootFolder

Параметр object всегда является объектом Drive.

Примечание
Ко всем папкам и файлам, содержащимся на диске, можно обращаться, используя возвращенный объект Folder.

Следующий пример иллюстрирует применение свойства RootFolder:

function GetRootFolder(drv)
{
  var fso,d;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.DriveExists(drv))
    {
      d = fso.GetDrive(drv);
      return(d.RootFolder);
    }
  else
    return(false);
}


Свойство RootFolder

Свойство RootFolder
Применение 		Справочник языка

Объект Drive


Свойство RootFolder

Свойство RootFolder
См. также 		Справочник языка

Свойство AvailableSpace
Свойство DriveLetter
Свойство DriveType
Свойство FileSystem
Свойство FreeSpace
Свойство IsReady
Свойство Path
Свойство SerialNumber
Свойство ShareName
Свойство TotalSize
Свойство VolumeName


Свойство SerialNumber

Свойство SerialNumber 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает десятичный серийный номер, используемый для уникального определения диска.
Синтаксис
object.SerialNumber

Параметр object всегда является именем объекта Drive.

Примечание
Вы можете использовать свойство SerialNumber для гарантии того, что в устройство со съемными дисками вставлен правильный диск.

Следующий пример иллюстрирует применение свойства SerialNumber:

function ShowDriveInfo(drvpath)
{
  var fso, d, s, t;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(fso.GetAbsolutePathName(drvpath)));
  switch (d.DriveType)
  {
    case 0: t = "Unknown"; break;
    case 1: t = "Removable"; break;
    case 2: t = "Fixed"; break;
    case 3: t = "Network"; break;
    case 4: t = "CD-ROM"; break;
    case 5: t = "RAM Disk"; break;
  }
  s = "Устройство " + d.DriveLetter + ": - " + t;
  s += "<br>" + "SN: " + d.SerialNumber;
  return(s);
}


Свойство SerialNumber

Свойство SerialNumber
Применение 		Справочник языка

Объект Drive


Свойство SerialNumber

Свойство SerialNumber
См. также 		Справочник языка

Свойство DriveLetter
Свойство DriveType
Свойство FileSystem
Свойство IsReady
Свойство ShareName
Свойство VolumeName


Свойство ShareName

Свойство ShareName 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает сетевое имя ресурса для указанного устройства.
Синтаксис
object.ShareName

Параметр object всегда является именем объекта Drive.

Примечание
Если object не является сетевым диском, свойство ShareName возвращает пустую строку ("").

Следующий пример иллюстрирует применение свойства ShareName:

function ShowDriveInfo(drvpath)
{
  var fso, d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(fso.GetAbsolutePathName(drvpath)));
  s = "Устройство " + d.DriveLetter + ": - " + d.ShareName;
  return(s);
}


Свойство ShareName

Свойство ShareName
Применение 		Справочник языка

Объект Drive


Свойство ShareName

Свойство ShareName
См. также 		Справочник языка

Свойство DriveLetter
Свойство DriveType
Свойство SerialNumber
Свойство VolumeName


Свойство TotalSize

Свойство TotalSize 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает размер (в байтах) диска или сетевого ресурса.
Синтаксис
object.TotalSize

Параметр object всегда объект Drive.

Примечание
Свойство TotalSize применено в следующем примере:
function SpaceReport(drvPath)
{
  var fso, d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(drvPath));
  s = "Диск " + drvPath + " - ";
  s += d.VolumeName + "<br>";
  s += "Всего на диске: "+ d.TotalSize/1024 + " Kbytes <br>";
  s += "Свободно на диске:  " + d.FreeSpace/1024 + " Kbytes";
  return(s);
}


Свойство TotalSize

Свойство TotalSize
Применение 		Справочник языка

Объект Drive


Свойство TotalSize

Свойство TotalSize
См. также 		Справочник языка

Свойство AvailableSpace
Свойство DriveLetter
Свойство DriveType
Свойство FileSystem
Свойство FreeSpace
Свойство IsReady
Свойство Path
Свойство RootFolder
Свойство SerialNumber
Свойство ShareName
Свойство VolumeName


Свойство VolumeName

Свойство VolumeName 		Справочник языка
|Версия 3

См. также Применение

Описание
Устанавливает или возвращает метку диска.
Синтаксис
object.VolumeName [= newname]

Синтаксис свойства VolumeName состоит из частей:

Часть | Описание
object | Требуется. Всегда имя объекта Drive.
newname | Необязательно. Если указано, newname - новая метка указанного object.

Примечание
Следующий код иллюстрирует применение свойства VolumeName:
function SpaceReport(drvPath)
{
  var fso, d, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(drvPath));
  s = "Устройство: " + drvPath + " - ";
  s += d.VolumeName + "<br>";
  s += "Общий размер: "+ d.TotalSize/1024 + " Kbytes <br>";
  s += "Свободное место:  " + d.FreeSpace/1024 + " Kbytes";
  return(s);
}


Свойство VolumeName

Свойство VolumeName
Применение 		Справочник языка

Объект Drive


Свойство VolumeName

Свойство VolumeName
См. также 		Справочник языка

Свойство DriveLetter
Свойство DriveType
Свойство FileSystem
Свойство IsReady
Свойство SerialNumber
Свойство ShareName


Метод atEnd

Метод atEnd 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает булево значение, указывающее, находится ли перечислитель в конце совокупности.
Синтаксис
myEnum.atEnd( )

Аргумент myEnum является некоторым объектом Enumerator.

Возвращаемое значение
Метод atEnd возвращает true, если текущий элемент является последним в совокупности, совокупность является пустой, или текущий элемент неопределен. Иначе возвращается false.
Примечание
В следующем примере метод atEnd определяет, достигнут ли конец списка дисков:
function ShowDriveList()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[Drive not ready]";
    s +=  n + "<br>";
  }
  return(s);
}


Метод atEnd

Метод atEnd
Применение 		Справочник языка

Объект Enumerator


Метод atEnd

Метод atEnd
См. также 		Справочник языка

Метод item
Метод moveFirst
Метод moveNext


Метод item

Метод item 		Language Reference
Version 3

См. также Применение

Описание
Возвращает текущий элемент коллекции.
Синтаксис
myEnum.item( )

Параметр myEnum - некоторый объект Enumerator.

Возвращаемые значения
Метод item возврщает текущий элемент. Если совокупность пустая или элемент не определен, возвращается значение undefined.
Примечание

В следующем примере метод item возвращает члены совокупности Drives:

function ShowDriveList()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[Drive not ready]";
    s +=  n + "<br>";
  }
  return(s);
}


Метод item

Метод item
Применение 		Справочник языка

Объект Enumerator


Метод item

Метод item
См. также 		Справочник языка

Метод atEnd
Метод moveFirst
Метод moveNext


Метод moveFirst

Метод moveFirst 		Справочник языка
Версия 3

См. также Применение

Описание
Сброс текущего элемента совокупности на первый элемент.
Синтаксис
myEnum.moveFirst( )

Аргумент myEnum является объектом Enumerator.

Примечание
Если в совокупности нет элементов, то текущий элемент устанавливается как undefined.

В следующем примере метод moveFirst применяется для прохождения элементов совокупности дисков с начала:

function ShowFirstAvailableDrive()
{
  var fso, s, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  e.moveFirst();
  s = "";
  do
  {
     x = e.item();
     if (x.IsReady)
     {
       s = x.DriveLetter + ":";
       break;
     }
     else
       if (e.atEnd())
       {
         s = "No drives are available";
         break;
       }
     e.moveNext();
  }
  while (!e.atEnd());
  return(s);
}


Метод moveFirst

Метод moveFirst
Применение 		Справочник языка

Объект Enumerator


Метод moveFirst

Метод moveFirst
См. также 		Справочник языка

Метод atEnd
Метод item
Метод moveNext


Метод moveNext

Метод moveNext 		Справочник языка
Версия 3

См. также Применение

Описание
Устанавливает текущий элемент на следующий элемент совокупности.
Синтаксис
myEnum.moveNext( )

Аргумент myEnum является объектом Enumerator.

Примечание
Если перечислитель находится в конце совокупности или совокупность пуста, значение текущего элемента устанавливается как undefined.

В следующем примере метод moveNext применяется для обращения к следующему диску совокупности дисков:

function ShowDriveList()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[Drive not ready]";
    s +=  n + "<br>";
  }
  return(s);
}


Метод moveNext

Метод moveNext
Применение 		Справочник языка

Объект Enumerator


Метод moveNext

Метод moveNext
См. также 		Справочник языка

Метод atEnd
Метод item
Метод moveFirst


Коды JScript-ошибок

Microsoft® Jscript™
Коды JScript-ошибок 		Справочник языка

Код ошибки | Сообщение
5 | Недопустимый параметр или вызов процедуры
6 | Переполнение
7 | Недостаточно памяти
9 | Недопустимый диапазон значения
10 | Массив фиксирован или временно заблокирован
11 | Деление на нуль
13 | Несоответствие типов
14 | Превышение размера строки
17 | Невыполнимая операция
28 | Переполнение стэка
35 | Объект или функция не определены
48 | Ошибка загрузки DLL
51 | Внутренняя ошибка
52 | Неправильно число или имя файла
53 | Файл не найден
54 | Файл поврежден
55 | Файл уже открыт
57 | Ошибка ввода-вывода (I/O)
58 | Файл уже существует
61 | Диск переполнен
62 | Ввод после конца файла
67 | Слишком много файлов
68 | Устройство недоступно
70 | Разрешение не допустимо
71 | Диск не готов
74 | Невозможно переименовать с разных дисков
75 | Ошибка доступа к пути файла
76 | Путь не найден
91 | Переменная Object или With не установлена
92 | Цикл For не инициализирован
93 | Неверный образец строки
94 | Неправильное использование Null
322 | Невозможно создать необходимые временные файлы
424 | Требуется объект
429 | Автоматически сервер не может создать объект
430 | Класс не поддерживается автоматически
432 | Имя файла или класса не найдено в течении автоматической операции
438 | Объект не поддерживает свойство или метод <item>
440 | Автоматическая ошибка
445 | Объект не поддерживает данное действие
446 | Объект не поддерживает указанные параметры
447 | Объект не поддерживает текущие локальные установки
448 | Имя аргумента не найдено
449 | Параметр необязателен
450 | Неверное количество параметров или присваивание недопустимого свойства
451 | Объект не является совокупностью
453 | Указанная функция DLL не найдена
458 | Переменная использует автоматический тип, не поддерживаемый JScript
501 | Невозможно присвоить к переменной
502 | Объект небезопасен для выполнения
503 | Объект небезопасен для инициализации
504 | Объект небезопасен для создания
5000 | Невозможно присвоить к 'this'
5001 | <Item> не является числом; ожидается объект Number
5002 | <Item> не является функцией; ожидается объект Function
5003 | Невозможно присвоить к результату функции
5004 | <Item> - не индексируемый объект
5005 | <Item> не является строкой; ожидается объект String
5006 | <Item> не является датой; ожидается объект Date
5007 | <Item> не является объектом; ожидается объект Object
5008 | Невозможно назначить <item>; недопустимое назначение
5009 | <Item> не определен; неопределенный идентификатор
5010 | <Item> не булев тип; ожидается объект Boolean
5011 | Невозможно выполнить код сценария
5012 | Невозможно удалить <item>
5013 | <Item> не является массивом VBArray; ожидается объект VBArray
5014 | <Item> не является объектом JScript; ожидается объект JScript
5015 | <Item> не является перечислителем; ожидается объект Enumerator
5016 | <Item> - не является регулярным выражением; ожидается объект Regular Expression
5017 | Синтаксическая ошибка в регулярном выражении
5018 | Неожиданный квантификатор
5019 | Ожидается ']' в регулярном выражении
5020 | Ожидается ')' в регулярном выражении
5021 | Недопустимый диапазон в таблице символов


Feature Information by Version

Microsoft® JScript®
Feature Information by Version 		Language Reference

Version Information

The following table lists JScript language features and the version when first introduced.

Language Element | Version First Introduced
1.0 | 2.0 | 3.0 | 4.0 | 5.0
$1...$9 Properties | X
abs Method | X
acos Method | X
ActiveXObject Object | X
Addition Operator (+) | X
anchor Method | X
arguments Property | X
Array Object | X
asin Method | X
Assignment Operator (=) | X
atan Method | X
atan2 Method | X
atEnd Method | X
big Method | X
Bitwise AND Operator (&) | X
Bitwise Left Shift Operator (<<) | X
Bitwise NOT Operator (~) | X
Bitwise OR Operator (|) | X
Bitwise Right Shift Operator (>>) | X
Bitwise XOR Operator (^) | X
blink Method | X
bold Method | X
Boolean Object | X
break Statement | X
caller Property | X
catch Statement | X
@cc_on Statement | X
ceil Method | X
charAt Method | X
charCodeAt Method | X
Comma Operator (,) | X
// (Single-line Comment Statement) | X
/*..*/ (Multiline Comment Statement) | X
Comparison Operators | X
compile Method | X
concat Method (Array) | X
concat Method (String) | X
Conditional Compilation | X
Conditional Compilation Variables | X
Conditional (trinary) Operator (?:) | X
constructor Property | X
continue Statement | X
cos Method | X
Data Type Conversion | X
Date Object | X
Decrement Operator (--) | X
delete Operator | X
description Property | X
dimensions Method | X
Division Operator (/) | X
do...while Statement | X
E Property | X
Enumerator Object | X
Equality Operator (==) | X
Error Object | X
escape Method | X
eval Method | X
exec Method | X
exp Method | X
fixed Method | X
floor Method | X
fontcolor Method | X
fontsize Method | X
for Statement | X
for...in Statement | X
fromCharCode Method | X
Function Object | X
function Statement | X
getDate Method | X
getDay Method | X
getFullYear Method | X
getHours Method | X
getItem Method | X
getMilliseconds Method | X
getMinutes Method | X
getMonth Method | X
GetObject Function | X
getSeconds Method | X
getTime Method | X
getTimezoneOffset Method | X
getUTCDate Method | X
getUTCDay Method | X
getUTCFullYear Method | X
getUTCHours Method | X
getUTCMilliseconds Method | X
getUTCMinutes Method | X
getUTCMonth Method | X
getUTCSeconds Method | X
getVarDate Method | X
getYear Method | X
Global Object | X
Greater than Operator (>) | X
Greater than or equal to Operator (>=) | X
Identity Operator (===) | X
@if Statement | X
if...else Statement | X
Increment Operator (++) | X
index Property | X
indexOf Method | X
Inequality Operator (!=) | X
Infinity Property | X
input Property | X
instanceof Operator | X
isFinite Method | X
isNaN Method | X
italics Method | X
item Method | X
join Method | X
Labeled Statement | X
lastIndex Property | X
lastIndexOf Method | X
lbound Method | X
length Property (Array) | X
length Property (Function) | X
length Property (String) | X
Less than Operator (<) | X
Less than or equal to Operator (<=) | X
link Method | X
LN2 Property | X
LN10 Property | X
log Method | X
LOG2E Property | X
LOG10E Property | X
Logical AND Operator (&&) | X
Logical NOT Operator (!) | X
Logical OR Operator (||) | X
match Method | X
Math Object | X
max Method | X
MAX_VALUE Property | X
min Method | X
MIN_VALUE Property | X
Modulus Operator (%) | X
moveFirst Method | X
moveNext Method | X
Multiplication Operator (*) | X
NaN Property (Global) | X
NaN Property (Number) | X
NEGATIVE_INFINITY Property | X
new Operator | X
Nonidentity Operator (!==) | X
Number Object | X
number Property | X
Object Object | X
Operator Precedence | X
parse Method | X
parseFloat Method | X
parseInt Method | X
PI Property | X
POSITIVE_INFINITY Property | X
pow Method | X
prototype Property | X
random Method | X
RegExp Object | X
Regular Expression Object | X
Regular Expression Syntax | X
replace Method | X
return Statement | X
reverse Method | X
round Method | X
ScriptEngine Function | X
ScriptEngineBuildVersion Function | X
ScriptEngineMajorVersion Function | X
ScriptEngineMinorVersion Function | X
search Method | X
@set Statement | X
setDate Method | X
setFullYear Method | X
setHours Method | X
setMilliseconds Method | X
setMinutes Method | X
setMonth Method | X
setSeconds Method | X
setTime Method | X
setUTCDate Method | X
setUTCFullYear Method | X
setUTCHours Method | X
setUTCMilliseconds Method | X
setUTCMinutes Method | X
setUTCMonth Method | X
setUTCSeconds Method | X
setYear Method | X
sin Method | X
slice Method (Array) | X
slice Method (String) | X
small Method | X
sort Method | X
source Property | X
split Method | X
sqrt Method | X
SQRT1_2 Property | X
SQRT2 Property | X
strike Method | X
String Object | X
sub Method | X
substr Method | X
substring Method | X
Subtraction Operator (-) | X
sup Method | X
switch Statement | X
tan Method | X
test Method | X
this Statement | X
throw Statement | X
toArray Method | X
toGMTString Method | X
toLocaleString Method | X
toLowerCase Method | X
toString Method | X
toUpperCase Method | X
toUTCString Method | X
try Statement | X
typeof Operator | X
ubound Method | X
Unary Negation Operator (-) | X
unescape Method | X
Unsigned Right Shift Operator (>>>) | X
UTC Method | X
valueOf Method | X
var Statement | X
VBArray Object | X
void Operator | X
while Statement | X
with Statement | X


Свойство Attributes

Свойство Attributes 		Справочник языка
Версия 3

См. также Применение

Описание
Устанавливает или возвращает атрибуты файлов или папок. Чтение/запись или только для чтения, зависит от атрибута.
Синтаксис
object.Attributes [= newattributes]

Синтаксис свойства Attributes состоит из частей:

Часть | Описание
object | Требуется. Всегда имя объекта File или Folder.
newattributes | Необязательно. Если указано, newattributes - новое значения атрибутов указанного объекта.

Аргумент newattributes может иметь любое одно или логическую комбинацию указанных ниже значений:

Константа | Значение | Описание
Normal | 0 | Обычный файл. Нет установленных атрибутов.
ReadOnly | 1 | Файл только для чтения. Атрибут - read/write.
Hidden | 2 | Скрытый файл. Атрибут - read/write.
System | 4 | Системный файл. Атрибут - read/write.
Volume | 8 | Значение метки. Атрибут - read-only.
Directory | 16 | Папка или каталог. Атрибут - read-only.
Archive | 32 | Архивный файл. Атрибут - read/write.
Alias | 64 | Ссылка или ярлык. Атрибут - read-only.
Compressed | 128 | Сжатый файл. Атрибут - read-only.

Примечание
В следующем примере приведен код, использующий свойство Attributes над файлами:
function ToggleArchiveBit(filespec)
{
  var fso, f, r, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec)
  if (f.attributes && 32)
  {
    f.attributes = f.attributes - 32;
    s = "Разряд архива обнулен.";
  }
  else
  {
    f.attributes = f.attributes + 32;
    s =  "Разряд архива установлен.";
  }
  return(s);
}


Свойство Attributes

Свойство Attributes
Применение 		Справочник языка

Объект File
Объект Folder


Свойство Attributes

Свойство Attributes
См. также 		Справочник языка

DateCreated свойство
DateLastAccessed свойство
DateLastModified свойство
Drive свойство
Files свойство
IsRootFolder свойство
Name свойство
ParentFolder свойство
Path свойство
ShortName свойство
ShortPath свойство
Size свойство
SubFolders свойство
Type свойство


Метод Copy

Метод Copy 		Справочник языка
Версия 3

См. также Применение

Описание
Копирование указанного файла или папки из одного места в другое.
Синтаксис
object.Copy( destination[, overwrite] );

Синтаксис метода Copy состоит из частей:

Часть | Описание
object | Требуется. Всегда имя объекта File или Folder.
destination | Требуется. Указывает, куда файл или папку требуется скопировать. Групповые символы не применяются.
overwrite | Необязательно. Булево значение: True (по умолчанию), если папки и файлы перезаписываются; False, если нет.

Примечание
Результаты метода для файлов и папок идентичны операциям FileSystemObject.CopyFile или FileSystemObject.CopyFolder. Однако, альтернативные методы позволяют копировать несколько файлов или папок.

В следующем примере используется метод Copy:

var fso, f;
fso = new ActiveXObject("Scripting.FileSystemObject");
f = fso.CreateTextFile("c:\\testfile.txt", true);
f.WriteLine("Тест. Только тест.");
f.Close();
f = fso.GetFile("c:\\testfile.txt");
f.Copy("c:\\windows\\desktop\\test2.txt");


Метод Copy

Метод Copy
Применение 		Справочник языка

Объект File
Объект Folder


Метод Copy

Метод Copy
См. также 		Справочник языка

Метод CopyFile
Метод CopyFolder
Метод Delete
Метод Move
Метод OpenAsTextStream


Метод CreateTextFile

Метод CreateTextFile 		Справочник языка
Версия 2

См. также Применение

Описание
Cоздает файл с указанным именем и возвращает объект TextStream, доступный для чтения/записи.
Синтаксис
object.CreateTextFile(filename[, overwrite[, unicode]])

Синтаксис метода CreateTextFile состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject или Folder.
filename | Требуется. Строковое выражение, указывающее на созданный файл.
overwrite | Необязательно. Логическое значение, указывающее на возможность перезаписи уже существующего файла. Значение true позволяет перезаписывать файл, значение false не позволяет. Если опущено, то перезаписывать файлы не допускается.
unicode | Необязательно. Логическое значение, указывающее на формат создаваемого файла. При значении, равным true, файл создается в формате Unicode, а если указано значение false, то в формате ASCII. Если значение не указано, то подразумевается формат ASCII.

Примечание
Следующий пример иллюстрирует применение метода CreateTextFile для создания и открытия файла:
var fso = new ActiveXObject("Scripting.FileSystemObject");
var a = fso.CreateTextFile("c:\\testfile.txt", true);
a.WriteLine("Это - тест!.");
a.Close();
Если аргумент overwrite имеет значение false (или не указан), то возникает ошибка, если файл filename уже существует.


Метод CreateTextFile

Метод CreateTextFile
Применение 		Справочник языка

Объект FileSystemObject
Объект Folder


Метод CreateTextFile

Метод CreateTextFile
См. также 		Справочник языка

Метод CreateFolder
Метод OpenAsTextStream
Метод OpenTextFile


Свойство DateCreated

Свойство DateCreated 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает дату и время, когда указанные файл или папка были созданы. Только для чтения.
Синтаксис
object.DateCreated

Параметр object всегда является именем объекта File или Folder.

Примечание
Следующий пример иллюстрирует применение свойства DateCreated:
function ShowFileInfo(filespec)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec);
  s = "Дата создания: " + f.DateCreated;
  return(s);
}


Свойство DateCreated

Свойство DateCreated
Применение 		Справочник языка

Объект File
Объект Folder


Свойство DateCreated

Свойство DateCreated
См. также 		Справочник языка

Свойства объекта File
Свойства объекта Folder


Свойство DateLastAccessed

Свойство DateLastAccessed 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает дату и время последнего доступа к указанному файлу (папке). Только для чтения.
Синтаксис
object.DateLastAccessed

Аргумент object всегда является именем объекта File или Folder.

Примечание
Следующий пример иллюстрирует применение свойства DateLastAccessed при работе с файлом:
function ShowFileAccessInfo(filespec)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec);
  s = filespec.toUpperCase() + "<br>";
  s += "Дата создания: " + f.DateCreated + "<br>";
  s += "Последний доступ: " + f.DateLastAccessed + "<br>";
  s += "Последнее изменение: " + f.DateLastModified;
  return(s);
}
Предупреждение Поведение метода зависит от основ операционной системы. Если операционная система не поддерживает обеспечение подобной информации, то ничего не будет возвращено.


Свойство DateLastAccessed

Свойство DateLastAccessed
Применение 		Справочник языка

Объект File
Объект Folder


Свойство DateLastAccessed

Свойство DateLastAccessed
См. также 		Справочник языка

Свойства объекта File
Свойства объекта Folder


Свойство DateLastModified

Свойство DateLastModified 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает дату и время последнего изменения указанного файла (папки). Только для чтения.
Синтаксис
object.DateLastModified

Аргумент object всегда является объектом File или Folder.

Примечание
Следующий пример иллюстрирует применение свойства DateLastModified при работе с файлами:
function ShowFileAccessInfo(filespec)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec);
  s = filespec.toUpperCase() + "<br>";
  s += "Дата создания: " + f.DateCreated + "<br>";
  s += "Последний доступ: " + f.DateLastAccessed + "<br>";
  s += "Последнее изменение: " + f.DateLastModified;
  return(s);
}


Свойство DateLastModified

Свойство DateLastModified
Применение 		Справочник языка

Объект File
Объект Folder


Свойство DateLastModified

Свойство DateLastModified
См. также 		Справочник языка

Свойства объекта File
Свойства объекта Folder


Метод Delete

Метод Delete 		Справочник языка
Версия 3

См. также Применение

Описание
Удаляет указанные файл или папку.
Синтаксис
object.Delete( force );

Синтаксис метода Delete состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта File или Folder.
force | Необязательно. Булево значение, True - если файлы или папки с аттрибутом read-only attribute должны удаляться, и False (по умолчанию) - если нет.

Примечание
Если указанные файл или папка не существуют, то возникает ошибка.

Результаты применения метода Delete над объектами File или Folder идентичны использованию FileSystemObject.DeleteFile или FileSystemObject.DeleteFolder.

Метод Delete не различает папки, имеющие содержание и пустые. Указанная папка удаляется независимо от того, имеет она какое-либо содержимое или нет.

Следующий пример иллюстрирует применение метода Delete:

var fso, f;
fso = new ActiveXObject("Scripting.FileSystemObject");
f = fso.CreateTextFile("c:\\testfile.txt", true);
f.WriteLine("Это только тест.");
f.Close();
f = fso.GetFile("c:\\testfile.txt");
f.Delete();


Метод Delete

Метод Delete
Применение 		Справочник языка

Объект File
Объект Folder


Метод Delete

Метод Delete
См. также 		Справочник языка

Метод Copy
Метод DeleteFile
Метод DeleteFolder
Метод Move
Метод OpenAsTextStream


Свойство Drive

Свойство Drive 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает символ диска, на котором постоянно находится указанный файл (папка). Только для чтения.
Синтаксис
object.Drive

Аргумент object всегдa является именем объекта File или Folder.

Примечание
Следующий пример иллюстрирует применение свойства Drive:
function ShowFileAccessInfo(filespec)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec);
  s = f.Name + " на диске " + f.Drive + "<br>";
  s += "Создан: " + f.DateCreated + "<br>";
  s += "Последний доступ: " + f.DateLastAccessed + "<br>";
  s += "Последнее обновление: " + f.DateLastModified;
  return(s);
}


Свойство Drive

Свойство Drive
Применение 		Справочник языка

Объект File
Объект Folder


Свойство Drive

Свойство Drive
См. также 		Справочник языка

Свойства объекта File
Свойства объекта Folder


Метод Move

Метод Move 		Справочник языка
Версия 3

См. также Применение

Описание
Перемещает указанный файл (папку) из одного места в другое.
Синтаксис
object.Move( destination );

Синтаксис метода Move состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта File или Folder.
destination | Требуется. Адрес, куда файл (папка) будет перемещен.

Примечание
Результат метода Move над объектом File или Folder идентичен использованию FileSystemObject.MoveFile или FileSystemObject.MoveFolder. Однако, альтернативные методы позволяют перемещение нескольких файлов или папок.


Метод Move

Метод Move
Применение 		Справочник языка

Объект File
Объект Folder


Метод Move

Метод Move
См. также 		Справочник языка

Метод Copy
Метод Delete
Метод MoveFile
Метод MoveFolder
Метод OpenAsTextStream


Свойство Name

Свойство Name 		Справочник языка
Версия 3

См. также Применение

Описание
Устанавливает или возвращает имя для указанного файла (папки). Чтение/запись.
Синтаксис
object.Name [= newname]

Синтаксис свойства Name состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта File или Folder.
newname | Необязательно. Если указан, то newname - новое имя указанного object.

Примечание
Следующий пример иллюстрирует применение свойства Name:
function ShowFileAccessInfo(filespec)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(filespec);
    s = f.Name + " на диске " + f.Drive + "<br>";
    s += "Дата создания: " + f.DateCreated + "<br>";
    s += "Последний доступ: " + f.DateLastAccessed + "<br>";
    s += "Последнее изменение: " + f.DateLastModified;
    return(s);
}


Свойство Name

Свойство Name
Применение 		Справочник языка

Объект File
Объект Folder


Свойство Name

Свойство Name
См. также 		Справочник языка

Свойства объекта File
Свойства объекта Folder


Метод OpenAsTextStream

Метод OpenAsTextStream 		Справочник языка
Версия 3

См. также Применение

Описание
Открывает указанный файл и возвращает объект TextStream, который можно использовать для чтения, записи и добавления в конец файла.
Синтаксис
object.OpenAsTextStream([iomode, [format]])

Синтаксис метода OpenAsTextStream состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта File.
iomode | Необязательно. Индикатор режима ввода-вывода. Равняется одной из констант: ForReading, ForWriting или ForAppending.
format | Необязательно. Значение Tristate - одно из трех состояний для открытия файла. Если параметр опущен, файл открывается как ASCII-файл.

Settings
Аргумент iomode может иметь одну из следующих установок:

Константа | Значение | Описание
ForReading | 1 | Открытие файла только для чтения. Невозможно произвести запись в файл.
ForWriting | 2 | Открывает файл для записи. Если файл существует, все его содержимое перезаписывается.
ForAppending | 8 | Открывает файл и добавляет записи в конец файла.

Аргумент format может иметь одну из следующих установок:

Константа | Значение | Описание
TristateUseDefault | -2 | Открытие файла в формате системы по умолчанию.
TristateTrue | -1 | Открытие файла в формате Unicode.
TristateFalse | 0 | Открытие файла в формате ASCII.

Примечание
Метод OpenAsTextStream обеспечивает те же самые функциональные возможности, что и метод OpenTextFile объекта FileSystemObject. Кроме того, метод OpenAsTextStream может применяться для записи в файл.

Следующий пример иллюстрирует применение метода OpenAsTextStream:

function TextStreamTest( )
{
    var fso, f, ts, s;
    var ForReading = 1, ForWriting = 2, ForAppending = 3;
    var TristateUseDefault = -2, TristateTrue = -1, TristateFalse = 0;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    fso.CreateTextFile( "test1.txt" );           // Создание файла
    f = fso.GetFile("test1.txt");
    ts = f.OpenAsTextStream(ForWriting, TristateUseDefault);
    ts.Write( "Привет, Народ!" );
    ts.Close( );
    ts = f.OpenAsTextStream(ForReading, TristateUseDefault);
    s = ts.ReadLine( );
    ts.Close( );
    return(s);
}


Метод OpenAsTextStream

Метод OpenAsTextStream
Применение 		Справочник языка

Объект File


Метод OpenAsTextStream

Метод OpenAsTextStream
См. также 		Справочник языка

Метод CreateTextFile
Метод OpenTextFile


Метод OpenTextFile

Метод OpenTextFile 		Справочник языка
Версия 2

См. также Применение

Описание
Открывает указанный файл и возвращает объект TextStream, который может применяться для чтения, записи и добавления в конец файла.
Синтаксис
object.OpenTextFile(filename[, iomode[, create[, format]]])

Синтаксис метода OpenTextFile состоит из частей:

Часть | Описание
object | Требуется. Object всегда является именем объекта FileSystemObject.
filename | Требуется. Строковое выражение, указывающее на файл для открытия.
iomode | Необязательно. Может быть одной из трех постоянных: ForReading, ForWriting или ForAppending.
create | Необязательно. Логическое значение, указывающее, должен ли создаваться новый файл, если файл filename не существует. При значении, равном True новый файл будет создан, при значении False - нет. Если значение не указано, то файл не создается.
format | Необязательно. Одно из трех значений Tristate, означающее формат файла. Если опущено, то подразумевается формат ASCII.

Settings
Аргумент iomode может принимать следующие значения:

Constant | Value | Описание
ForReading | 1 | Открывает файл только для чтения.
ForWriting | 2 | Открывает файл для записи (перезаписи).
ForAppending | 8 | Открывает файл для записи в конец файла.

Аргумент format может принимать одно из следующих значений:

Value | Описание
TristateTrue | Открывает файл как Unicode.
TristateFalse | Открывает файл как ASCII.
TristateUseDefault | Открывает файл согласно установкам системы по умолчанию.

Примечание
Следующий пример иллюстрирует применение метода OpenTextFile для открытия и записи в конец файла:
var fs, a, ForAppending;
ForAppending = 8;
fs = new ActiveXObject("Scripting.FileSystemObject");
a = fs.OpenTextFile("c:\\testfile.txt", ForAppending, false);
...
a.Close();


Метод OpenTextFile

Метод OpenTextFile
Применение 		Справочник языка

Объект FileSystemObject


Метод OpenTextFile

Метод OpenTextFile
См. также 		Справочник языка

Метод CreateTextFile
Метод OpenAsTextStream


Свойство ParentFolder

Свойство ParentFolder 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает папку, родительскую для указанного файла (папки). Только для чтения.
Синтаксис
object.ParentFolder

Аргумент object всегда является именем объекта File или Folder.

Примечание
Следующий пример иллюстрирует применение свойства ParentFolder:
function ShowFileAccessInfo(filespec)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(filespec);
    s = f.Name + " в папке " + f.ParentFolder + "<br>";
    s += "Дата создания: " + f.DateCreated + "<br>";
    s += "Последний доступ: " + f.DateLastAccessed + "<br>";
    s += "Последнее изменение: " + f.DateLastModified;
    return(s);
}


Свойство ParentFolder

Свойство ParentFolder
Применение 		Справочник языка

Объект File
Объект Folder


Свойство ParentFolder

Свойство ParentFolder
См. также 		Справочник языка

Свойства объекта File
Свойства объекта Folder


Свойство ShortName

Свойство ShortName 		Справочник языка
|Версия 3

См. также Применение

Описание
Возвращает короткое имя в формате соглашения "8.3".
Синтаксис
object.ShortName

Параметр object всегда является именем объекта File или Folder.

Примечание
Следующий пример иллюстрирует применение свойства ShortName в объекте File:
function ShowShortName(filespec)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(filespec);
    s = "Полное имя: " + "" + f.Name;
    s += "" + "<br>";
    s += " Короткое имя: " + "" + f.ShortName + "";
    return(s);
}


Свойство ShortName

Свойство ShortName
Применение 		Справочник языка

Объект File
Объект Folder


Свойство ShortName

Свойство ShortName
См. также 		Справочник языка

Свойства объекта File
Свойства объекта Folder


Свойство ShortPath

Свойство ShortPath 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает короткий путь для программ, использующих соглашение "8.3".
Синтаксис
object.ShortPath

Аргумент object всегда является именем объекта File или Folder.

Примечание
Следующий пример иллюстрирует применение свойства ShortName при работе с объектом File:
function ShowShortPath(filespec)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFile(filespec);
    s = "The short path for " + "" + f.Name;
    s += "" + "<br>";
    s += "is: " + "" + f.ShortPath + "";
    return(s);
}


Свойство ShortPath

Свойство ShortPath
Применение 		Справочник языка

Объект File
Объект Folder


Свойство ShortPath

Свойство ShortPath
См. также 		Справочник языка

Свойства объекта File
Свойства объекта Folder


Свойство Size

Свойство Size 		Справочник языка
|Версия 3

См. также Применение

Описание
Для файлов возвращает размер (в байтах) указанного файла. Для папок возвращает размер (в байтах) всех файлов и подкаталогов, содержащихся в указанной папкеr.
Синтаксис
object.Size

Параметр object всегда является именем объекта File или Folder.

Примечание
Следующий пример иллюстрирует применение свойства Size в объекте Folder:
function ShowFolderSize(filespec)
{
    var fso, f, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    f = fso.GetFolder(filespec);
    s = f.Name + " занимает " + f.size + " байт.";
    return(s);
}


Свойство Size

Свойство Size
Применение 		Справочник языка

Объект File
Объект Folder


Свойство Size

Свойство Size
См. также 		Справочник языка

Свойства объекта File
Свойства объекта Folder


Метод BuildPath

Метод BuildPath 		Справочник языка
Версия 3

См. также Применение

Описание
Добавляет имя к существующему пути.
Синтаксис
object.BuildPath(path, name)

Синтаксис метода BuildPath состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
path | Требуется. Существующий путь, к которому добавляется name. Путь может быть абсолютным и относительным.
name | Требуется. Имя, добавляемое к существующему path.

Примечание
Метод BuildPath вставляет разделитель пути между существующим путем и именем только в том случае, когда это необходимо.

Следующий пример иллюстрирует применение метода BuildPath:

function GetBuildPath(path)
{
  var fso, newpath;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  newpath = fso.BuildPath(path, "New  Folder");
  return(newpath);
}


Метод BuildPath

Метод BuildPath
Применение 		Справочник языка

Объект FileSystemObject


Метод BuildPath

Метод BuildPath
См. также 		Справочник языка

Метод GetAbsolutePathName
Метод GetBaseName
Метод GetTempName


Метод CopyFile

Метод CopyFile 		Справочник языка
Версия 3

См. также Применение

Описание
Копирует один или более файлов из одного места в другое.
Синтаксис
object.CopyFile ( source, destination[, overwrite] )

Синтаксис метода CopyFile состоит из частей:

Часть | Описание
object | Требуется. Параметр object всегда является именем объекта FileSystemObject.
source | Требуется. Строковое выражение, указывающее путь (возможно включающий символы подстановки), откуда будут скопированы файлы.
destination | Требуется. Строковое выражение, указывающее, куда будут скопированы файлы из source. Символы подстановки недопустимы.
overwrite | Необязательно. Логическое значение, указывающее, должны ли существующие файлы быть перезаписаны. Если значение равно true, файлы перезаписываются; если false, то не перезаписываются. Значение по умолчанию равно true. Обратите внимание,что применение метода CopyFile вызовет сбой, если для destination установлен аттрибут только для чтения независимо от значения overwrite.

Примечание
Символы подстановки могут применяться лишь в последнем компоненте пути параметра source. Например, можно применить следующий код:
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CopyFile ("c:\\mydocuments\\letters\\*.doc", "c:\\tempfolder\\")
Подобный код недопустим:
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CopyFile ("c:\\mydocuments\\*\\R1???97.xls", "c:\\tempfolder")
Если source содержит символы подстановки или destination заканчивается разделителем пути (\), подразумевается, что destination - существующая папка, в которую будут скопированы соответствующие файлы. В других случаях destination принимается как имя файла для создания. При копировании отдельного файла возможны три случая.
  • Если destination не существует, source копируется. Это обычный случай.
  • Если destination - существующий файл, возникает ошибка при overwrite равном false. Иначе делается попытка скопировать source поверх существующего файла.
  • Если destination является директорией, то возникает ошибка.
Также возникает ошибка, если в source применены символы подстановки, несоответствующие ни одному файлу. Метод CopyFile останавливается при встрече с первой ошибкой. Никаких попыток для отмены сделанных изменений до возникновения ошибки не производится.


Метод CopyFile

Метод CopyFile
Применение 		Справочник языка

Объект FileSystemObject


Метод CopyFile

Метод CopyFile
См. также 		Справочник языка

Метод Copy
Метод CopyFolder
Метод CreateTextFile
Метод DeleteFile
Метод MoveFile


Метод CopyFolder

Метод CopyFolder 		Справочник языка
Версия 3

См. также Применение

Описание
Рекурсивно копирует папку из одного места в другое.
Синтаксис
object.CopyFolder ( source, destination[, overwrite] );

Синтаксис метода CopyFolder состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
source | Требуется. Строковое значение, обозначающее путь, откуда одна или несколько папок будут скопированы. Может содержать символы подстановки.
destination | Требуется. Строковое значение, обозначающее путь, куда папки и подкаталоги будут копироваться из source. Символы подстановки не допускаются.
overwrite | Необязательно. Логическое значение, указывающее, должны ли существующие папки быть перезаписаны. При значении true файлы перезаписываются, при false - не перезаписываются. Значение по умолчанию - true.

Примечание
Символы подстановки могут использоваться только в последнем компоненте пути аргумента source. Например, можно применить следующий код:
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CopyFolder ("c:\\mydocuments\\letters\\*", "c:\\tempfolder\\")
А подобный код не допустим:
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CopyFolder ("c:\\mydocuments\\*\\*", "c:\\tempfolder\\")
Если source содержит символы подстановки или destination оканчивается разделителем пути (\), подразумевается, что destination - существующая папка, в которую будут скопированы соответствующие папки и подкаталоги. Иначе destination считается именем папки для создания. Вообще, при копировании отдельной папки возможны четыре случая.
  • Если destination не существует, то папка source со всем содержимым будет скопирована. Это обычный случай.
  • Если destination является существующим файлом, то возникает ошибка.
  • Если destination является папкой, то выполняется попытка скопировать папку со всем содержимым. Если файл, содержащийся в source уже существует в destination, то возникает ошибка, если значение overwrite равно false. Иначе при копировании файл будет перезаписан поверх существующего.
  • Если destination является папкой с аттрибутом только для чтения, то ошибка возникает если сделана попытка скопировать существующий файл с установленным аттрибутом только для чтения в папку, и значение overwrite равно false.
Также возникает ошибка, если в source используются символы подстановки, не соответствующие никакой из папок.

Метод CopyFolder останавливается после первой встреченной ошибки. Никаких попыток для восстановления уже сделанных до ошибки изменений не производится.


Метод CopyFolder

Метод CopyFolder
Применение 		Справочник языка

Объект FileSystemObject


Метод CopyFolder

Метод CopyFolder
См. также 		Справочник языка

Метод CopyFile
Метод Copy
Метод CreateFolder
Метод DeleteFolder
Метод MoveFolder


Метод CreateFolder

Метод CreateFolder 		Справочник языка
Версия 3

См. также Применение

Описание
Создает папку.
Синтаксис
object.CreateFolder(foldername)

Синтаксис метода CreateFolder состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
foldername | Требуется. Строковое выражение, идентифицируемое для создания папки.

Примечание
Если указанная папка уже существует, то возникает ошибка.

Следующий пример иллюстрирует применение метода CreateFolder для создания папки:

var fso = new ActiveXObject("Scripting.FileSystemObject");
var a = fso.CreateFolder("c:\\new folder");


Метод CreateFolder

Метод CreateFolder
Применение 		Справочник языка

Объект FileSystemObject


Метод CreateFolder

Метод CreateFolder
См. также 		Справочник языка

Метод CopyFolder
Метод DeleteFolder
Метод MoveFolder


Метод DeleteFile

Метод DeleteFile 		Справочник языка
Версия 3

См. также Применение

Описание
Удаляет указанный файл.
Синтаксис
object.DeleteFile ( filespec[, force] );

Синтаксис метода DeleteFile состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
filespec | Требуется. Имя файла для удаления. Параметр filespec может содержать символы подстановки в последнем компоненте пути.
force | Необязательно. Логическое значение: true - файлы с аттрибутом только для чтения удаляются; false (по умолчанию) - не удаляются.

Примечание
Если указанный файл не найден, то возникает ошибка. Метод DeleteFile останавливается на первой ошибке. Никакой откат не допустим для изменений, которые были сделаны прежде, чем произошла ошибка.

Следующий пример иллюстрирует применение метода DeleteFile:

function DeleteFile(filespec)
{
  var fso;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  fso.DeleteFile(filespec);
}


Метод DeleteFile

Метод DeleteFile
Применение 		Справочник языка

Объект FileSystemObject


Метод DeleteFile

Метод DeleteFile
См. также 		Справочник языка

Метод CopyFile
Метод CreateTextFile
Метод Delete
Метод DeleteFolder
Метод MoveFile


Метод DeleteFolder

Метод DeleteFolder 		Справочник языка
Версия 3

См. также Применение

Описание
Удаляет указанную папку и ее содержимое.
Синтаксис
object.DeleteFolder ( folderspec[, force] );

Синтаксис метода DeleteFolder состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
folderspec | Требуется. Имя папки для удаления. Аргумент folderspec может содержать символы подстановки при указании пути.
force | Необязательно. Логическое значение: true - папки с аттрибутом только для чтения будут удалены; false (по умолчанию) - не будут удалены.

Примечание
Метод DeleteFolder не делает различий между папками, имеющими содержимое или пустыми. Указанная папка удаляется независимо от ее содержимого.

Если указанная папка не найдена, то возникает ошибка. Метод DeleteFolder останавливается после первой ошибки. Никаких попыток восстановить измененные до возникновения ошибки данные не производится.

Следующий пример иллюстрирует применение метода DeleteFolder:

function DeleteFolder(folderspec)
{
  var fso;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  fso.DeleteFolder(folderspec);
}


Метод DeleteFolder

Метод DeleteFolder
Применение 		Справочник языка

Объект FileSystemObject


Метод DeleteFolder

Метод DeleteFolder
См. также 		Справочник языка

Метод CopyFolder
Метод CreateFolder
Метод Delete
Метод DeleteFile
Метод MoveFolder


Метод DriveExists

Метод DriveExists 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает True, если указанное устройство существует, и False если нет.
Синтаксис
object.DriveExists(drivespec)

Синтаксис метода DriveExists состоит из частей:

Часть | Описание
object | Требуется. Всегда имя объекта FileSystemObject.
drivespec | Требуется. Символ диска или указание полного пути.

Примечание
Для устройств со съемными дисками, метод DriveExists возвращает значение true, если диск не вставлен. Для определения готовности устройства используется свойство IsReady объекта Drive.

Следующий пример иллюстрирует применение метода DriveExists:

function ReportDriveStatus(drv)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.DriveExists(drv))
    s += "Устройство " + drv + " существует.";
  else
    s += "Устройство " + drv + " не существует.";
  return(s);
}


Метод DriveExists

Метод DriveExists
Применение 		Справочник языка

Объект FileSystemObject


Метод DriveExists

Метод DriveExists
См. также 		Справочник языка

Объект Drive
Совокупность дисков
Метод FileExists
Метод FolderExists
Свойство IsReady


Свойство Drives

Свойство Drives 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает совокупность дисков, состоящую из всех объектов Drive, доступных на локальной машине.
Синтаксис
object.Drives

Аргумент object всегда является именем объекта FileSystemObject.

Примечание

Вы можете итерировать по элементам совокупность дисков, используя объeкт Enumerator и инструкцию for:

function ShowDriveList()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (; !e.atEnd(); e.moveNext())
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[Устройство не готово]";
    s +=  n + "<br>";
  }
  return(s);
}


Свойство Drives

Свойство Drives
Применение 		Справочник языка

Объект FileSystemObject


Свойство Drives

Свойство Drives
См. также 		Справочник языка

Совокупность дисков
Свойство Files
Свойство SubFolders


Метод FileExists

Метод FileExists 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает True, если указанный файл существует, и False, если нет.
Синтаксис
object.FileExists(filespec)

Синтаксис метода FileExists состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
filespec | Требуется. Имя файла, чье существование должно быть определено. Указание пути (абсолютного или относительного) необходимо в случае, если существование указанного файла определяется не для текущей папки.

Следующий пример иллюстрирует применение метода FileExists:

function ReportFileStatus(filespec)
{
  var fso, s = filespec;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.FileExists(filespec))
    s += " существует.";
  else
    s += " не существует.";
  return(s);
}


Метод FileExists

Метод FileExists
Применение 		Справочник языка

Объект FileSystemObject


Метод FileExists

Метод FileExists
См. также 		Справочник языка

Метод DriveExists
Метод FolderExists


Метод FolderExists

Метод FolderExists 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает True, если указанная папка существует, и False - если не существует.
Синтаксис
object.FolderExists(folderspec)

Синтаксис метода FolderExists состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
folderspec | Требуется. Имя папки, чье существование должно быть определено. Указание пути (абсолютного или относительного) необходимо в случае, если существование указанной папки определяется не для текущей папки.

Следующий пример иллюстрирует применение метода FolderExists:

function ReportFolderStatus(fldr)
{
  var fso, s = fldr;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.FolderExists(fldr))
    s += " существует.";
  else
    s += " не существует.";
  return(s);
}


Метод FolderExists

Метод FolderExists
Применение 		Справочник языка

Объект FileSystemObject


Метод FolderExists

Метод FolderExists
См. также 		Справочник языка

Метод DriveExists
Метод FileExists


Метод GetAbsolutePathName

Метод GetAbsolutePathName 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает полный однозначный путь для заданного пути.
Синтаксис
object.GetAbsolutePathName(pathspec)

Синтаксис метода GetAbsolutePathName состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
pathspec | Требуется. Указание пути для определения полного однозначного пути.

Примечание
Путь является законченным и однозначным, если он обеспечивает полную ссылку от корневой директории указанного диска. Полный путь может заканчиваться только символом разделителя пути (\), если он указывает корневую папку отображаемого диска.

Допустим, что текущим каталогом является c:\mydocuments\reports, тогда в следующей таблице показано поведение метода GetAbsolutePathName.

pathspec | Возвращаемый путь
"c:" | "c:\mydocuments\reports"
"c:.." | "c:\mydocuments"
"c:\\" | "c:\"
"c:*.*\\may97" | "c:\mydocuments\reports\*.*\may97"
"region1" | "c:\mydocuments\reports\region1"
"c:\\..\\..\\mydocuments" | "c:\mydocuments"

Следующий пример иллюстрирует применение метода GetAbsolutePathName:

function ShowAbsolutePath(path)
{
  var fso, s= "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetAbsolutePathName(path);
  return(s);
}


Метод GetAbsolutePathName

Метод GetAbsolutePathName
Применение 		Справочник языка

Объект FileSystemObject


Метод GetAbsolutePathName

Метод GetAbsolutePathName
См. также 		Справочник языка

Метод GetBaseName
Метод GetDrive
Метод GetDriveName
Метод GetExtensionName
Метод GetFile
Метод GetFileName
Метод GetFolder
Метод GetParentFolderName
Метод GetSpecialFolder
Метод GetTempName


Метод GetBaseName

Метод GetBaseName 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает строку, содержащую основу имени последнего компонента пути, исключая расширение файла.
Синтаксис
object.GetBaseName(path)

Синтаксис метода GetBaseName состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
path | Требуется. Задание пути для компонента, для которого основное имя должно быть возвращено.

Примечание
Метод GetBaseName возвращает строку нулевой длины (""), если не существует компонента, соответствующего аргументу path.
Предупреждение Метод GetBaseName работает лишь при указанном path. Метод не пытается определить путь и не проверяет существование указанного пути.

Следующий пример иллюстрирует применение метода GetBaseName:

function ShowBaseName(filespec)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetBaseName(filespec);
  return(s);
}


Метод GetBaseName

Метод GetBaseName
Применение 		Справочник языка

Объект FileSystemObject


Метод GetBaseName

Метод GetBaseName
См. также 		Справочник языка

Метод GetAbsolutePathName
Метод GetDrive
Метод GetDriveName
Метод GetExtensionName
Метод GetFile
Метод GetFileName
Метод GetFolder
Метод GetParentFolderName
Метод GetSpecialFolder
Метод GetTempName


Метод GetDrive

Метод GetDrive 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает объект a Drive, соответствующий диску указанного пути.
Синтаксис
object.GetDrive ( drivespec );

Синтаксис метода GetDrive состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
drivespec | Требуется. Аргумент drivespec может быть буквой диска (c), буквой диска с двоеточием (c:), буквой диска с двоеточием и разделителем пути (c:\) или указанием сетевого ресурса (\\computer2\share1).

Примечание
Для сетевых ресурсов производится проверка для гарантии того, что ресурс существует.

Если drivespec не соответствует ни одной из форм описания или не существует, то возникает ошибка.

Следующий пример иллюстрирует применение метода GetDrive:

function ShowFreeSpace(drvPath)
{
  var fso, d, s ="";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  d = fso.GetDrive(fso.GetDriveName(drvPath));
  s = "Диск " + drvPath.toUpperCase( ) + " - ";
  s += d.VolumeName + "<br>";
  s += "Свободно: " + d.FreeSpace/1024 + " Kb";
  return(s);
}


Метод GetDrive

Метод GetDrive
Применение 		Справочник языка

Объект FileSystemObject


Метод GetDrive

Метод GetDrive
См. также 		Справочник языка

Метод GetAbsolutePathName
Метод GetBaseName
Метод GetDriveName
Метод GetExtensionName
Метод GetFile
Метод GetFileName
Метод GetFolder
Метод GetParentFolderName
Метод GetSpecialFolder
Метод GetTempName


Метод GetDriveName

Метод GetDriveName 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает строку, содержащую имя диска для указанного пути.
Синтаксис
object.GetDriveName(path)

Синтаксис метода GetDriveName состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
path | Требуется. Задание пути для компонента, для которого возвращается имя дисковода.

Примечание
Метод GetDriveName возвращает пустую строку (""), если диск не может быть определен.
Предупреждение Метод GetDriveName работает только при указанном path. Метод не пытается определить путь и не проверяет существование указанного пути.

Следующий пример иллюстрирует применение метода GetDriveName:

function GetDriveLetter(path)
{
  var fso, s ="";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetDrive(fso.GetDriveName(fso.GetAbsolutePathName(path)));
  return(s);
}


Метод GetDriveName

Метод GetDriveName
Применение 		Справочник языка

Объект FileSystemObject


Метод GetDriveName

Метод GetDriveName
См. также 		Справочник языка

Метод GetAbsolutePathName
Метод GetBaseName
Метод GetDrive
Метод GetExtensionName
Метод GetFile
Метод GetFileName
Метод GetFolder
Метод GetParentFolderName
Метод GetSpecialFolder
Метод GetTempName


Метод GetExtensionName

Метод GetExtensionName 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает строку, содержащую расширение последнего компонента в пути.
Синтаксис
object.GetExtensionName(path)

Синтаксис метода GetExtensionName состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
path | Требуется. Задание пути для компонента, чье расширение должно быть возвращено.

Примечание
Для сетевых дисков, рассматриваемый корневой каталог (\) является компонентом.

Следующий пример иллюстрирует применение метода GetExtensionName:

function ShowExtensionName(filespec)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetExtensionName(filespec);
  return(s);
}


Метод GetExtensionName

Метод GetExtensionName
Применение 		Справочник языка

Объект FileSystemObject


Метод GetExtensionName

Метод GetExtensionName
См. также 		Справочник языка

Метод GetAbsolutePathName
Метод GetBaseName
Метод GetDrive
Метод GetDriveName
Метод GetFile
Метод GetFileName
Метод GetFolder
Метод GetParentFolderName
Метод GetSpecialFolder
Метод GetTempName


Метод GetFile

Метод GetFile 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает объект File, соответствующий файлу в указанном пути.
Синтаксис
object.GetFile(filespec)

Синтаксис метода GetFile состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
filespec | Требуется. Параметр filespec является путем (абсолютным или относительным) к указанному файлу.

Примечание
Если указанный файл не существует, то возникает ошибка.

Следующий пример иллюстрирует применение метода GetFile:

function ShowFileAccessInfo(filespec)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec);
  s = f.Path.toUpperCase() + "<br>";
  s += "Дата создания: " + f.DateCreated + "<br>";
  s += "Последний доступ: " + f.DateLastAccessed + "<br>";
  s += "Последнее изменение: " + f.DateLastModified
  return(s);
}


Метод GetFile

Метод GetFile
Применение 		Справочник языка

Объект FileSystemObject


Метод GetFile

Метод GetFile
См. также 		Справочник языка

Метод GetAbsolutePathName
Метод GetBaseName
Метод GetDrive
Метод GetDriveName
Метод GetExtensionName
Метод GetFileName
Метод GetFolder
Метод GetParentFolderName
Метод GetSpecialFolder
Метод GetTempName


Метод GetFileName

Метод GetFileName 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает последний компонент указанного пути, который не является частью пути диска.
Синтаксис
object.GetFileName(pathspec)

Синтаксис метода GetFileName состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
pathspec | Требуется. Путь (абсолютный или относительный) к указанному файлу.

Примечание
Метод GetFileName возвращает пустую строку (""), если pathspec не оканчивается названным компонентом.
Предупреждение Мeтод GetFileName работает только при указании pathspec. Метод не пытается определить путь и не проверяет существование указанного пути.

Следующий пример иллюстрирует применение метода GetFileName:

function ShowFileName(filespec)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetFileName(filespec);
  return(s);
}


Метод GetFileName

Метод GetFileName
Применение 		Справочник языка

Объект FileSystemObject


Метод GetFileName

Метод GetFileName
См. также 		Справочник языка

Метод GetAbsolutePathName
Метод GetBaseName
Метод GetDrive
Метод GetDriveName
Метод GetExtensionName
Метод GetFile
Метод GetFolder
Метод GetParentFolderName
Метод GetSpecialFolder
Метод GetTempName


GetFileVersion Method

Microsoft® JScript®
GetFileVersion Method 		Scripting Run-Time Reference
Version 5

See Also Applies To

Description
Returns the version number of a specified file.
Syntax
object.GetFileVersion(pathspec)

The GetFileVersion method syntax has these parts:

Part | Description
object | Required. Always the name of a FileSystemObject.
pathspec | Required. The path (absolute or relative) to a specific file.

Remarks
The GetFileVersion method returns a zero-length string ("") if pathspec does not end with the named file or if the file does not contain version information.
Note The GetFileVersion method works only on the provided path string. It does not attempt to resolve the path, nor does it check for the existence of the specified path.

The following example illustrates the use of the GetFileVersion method:

function ShowFileVersion(pathspec)
{
  var fso, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  s += fso.GetFileVersion(pathspec);
  if (s == "")
    s = "No version information available.";
  return(s);
}


GetFileVersion Method

Microsoft® JScript®
GetFileVersion Method
Applies To 		Scripting Run-Time Reference

FileSystemObject Object


GetFileVersion Method

Microsoft® JScript®
GetFileVersion Method
See Also 		Scripting Run-Time Reference

GetAbsolutePathName Method
GetBaseName Method
GetDrive Method
GetDriveName Method
GetExtensionName Method
GetFile Method
GetFileName Method
GetFolder Method
GetParentFolderName Method
GetSpecialFolder Method
GetTempName Method


Метод GetFolder

Метод GetFolder 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает объект Folder, соответствующий папке в указанном пути.
Синтаксис
object.GetFolder(folderspec)

Синтаксис метода GetFolder состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объектa FileSystemObject.
folderspec | Требуется. Является путем (абсолютным или относительным) к указанной папке.

Примечание
Если указанная папка не существует, то возникает ошибка.

Следующий пример иллюстрирует применение метода GetFolder:

function ShowFolderList(folderspec)
{
  var fso, f, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(folderspec);
  fc = new Enumerator(f.SubFolders);
  s = "";
  for (; !fc.atEnd(); fc.moveNext())
  {
    s += fc.item();
    s += "<br>";
  }
  return(s);
}


Метод GetFolder

Метод GetFolder
Применение 		Справочник языка

Объект FileSystemObject


Метод GetFolder

Метод GetFolder
См. также 		Справочник языка

Метод GetAbsolutePathName
Метод GetBaseName
Метод GetDrive
Метод GetDriveName
Метод GetExtensionName
Метод GetFile
Метод GetFileName
Метод GetParentFolderName
Метод GetSpecialFolder
Метод GetTempName


Метод GetParentFolderName

Метод GetParentFolderName 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает строку, содержащую имя родительской папки последнего компонента указанного пути.
Синтаксис
object.GetParentFolderName(path)

Синтаксис метода GetParentFolderName состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
path | Требуется. Указание пути для компонента, для которого возвращается имя родительской папки.

Примечание
Метод GetParentFolderName возвращает пустую строку (""), если не имеется родительской папки у компонента, указанного в параметре path.
Предупреждение Метод GetParentFolderName работает лишь при указании path. Метод не пытается определить путь и не проверяет существование указанного пути.

Следующий пример иллюстрирует применение метода GetParentFolderName:

function ShowParentFolderName(filespec)
{
 var fso, s = "";
 fso = new ActiveXObject("Scripting.FileSystemObject");
 s += fso.GetParentFolderName(filespec);
 return(s);
}


Метод GetParentFolderName

Метод GetParentFolderName
Применение 		Справочник языка

Объект FileSystemObject


Метод GetParentFolderName

Метод GetParentFolderName
См. также 		Справочник языка

Метод GetAbsolutePathName
Метод GetBaseName
Метод GetDrive
Метод GetDriveName
Метод GetExtensionName
Метод GetFile
Метод GetFileName
Метод GetFolder
Метод GetSpecialFolder
Метод GetTempName


Метод GetSpecialFolder

Метод GetSpecialFolder 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает специальную папку указанного объекта.
Синтаксис
object.GetSpecialFolder(folderspec)

Синтаксис метода GetSpecialFolder состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
folderspec | Требуется. Параметр специальной папки. Может принимать значение любой из констант, указанных ниже.

Установки
Аргумент folderspec может принимать одно из следующих значений:

Константа | Значение | Описание
WindowsFolder | 0 | Папка Windows содержит файлы, установленные операционной системой Windows.
SystemFolder | 1 | Папка System содержит библиотеки, шрифты и драйвера устройств.
TemporaryFolder | 2 | Папка Temp используется для хранения временных файлов.

Следующий пример иллюстрирует применение метода GetSpecialFolder:

var fso, tempfile;
fso = new ActiveXObject("Scripting.FileSystemObject");

function CreateTempFile()
{
  var tfolder, tfile, tname, fname, TemporaryFolder = 2;
  tfolder = fso.GetSpecialFolder(TemporaryFolder);
  tname = fso.GetTempName();
  tfile = tfolder.CreateTextFile(tname);
  return(tfile);
}
tempfile = CreateTempFile();
tempfile.writeline("Hello World");
tempfile.close();


Метод GetSpecialFolder

Метод GetSpecialFolder
Применение 		Справочник языка

Объект FileSystemObject


Метод GetSpecialFolder

Метод GetSpecialFolder
См. также 		Справочник языка

Метод GetAbsolutePathName
Метод GetBaseName
Метод GetDrive
Метод GetDriveName
Метод GetExtensionName
Метод GetFile
Метод GetFileName
Метод GetFolder
Метод GetParentFolderName
Метод GetTempName


Метод GetTempName

Метод GetTempName 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает случайно сгенерированное имя временного файла или папки, которое используется для выполнения действий, требующих имя временного файла (папки).
Синтаксис
object.GetTempName ( );

Необязательный параметр object всегда является именем объекта FileSystemObject.

Примечание
Метод GetTempName не создает файл. Он обеспечивает только временное имя файла, которое может использоваться вызовом CreateTextFile для создания файла.

Следующий пример иллюстрирует применение метода GetTempName:

var fso, tempfile;
fso = new ActiveXObject("Scripting.FileSystemObject");

function CreateTempFile()
{
  var tfolder, tfile, tname, fname, TemporaryFolder = 2;
  tfolder = fso.GetSpecialFolder(TemporaryFolder);
  tname = fso.GetTempName();
  tfile = tfolder.CreateTextFile(tname);
  return(tfile);
}
tempfile = CreateTempFile();
tempfile.writeline("Hello World");
tempfile.close();


Метод GetTempName

Метод GetTempName
Применение 		Справочник языка

Объект FileSystemObject


Метод GetTempName

Метод GetTempName
См. также 		Справочник языка

Метод GetAbsolutePathName
Метод GetBaseName
Метод GetDrive
Метод GetDriveName
Метод GetExtensionName
Метод GetFile
Метод GetFileName
Метод GetFolder
Метод GetParentFolderName
Метод GetSpecialFolder


Метод MoveFile

Метод MoveFile 		Справочник языка
Версия 3

См. также Применение

Описание
Перемещение одного или нескольких файлов из одного размещения в другое.
Синтаксис
object.MoveFile ( source, destination );

Синтаксис метода MoveFile состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
source | Требуется. Путь, откуда будут перемещены файл или файлы. Аргумент source может содержать символы подстановки только в последнем компоненте пути.
destination | Требуется. Путь, куда файл (файлы) будут перемещены. Аргумент destination не может содержать символы подстановки.

Примечание
Если source содержит символы подстановки или destination заканчивается разделителем пути (\), подразумевается, что destination указывает на существующую папку, в которую будут перемещены соответствующие файлы. Иначе destination считается именем создаваемого файла. Вообще, при перемещении отдельного файла возможны три случая:
  • Если destination не существует, то файлы будут перемещены. Это обычный случай.
  • Если destination - существующий файл, то возникает ошибка.
  • Если destination является папкой, то возникает ошибка.
Ошибка возникает также, если используемые символы подстановки в source не соответствуют никакому файлу. Метод MoveFile останавливается после первой ошибки. Никаких попыток для восстановления сделанных до ошибки изменений не производится.
Предупреждение Этот метод позволяет перемещать файлы между дисками только если это поддерживается операционной системой.

Следующий пример иллюстрирует применение метода MoveFile:

function MoveFile2Desktop(filespec)
{
  var fso;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  fso.MoveFile(filespec, "c:\\windows\\desktop\\");
}


Метод MoveFile

Метод MoveFile
Применение 		Справочник языка

Объект FileSystemObject


Метод MoveFile

Метод MoveFile
См. также 		Справочник языка

Метод CopyFile
Метод DeleteFile
Метод GetFile
Метод GetFileName
Метод Move
Метод MoveFolder
Метод OpenTextFile


Метод MoveFolder

Метод MoveFolder 		Справочник языка
Версия 3

См. также Применение

Описание
Перемещение одной или нескольких папок из одного размещения в другое.
Синтаксис
object.MoveFolder ( source, destination );

Синтаксис метода MoveFolder состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта FileSystemObject.
source | Требуется. Путь к папке (папкам) для перемещения. Аргумент source может содержать символы подстановки только в последнем компоненте пути.
destination | Требуется. Путь, куда будут перемещены папки. Аргумент destination не может содержать символы подстановки.

Примечание
Если source содержит символы подстановки или destination заканчивается разделителем пути (\), подразумевается, что destination указывает на существующую папку, в которую будут перемещены соответствующие файлы. Иначе destination именем для создаваемой папки. Вообще, при перемещении отдельной папки возможны три случая:
  • Если destination не существует, то папка будет перемещена. Это обычный случай.
  • Если destination является существующим файлом, то возникает ошибка.
  • Если destination является папкой, то возникает ошибка.
Ошибка возникает также, если символы подстановки, используемые в source, не соответствуют ни одной папки. Метод MoveFolder останавливается после первой же ошибки. Никаких попыток для восстановления уже сделанных до ошибки изменений не производится.
Предупреждение Этот метод позволяет перемещать папки между дисками, только если это поддерживается операционной системой.

Следующий пример иллюстрирует применение метода MoveFolder:

function MoveFldr2Desktop(fldrspec)
{
  var fso;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  fso.MoveFolder(fldrspec, "c:\\windows\\desktop\\");
}


Метод MoveFolder

Метод MoveFolder
Применение 		Справочник языка

Объект FileSystemObject


Метод MoveFolder

Метод MoveFolder
См. также 		Справочник языка

Метод CopyFile
Метод DeleteFile
Метод GetFile
Метод GetFileName
Метод Move
Метод MoveFile
Метод OpenTextFile


Свойство Type

Свойство Type 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает информацию о типе файла или папки. Например, для файлов с расширением .TXT, возвращается строка "Text Document" .
Синтаксис
object.Type

Параметр object всегда является именем объекта File или Folder.

Примечание
Следующий пример иллюстрирует применение свойства Type для получения информации о типе папки:
function ShowFileType(filespec)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  if (fso.FolderExists(filespec))
    f = fso.GetFolder(filespec);
  else if (fso.FileExists(filespec))
    f = fso.GetFile(filespec);
  else
    s = "Файл (папка) не существует.";
  s = f.Name + " is a " + f.Type;
  return(s);
}


Свойство Type

Свойство Type
Применение 		Справочник языка

Объект File


Свойство Type

Свойство Type
См. также 		Справочник языка

Свойства объекта File
Свойства объекта Folder


Функция GetObject

Функция GetObject 		Справочник языка
Версия 3

См. также

Описание
Возвращает ссылку на автоматический объект (Automation object) из файла.
Синтаксис
GetObject([pathname] [, class])

Синтаксис функции GetObject состоит из частей:

Часть | Описание
pathname | Необязательно. Полный путь к файлу, содержащего объект. Если pathname опущен, необходимо указывать class.
class | Необязательно. Класс (сlass) oбъекта.

Параметр class имеет синтаксис типа appname.objectype и состоит из частей:

Часть | Описание
appname | Требуется. Название приложения.
objectype | Требуется. Тип класса для создания объекта.

Примечание
Объект GetObject используется для доступа к автоматическому объекту из файла. Например:
var CADObject;
CADObject = GetObject("C:\\CAD\\SCHEMA.CAD");
При выполнении кода, приложение связывается с pathname, а объект в файле активируется. Если pathname является нулевой строкой (""), GetObject возвращает новый объект образца указанного типа. Если параметр pathname опущен, GetObject возвращает текущий активный объект указанного типа. Если объект указанного типа не существует, возникает ошибка.

Некоторые приложения позволяют активировать часть файла. Добавление восклицательного знака (!) к концу файла идентифицирует ту часть файла, которая следует за строкой. Для информации относительно создания этой строки, обратитесь к. документации того приложения, которое создает объект.

Например, в графическом приложении можно получить несколько слоев рисунка, сохраненному в файле. Можно использовать следующий код для активации слоя в рисунке, называемом SCHEMA.CAD:

var LayerObject = GetObject("C:\\CAD\\SCHEMA.CAD!Layer3");
Если не определен класс объекта, приложение автоматически определяет запуск и активацию объекта на основании файла, которое был указан. Однако, некоторые файлы могут поддерживать более одного класса объектов. Например, рисунок может поддерживать три различных типа объекта: объект приложения, объект рисунка и объект панели инструментов, каждый из которых является частью одного и того же файла. Для определения запускаемых объектов из файла, необходимо использовать необязательный параметр class. Например:
var MyObject;
MyObject = GetObject("C:\\DRAWINGS\\SAMPLE.DRW", "FIGMENT.DRAWING");
В предыдущем примере, FIGMENT является именем приложения рисунка, а DRAWING - один из поддерживаемых им типом объекта. Как только объект запущен, вы ссылаетесь на код, используемый для определения переменной объекта. В предыдущем примере, вы получаете доступ к свойствам и методам нового объекта, используя переменную объекта MyObject. Например:
MyObject.Line(9, 90);
MyObject.InsertText(9, 100, "Привет, мир!");
MyObject.SaveAs("C:\\DRAWINGS\\SAMPLE.DRW");
Предупреждение Используйте функцию GetObject , если текущий образец объекта уже существует, или если Вы хотите создать объект уже загруженным файлом. Если не существует никакого текущего образца, или вы не хотите создавать объект из загруженного файла, применяйте объект ActiveXObject .

Если объект регистрирует себя как одиночный экземпляр объекта, только один экземпляр объекта может быть создан, независимо от того, сколько раз выполнен ActiveXObject .


Функция GetObject

Функция GetObject
См. также 		Справочник языка

Объект ActiveXObject


Функция ScriptEngine

Функция ScriptEngine 		Справочник языка
Версия 2

См.также

Описание
Возвращает название используемого языка сценария.
Синтаксис
ScriptEngine( )
Возможные значения
Функция ScriptEngine может возвращать следующие значения строкового типа:

Строка | Описание
JScript | Используется Microsoft JScript.
VBA | Используется Microsoft Visual Basic® for Applications.
VBScript | Используется Microsoft Visual Basic Scripting Edition.

Примечание
В следующем примере иллюстрируется применение функции ScriptEngine:
function GetScriptEngineInfo()
{
    var s;
    s = "";
    s += ScriptEngine() + " Version ";
    s += ScriptEngineMajorVersion() + ".";
    s += ScriptEngineMinorVersion() + ".";
    s += ScriptEngineBuildVersion();
    return(s);
}


Функция ScriptEngineBuildVersion

Функция ScriptEngineBuildVersion 		Справочник языка
Версия 2

См. также

Описание
Возвращает номер build-версии используемого обработчика сценария.
Синтаксис
ScriptEngineBuildVersion( )
Возвращаемые значения
Возвращает значение номера версии библиотеки динамической компоновки (DLL) используемого обработчика сценария.
Примечание
В следующем примере применяется функция ScriptEngineBuildVersion:
function GetScriptEngineInfo()
{
    var s;
    s = "";
    s += ScriptEngine() + " Version ";
    s += ScriptEngineMajorVersion() + ".";
    s += ScriptEngineMinorVersion() + ".";
    s += ScriptEngineBuildVersion();
    return(s);
}


Функция ScriptEngineBuildVersion

Функция ScriptEngineBuildVersion
См. также 		Language Reference

Функция ScriptEngine
Функция ScriptEngineMajorVersion
Функция ScriptEngineMinorVersion


Функция ScriptEngine

Функция ScriptEngine
См. также 		Справочник языка

Функция ScriptEngineBuildVersion
Функция ScriptEngineMajorVersion
Функция ScriptEngineMinorVersion


Функция ScriptEngineMajorVersion

Функция ScriptEngineMajorVersion 		Справочник языка
Версия 2

См. также

Описание
Возвращает major-номер версии используемого обработчика сценариев.
Синтаксис
ScriptEngineMajorVersion( )
Возвращаемые значения
Возвращаемое значение соответствует номеру, содержащемуся в библиотеке динамической компоновки (DLL) для используемого языка сценария.
Примечание
Функция ScriptEngineMajorVersion применена в следующем примере:
function GetScriptEngineInfo()
{
    var s;
    s = "";
    s += ScriptEngine() + " Версия ";
    s += ScriptEngineMajorVersion() + ".";
    s += ScriptEngineMinorVersion() + ".";
    s += ScriptEngineBuildVersion();
    return(s);
}


Функция ScriptEngineMajorVersion

Функция ScriptEngineMajorVersion
См. также 		Справочник языка

Функция ScriptEngine
Функция ScriptEngineBuildVersion
Функция ScriptEngineMinorVersion


Функция ScriptEngineMinorVersion

Функция ScriptEngineMinorVersion 		Справочник языка
Версия 2

См. также

Описание
Возвращает minor-номер версии используемого обработчика сценариев.
Синтаксис
ScriptEngineMinorVersion( )
Возвращаемые значения
Возвращаемое значение соответствует номеру, содержащемуся в библиотеке динамической компоновки (DLL) для используемого языка сценария.
Примечание
Функция ScriptEngineMinorVersion применена в следующем примере:
function GetScriptEngineInfo()
{
    var s;
    s = "";
    s += ScriptEngine() + " Версия ";
    s += ScriptEngineMajorVersion() + ".";
    s += ScriptEngineMinorVersion() + ".";
    s += ScriptEngineBuildVersion();
    return(s);
}


Функция ScriptEngineMinorVersion

Функция ScriptEngineMinorVersion
См. также 		Справочник языка

Функция ScriptEngine
Функция ScriptEngineBuildVersion
Функция ScriptEngineMajorVersion


Метод Add (Folders)

Метод Add (Folders) 		Справочник языка
Версия 3

См. также Применение

Описание
Добавление нового объекта Folder в совокупность папок.
Синтаксис
object.Add (folderName)

Синтаксис метода Add состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем совокупности папок.
folderName | Требуется. Имя добавляемого объекта Folder.

Примечание
Следующий пример иллюстрирует применение метода Add для создания новой папки:
function AddNewFolder(path,folderName)
{
  var fso, f, fc, nf;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(path);
  fc = f.SubFolders;
  if (folderName != "" )
    nf = fc.Add(folderName);
  else
    nf = fc.Add("Новая папка");
}
Если folderName уже существует, то возникает ошибка.


Метод Add (Folders)

Метод Add (Folders)
Применение 		Справочник языка

Совокупность папок


Метод Add (Folders)

Метод Add (Folders)
См. также 		Справочник языка

Метод Add (Dictionary)


Свойство Files

Свойство Files 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает совокупность файлов, содержащую все объекты File в указанной папке, включая системные и скрытые.
Синтаксис
object.Files

Аргумент object всегда является именем объекта Folder.

Примечание
Следующий пример иллюстрирует применение свойства Files:
function ShowFolderFileList(folderspec)
{
  var fso, f, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(folderspec);
  fc = new Enumerator(f.files);
  s = "";
  for (; !fc.atEnd(); fc.moveNext())
  {
    s += fc.item();
    s += "<br>";
  }
  return(s);
}


Свойство Files

Свойство Files
Применение 		Справочник языка

Объект Folder


Свойство Files

Microsoft® Visual Basic® Scripting Edition
Свойство Files
См. также 		Справочник языка

Свойства объекта Folder


Свойство IsRootFolder

Свойство IsRootFolder 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает значение True, если указанная папка является корневой, и значение False, если папка некорневая.
Синтаксис
object.IsRootFolder

Аргумент object всегда является именем объекта Folder.

Примечание
The following code illustrates the use of the IsRootFolder property:
function DisplayLevelDepth(pathspec)
{
  var fso, f, n, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(pathspec);
  n = 0;
  if (f.IsRootFolder)
      s = "The specified folder is the root folder."
  else
  {
    do
    {
      f = f.ParentFolder;
      n++;
    }
    while (!f.IsRootFolder)
    s = "The specified folder is nested " + n + " levels deep."
  }
  return(s);
}


Свойство IsRootFolder

Свойство IsRootFolder
Применение 		Справочник языка

Объект Folder


Свойство IsRootFolder

Свойство IsRootFolder
См. также 		Справочник языка

Свойства объекта Folder


Свойства SubFolders

Свойство SubFolders 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает совокупность папок, содержащую все папки в указанной папке, включая папки с установленными аттрибутами - скрытая и системная.
Синтаксис
object.SubFolders

Параметр object всегда является объектом Folder.

Примечание
Следующий пример иллюстрирует применение свойства SubFolders:
function ShowFolderList(folderspec)
{
  var fso, f, fc, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFolder(folderspec);
  fc = new Enumerator(f.SubFolders);
  s = "";
  for (;!fc.atEnd(); fc.moveNext())
    {
      s += fc.item();
      s += "<br>";
    }
    return(s);
}


Свойство SubFolders

Свойство SubFolders
Применение 		Справочник языка

Объект Folder


Свойство SubFolders

Свойство SubFolders
См. также 		Справочник языка

Свойства объекта Folder


JScript Run-Time Library Reference

Microsoft® JScript®
Scripting Run-Time Library Reference 		Language Reference
Version Information

Feature Information

Alphabetic Keyword List

Methods

Objects

Properties

Welcome to the Scripting Run-Time Library Reference

These handy blocks of information will help you explore the many different parts of the Scripting Run-Time Library.

You'll find all the parts of the Scripting Run-Time Library listed alphabetically under the Alphabetic Keyword List. But if you want to examine just one category, say, objects, each language category has its own, more compact section.

How's it work? Click on one of the headings to the left to display a list of items contained in that category. From this list, select the topic that you want to view. Once you've opened that topic, you can easily link to other related sections.

So, go ahead and take a look! Study some statements, mull over the methods, or figure out a few functions. You'll see just how versatile the Scripting Run-Time Library can be!

Features | Description
Microsoft Scripting Run-Time Features | List of features currently in Microsoft Scripting Run-Time Library.
Language Element | Description
Add Method (Dictionary) | Adds a key and item pair to a Dictionary object.
Add Method (Folders) | Adds a new Folder to a Folders collection.
AtEndOfLine Property | Returns True if the file pointer immediately precedes the end-of-line marker in a TextStream file; False if it is not.
AtEndOfStream Property | Returns True if the file pointer is at the end of a TextStream file; False if it is not.
Attributes Property | Sets or returns the attributes of files or folders.
AvailableSpace Property | Returns the amount of space available to a user on the specified drive or network share.
BuildPath Method | Appends a name to an existing path.
Close Method | Closes an open TextStream file.
Column Property | Returns the column number of the current character position in a TextStream file.
CompareMode Property | Sets and returns the comparison mode for comparing string keys in a Dictionary object.
Copy Method | Copies a specified file or folder from one location to another.
CopyFile Method | Copies one or more files from one location to another.
CopyFolder Method | Recursively copies a folder from one location to another.
Count Property | Returns the number of items in a collection or Dictionary object.
CreateFolder Method | Creates a folder.
CreateTextFile Method | Creates a specified file name and returns a TextStream object that can be used to read from or write to the file.
DateCreated Property | Returns the date and time that the specified file or folder was created.
DateLastAccessed Property | Returns the date and time that the specified file or folder was last accessed.
DateLastModified Property | Returns the date and time that the specified file or folder was last modified.
Delete Method | Deletes a specified file or folder.
DeleteFile Method | Deletes a specified file.
DeleteFolder Method | Deletes a specified folder and its contents.
Dictionary Object | Object that stores data key, item pairs.
Drive Object | Provides access to the properties of a particular disk drive or network share.
Drive Property | Returns the drive letter of the drive on which the specified file or folder resides.
DriveExists Method | Returns True if the specified drive exists; False if it does not.
DriveLetter Property | Returns the drive letter of a physical local drive or a network share.
Drives Collection | Read-only collection of all available drives.
Drives Property | Returns a Drives collection consisting of all Drive objects available on the local machine.
DriveType Property | Returns a value indicating the type of a specified drive.
Exists Method | Returns True if a specified key exists in the Dictionary object, False if it does not.
File Object | Provides access to all the properties of a file.
FileExists Method | Returns True if a specified file exists; False if it does not.
Files Collection | Collection of all File objects within a folder.
Files Property | Returns a Files collection consisting of all File objects contained in the specified folder, including those with hidden and system file attributes set.
FileSystemObject Object | Provides access to a computer's file system.
FileSystem Property | Returns the type of file system in use for the specified drive.
Folder Object | Provides access to all the properties of a folder.
Folders Collection | Collection of all Folder objects contained within a Folder object.
FolderExists Method | Returns True if a specified folder exists; False if it does not.
FreeSpace Property | Returns the amount of free space available to a user on the specified drive or network share.
GetAbsolutePathName Method | Returns a complete and unambiguous path from a provided path specification.
GetBaseName Method | Returns a string containing the base name of the file (less any file extension), or folder in a provided path specification.
GetDrive Method | Returns a Drive object corresponding to the drive in a specified path.
GetDriveName Method | Returns a string containing the name of the drive for a specified path.
GetExtensionName Method | Returns a string containing the extension name for the last component in a path.
GetFile Method | Returns a File object corresponding to the file in a specified path.
GetFileName Method | Returns the last file name or folder of a specified path that is not part of the drive specification.
GetFileVersion Method | Returns the version number of a specified file.
GetFolder Method | Returns a Folder object corresponding to the folder in a specified path.
GetParentFolderName Method | Returns a string containing the name of the parent folder of the last file or folder in a specified path.
GetSpecialFolder Method | Returns the special folder specified.
GetTempName Method | Returns a randomly generated temporary file or folder name.
IsReady Property | Returns True if the specified drive is ready; False if it is not.
IsRootFolder Property | Returns True if the specified folder is the root folder; False if it is not.
Item Property | Sets or returns an item for a specified key in a Dictionary object.
Items Method | Returns an array containing all the items in a Dictionary object.
Key Property | Sets a key in a Dictionary object.
Keys Method | Returns an array containing all existing keys in a Dictionary object.
Line Property | Returns the current line number in a TextStream file.
Move Method | Moves a specified file or folder from one location to another.
MoveFile Method | Moves one or more files from one location to another.
MoveFolder Method | Moves one or more folders from one location to another.
Name Property | Sets or returns the name of a specified file or folder.
OpenAsTextStream Method | Opens a specified file and returns a TextStream object that can be used to read from, write to, or append to the file.
OpenTextFile Method | Opens a specified file and returns a TextStream object that can be used to read from, write to, or append to the file.
ParentFolder Property | Returns the folder object for the parent of the specified file or folder.
Path Property | Returns the path for a specified file, folder, or drive.
Read Method | Reads a specified number of characters from a TextStream file and returns the resulting string.
ReadAll Method | Reads an entire TextStream file and returns the resulting string.
ReadLine Method | Reads an entire line (up to, but not including, the newline character) from a TextStream file and returns the resulting string.
Remove Method | Removes a key, item pair from a Dictionary object.
RemoveAll Method | Removes all key, item pairs from a Dictionary object.
RootFolder Property | Returns a Folder object representing the root folder of a specified drive.
SerialNumber Property | Returns the decimal serial number used to uniquely identify a disk volume.
ShareName Property | Returns the network share name for a specified drive.
ShortName Property | Returns the short name used by programs that require the earlier 8.3 naming convention.
ShortPath Property | Returns the short path used by programs that require the earlier 8.3 file naming convention.
Size Property | Returns the size, in bytes, of the specified file or folder.
Skip Method | Skips a specified number of characters when reading a TextStream file.
SkipLine Method | Skips the next line when reading a TextStream file.
SubFolders Property | Returns a Folders collection consisting of all folders contained in a specified folder, including those with Hidden and System file attributes set.
TextStream Object | Facilitates sequential access to file.
TotalSize Property | Returns the total space, in bytes, of a drive or network share.
Type Property | Returns information about the type of a file or folder.
VolumeName Property | Sets or returns the volume name of the specified drive.
Write Method | Writes a specified string to a TextStream file.
WriteBlankLines Method | Writes a specified number of newline characters to a TextStream file.
WriteLine Method | Writes a specified string and newline character to a TextStream file.
Language Element | Description
Add Method (Dictionary) | Adds a key and item pair to a Dictionary object.
Add Method (Folders) | Adds a new Folder to a Folders collection.
BuildPath Method | Appends a name to an existing path.
Close Method | Closes an open TextStream file.
Copy Method | Copies a specified file or folder from one location to another.
CopyFile Method | Copies one or more files from one location to another.
CopyFolder Method | Recursively copies a folder from one location to another.
CreateFolder Method | Creates a folder.
CreateTextFile Method | Creates a specified file name and returns a TextStream object that can be used to read from or write to the file.
Delete Method | Deletes a specified file or folder.
DeleteFile Method | Deletes a specified file.
DeleteFolder Method | Deletes a specified folder and its contents.
DriveExists Method | Returns True if the specified drive exists; False if it does not.
Exists Method | Returns True if a specified key exists in the Dictionary object, False if it does not.
FileExists Method | Returns True if a specified file exists; False if it does not.
FolderExists Method | Returns True if a specified folder exists; False if it does not.
GetAbsolutePathName Method | Returns a complete and unambiguous path from a provided path specification.
GetBaseName Method | Returns a string containing the base name of the file (less any file extension), or folder in a provided path specification.
GetDrive Method | Returns a Drive object corresponding to the drive in a specified path.
GetDriveName Method | Returns a string containing the name of the drive for a specified path.
GetExtensionName Method | Returns a string containing the extension name for the last component in a path.
GetFile Method | Returns a File object corresponding to the file in a specified path.
GetFileName Method | Returns the last file name or folder of a specified path that is not part of the drive specification.
GetFileVersion Method | Returns the version number of a specified file.
GetFolder Method | Returns a Folder object corresponding to the folder in a specified path.
GetParentFolderName Method | Returns a string containing the name of the parent folder of the last file or folder in a specified path.
GetSpecialFolder Method | Returns the special folder specified.
GetTempName Method | Returns a randomly generated temporary file or folder name.
Items Method | Returns an array containing all the items in a Dictionary object.
Keys Method | Returns an array containing all existing keys in a Dictionary object.
Move Method | Moves a specified file or folder from one location to another.
MoveFile Method | Moves one or more files from one location to another.
MoveFolder Method | Moves one or more folders from one location to another.
OpenAsTextStream Method | Opens a specified file and returns a TextStream object that can be used to read from, write to, or append to the file.
OpenTextFile Method | Opens a specified file and returns a TextStream object that can be used to read from, write to, or append to the file.
Read Method | Reads a specified number of characters from a TextStream file and returns the resulting string.
ReadAll Method | Reads an entire TextStream file and returns the resulting string.
ReadLine Method | Reads an entire line (up to, but not including, the newline character) from a TextStream file and returns the resulting string.
Remove Method | Removes a key, item pair from a Dictionary object.
RemoveAll Method | Removes all key, item pairs from a Dictionary object.
Skip Method | Skips a specified number of characters when reading a TextStream file.
SkipLine Method | Skips the next line when reading a TextStream file.
Write Method | Writes a specified string to a TextStream file.
WriteBlankLines Method | Writes a specified number of newline characters to a TextStream file.
WriteLine Method | Writes a specified string and newline character to a TextStream file.
Language Element | Description
Dictionary Object | Object that stores data key, item pairs.
Drive Object | Provides access to the properties of a particular disk drive or network share.
Drives Collection | Read-only collection of all available drives.
File Object | Provides access to all the properties of a file.
Files Collection | Collection of all File objects within a folder.
FileSystemObject Object | Provides access to a computer's file system.
Folder Object | Provides access to all the properties of a folder.
Folders Collection | Collection of all Folder objects contained within a Folder object.
TextStream Object | Facilitates sequential access to file.
Language Element | Description
AtEndOfLine Property | Returns True if the file pointer immediately precedes the end-of-line marker in a TextStream file; False if it is not.
AtEndOfStream Property | Returns True if the file pointer is at the end of a TextStream file; False if it is not.
Attributes Property | Sets or returns the attributes of files or folders.
AvailableSpace Property | Returns the amount of space available to a user on the specified drive or network share.
Column Property | Returns the column number of the current character position in a TextStream file.
CompareMode Property | Sets and returns the comparison mode for comparing string keys in a Dictionary object.
Count Property | Returns the number of items in a collection or Dictionary object.
DateCreated Property | Returns the date and time that the specified file or folder was created.
DateLastAccessed Property | Returns the date and time that the specified file or folder was last accessed.
DateLastModified Property | Returns the date and time that the specified file or folder was last modified.
Drive Property | Returns the drive letter of the drive on which the specified file or folder resides.
DriveLetter Property | Returns the drive letter of a physical local drive or a network share.
Drives Property | Returns a Drives collection consisting of all Drive objects available on the local machine.
DriveType Property | Returns a value indicating the type of a specified drive.
Files Property | Returns a Files collection consisting of all File objects contained in the specified folder, including those with hidden and system file attributes set.
FileSystem Property | Returns the type of file system in use for the specified drive.
FreeSpace Property | Returns the amount of free space available to a user on the specified drive or network share.
IsReady Property | Returns True if the specified drive is ready; False if it is not.
IsRootFolder Property | Returns True if the specified folder is the root folder; False if it is not.
Item Property | Sets or returns an item for a specified key in a Dictionary object.
Key Property | Sets a key in a Dictionary object.
Line Property | Returns the current line number in a TextStream file.
Name Property | Sets or returns the name of a specified file or folder.
ParentFolder Property | Returns the folder object for the parent of the specified file or folder.
Path Property | Returns the path for a specified file, folder, or drive.
RootFolder Property | Returns a Folder object representing the root folder of a specified drive.
SerialNumber Property | Returns the decimal serial number used to uniquely identify a disk volume.
ShareName Property | Returns the network share name for a specified drive.
ShortName Property | Returns the short name used by programs that require the earlier 8.3 naming convention.
ShortPath Property | Returns the short path used by programs that require the earlier 8.3 file naming convention.
Size Property | Returns the size, in bytes, of the specified file or folder.
SubFolders Property | Returns a Folders collection consisting of all folders contained in a specified folder, including those with Hidden and System file attributes set.
TotalSize Property | Returns the total space, in bytes, of a drive or network share.
Type Property | Returns information about the type of a file or folder.
VolumeName Property | Sets or returns the volume name of the specified drive.

© 2000 Microsoft Corporation. All rights reserved.


Microsoft® JScript Run-Time Library Reference

Microsoft® JScript®
Scripting
Run-Time Library Reference 		Language Reference
Version Information

Feature
Information
Alphabetic
Keyword List
Methods
Objects
Properties
© 2000 Microsoft Corporation. All rights reserved.


JScript Tutorial

Microsoft® JScript®
FileSystemObject Object Tutorial
 Scripting Run-Time Library Reference

The FileSystemObject Object Model
Introduction to the FileSystemObject
and the Scripting Run-Time Library Reference
FileSystemObject Objects
Programming the FileSystemObject
Working with Drives and Folders
Working with Files
FileSystemObject Sample Code


Свойство arguments

Свойство arguments 		Справочник языка
Версия 2

См. также Применение

Описание
Массив, содержащий параметры выполняемой в настоящее время функции.
Синтаксис
function.arguments[ ]

Параметр function является именем исполняемой функции.

Примечание
Свойство arguments - изящный путь для обработки функциями переменных аргументов. Свойство массива length содержит количество параметров, сообщенных функции.

В следующем примере показано применение свойства arguments:

function ArgTest()
{
   var i, s, numargs = ArgTest.arguments.length;
   s = numargs;
   if (numargs < 2)
     s += " аргумент был сообщен ArgTest.  ";
   else
     s += " аргументов было сообщено ArgTest.  " ;

   for (i = 0; i < numargs; i++)
     {
       s += ArgTest.arguments[i] + " ";
     }
   return(s);
}


Свойство arguments

Свойство arguments
Применение 		Справочник языка

Объект Function


Свойство arguments

Свойство arguments
См. также 		Справочник языка

Инструкция function
Свойство массива length


Свойство caller

Свойство caller 		Справочник языка
Версия 2

См. также Применение

Описание
Содержит ссылку на функцию, которая вызвала текущую функцию.
Синтаксис
functionname.caller
Примечание
Свойство caller определено для функции только тогда, пока функция выполняется. Если функция вызвана из верхнего уровня программы JScript, caller содержит null.

Если свойство caller применяется в строковом контексте, результат тот же самый что и functionname.toString, то есть отображается декомпилируемый текст.

В следующем примере применяется свойство caller :

function CallLevel()
{
  if (CallLevel.caller == null)
    return("CallLevel вызвана из верхнего уровня.");
  else
    return("CallLevel вызвана другой функцией.");
}


Свойство caller

Свойство caller
Применение 		Справочник языка

Объект Function


Свойство caller

Свойство caller
См. также 		Справочник языка

Инструкция function


Свойство length (функция)

Свойство length (функция) 		Справочник языка
Версия 2

См. также Применение

Описание
Содержит количество аргументов объявленной функции.
Синтаксис
functionname.length

Параметр functionname обязателен, является именем функции.

Примечание
Свойство функции length инициализируется обработчиком сценария в определении функции при ее создании.

Что происходит с функцией, вызванной с количеством аргументов, отличном от значения свойства length, зависит от самой функции.

Ниже приведен пример использования свойства length:

function ArgTest(a, b)
{
   var i, s = "The ArgTest function expected ";
   var numargs = ArgTest.arguments.length;
   var expargs = ArgTest.length;
   if (expargs < 2)
     s += expargs + " argument. ";
   else
     s += expargs + " arguments. ";
   if (numargs < 2)
     s += numargs + " was passed.";
   else
     s += numargs + " were passed.";
   return(s);
}


Свойство length

Свойство length
Применение 		Справочник языка

Объект Function


Свойство length (функция)

Свойство length (функция)
См. также 		Справочник языка

Свойство arguments
Свойство length (массив)
Свойство length (строка)


Метод escape

Метод escape 		Справочник языка
Версия 1

См.также Применение

Описание
Кодирует объекты String для возможного чтения на всех компьютерах.
Синтаксис
escape(charstring)

Параметр charstring является объектом String для кодирования.

Примечание
Метод escape возвращает новый объект String в формате Unicode, перекодированный параметр charstring. Все пробелы, знаки пунктуации, спец-символы и другие non-ASCII символы заменяются кодом типа %xx, где xx - шестнадцатиричный код символа. Например, пробел преобразовывается в "%20."

Символы с кодом более 255 преобразовываются в формат %u xxxx.


Метод escape

Метод escape
Применение 		Справочник языка

Объект Global


Метод escape

Метод escape
См. также 		Справочник языка

Объект String
Метод unescape


Метод eval

Метод eval 		Справочник языка
Версия 1

См. также Применение

Описание
Выполняет код JScript.
Синтаксис
eval(codestring)

Параметр codestring является объектом String, содержащим допустимый код JScript. Строка анализируется обработчиком JScript и выполняется.

Примечание
Функция eval позволяет применять динамическое выполнение кода JScript. Например, следующий код создает новую переменную mydate, содержащую объект Date:
eval("var mydate = new Date();");


Метод eval

Метод eval
Применение 		Справочник языка

Объект Global


Метод eval

Метод eval
См. также 		Справочник языка

Объект String


Свойство Infinity

Свойство Infinity 		Справочник языка
Версия 3

См. также Применение

Описание
Содержит значение Number.POSITIVE_INFINITY.
Синтаксис
Infinity
Примечание
Свойство Infinity является элементом объекта Global и доступно при инициализации сценария немедленно.


Свойство Infinity

Свойство Infinity
Применение 		Справочник языка

Объект Global


Свойство Infinity

Свойство Infinity
См. также 		Справочник языка

Свойство POSITIVE_INFINITY
Свойство NEGATIVE_INFINITY


Метод isFinite

Метод isFinite 		Справочник языка
Версия 3

См. также Применение

Описание
Проверка числа на конечность.
Синтаксис
isFinite(number)

Аргумент number должен иметь числовое значение.

Примечание
Метод isFinite возвращает true, если number - число, не имеющее значение NaN, минус-бесконечность или плюс-бесконечность. В данных трех случаях возвращается false.


Метод isFinite

Метод isFinite
Применение 		Справочник языка

Объект Global


Метод isFinite

Метод isFinite
См. также 		Справочник языка

Метод isNaN


Метод isNaN

Метод isNaN 		Справочник языка
Версия 1

см. также Применение

Описание
Проверяет на соответствие значению NaN.
Синтаксис
isNaN(numvalue)

Параметр numvalue проверяется на значение NaN.

Примечание
Функция isNaN возвращает значение true, если значение numvalue является NaN, и false в остальных случаях. Обычно применяется при проверки методов parseInt и parseFloat.

Переменная могла бы сравниваться с собой. Но значение NaN неравно само себе, поэтому необходимо применять isNaN().


Метод isNaN

Метод isNaN
Применение 		Справочник языка

Объект Global


Метод isNaN

Метод isNaN
См. также 		Справочник языка

Метод isFinite
Свойство NaN (глобальное)
Метод parseFloat
Метод parseInt


Свойство NaN (Global)

Свойство NaN 		Справочник языка
Версия 3

См. также Применение

Описание
Содержит значение NaN.
Синтаксис
NaN
Примечание
Свойство NaN (not a number - НеЧисло) является элементом объекта Global и доступно при инициализации сценария.


Свойство NaN

Свойство NaN
Применение 		Справочник языка

Объект Global


Свойство NaN

Свойство NaN
См. также 		Справочник языка

Метод isNaN


Метод parseFloat

Метод parseFloat 		Справочник языка
Версия 1

См. также Применение

Описание
Преобразование строк в числа с плавающей точкой(запятой).
Синтаксис
parseFloat(numstring)

Аргумент numstring является строкой для преобразования в число с плавающей точкой.

Примечание
Метод parseFloat возвращает числовое значение, содержащееся в строке numstring. Если numstring не может быть обработано как число с плавающей точкой, возвращается значение NaN.
parseFloat("abc")    // Возвращает NaN.
parseFloat("1.2abc") // Возвращает 1.2.
Для проверки на значение NaN применяется метод isNaN.


Метод parseFloat

Метод parseFloat
Применение 		Справочник языка

Объект Global


Метод parseFloat

Метод parseFloat
См. также 		Справочник языка

Метод isNaN
Метод parseInt
Объект String


Метод parseInt

Метод parseInt 		Справочник языка
Версия 1

См. также Применение

Описание
Преобразование строки в целое число.
Синтаксис
parseInt(numstring, [radix])

Синтаксис метода parseInt состоит из частей:

Часть | Описание
numstring | Требуется. Строка для преобразования в целое число.
radix | Необязательно. Значение между 2 и 36 - основание числа, содержащегося в numstring. Если параметр не указан, строки с префиксом '0x' рассматриваются как 16-ричные, с префиксом '0' - как 8-ричные. Все остальные строки считаются 10-ричными.

Примечание
Метод parseInt возвращает целое значение, равное числу, содержащемуся в numstring. Если numstring не может быть обработано как целое, возвращается NaN.
parseInt("abc")    // Возвращает NaN.
parseInt("12abc")  // Возвращает 12.
Для проверки на значение NaN применяется метод isNaN.


Метод parseInt

Метод parseInt
Применение 		Справочник языка

Объект Global


Метод parseInt

Метод parseInt
См. также 		Справочник языка

Метод isNaN
Метод parseFloat
Объект String
Метод valueOf


Метод unescape

Метод unescape 		Справочник языка
Версия 1

См. также Применение

Описание
Декодирует объект String, закодированный при помощи метода escape.
Синтаксис
unescape(charstring)

Аргумент charstring является объектом String для декодирования.

Пример
Метод unescape возвращает объект String, включающий содержание charstring. Все символы, закодированные в виде формата %xx, заменяются соответствующими символами таблицы ASCII.

Символы, закодированные в %u xxxx формате (Unicode), заменяются соответствующими символами Unicode.


Метод unescape

Метод unescape
Применение 		Справочник языка

Объект Global


Метод unescape

Метод unescape
См. также 		Справочник язык

Метод escape
Объект String


Операторы сравнения в JScript

Операторы сравнения 		Справочник языка
Версия 1

См. также

Описание
Возвращают логический результат сравнения выражений.
Синтаксис
expression1 comparisonoperator expression2

Синтаксис операторов сравнения состоит из следующих частей:

Часть | Описание
expression1 | Некоторое выражение - expression.
comparisonoperator | Некоторый оператор сравнения - comparison operator.
expression2 | Некоторое выражение.

Примечание
При сравнении строк JScript использует значения символов Unicode строкового выражения.

Ниже описано поведение видов операторов сравнения в зависимости от типов и значений expression1 и expression2:

Отношения (<, >, <=, >=)

  • Пытаются преобразовать expression1 и expression2 в числовой тип.
  • Если оба выражения - строки, проводится лексиграфическое сравнение строк.
  • Если хотя бы одно из выражений - NaN, возвращают false.
  • Отрицательный нуль равен положительному нулю.
  • Минус-бесконечность меньше любого числа, принадлежащего ему.
  • Плюс-бесконечность больше любого числа, принадлежащего ему.
Равенства (==, !=)
  • Если типы обоих выражений отличаются, пытаются преобразовать их в строки, числа или логические переменные.
  • NaN не равен ничему, даже самому себе.
  • Отрицательный нуль равен положительному нулю.
  • null равен null и undefined.
  • Значения считаются равными, если они - идентичные строки, равные числа, подобные объекты, такие же логические значения.
  • Остальные результаты сравнения рассматриваются как неравные.
Тождественности (===. !==)
Поведение этих операторов аналогично операторам равенства, за исключением того, что они не производят какого-либо преобразования типов; для выполнения условия на тождественность, выражения должны быть одного и того же типа.


Операторы сравнения

Операторы сравнения
См. также 		Справочник языка

Поведение операторов
Приоритет операторов
Список операторов


Особенности Microsoft JScript - ECMA

Особенности Microsoft JScript ECMA 		Справочник языка

Содержание

Категория | Особенности/Ключевое слово
Обработка массивов Array
join, length, reverse, sort
Присваивание Assign (=)
Compound Assign (OP=)
Булев (логический) объект Boolean
Комментарий | /*...*/ or //
Константы NaN
null
true, false
Infinity
undefined
Управление ходом программы break
continue
for
for...in
if...else
return
while
Дата и время Date
getDate, getDay, getFullYear, getHours, getMilliseconds, getMinutes, getMonth, getSeconds, getTime, getTimezoneOffset, getYear,
getUTCDate, getUTCDay, getUTCFullYear, getUTCHours, getUTCMilliseconds, getUTCMinutes, getUTCMonth, getUTCSeconds,
setDate, setFullYear, setHours, setMilliseconds, setMinutes, setMonth, setSeconds, setTime, setYear,
setUTCDate, setUTCFullYear, setUTCHours, setUTCMilliseconds, setUTCMinutes, setUTCMonth, setUTCSeconds,
toGMTString, toLocaleString, toUTCString, parse, UTC
Объявления function
new
this
var
with
Создание функций Function
arguments, length
Глобальные методы Global
escape, unescape
eval
isFinite, isNaN
parseInt, parseFloat
Math Math
abs, acos, asin, atan, atan2, ceil, cos, exp, floor, log, max, min, pow, random, round, sin, sqrt tan,
E, LN2, LN10, LOG2E, LOG10E, PI, SQRT1_2, SQRT2,
Numbers Number
MAX_VALUE, MIN_VALUE
NaN
NEGATIVE_INFINITY, POSITIVE_INFINITY,
Создание объектов Object
new
constructor, prototype, toString, valueOf
Операторы Сложение (+), Вычитание (-)
Деление по остатку (%)
Умножение (*), Деление (/)
Унарный минус (-)
Равно (==), Неравно (!=)
Меньше (<), Меньше или равно (<=)
Больше (>), Больше или равно (>=)
 Логическое И(&&), Логическое ИЛИ (||), Логическое НЕ (!)
Разрядное И (&), Разрядное ИЛИ (|), Разрядное НЕ (~), Разрядное ИСКЛЮЧАЮЩЕЕ ИЛИ (^)
Поразрядный левый сдвиг (<<), Поразрядный правый сдвиг (>>)
Поразрядный беззнаковый правый сдвиг (>>>)
Условное выражение (?:)
Запятая (,)
delete, typeof, void
Декремент (--), Инкремент (++)
Объекты Array
Boolean
Date
Function
Global
Math
Number
Object
String
Строки String
charAt, charCodeAt, fromCharCode
indexOf, lastIndexOf
split
toLowerCase, toUpperCase
length


Особенности Microsoft JScript - Non-ECMA

Особенности Microsoft JScript Non-ECMA 		Справочник языка

Содержание

Category | Feature/Keyword
Обработка массивов concat, slice
VBArray
dimensions, getItem, lbound, toArray, ubound
Трансляция условных выражений @cc_on
@if Statement
@set Statement
Conditional Compilation Variables
Управление ходом программы do...while
Labeled
switch
Дата и время getVarDate
Перечисление Enumerator
atEnd, item, moveFirst, moveNext
Создание функций | caller
Операторы Identity (===), Nonidentity (!==)
Объекты Enumerator
RegExp
Regular Expression
VBArray
ActiveXObject
GetObject
Регулярные выражения RegExp
index, input, lastIndex, $1...$9, source, compile, exec, test
Regular Expression Syntax
Информация об обработчике сценариев ScriptEngine
ScriptEngineBuildVersion
ScriptEngineMajorVersion
ScriptEngineMinorVersion
Строки concat, slice
match, replace, search
anchor, big, blink, bold, fixed, fontcolor, fontsize, italics, link, small, strike, sub, sup


Microsoft особенности выполнения сценариев

Microsoft особенности выполнения сценариев 		Справочник языка

Содержание

Категория Особенность/Ключевое слово
Совокупности Drives
Files
Folders
Управление файлами и системой
  • Dictionary
    Add, Exists, Items, Keys, Remove, RemoveAll
    Count, Item, Key
  • Drive, File, Folder
    Copy, Delete, Move, OpenAsTextStream
    Attributes, Count, DateCreated, DateLastAccessed, DateLastModified, Drive, ParentFolder, Name, Path, ShortName, ShortPath, Size
    AvailableSpace, DriveLetter, DriveType, FileSystem, FreeSpace, IsReady, RootFolder, SerialNumber, ShareName, TotalSize, VolumeName
  • FileSystemObject
    BuildPath, CopyFile, CopyFolder, CreateFolder, CreateTextFile, DeleteFile, DeleteFolder, DriveExists, FileExists, FolderExists, GetAbsolutePathName, GetBaseName, GetDrive, GetDriveName, GetExtensionName, GetFile, GetFileName, GetFolder, GetParentFolderName, GetSpecialFolder, GetTempName, MoveFile, MoveFolder, OpenTextFile
    Drives
  • TextStream
    Close, Read, ReadAll, ReadLine, Skip, SkipLine, Write, WriteBlankLines, WriteLine
    AtEndOfLine, AtEndOfStream, Column, Line


Метод abs

Метод abs 		Справочник языка
Версия 1

См. также Применение

Описание
Определение абсолютного значения числового параметра.
Синтаксис
Math.abs(number)

Параметр number - числовое выражение (numeric expression), для которого следует определить абсолютное значение.

Примечание
Возвращает абсолютное значение параметра number.

В следующем примере рассмотрено применение метода abs:

function ComparePosNegVal(n)
{
  var s;
  var v1 = Math.abs(n);
  var v2 = Math.abs(-n);
  if (v1 = v2)
    s = "Абсолютные величины " + n + " и "
    s += -n + " равны.";
  return(s);
}


Метод abs

Метод abs
Применение 		Справочник языка

Объект Math


Метод abs

Метод abs
См. также 		Справочник языка

Методы объекта Math


Метод acos

Метод acos 		Справочник языка
Версия 1

См. также Применение

Описание
Вычисление арккосинуса числового параметра
Синтаксис
Math.acos(number)

Параметр number является числовым выражением (numeric expression), для которого определяется арккосинус.

Примечание
Возвращает значение арккосинуса параметра number.


Метод acos

Метод acos
Применение 		Справочник языка

Объект Math


Метод acos

Метод acos
См. также 		Справочник языка

asin метод
atan метод
cos метод
Методы объекта Math
sin метод
tan метод


Метод asin

Метод asin 		Справочник языка
Версия 1

См. также Применение

Описание
Вычисляет арксинус числового параметра.
Синтаксис
Math.asin(number)

Аргумент number является числовым выражением (numeric expression), для которого вычисляется арксинус.

Примечание
Возвращает значение арксинуса числового параметра.


Метод asin

Метод asin
Применение 		Справочник языка

Объект Math


Метод asin

Метод asin
См. также 		Справочник языка

acos метод
atan метод
cos метод
Методы объекта Math
sin метод
tan метод


Метод atan

Метод atan 		Справочник языка
Версия 1

См. также Применение

Описание
Вычисляет арктангенс числового аргумента.
Синтаксис
Math.atan(number)

Аргумент number является числовым выражением (numeric expression), для которого определяется арктангенс.

Примечание
Возвращает значение арктангенса числового аргумента.


Метод atan2

Метод atan2 		Справочник языка
Версия 2

См. также Применение

Описание
Возвращает угол (в радианах) к оси X и точки point (y,x).
Синтаксис
Math.atan2(y, x)

Синтаксис метода atan2 состоит из частей:

Часть | Описание
Math | Вызывает встроенный объект Math.
x | Числовое выражение (numeric expression), выражающую декартову x-координату.
y | Числовое выражение, выражающую декартову y-координату.

Примечание
Возвращает значение между -pi и pi, представляющее собой угол в точку с (y,x) координатами.


Метод atan2

Метод atan2
Применение 		Справочник языка

Объект Math


Метод atan2

Метод atan2
См. также 		Справочник языка

Метод atan
Методы объекта Math
Метод tan


Метод atan

Метод atan
Применение 		Справочник языка

Объект Math


Метод atan

Метод atan
См. также 		Справочник языка

acos метод
asin метод
atan2 метод
cos метод
Методы объекта Math
sin метод
tan метод


Метод ceil

Метод ceil 		Справочник языка
Версия 1

См. также Применение

Описание
Определение наименьшего целого, большего или равного числовому аргументу.
Синтаксис
Math.ceil(number)

Аргумент number является числовым выражением (numeric expression).


Метод ceil

Метод ceil
Применение 		Справочник языка

Объект Math


Метод ceil

Метод ceil
См. также 		Справочник языка

Метод floor
Методы объекта Math


Метод cos

Метод cos 		Справочник языка
Версия 1

См. также Применение

Описание
Вычисление косинуса числового аргумента.
Синтаксис
Math.cos(number)

Аргумент number является числовым выражением (numeric expression), для которого определяется косинус.

Примечание
Возвращает значение косинуса числового аргумента.


Метод cos

Метод cos
Применение 		Справочник языка

Объект Math


Метод cos

Метод cos
См. также 		Language Reference

acos метод
asin метод
atan метод
Методы объекта Math
sin метод
tan метод


Свойство E

Свойство E 		Справочник языка
Версия 1

См. также Применение

Описание
Постоянная Эйлера, основание натуральных логарифмов.
Синтаксис
var numVar
numVar = Math.E
Примечание
Свойство E приблизительно равно 2.718.


Свойство E

Свойство E
Применение 		Справочник языка

Объект Math


Свойство E

Свойство E
См. также 		Справочник языка

Метод exp
Свойства объекта Math


Метод exp

Метод exp 		Справочник языка
Версия 1

См. также Применение

Описание
Вычисляет e в степени числового аргумента.
Синтаксис
Math.exp(number)

Параметр number является числовым выражением (numeric expression) и является степенью e.

Примечание
Возвращает значение enumber. Константа e является постоянной Эйлера и приблизительно равна 2.178, а number - параметр, определяющий степень.


exp Method

Microsoft® JScript®
exp Method
Applies To 		Language Reference

Math Object


Метод exp

Метод exp
См. также 		Справочник языка

Свойство E
Методы объекта Math


Метод floor

Метод floor 		Справочник языка
Версия 1

См. также Применение

Описание
Вычисляет наибольшее целое, меньшее или равное числовому аргументу.
Синтаксис
Math.floor(number)

Аргумент number является числовым выражением (numeric expression).


Метод floor

Метод floor
Применение 		Справочник языка

Объект Math


Метод floor

Метод floor
См. также 		Справочник языка

Метод ceil
Методы объекта Math


Свойство LN2

LN2 Property 		Справочник языка
Версия 1

См. также Применение

Описание
Натуральный логарифм числа 2.
Синтаксис
var numVar
numVar = Math.LN2
Примечание
Свойство LN2 - число, приблизительно равное 0.693.


Свойство LN2

Свойство LN2
Применение 		Справочник языка

Объект Math


Свойство LN2

Свойство LN2
См. также 		Справочник языка

Свойства объекта Math


Свойство LN10

Свойство LN10 		Справочник Языка
Версия 1

См. также Применение

Описание
Натуральный логарифм числа 10.
Синтаксис
var numVar
numVar = Math.LN10
Примечание
Свойство LN10 - число, приблизительно равное 2.302.


Свойство LN10

Свойство LN10
Применение 		Справочник языка

Объект Math


Свойство LN10

Свойство LN10
См. также 		Справочник языка

Свойства объекта Math


Метод log

Метод log 		Справочник языка
Версия 1

См. также Применение

Описание
Вычисляет натуральный логарифм числового выражения (numeric expression).
Синтаксис
Math.log(number)

Аргумент number представляет собой числовое выражение, для которого вычисляется натуральный логарифм.

Примечание
Возвращает значение натурального логарифма number. Основанием натурального логарифма является e - постоянная Эйлера. Если number равен 0, возвращается -Infinity. Если number - число отрицательное, возвращается значение NaN.


Свойство LOG2E

Свойство LOG2E 		Справочник языка
Версия 1

См. также Применение

Описание
Логарифм e, постоянной Эйлера, по основанию 2.
Синтаксис
var varName
varName = objName.LOG2E
Примечание
Свойство LOG2E является константой, приблизительно равной 1.442.


Свойство LOG2E

Свойство LOG2E
Применение 		Справочник языка

Объект Math


Свойство LOG2E

Свойство LOG2E
См. также 		Справочник языка

Свойства объекта Math


Свойство LOG10E

Свойство LOG10E 		Справочник языка
Версия 1

См. также Применение

Описание
Десятичный логарифм e, постоянной Эйлера.
Синтаксис
var varName
varName = objName.LOG10E
Примечание
Свойство LOG10E является константой, приблизительно равной 0.434.


Свойство LOG10E

Свойство LOG10E
Применение 		Справочник языка

Объект Math


Свойство LOG10E

Свойство LOG10E
См. также 		Справочник языка

Свойства объекта Math


Метод log

Метод log
Применение 		Справочник языка

Объект Math


Метод log

Метод log
См. также 		Справочник языка

Методы объекта Math


Методы max

Метод max 		Справочник языка
Версия 1

См. также Применение

Описание
Возвращает значение большего из параметров.
Синтаксис
retVal = Math.max(number1, number2)

Синтаксис метода max состоит из частей:

Часть | Описание
retVal | Большее из number1 и number2.
number1 | Числовое выражение (numeric expression), сравниваемое с number2.
number2 | Значение, сравниваемое с number1.


max Method

Microsoft® JScript®
max Method
Applies To 		Language Reference

Math Object


Метод max

Метод max
См. также 		Справочник языка

Методы объекта Math
Метод min


Метод min

Метод min 		Справочник языка
Версия 1

См. также Применение

Описание
Возвращается меньшее из двух чисел.
Синтаксис
retVal = Math.min(number1, number2)

Синтаксис метода min состоит из частей:

Часть | Описание
retVal | Меньшее из number1 и number2.
number1 | Числовое выражение (numeric expression), сравниваемое с number2.
number2 | Числовое значение, сравниваемое с number1.


Метод min

Метод min
Применение 		Справочник языка

Объект Math


Метод min

Метод min
См. также 		Справочник языка

Методы объекта Math
Метод max


Свойство PI

Свойство PI 		Справочник языка
Версия 1

См. также Применение

Описание
Отношение длины окружности к диаметру.
Синтаксис
var numVar
numVar = Math.PI
Примечание
Свойство PI является константой, приблизительно равной 3.14159.


Свойство PI

Свойство PI
Применение 		Справочник языка

Объект Math


Свойство PI

Свойство PI
См. также 		Справочник языка

Свойства объекта Math


Метод pow

Метод pow 		Справочник языка
Версия 1

См. также Применение

Описание
Возвращает значение степенного выражения параметров.
Синтаксис
Math.pow(base, exponent)

Синтаксис метода pow состоит из частей:

Часть | Описание
base | Выражение - основание степени.
exponent | Выражение - экспонента степени.

Примечание
В следующем примере, значение числового выражения (numeric expression) baseexponent равно 1000.
Math.pow(10,3);


Метод pow

Метод pow
Применение 		Справочник языка

Объект Math


Метод pow

Метод pow
См. также 		Справочник языка

Методы объекта Math


Метод random

Метод random 		Справочник языка
Версия 1

См. также Применение

Описание
Возвращает псевдослучайное значение между 0 и 1.
Синтаксис
Math.random( )
Примечание
Генерируемое псевдослучайное значение имеет значение от 0 по 1 включительно. Генератор случайных чисел загружается при первом вызове JScript.


Метод random

Метод random
Применение 		Справочник языка

Объект Math


Метод random

Метод random
См. также 		Справочник языка

Методы объекта Math


Метод round

Метод round 		Справочник языка
Версия 1

См. также Применение

Описание
Округление значения числового выражения (numeric expression) к ближайшему целому.
Синтаксис
Math.round(number)

Аргумент number - число, округляемое до ближайшего целого.

Примечание
Если десятичная часть number равна 0.5 или более, возвращается наименьшее целое, большее чем number. В обратном случае, round возвращает наибольшее целое, меньшее чем number.


Метод round

Метод round
Применение 		Справочник языка

Объект Math


Метод round

Метод round
См. также 		Справочник языка

Методы объекта Math


Метод sin

Метод sin 		Справочник языка
Версия 1

См. также Применение

Описание
Возвращает значение синуса числового параметра.
Синтаксис
Math.sin(number)

Аргумент number является числовым выражением (numeric expression), для которого вычисляется синус.


Метод sin

Метод sin
Применение 		Справочник языка

Объект Math


Метод sin

Метод sin
См. также 		Справочник языка

acos метод
asin метод
atan метод
cos метод
Методы объекта Math
tan метод


Метод sqrt

Метод sqrt 		Справочник языка
Версия 1

См. также Применение

Описание
Возвращает квадратный корень числа.
Синтаксис
Math.sqrt(number)

Аргумент number является числовым выражением ( numeric expression).

Примечание
Если значение number отрицательно, возвращается значение, равное нулю.


Свойство SQRT1_2

Свойство SQRT1_2 		Справочник языка
Версия 1

См. также Применение

Описание
Квадратный корень 0.5 - равен единице, деленной на квадратный корень 2.
Синтаксис
var numVar
numVar = Math.SQRT1_2
Примечание
Свойство SQRT1_2 является константой, приблизительно равной 0.707.


Свойство SQRT1_2

Свойство SQRT1_2
Применение 		Справочник языка

Объект Math


Свойство SQRT1_2

Свойство SQRT1_2
См. также 		Справочник языка

Свойства объекта Math
Метод sqrt
Свойство SQRT2


Свойство SQRT2

Свойство SQRT2 		Справочник языка
Версия 1

См. также Применение

Описание
Квадратный корень 2.
Синтаксис
var numVar
numVar = Math.SQRT2
Примечание
Свойство SQRT2 является константой, приблизительно равной 1.414.


Свойство SQRT2

Свойство SQRT2
Применение 		Справочник языка

Объект Math


Свойство SQRT2

Свойство SQRT2
См. также 		Справочник языка

Свойства объекта Math
Метод sqrt
Свойство SQRT1_2


Метод sqrt

Метод sqrt
Применение 		Справочник языка

Объект Math


Метод sqrt

Метод sqrt
См. также 		Справочник языка

Методы объекта Math
Свойство SQRT1_2
Свойство SQRT2


Метод tan

Метод tan 		Справочник языка
Версия 1

См. также Применение

Описание
Вычисляет тангенс числа.
Синтаксис
Math.tan(number)

Аргумент number представляет собой числовое выражение (numeric expression), для которого определяется тангенс.

Примечание
Возвращение значение тангенса number.


Метод tan

Метод tan
Применение 		Справочник языка

Объект Math


Метод tan

Метод tan
См. также 		Справочник языка

acos метод
asin метод
atan метод
atan2 метод
cos метод
Методы объекта Math
sin метод


JScript Run-time Errors

Microsoft® JScript®
JScript Run-time Errors 		Language Reference
Version 1

JScript Syntax Errors

Error Number | Description
5 | Invalid procedure call or argument
6 | Overflow
7 | Out of memory
9 | Subscript out of range
10 | This array is fixed or temporarily locked
11 | Division by zero
13 | Type mismatch
14 | Out of string space
17 | Can't perform requested operation
28 | Out of stack space
35 | Sub or Function not defined
48 | Error in loading DLL
51 | Internal error
52 | Bad file name or number
53 | File not found
54 | Bad file mode
55 | File already open
57 | Device I/O error
58 | File already exists
61 | Disk full
62 | Input past end of file
67 | Too many files
68 | Device unavailable
70 | Permission denied
71 | Disk not ready
74 | Can't rename with different drive
75 | Path/File access error
76 | Path not found
91 | Object variable or With block variable not set
92 | For loop not initialized
94 | Invalid use of Null
322 | Can't create necessary temporary file
424 | Object required
429 | Automation server can't create object
430 | Class doesn't support Automation
432 | File name or class name not found during Automation operation
438 | Object doesn't support this property or method
440 | Automation error
445 | Object doesn't support this action
446 | Object doesn't support named arguments
447 | Object doesn't support current locale setting
448 | Named argument not found
449 | Argument not optional
450 | Wrong number of arguments or invalid property assignment
451 | Object not a collection
453 | Specified DLL function not found
458 | Variable uses an Automation type not supported in JScript
462 | The remote server machine does not exist or is unavailable
501 | Cannot assign to variable
502 | Object not safe for scripting
503 | Object not safe for initializing
504 | Object not safe for creating
507 | An exception occurred
5000 | Cannot assign to 'this'
5001 | Number expected
5002 | Function expected
5003 | Cannot assign to a function result
5004 | Cannot index object
5005 | String expected
5006 | Date object expected
5007 | Object expected
5008 | Illegal assignment
5009 | Undefined identifier
5010 | Boolean expected
5011 | Can't execute code from a freed script
5012 | Object member expected
5013 | VBArray expected
5014 | JScript object expected
5015 | Enumerator object expected
5016 | Regular Expression object expected
5017 | Syntax error in regular expression
5018 | Unexpected quantifier
5019 | Expected ']' in regular expression
5020 | Expected ')' in regular expression
5021 | Invalid range in character set
5022 | Exception thrown and not caught
5023 | Function does not have a valid prototype object


JScript Syntax Errors

Microsoft® JScript®
JScript Syntax Errors 		Language Reference
Version 1

JScript Run-time Errors

Error Number | Description
1001 | Out of memory
1002 | Syntax error
1003 | Expected ':'
1004 | Expected ';'
1005 | Expected '('
1006 | Expected ')'
1007 | Expected ']'
1008 | Expected '{'
1009 | Expected '}'
1010 | Expected identifier
1011 | Expected '='
1012 | Expected '/'
1013 | Invalid number
1014 | Invalide character
1015 | Unterminated string constant
1016 | Unterminated comment
1018 | 'return' statement outside of function
1019 | Can't have 'break' outside of loop
1020 | Can't have 'continue' outside of loop
1023 | Expected hexadecimal digit
1024 | Expected 'while'
1025 | Label redefined
1026 | Label not found
1027 | 'default' can only appear in a 'switch' statement
1028 | Expected identifier or string
1029 | Expected '@end'
1030 | Conditional compilation turned off
1031 | Expected constant
1032 | Expected '@'
1033 | Expected 'catch'
1034 | Expected 'var'
1035 | 'throw' must be followed by an expression on the same source line


Свойство MAX_VALUE

Свойство MAX_VALUE 		Справочник языка
Версия 2

См. также Применение

Описание
Наибольшее возможное число в JScript. Приблизительно равно 1.79E+308.
Синтаксис
Number.MAX_VALUE

Параметр number является объектом Number.

Примечание
Объект Number не может быть создан до того, как свойство MAX_VALUE может быть доступно.


Свойство MAX_VALUE

Свойство MAX_VALUE
Применение 		Справочник языка

Объект Number


Свойство MAX_VALUE

Свойство MAX_VALUE
См. также 		Справочник языка

Свойство MIN_VALUE
Свойство NaN
Свойство NEGATIVE_INFINITY
Свойство POSITIVE_INFINITY
Метод toString


Свойство MIN_VALUE

Свойство MIN_VALUE 		Справочник языка
Версия 2

См. также Применение

Описание
Ближайшее к нулю число, которое может быть представлено в JScript. Приблизительно равно 2.22E-308.
Синтаксис
Number.MIN_VALUE

Аргумент number всегда является объектом Number.

Примечание
Объект Number не может быть создан до того, как свойство MIN_VALUE может быть доступно.


Свойство MIN_VALUE

Свойство MIN_VALUE
Применение 		Справочник языка

Объект Number


Свойство MIN_VALUE

Свойство MIN_VALUE
См. также 		Справочник языка

Свойство MAX_VALUE
Свойство NaN
Свойство NEGATIVE_INFINITY
Свойство POSITIVE_INFINITY
Метод toString


Свойство NaN

Свойство NaN 		Справочник языка
Версия 2

См. также Применение

Описание
Специальное значение арифметического выражения, возвращаемое в случае, когда значение - НеЧисло.
Синтаксис
Number.NaN

Аргумент number является объектом Number.

Примечание
Объект Number не может быть создан до того, как свойство NaN может быть доступно.

NaN не равно никакому значению, включая само себя. Для проверки на значение NaN необходимо применить функцию isNaN.


Свойство NaN

Свойство NaN
Применение 		Справочник языка

Объект Number


Свойство NaN

Свойство NaN
См. также 		Справочник языка

Метод isNaN
Свойство MAX_VALUE
Свойство MIN_VALUE
Свойство NEGATIVE_INFINITY
Свойство POSITIVE_INFINITY
Метод toString


NEGATIVE_INFINITY Property

Microsoft® JScript®
NEGATIVE_INFINITY Property 		Language Reference
Version 2

See Also Applies To

Description
Returns a value more negative than the largest negative number (-Number.MAX_VALUE) representable in JScript.
Syntax
Number.NEGATIVE_INFINITY

The number argument is the Number object.

Remarks
The Number object does not have to be created before the NEGATIVE_INFINITY property can be accessed.

JScript displays NEGATIVE_INFINITY values as -infinity. This value behaves mathematically as infinity.


NEGATIVE_INFINITY Property

Microsoft® JScript®
NEGATIVE_INFINITY Property
Applies To 		Language Reference

Number Object


NEGATIVE_INFINITY Property

Microsoft® JScript®
NEGATIVE_INFINITY Property
See Also 		Language Reference

MAX_VALUE Property
MIN_VALUE Property
NaN Property
POSITIVE_INFINITY Property
toString Method


Свойство POSITIVE_INFINITY

Свойство POSITIVE_INFINITY 		Справочник языка
Версия 2

См. также Применение

Описание
Значение, большее чем наибольшее значение (Number.MAX_VALUE) в JScript.
Синтаксис
Number.POSITIVE_INFINITY

Аргумент number является объектом Number.

Примечание
Объект Number не создается до того как значение свойства POSITIVE_INFINITY может быть доступно.

JScript показывает значение POSITIVE_INFINITY как infinity. Математически значение равно плюс-бесконечности.


Свойство POSITIVE_INFINITY

Свойство POSITIVE_INFINITY
Применение 		Справочник языка

Объект Number


Свойство POSITIVE_INFINITY

Свойство POSITIVE_INFINITY
См. также 		Справочник языка

Свойство MAX_VALUE
Свойство MIN_VALUE
Свойство NaN
Свойство NEGATIVE_INFINITY
Метод toString


Объект ActiveXObject

Объект ActiveXObject 		Справочник языка
Версия 3

См. также

Описание
Возвращает и включает ссылку к автоматическому объекту (Automation object).
Синтаксис
var newObject = new ActiveXObject(class)

Синтаксис параметра class имеет вид servername.typename и состоит из частей:

Часть | Описание
servername | Название приложения, обеспечивающего объект.
typename | Тип или класс объекта для создания.

Примечание
Автоматически создается по крайней мере один тип объекта. Например, приложение текстового процессора может обеспечивать объект приложения, объект документа и объект панели инструментов.

Чтобы создать автоматический объект, необходимо назначить новый ActiveXObject к переменной объекта:

var ExcelSheet;
ExcelSheet = new ActiveXObject("Excel.Sheet");
Код запускает приложение, создающее объект (в данном случае это таблица Microsoft Excel). Как только объект создан, для обращения к нему в коде используется переменная объекта, которая была определена. В следующем примере, вам доступны свойства и методы нового объекта при использовании переменной объекта ExcelSheet, а также других объектов Excel, включая объект приложения и коллекцию ActiveSheet.Cells. Например:

//Делает Excel видимым через объект приложения.
ExcelSheet.Application.Visible = true;
// Запись некоторого текста в первую ячейку таблицы.
ExcelSheet.ActiveSheet.Cells(1,1).Value = "Это столбец A, строка 1";
// Сохранение таблицы.
ExcelSheet.SaveAs("C:\\TEST.XLS");
// Закрытие Excel методом Quit объекта приложения.
ExcelSheet.Application.Quit();
// Очистка переменной объекта
ExcelSheet = "";


Объект ActiveXObject

Объект ActiveXObject
См. также 		Справочник языка

Функция GetObject


Объект Array

Объект Array
 Справочник языка
Версия 2

См. также Методы Свойства

Описание
Обеспечивает поддержку для создания массивов с элементами любых типов данных.
Синтаксис
new Array()
new Array(size)
new Array(element0, element1, ..., elementn)

Синтаксис объекта Array состоит из следующих частей:

Часть | Описание
size | Размер массива. Так как индексация массивов начинается с нуля, созданные элементы имеют индексы от нуля до size -1.
element0,...,elementn | Элементы, включенные в массив.

Примечание
После того, как массив создан, для доступа к отдельному элементу массива применяется индексная ([ ]) нотация, к примеру:
var my_array = new Array();
for (i = 0; i < 10; i++)
    {
    my_array[i] = i;
    }
x = my_array[4];
Так как в Microsoft JScript нумерация начинается с нуля, последняя инструкция примера применяется к пятому элементу массива. Этот элемент имеет значение 4.

Если только один элемент используется в конструкторе Array, и этот аргумент является числом, он преобразовывается в беззнаковое целое, и это значение используется как размер массива. Иначе параметр является лишь элементом массива.


Объект Array

Объект Array
См. также 		Справочник языка

Оператор new


Методы объекта Array

Объект Array
Методы 		Справочник языка

Элементы Array.prototype
Метод concat
Метод join
Метод reverse
Метод slice
Метод sort

Метод toString
Метод valueOf

Неэлементы Array.prototype
Объект Array не имеет методов, которые не являются частями прототипа.


Свойства Array

Объект Array
Свойства 		Справочник языка

Элементы Array.prototype
Свойство constructor
Неэлементы Array.prototype
Свойство length
Свойство prototype


Объект Boolean

Объект Boolean 		Справочник языка
Версия 2

См. также Методы Свойства

Описание
Создает новый объект Boolean.
Синтаксис
var variablename = new Boolean(boolvalue)

Аргумент boolvalue задает значение для нового объекта Boolean. Если параметр опущен, имеет значения false, 0, null, NaN или является пустой строкой, значение объекта Boolean равно false. В остальных случаях - true.

Примечание
Объект Boolean является wrapper-объектом. JScript неявно используется в объекте Boolean при логическом преобразовании объекта Boolean.

Очень редко объект Boolean объявляется явно.


Объект Boolean

Объект Boolean
См. также 		Справочник языка

Оператор new
Инструкция var


Методы Boolean

Объект Boolean
Методы 		Справочник языка

Элементы Boolean.prototype
Метод toString
Метод valueOf
Не элементы Boolean.prototype
Объект Boolean не имеет методов, которые не являются частями prototype.


Свойства объекта Boolean

Объект Boolean
Свойства 		Справочник языка

Элементы Boolean.prototype
Свойство constructor
Неэлементы of Boolean.prototype
Свойство prototype


Объект Date

Объект Date 		Справочник языка
Версия 1

См. также Методы Свойства

Описание
Допускает хранение и исправление дат и времени.
Синтаксис
var newDateObj = new Date()
var newDateObj = new Date(dateVal)
var newDateObj = new Date(year, month, date[, hours[, minutes[, seconds[,ms]]]])

Синтаксис конструктора (constructor) объекта Date состоит из частей:

Часть | Описание
dateVal | При числовом значении, dateVal представляет количество миллисекунд согласно Универсальной Координате Времени (Universal Coordinated Time) между указанной датой и полночью 01/01/1970. Если значение dateVal является строковым, применяется обработка согласно метода parse. Аргумент dateVal также может быть значением VT_DATE как возвращенным объектом ActiveX®.
year | Требуется. Полный формат года, например, 1976 (а не 76).
month | Требуется. Месяц как целое число между 0 и 11 (январь-декабрь).
date | Требуется. Дань месяца как целое число от 1 до 31.
hours | Необязательно. Должно быть указано, если требуется указание minutes. Целое число между 0 и 23, указывает час.
minutes | Необязательно. Должно быть указано, если требуется указание seconds. Целое число между 0 и 59, указывает минуты.
seconds | Необязательно. Должно быть указано, если требуется указание milliseconds. Целое число между 0 и 59, указывает секунды.
ms | Необязательно. Целое число между от 0 до 999, указывает миллисекунды.

Примечание
Объект Date содержит представление момента времени в миллисекундах. Если значение параметра превышает допустимое значение диапазона или является отрицательным, другие указанные значения меняются соответственно. Например, если указано 150 секунд, JScript переопределяет это число как две минуты и 30 секунд.

Если значение числа NaN, это указывает на то, что объект не представлен определенным моментом времени. Если у объекта Date отсутствуют параметры, значение представляется как текущее время по UTC. Значение должно быть присвоено объекту до его использования.

Диапазон дат, которые могут быть представлены объектом Date - приблизительно 285 616 лет от 01/01/1970 - в прошлое или будущее.

Объект Date имеет два статичных метода, вызываемых без создания объекта Date. Это - parse и UTC.


Объект Date

Объект Date
См. также 		Справочник языка

Оператор new
Инструкция var


Методы объекта Date

Объект Date
Методы 		Справочник языка

Элементы Date.prototype
getDate метод
getDay метод
getFullYear метод
getHours метод
getMilliseconds метод
getMinutes метод
getMonth метод
getSeconds метод
getTime метод
getTimezoneOffset метод
getUTCDate метод
getUTCDay метод
getUTCFullYear метод
getUTCHours метод
getUTCMilliSeconds метод
getUTCMinutes метод
getUTCMonth метод
getUTCSeconds метод
getVarDate метод
getYear метод
setDate метод
setFullYear метод
setHours метод
setMilliSeconds метод
setMinutes метод
setMonth метод
setSeconds метод
setTime метод
setUTCDate метод
setUTCFullYear метод
setUTCHours метод
setUTCMilliseconds метод
setUTCMinutes метод
setUTCMonth метод
setUTCSeconds метод
setYear метод
toGMTString метод
toLocaleString метод
toUTCString метод

toString метод
valueOf метод

Неэлементы Date.prototype
parse метод
UTC метод


Свойства объекта Date

Объект Date
Свойства 		Справочник языка

Свойства constructor
Свойства prototype


Объект Dictionary

Объект Dictionary 		Справочник языка
Версия 2

См. также Методы Свойства

Описание
Объект, хранящий данные парами "ключ-значение".
Синтаксис
y = new ActiveXObject("Scripting.Dictionary")
Примечание
Объект Dictionary эквивалентен ассоциативным массивам PERL. Значения могут иметь любую форму представления данных, они хранятся в массиве. Каждое значение ассоциируется с уникальных ключом. Ключ служит для обращения к отдельному значению и обычно является целым числом или строкой, он не может быть массивом.

В следующем примере показано, как создается объект Dictionary:

var y = new ActiveXObject("Scripting.Dictionary");
y.add ("a", "test");
if (y.Exists("a"))
  document.write("true");
...


Объект Dictionary

Объект Dictionary
См. также 		Справочник языка

Объект FileSystemObject
Объект TextStream


Методы объекта Dictionary

Объект Dictionary
Методы 		Справочник языка

Метод Add (Dictionary)
Метод Exists
Метод Items
Метод Keys
Метод Remove
Метод RemoveAll


Свойства объекта Dictionary

Объект Dictionary
Свойства 		Справочник языка

Свойство Count
Свойство Item
Свойство Key


Объект Drive

Объект Drive 		Справочник языка
Версия 3

См. также Свойства Методы

Описание
Обеспечивает доступ к свойствам дисков и сетевых ресурсов.
Примечание
Использование объекта Drive иллюстрируется в следующем примере:
function ShowFreeSpace(drvPath)
{
    var fso, d, s;
    fso = new ActiveXObject("Scripting.FileSystemObject");
    d = fso.GetDrive(fso.GetDriveName(drvPath));
    s = "Диск " + drvPath + " - " ;
    s += d.VolumeName + "<br>";
    s += "Свободно: " + d.FreeSpace/1024 + " Kbytes";
    return(s);
}


Объект Drive

Объект Drive
См. также 		Справочник языка

Совокупность дисков
Объект File
Совокупность файлов
Объект Folder
Совокупность папок
Метод GetDrive


Объект Drive

Объект Drive
Методы 		Справочник языка

Объект Drive не имеет методов.


Объект Drive

Объект Drive
Свойства 		Справочник языка

AvailableSpace
DriveLetter
DriveType
FileSystem
FreeSpace
IsReady
Path
RootFolder
SerialNumber
ShareName
TotalSize
VolumeName


Свойство constructor

Свойство constructor 		Справочник языка
Версия 2

См. также Применение

Описание
Определяет функцию, которая создает объект.
Синтаксис
object.constructor

Обязательный параметр object является названием объекта или функции.

Применение
Свойство constructor - элемент прототипа каждого объекта, имеющего прототип. Включает все встроенные объекты (intrinsic JScript objects), исключая объекты Global и Math. Например:
x = new String("Привет!");
if (x.constructor == String)
   //  некоторые действия (если условие - true).
или
function MyFunc {
// тело функции.
}

y = new MyFunc;
if (y.constructor == MyFunc)
   // некоторые действия (если условие - true).


Свойство constructor

Свойство constructor
Применение 		Справочник языка

Объект Array
Объект Boolean
Объект Date
Объект Function
Объект Math
Объект Number
Объект Object
Объект String


Свойство constructor

Свойство constructor
См. также 		Справочник языка

Свойство prototype


Свойство prototype

Свойство prototype 		Справочник языка
Версия 2

См. также Применение

Описание
Содержит ссылку на прототип класса объекта.
Синтаксис
objectname.prototype

Параметр objectname является именем объекта.

Примечание
Свойство prototype применяется для обеспечения основных функциональных возможностей классу объектов. Новые экземпляры объекта "наследуют" поведение прототипа, назначенного на тот объект.

Например, необходимо добавить метод объекту Array для определения значения наибольшего значения массива. Чтобы сделать это, объявите функцию, добавьте к Array.prototype и используйте.

function array_max( )
{
  var i, max = this[0];
  for (i = 1; i < this.length; i++)
  {
     if (max < this[i])
         max = this[i];
  }
  return max;
}
Array.prototype.max = array_max;
var x = new Array(1, 2, 3, 4, 5, 6);
var y = x.max( );
После выполнения кода, y содержит значение наибольшего элемента массива x, равное 6.

Все встроенные объекты (intrinsic JScript objects) имеют свойство prototype - "только для чтения". Функциональные возможности могут быть добавлены к образцу, как в примере, но объекту нельзя изменить свойства. Однако, в пользовательских объектах (user-defined objects), может быть назначен новый образец.

Списки методов и свойств для каждого встроенного объекта указаны в справочнике языка.


Свойство prototype

Свойство prototype
Применение 		Справочник языка

Объект Array
Объект Boolean
Объект Date
Объект Function
Объект Number
Объект Object
Объект String


Свойство prototype

Свойство prototype
См. также 		Справочник языка

Свойство constructor


Метод toString

Метод toString 		Справочник языка
Версия 2

См. также Применение

Описание
Возвращает строковое представление объекта.
Синтаксис
objectname.toString( )

Параметр objectname - объект, представляемый в виде строки.

Примечание
Метод toString является элементом всех встроенных в JScript объектов. Его поведение зависит от типа данных:

Объект | Поведение
Array | Элементы Array преобразуются в строки. Результатом является конкатенация строк, разделенных запятыми.
Boolean | Если логическое значение равно true, возвращает "true". Иначе возвращается значение "false".
Function Возвращает следующее значение, где functionname является именем функции, которую вызвал метод toString:
function functionname( ) { [код функции] }
Number | Возвращает текстовое представление числа.
String | Возвращает значение объекта String.
По умолчанию | Возвращает "[object objectname]", где objectname - имя типа объекта.

Следующий пример иллюстрирует использование метода toString с параметром основания системы счисления:

function CreateRadixTable ()
{
  var s1, s2, s3, x;
  document.write("Hex    Dec   Bin<BR>");
  for (x = 0; x < 16; x++)
  {
    switch(x)
    {
      case 0 :
        s1 = "      ";
        s2 = "    ";
        s3 = "   ";
        break;
      case 1 :
        s1 = "      ";
        s2 = "    ";
        s3 = "   ";
        break;
      case 2 :
        s3 = "  ";
        break;
      case 3 :
        s3 = "  ";
        break;
      case 4 :
        s3 = " ";
        break;
      case 5 :
        s3 = " ";
        break;
      case 6 :
        s3 = " ";
        break;
      case 7 :
        s3 = " ";
        break;
      case 8 :
        s3 = "" ;
        break;
      case 9 :
        s3 = "";
        break;
      default:
        s1 = "     ";
        s2 = "";
        s3 = "    ";
    }
    document.write(" ", x.toString(16), s1, x.toString(10), s2, s3, x.toString(2), "<BR>");
  }
}


Метод toString

Метод toString
См. также 		Справочник языка

Объект Array
Объект Boolean
Объект Function
Объект Number
Объект Object
Объект String


Метод valueOf

Метод valueOf 		Справочник языка
Версия 2

См. также Применение

Описание
Возвращает значение примитива указанного объекта.
Синтаксис
object.valueOf( )

Параметром object является любой объект JScript.

Примечание
Метод valueOf выполняется по разному в зависимости от типа объекта.

Объект | Возвращаемое значение
Array | Элементы массива преобразуются в строки, которые складываются в одну, разделенные запятой. Поведение аналогично методам Array.toString и Array.join.
Boolean | Булево значение.
Date | Количество миллисекунд прошедших с полуночи 01/01/1970 UTC.
Function | Сама функция.
Number | Числовое значение.
Object | Сам объект. Значение по умолчанию.
String | Строковое значение.

Объект Math не имеет метода valueOf.


Метод valueOf

Метод valueOf
Применение 		Справочник языка

Объект Array
Объект Boolean
Объект Date
Объект Function
Объект Number
Объект Object
Объект String


Метод valueOf

Метод valueOf
См. также 		Справочник языка

Метод toString


Объект Enumerator

Объект Enumerator 		Справочник языка
Версия 3

См. также Методы Свойства

Описание
Обеспечивает перечисление членов совокупности.
Синтаксис
new Enumerator(collection)

Параметр collection - любой объект совокупности.

Примечание
Совокупности отличаются от массивов тем, что члены совокупности не доступны непосредственно. Вместо использования индексации, как в массивах, можно только перемещать текущий указатель на элемент к первому или следующему элементу коллекции.

Объект Enumerator обеспечивает доступ к любому члену совокупности и ведет себя подобно инструкции For...Each в VBScript.

Следующий пример иллюстрирует применение объекта Enumerator:

function ShowDriveList()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  for (;!e.atEnd();e.moveNext())
    {
      x = e.item();
      s = s + x.DriveLetter;
      s += " - ";
      if (x.DriveType == 3)
        n = x.ShareName;
      else if (x.IsReady)
        n = x.VolumeName;
      else
        n = "[Drive not ready]";
      s +=  n + "<br>";
    }
  return(s);
}


Объект Enumerator

Объект Enumerator
См. также 		Справочник языка

Совокупность дисков
Совокупность файлов
Совокупность папок


Объект Enumerator

Объект Enumerator
Методы 		Справочник языка

Метод atEnd
Метод item
Метод moveFirst
Метод moveNext


Объект Enumerator

Объект Enumerator
Свойства 		Справочник языка

Объект Enumerator не имеет свойств.


Error Object

Microsoft® JScript®
Error Object 		Language Reference
Version 5

See Also Properties

Description
Contains information about errors.
Syntax
var newErrorObj = new Error()
var newErrorObj = new Error(number)
var newErrorObj = new Error(number, description)

The Error object constructor syntax has these parts:

Part | Description
number | Numeric value assigned to an error. Zero if omitted.
description | Brief string that describes an error. Empty string if omitted.

Remarks
Whenever a run-time error occurs, an instance of the Error object is created to describe the error. This instance has two intrinsic properties that contain the description of the error (description property) and the error number (number property).

An error number is a 32-bit value. The upper 16-bit word is the facility code, while the lower word is the actual error code.

Error objects can also be explicitly created, using the syntax shown above, or thrown using the throw statement. In both cases, you can add any properties you choose, to expand the capability of the Error object.

Typically, the local variable that's created in a try...catch statement refers to the implicitly created Error object. As a result, you can use the error number and description in any way you choose.

The following example illustrates the use of the implicitly created Error object:

try {
  x = y                		     // Cause an error.
}
catch(e) {              		     // Create local variable e.
  response.write(e)                  // Prints "[object Error]".
  response.write(e.number & 0xFFFF)  // Prints 5009.
  response.write(e.description)      // Prints "'y' is undefined".
}


Error Object

Microsoft® JScript®
Error Object
See Also 		Language Reference

new Operator
throw Statement
try...catch Statement
var Statement


Error Object

Microsoft® JScript®
Error Object
Properties 		Language Reference

description Property
number Property


Объект File

Объект File 		Справочник языка
Версия 3

См. также Свойства Методы

Описание
Обеспечивает доступ ко всем свойствам файла.
Примечание
Следующий пример иллюстрирует как получить объект File и просмотреть одно из его свойств.
function ShowFileInfo(filespec)
{
  var fso, f, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.GetFile(filespec);
  s = f.DateCreated;
  return(s);
}


Объект File

Объект File
См. также 		Справочник языка

Объект Drive
Совокупность дисков
Совокупность файлов
Объект Folder
Совокупность папок


Объект File

Объект File
Методы 		Справочник языка

Метод Copy
Метод Delete
Метод Move
Метод OpenAsTextStream


Объект File

Объект File
Свойства 		Справочник языка

Attributes
DateCreated
DateLastAccessed
DateLastModified
Drive
Name
ParentFolder
ShortName
ShortPath
Size
Type


Объект FileSystemObject

Объект FileSystemObject 		Справочник языка
Версия 2

См. также Методы Свойства

Описание
Обеспечивает доступ к файловой системе компьютера.
Синтаксис
y = new ActiveXObject("Scripting.FileSystemObject")
Примечание
Следующий пример иллюстрирует, как применяется FileSystemObject для записи или чтения объекта TextStream :
var fso = new ActiveXObject("Scripting.FileSystemObject");
var a = fso.CreateTextFile("c:\\testfile.txt", true);
a.WriteLine("Это - тест!");
a.Close();
В данном примере объект ActiveXObject ассоциируется с FileSystemObject (fso). Метод CreateTextFile создает файл как объект TextStream (a), a метод WriteLine записывает текстовую строку в созданный файл. Метод Close очищает буфер и закрывает файл.


Объект FileSystemObject

Объект FileSystemObject
См. также 		Справочник языка

Объект Dictionary
Объект Drive
Совокупность дисков
Объект File
Совокупность файлов
Объект Folder
Совокупность папок
Объект TextStream


Объект FileSystemObject

Объект FileSystemObject
Методы 		Справочник языка

BuildPath
CopyFile
CopyFolder
CreateFolder
CreateTextFile
DeleteFile
DeleteFolder
DriveExists
FileExists
FolderExists
GetAbsolutePathName
GetBaseName
GetDrive
GetDriveName
GetExtensionName
GetFile
GetFileName
GetFolder
GetParentFolderName
GetSpecialFolder
GetTempName
MoveFile
MoveFolder
OpenTextFile


Объект FileSystemObject

Объект FileSystemObject
Свойства 		Справочник языка

Свойство Drives


Объект Folder

Объект Folder 		Справочник языка
Версия 3

См. также Свойства Методы

Описание
Обеспечивает доступ ко всем свойствам папки.
Примечание
Следующий пример иллюстрирует, как получить объект Folder и его свойства:
function ShowFolderInfo(folderspec)
{
  var fso, folder, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  folder = fso.GetFolder(folderspec);
  s = folder.DateCreated;
  return(s);
}


Объект Folder

Объект Folder
См. также 		Справочник языка

Объект Drive
Совокупность дисков
Объект File
Совокупность файлов
Совокупность папок


Объект Folder

Объект Folder
Методы 		Справочник языка

Copy
Delete
Move
OpenAsTextStream


Объект Folder

Объект Folder
Свойства 		Справочник языка

Attributes
DateCreated
DateLastAccessed
DateLastModified
Drive
Files
IsRootFolder
Name
ParentFolder
Path
ShortName
ShortPath
Size
SubFolders


Объект Function

Объект Function 		Справочник языка
Версия 2

См. также Методы Свойства

Описание
Создание новой функции.
Синтаксис 1
function functionname( [argname1 [, ... argnameN]] )
{
body
}
Синтаксис 2
var functionname = new Function( [argname1, [... argnameN,]] body );

Синтаксис объекта Function состоит из следующих частей:

Часть | Описание
functionname | Имя новосозданной функции
argname1...argnameN | Необязательный список параметров функции.
body | Блок кода JScript, выполняемый при вызове функции.

Примечание
Функция является основным типом данных в JScript. Синтаксис 1 создает функцию, которая при необходимости преобразовывается в объект Function. JScript преобразовывает объект Function, созданный при помощи Синтаксиса 2 в саму функцию во время вызова функции.

Синтаксис 1 является стандартным способом создания функций в JScript. Синтаксис 2 - альтернативная форма, применяемая для создания объекта явно.

Например, для создания функции, которая находит сумму двух аргументов, применяется два способа:

Пример 1
function add(x, y)
{
   return(x + y);
}
Пример 2
var add = new Function("x", "y", "return(x+y)");
В любом случае для вызова функции применяется конструкция типа:
add(2, 3);


Объект Function

Объект Function
См. также 		Справочник языка

Инструкция function
Оператор new
Инструкция var


Методы объекта Function

Объект Function
Методы 		Справочник языка

Элементы Function.prototype
Метод toString
Метод valueOf
Неэлементы Function.prototype
Объект Function не имеет методов, не являющимися частями prototype.


Свойства объекта Function

Объект Function
Свойства 		Справочник языка

Элементы Function.prototype
Свойство arguments
Свойство caller

Свойство constructor

Неэлементы Function.prototype
Свойство prototype


Объект Global

Объект Global 		Справочник языка
Версия 3

См. также Методы Свойства

Описание
Встроенный объект (intrinsic object), цель которого - собрать все глобальные методы в один объект.
Синтаксис
Объект Global не имеет синтаксиса. Все его методы вызываются непосредственно.
Примечание
Объект Global никогда не используется непосредственно, для его создания не используется оператор new. Он создается при инициализации сценария, немедленно делая доступными все методы и свойства.


Объект Global

Объект Global
См. также 		Справочник языка

Объект Object


Объект Global

Объект Global
Методы 		Справочник языка

escape метод
eval метод
isFinite метод
isNaN метод
parseFloat метод
parseInt метод
unescape метод


Объект Global

Объект Global
Свойства 		Справочник языка

Свойство Infinity
Свойство NaN


Объект Math

Объект Math 		Справочник языка
Версия 1

См. также Методы Свойства

Описание
Встроенный объект, содержит основные математические функции и константы.
Синтаксис
Math[.{property | method}]
Примечание
Объект Math не может быть создан с использованием оператора new, при попытке сделать это, возникает ошибка. Все методы и свойства объекта доступны для применения в сценариях в любой момент.


Объект Math

Объект Math
См. также 		Справочник языка

Объект Number


Методы объекта Math

Объект Math
Методы 		Справочник языка

Элементы Math.prototype
Объект Math не имеет методов, являющимися частями prototype.
Неэлементы Math.prototype
abs Метод
acos Метод
asin Метод
atan Метод
atan2 Метод
ceil Метод
cos Метод
exp Метод
floor Метод
log Метод
max Метод
min Метод
pow Метод
random Метод
round Метод
sin Метод
sqrt Метод
tan Метод


Свойства объекта Math

Объект Math
Свойства 		Справочник языка

E Свойство
LN2 Свойство
LN10 Свойство
LOG2E Свойство
LOG10E Свойство
PI Свойство
SQRT1_2 Свойство
SQRT2 Свойство


Объект Number

Объект Number 		Справочник языка
Версия 2

См. также Методы Свойства

Описание
Объект представляет собой числовой тип данных.
Синтаксис
new Number( value )

Параметр value является искомым численным значением объекта.

Примечание
JScript создает объекты Number из числовых значений. Редко когда требуется явное создание объекта Number.

Первая цель объекта Number - набор всех свойств в один объект, что позволяет преобразовывать числа в строки через метод toString.


Объект Number

Объект Number
См. также 		Справочник языка

Объект Math
Оператор new


Методы объекта Number

Объект Number
Методы 		Справочник языка

Элементы Number.prototype
Метод toString
Метод valueOf
Неэлементы Number.prototype
Объект Number не имеет методов, которые - не являются частью прототипа.


Свойства объекта Number

Объект Number
Свойства 		Справочник языка

Элементы Number.prototype
MAX_VALUE Свойство
MIN_VALUE Свойство
NaN Свойство
NEGATIVE_INFINITY Свойство
POSITIVE_INFINITY Свойство

constructor Свойство

Неэлементы Number.prototype
prototype Свойство


Объект Object

Объект Object 		Справочник языка
Версия 3

См. также Методы Свойства

Описание
Обеспечивает общие функциональные возможности всех объектов JScript.
Синтаксис
new Object([value])

Необязательный параметр value используется для преобразования примитивных (primitive) типов данных (числа, булевы значения, строки, функции) в объект. Если опущен, создается объект без содержания.

Примечание
Объект Object содержится во всех других объектах JScript - все методы и свойства доступны в других объектах. Методы могут быть переопределены в пользовательских объектах и вызваны JScript в соответствующее время. Метод toString - пример часто переопределяемого метода Object.

В справочнике языка дано описание каждого метода Object.


Объект Object

Объект Object
См. также 		Справочник языка

Объект Function
Объект Global


Объект Object

Объект Object
Методы 		Справочник языка

Элементы Object.prototype
Метод toString
Метод valueOf

Неэлементы Object.prototype
Объект Object не имеет методов, которые не являются частями прототипа.


Объект Object

Объект Object
Свойства 		Справочник

Элементы Object.prototype
Свойство prototype
Свойство constructor

Элементы Object.prototype
Объект Object не имеет свойств, не являющимися частями прототипа.


Объект RegExp

Объект RegExp 		Справочник языка
Версия 3

См. также Методы Свойства

Описание
Сохраняет информацию о найденных соответствиях регулярных выражений.
Syntax
RegExp.propertyname

Аргумент propertyname - одно из свойств объекта RegExp.

Примечание
Объект RegExp не может быть создан непосредственно, но всегда доступен для использования. Значение его свойств неопределены (undefined) до окончания поиска на соответствие регулярному выражению.

В следующем примере применяется объект RegExp:

function matchDemo()
{
  var s;
  var re = new RegExp("d(b+)(d)","ig");
  var str = "cdbBdbsbdbdz";
  var arr = re.exec(str);
  s = "$1 содержит: " + RegExp.$1 + "<BR>";
  s += "$2 содержит: " + RegExp.$2 + "<BR>";
  s += "$3 содержит: " + RegExp.$3;
  return(s);
}


Объект RegExp

Объект RegExp
См. также 		Справочник языка

Объект Regular Expression
Синтаксис регулярных выражений
Объект String


Объект RegExp

Объект RegExp
Метод 		Справочник языка

Объект RegExp не содержит методов.


Объект RegExp

Объект RegExp
Свойства 		Справочник языка

Свойства $1...$9
Свойство index
Свойство input
Свойство lastIndex


Объект Regular Expression

Объект Regular Expression 		Справочник языка
Версия 3

См. также Методы Свойства

Описание
Содержит регулярное выражение.
Синтаксис 1
var regularexpression = /pattern/[switch]
Синтаксис 2
var regularexpression = new RegExp("pattern",["switch"])

Синтаксис объекта состоит из частей:

Часть | Описание
pattern | Требуется. Регулярное выражение для применения. Если используется синтаксис 1, ограничителем является символ "/". Если применяется синтаксис 2, необходимо регулярное выражение заключить в кавычки.
switch Необязательно. Необходимо заключать switch в кавычки при использовании синтаксиса 2. Возможные варианты:
  • i (игнорирование регистра)
  • g (глобальный поиск всех местонахождений pattern)
  • gi (глобальный поиск с игнорированием регистра)

    • Примечание
    Объект Regular Expression сохраняет образцы, использованные для поиска комбинаций символов. Информация о недавних поисках находится в объекте RegExp.

    Применять синтаксис 1 следует тогда, когда строка поиска известна заранее, а синтаксис 2 при частом изменении строки поиска, либо когда она неизвестна, например, строка вводится пользователем.

    Параметр pattern перед использованием компилируется во внутренний формат. Для синтаксиса 1 pattern компилируется при загрузке сценария. Для синтаксиса 2 pattern компилируется только перед применением или при вызове метода compile.


Объект Regular Expression

Объект Regular Expression
См. также 		Справочник языка

Объект RegExp
Синтаксис регулярных выражений
Объект String


Объект Regular Expression

Объект Regular Expression
Mетоды 		Справочник языка

Метод compile
Метод exec
Метод test


Объект Regular Expression

Объект Regular Expression
Свойства 		Справочник языка

Свойство lastIndex
Свойство source


Объект String

Объект String 		Справочник языка
Версия 1

См. также Методы Свойства

Описание
Позволяет обработку и форматирование текстовых строк и подстрок в пределах строкового объекта.
Синтаксис
StringObj[.method]
"String Literal"[.method]
Примечание
Объект String может быть создан явно, используя строковые литералы. Объект String может быть создан как строка и как объект при помощи оператора new. Все строковые литералы используются как глобальный строковый объект. Так, если свойство добавлено к строковому литералу, оно доступно всем стандартным строковым объектам:
var alpha, beta;
alpha = "This is a string";
beta = "This is also a string";

alpha.test = 10;

В данном примере test определен и для beta, и для всех будущих строковых литералов. В следующем примере, однако, добавляемые свойства обрабатываются по-другому:

var gamma, delta;
gamma = new String("This is a string");
delta = new String("This is also a string");

gamma.test = 10;
В данном случае test не определен для delta. Каждый объект String объявляется как новый объект String с собственными свойствами своих элементов. Это - единственный случай, когда объект String и строковый литерал обрабатываются по-разному.


Объект String

Объект String
См. также 		Справочник языка

Оператор new


Методы объекта String

Объект String
Методы 		Справочник языка

Элементы String.prototype
anchor
big
blink
bold
charAt
charCodeAt
concat
fixed
fontcolor
fontsize
fromCharCode
indexOf
italics
lastIndexOf
link
match
replace
search
slice
small
split
strike
sub
substr
substring
sup
toLowerCase
toUpperCase

toString
valueOf

Неэлементы String.prototype
Объект String не имеет методов, которые не являются частью прототипа.


Свойства объекта String

Объект String
Свойства 		Справочник языка

Элементы String.prototype
Свойство constructor
Неэлементы String.prototype
Свойство length
Свойство prototype


Объект TextStream

Объект TextStream 		Справочник языка
Версия 2

См. также Методы Свойства

Описание
Обеспечивает последовательный доступ к файлу.
Синтаксис
TextStream.{property | method( )}

Параметры property and method могут быть любыми свойствами и методами объекта TextStream. Фактически, TextStream заменяется переменной объекта TextStream, возвращенного из FileSystemObject.

Примечание
В следующем коде a является объектом TextStream, возвращаемом методом CreateTextFile объекта FileSystemObject:
var fso = new ActiveXObject("Scripting.FileSystemObject")
var a = fso.CreateTextFile("c:\\testfile.txt", true)
a.WriteLine("Это тест, только тест.")
a.Close
WriteLine и Close являются методами объекта TextStream.


Объект TextStream

Объект TextStream
См. также 		Справочник языка

Объект Dictionary
Объект FileSystemObject


Объект TextStream

Объект TextStream
Методы 		Справочник языка

Close
Read
ReadAll
ReadLine
Skip
SkipLine
Write
WriteBlankLines
WriteLine


Объект TextStream

Объект TextStream
Свойства 		Language Reference

Свойство AtEndOfLine
Свойство AtEndOfStream
Свойство Column
Свойство Line


Объект VBArray

Объект VBArray 		Справочник языка
Версия 3

См. также Методы Свойства

Описание
Обеспечивает доступ к массивам Visual Basic.
Синтаксис
new VBArray(safeArray)

safeArray является значением VBArray.

Примечание
VBArrays - только для чтения, и не может быть создан непосредственно. Параметр safeArray должен быть получен как значение VBArray до вызова конструктора VBArray. Его можно получить из объекта ActiveX или других объектов.

VBArrays может быть многомерным. Индексы каждой размерности могут различаться. Метод dimensions возвращает мерность массива; методы lbound и ubound возвращают диапазон индексов каждой размерности.

Следующий пример состоит из трех частей. В первой части код VBScript создает массив Visual Basic. Вторая часть - код на JScript преобразует VB-массив в массив JScript. Обе части расположены в секции <HEAD> страницы HTML. Третья часть находится в секции <BODY> и содержит код JScript, запускающий первые две части.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function CreateVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      document.writeln(k)
      k = k + 1
    Next
    document.writeln("<BR>")
  Next
  CreateVBArray = a
End Function
-->
</SCRIPT>
<SCRIPT LANGUAGE="JScript">
<!--
function VBArrayTest(vbarray)
{
  var a = new VBArray(vbarray);
  var b = a.toArray();
  var i;
  for (i = 0; i < 9; i++)
  {
    document.writeln(b[i]);
  }
}
-->
</SCRIPT>
</HEAD>
<BODY>
<SCRIPT LANGUAGE="JScript">
<!--
  VBArrayTest(CreateVBArray());
-->
</SCRIPT>
</BODY>


Объект VBArray

Объект VBArray
См. также 		Справочник языка

Объект Array


Объект VBArray

Объект VBArray
Методы 		Справочник языка

dimensions
getItem
lbound
toArray
ubound


Объект VBArray

Объект VBArray
Свойства 		Справочник языка

Объект VBArray не имеет свойств.


Приоритет операторов

Приоритет операторов 		Справочник языка
Версия 1

В JScript операторы выполняются в определенном порядке, называемом приоритет операций. Следующий список отражает приоритет операторов от высшего к низшему. Операторы, указанные в одной строке, выполняются слева направо.

Оператор | Описание
. [] () Точка, индексы массивов, вызов функции
++ -- - ~ ! typeof new void delete | Унарные операции, вывод типов данных, создание объектов, неопределенные значения
* / % Умножение, деление, деление по остатку
+ - + Сложение, вычитание, конкатенация строк
<< >> >>> Поразрядные сдвиги
< <= > >= Меньше, меньше или равно, больше, больше или равно
== != === !== Равно, неравно, тождественно, нетождественно
& Разрядное И
^ Разрядное ИСКЛЮЧАЮЩЕЕ ИЛИ
| Разрядное ИЛИ
&& Логическое И
|| Логическое ИЛИ
?: Условное выражение
= OP= | Операторы присваивания
, Запятая

Круглые скобки используются, чтобы изменить порядок выполнения операторов. Выражение в круглых скобках полностью вычисляется прежде, и его значение используется как остаточный член инструкции. .

Оператор с более высоким приоритетом выполняется ранее оператора с низким приоритетом. Например:

z = 78 * (96 + 3 + 45)
В данном выражении пять операторов: =, *, (), +, and +. Приоритет операторов - следующий: (), *, +, +, =.
  1. Первым вычисляется значение выражения в круглых скобках: К сумме операции 96 и 3 прибавляется 45, общая сумма равна 144.
  2. Далее выполняется умножение: произведение 78 и 144 дает результат 11232.
  3. Переменной z присваивается значение 11232 .


Оператор сложения (+)

Оператор + 		Справочник языка
Версия 1

См.также

Описание
Применяется для вычисления суммы двух чисел или конкатенации строк.
Синтаксис
result = expression1 + expression2

Синтаксис оператора + состоит из следующих частей:

Часть | Описание
result | Некоторая переменная - variable.
expression1 | Некоторое выражение - expression.
expression2 | Некоторое выражение.

Примечание
Поведение оператора + зависит от типа выражений.

Условие | Операция
Оба выражения - числовые или логические | Сложение.
Оба выражения - строки | Конкатенация.
Одно выражение - числовое, второе - строковое | Конкатенация.

Для получения информации о возникновении ошибок типа run-time error при использовании оператора +, обратитесь к таблице Поведения операторов.


Оператор сложения (+)

Оператор +
См. также 		Справочник языка

Оператор +=
Поведение операторов
Приоритет операторов
Список операторов


Оператор сложения с присваиванием (+=)

Оператор += 		Справочник языка
Версия 1

См. также

Описание
Применяется для увеличения переменной на выражение.
Синтаксис
result += expression

Синтаксис оператора += состоит из следующих частей:

Часть | Описание
result | Некоторая переменная - variable.
expression | Некоторое выражение - expression.

Примечание
Использование оператора аналогично выражению:
result = result + expression
Зависимость поведения оператора += от типов данных, приведена ниже.

Условие | Операция
Оба выражения - числовые или логические | Сложение.
Оба выражения - строки | Конкатенация.
Одно выражение - число, другое - строка | Конкатенация.

Для получения информации об ошибке run-time error при использовании оператора +=, смотрите таблицу поведения операторов.


Составное присваивание

Составные операторы присваивания 		Справочник языка

Составные операторы

Беззнакового правого сдвига (>>>=)
Вычитания (-=)
Деления (/=)
Деления по остатку (%=)
Левого сдвига (<<=)
Правого сдвига (>>=)
Разрядного И (&=)
Разрядного ИЛИ (|=)
Разрядного ИСКЛЮЧАЮЩЕГО ИЛИ (^=)
Сложения (+=)
Умножения (*=)


Логический оператор И (&&)

Оператор && 		Справочник языка
Версия 1

См. также

Описание
Логическая конъюнкция двух выражений.
Систаксис
result = expression1 && expression2

Синтаксис оператора && состоит из частей:

Часть | Описание
result | Некоторая переменная - variable.
expression1 | Некоторое выражение - expression.
expression2 | Некоторое выражение.

Примечание
Только при значении обоих выражений, равном True, result равен True. Если хотя бы одно из выражений равно False, result равен False.

Для получения информации об ошибке run-time error при применении оператора &&, смотрите таблицу поведения операторов.

JScript следует следующим правилам для преобразования нелогических выражений к логическому значению:

  • Все объекты принимают значение true.
  • Строки равны false, если они пустые.
  • Значения null и undefined рассматриваются как false.
  • Числа обрабатываются как false, если они равны нулю.


Оператор (&&)

Оператор &&
См. также 		Справочник языка

Поведение операторов
Приоритет операторов
Список операторов


Оператор присваивания (=)

Оператор = 		Справочник языка
Версия 1

См. также

Описание
Присваивает значение переменной.
Синтаксис
result = expression

Оператор = состоит из частей:

Часть | Описание
result | Некоторая переменная - variable.
expression | Некоторое числовое выражение - numeric expression.

Примечание
Оператор = присваивает переменной значение выражения. Следовательно, что можно применять цепные операторы для присваивания следующим образом:
j = k = l = 0;
j, k и l становятся равными нулю после выполнения инструкций.


Оператор присваивания (=)

Оператор =
См. также 		Справочник языка

Составные операторы присваивания
Поведение операторов
Приоритет операторов
Список операторов


Составной оператор разрядного И (&=)

Оператор &= 		Справочник языка
Версия 1

См. также

Описание
Применяется для операции разрядного И над выражением.
Синтаксис
result &= expression

Синтаксис оператора &= состоит из частей:

Часть | Описание
result | Некоторая переменная - variable.
expression | Некоторое выражение - expression.

Примечание
Применение оператора аналогично выражению:
result = result & expression
Оператор &= производит операцию разрядного И над двоичными представлениями result и expression. Например:
0101    (result)
1100    (expression)
----
0100    (output)
Если оба соответствующих разряда равны 1, результат равен 1. В иных случаях результат равен 0.

Для получения информации об ошибке run-time error при использовании оператора &= смотрите таблицу поведения операторов.


Составной оператор разрядного И (&=)

Оператор &=
См. также 		Справочник языка

Оператор &
Поведение операторов
Приоритет операторов
Список операторов


Составной оператор разрядного ИЛИ (|=)

Оператор |= 		Справочник языка
Версия 1

См. также

Description
Применение разрядного ИЛИ над выражением.
Синтаксис
result |= expression

Синтаксис оператора |= состоит из частей:

Часть | Описание
result | Некоторая пераменная (variable).
expression | Некоторое выражение (expression).

Примечание
Использование этого составного оператора аналогично следующему выражению:
result = result | expression
Оператор |= над двоичными представлениями значений result и expression производит операцию разрядного ИЛИ. Пример подобной операции:
0101    (result)
1100    (expression)
----
1101    (output)
Если хотя бы один из соответствующих разрядов равен единице - итог также равен 1. Иначе результат - 0.

Для информации о возникновении ошибки run-time error при применении оператора |=, смотрите таблицу поведения операторов.


Составной оператор разрядного ИЛИ (|=)

Оператор |=
См. также 		Справочник языка

Оператор |
Поведение операторов
Приоритет операторов
Список операторов


Оператор разрядного И (&)

Оператор & 		Справочник языка
Версия 1

См. также

Описание
Применение разрядного И над двумя выражениями.
Синтаксис
result = expression1 & expression2

Синтаксис оператора & состоит из частей:

Часть | Описание
result | Некоторая переменная - variable.
expression1 | Некоторое выражение - expression.
expression2 | Некоторое выражение.

Примечание
Оператор & производит операцию разрядного И над двоичными представлениями двух выражений. Например:
0101    (expression1)
1100    (expression2)
----
0100    (result)
Когда оба соответствующих разряда равны 1, результат равен 1. В остальных случаях результат равен 0.

Для получения информации об ошибке run-time error при использовании оператора & следует обратиться к таблице поведения операторов.


Оператор разрядного И (&)

Оператор &
См. также 		Справочник языка

Оператор &=
Поведение операторов
Приоритет операторов
Список операторов


Разрядное НЕ (~)

Оператор ~ 		Справочник языка
Версия 1

См. также

Описание
Операция разрядного отрицания (НЕ) в выражении.
Синтаксис
result = ~ expression

Синтаксис оператора ~ состоит из частей:

Часть | Описание
result | Некоторая переменная - variable.
expression | Некоторое выражение - expression.

Примечание
Для всех унарных операторов, подобных ~, установлены следующие правила:
  • При использовании значений undefined или null в выражениях, возникает ошибка run-time error.
  • Объекты преобразуются в строки.
  • Строки преобразуются в числа, если возможно. Если нет, возникает ошибка run-time error.
  • Логические значения применяются как числовые (0 при false, 1 при true).
Оператор применяется к конечному результату.

Оператор ~ рассматривается как двоичное представление значений и совершает операцию разрядного отрицания (НЕ). Например:

0101    (expression)
----
1010    (result)
Все цифры 1 в выражении становятся равными 0 в результате, наоборот, все цифры 0 в выражении становятся равными 1 в результате.


Оператор Разрядного НЕ (~)

Оператор ~
См. также 		Справочник языка

Оператор !
Поведение операторов
Приоритет операторов
Список операторов


Оператор разрядного ИЛИ (|)

Оператор | 		Справочник языка
Версия 1

См. также

Описание
Производит операцию разрядного ИЛИ над двумя выражениями.
Синтаксис
result = expression1 | expression2

Синтаксис оператора | состоит из частей:

Часть | Описание
result | Некоторая переменная (variable).
expression1 | Некоторое выражение (expression).
expression2 | Некоторое выражение.

Примечание
Оператор | над двоичными значениями двух выражений производит операцию разрядного ИЛИ. Результат операции следующий:
0101    (expression1)
1100    (expression2)
----
1101    (result)
Если хотя бы один из соответствующих разрядов равен 1, результат также равен 1. Иначе, результат равен 0.

Для информации о возникновении ошибки run-time error при применении оператора |, смотрите таблицу поведения операторов.


Оператор разрядного ИЛИ (|)

Оператор |
См. также 		Справочник языка

Оператор |=
Поведение операторов
Приоритет операторов
Список операторов


Запятая (,)

Оператор , 		Справочник языка
Версия 1

См. также

Описание
Применяется для последовательного выполнения двух выражений.
Синтаксис
expression1, expression2

Синтаксис оператора , состоит из частей:

Часть | Описание
expression1 | Некоторое выражение - expression.
expression2 | Некоторое выражение.

Примечание
Оператор , предписывает выполнение перечисленных выражений в порядке слева направо. В большинстве случаев оператор , используется в цикле for. Например:

for (i = 0, j = 0; i < 10; i++, j++)
{
  k = i + j;
  document.write(k + " ");
}
выведет на экран 0 2 4 6 8 10 12 14 16 18. Таким образом, оператор , позволяет в конце каждой итерации выполнять несколько инструкций, обходя ограничения.


Оператор запятая (,)

Оператор ,
См. также 		Справочник языка

Инструкция for
Поведение операторов
Приоритет операторов
Список операторов


Условное выражение (Тринар) (?:)

Оператор ?: 		Справочник языка
Версия 1

См.также

Описание
Выполняет одну из двух инструкций в зависимости от условия.
Синтаксис
test ? statement1 : statement2

Синтаксис оператора ?: включает следующее:

Часть | Описание
test | Некоторое логическое выражение - Boolean expression.
statement1 | Выполняемое выражение, если test равен true. Может быть составным - compound statement.
statement2 | Выполняемое выражение, если test равен false. Может быть составным.

Примечание
Оператор ?: является сокращением инструкции if...else. Иногда большое выражение, составленное с помощью инструкции if...else выглядит громоздким. Например:
var now = new Date();
var greeting = "Добрый" + ((now.getHours() > 17) ? " вечер." : " день.");
В данном примере создается приветствие "Добрый вечер." после 18 часов. Вот как выглядел бы код с применением инструкции if...else:
var now = new Date();
var greeting = "Добрый";
if (now.getHours() > 17)
   greeting += " вечер.";
else
   greeting += " день.";


Условное выражение (тринар) (?:)

Оператор ?:
См. также 		Справочник языка

Инструкция if...else
Поведение операторов
Приоритет операторов
Список операторов


Оператор delete

Оператор delete 		Справочник языка
Версия 3

См. также

Описание
Удаляет свойство объекта или элемент массива.
Синтаксис
delete expression

Где expression - допустимое в JScript выражение, означающее свойство объекта или элемент массива.

Примечание
Если expression - объект со свойствами, не позволяющими удалить себя, возвращается false.

Во всех остальных случаях возвращается значение true.


Оператор delete

Оператор delete
См. также 		Справочник языка

Поведение операторов
Приоритет операторов
Список операторов


Составной оператор деления (/=)

Оператор /= 		Справочник языка
Версия 1

См. также

Description
Используется для деления переменной на выражение.
Синтаксис
result /= expression

Синтаксис оператора /= состоит из частей:

Часть | Описание
result | Некоторая числовая переменная (variable).
expression | Некоторое числовое выражение (expression).

Примечание
Использование оператора /= аналогично следующему выражению:
result = result / expression
Для получения информации о возникновении ошибки run-time error при использовании оператора /= смотрите таблицу поведения операторов.


Составной оператор деления (/=)

Оператор /=
См. также 		Справочник языка

Оператор /
Поведение операторов
Приоритет операторов
Список операторов


Оператор деления (/)

Оператор / 		Справочник языка
Версия 1

См. также

Описание
Применяется для определения частного от деления двух чисел.
Синтаксис
result = number1 / number2

Синтаксис оператора / состоит из следующих частей:

Часть | Описание
result | Некоторая переменная - variable.
number1 | Некоторое числовое выражение - numeric expression.
number2 | Некоторое числовое выражение.

Примечание
Для получения информации о возникновении ошибок типа run-time error при использовании оператора /, обратитесь к таблице Поведения операторов.


Оператор деления (/)

Оператор /
См. также 		Справочник языка

Оператор /=
Поведение операторов
Приоритет операторов
Список операторов


Операторы Инкремента (++) and Декремента (--)

Операторы ++ и -- 		Language Reference
Version 1

См. также

Описание
Применяется для увеличения или уменьшения переменной на единицу.
Синтаксис 1
result = ++variable
result = --variable
result = variable++
result = variable--
Синтаксис 2
++variable
--variable
variable++
variable--

Синтаксис операторов ++ и -- состоит из частей:

Часть | Описание
result | Некоторая переменная - variable.
variable | Некоторая переменная.

Примечание
Операторы инкремента и декремента используются как сокращенные для изменения значения переменной. Значение выражения, содержащее эти операторы, отличается в зависимости от их расположения - до или после переменной:
var j, k;
k = 2;
j = ++k;
j принимает значение 3, так как увеличение происходит до присваивания.

Сравните со следующим примером:

var j, k;
k = 2;
j = k++;
Здесь j принимает значение 2, так как увеличение происходит после присваивания.


Операторы Инкремента (++) и Декремента (--)

Операторы ++ и --
См. также 		Справочник языка

Поведение операторов
Приоритет операторов
Список операторов


instanceof Operator

Microsoft® JScript®
instanceof Operator 		Language Reference
Version 5

See Also

Description
Returns a Boolean value that indicates whethor or not an object is an instance of a particular class.
Syntax
result = object instanceof class

The instanceof operator syntax has these parts:

Part | Description
result | Any variable.
object | Any object expression.
class | Any defined object class.

Remarks
The instanceof operator returns true if object is an instance of class. It returns false if object is not an instance of the specified class, or if object is null.

The following example illustrates the use of the instanceof operator:

function objTest(obj)
{
  var i, t, s = "";            // Create variables.
  t = new Array();             // Create an array.
  t["Date"] = Date;            // Populate the array.
  t["Object"] = Object;
  t["Array"] = Array;
    for (i in t)
    {
      if (obj instanceof t[i]) // Check class of obj.
      {
        s += "obj is an instance of " + i + "\n";
      }
      else
      {
        s += "obj is not an instance of " + i + "\n";
      }
  }
  return(s);                   // Return string.
}

var obj = new Date();
response.write(objTest(obj));


instanceof Operator

Microsoft® JScript®
instanceof Operator
See Also 		Language Reference

Operator Precedence
Operator Summary


Список операторов

Список операторов 		Справочник языка
Версия 1

Вычислительные
Вычитание (-)
Декремент (--)
Деление (/)
Деление по остатку (%)
Инкремент (++)
Сложение (+)
Умножение (*)
Унарный минус (-)
Логические
Больше (>)
Больше или равно (>=)
Запятая (,)
Логическое И (&&)
Логическое ИЛИ (||)
Логическое НЕ (!)
Меньше (<)
Меньше или равно(<=)
Неравно (!=)
Нетождественно (!==)
Равно (==)
Тождественно (===)
Условное выражение (тринар) (?:)
Разрядные
Беззнаковый поразрядный правый сдвиг (>>>)
Поразрядный левый сдвиг (<<)
Поразрядный правый сдвиг (>>)
Разрядное И (&)
Разрядное ИЛИ (|)
Разрядное ИСКЛЮЧАЮЩЕЕ ИЛИ (^)
Разрядное НЕ (~)
Присваивания
Присваивание (=)
Составное присваивание
Прочие
delete
typeof
void


Составной оператор левого сдвига (<<=)

Оператор <<= 		Справочник языка
Версия 1

См. также

Описание
Применение разрядного сдвига влево в выражении.
Синтаксис
result <<= expression

Синтаксис оператора <<= состоит из частей:

Часть | Описание
result | Некоторая переменная - variable.
expression | Некоторое выражение - expression.

Примечание
Использование оператора <<= аналогично следующему:
result = result << expression
Оператор <<= сдвигает влево разряды в result на количество, указанное в expression. Например:
var temp
temp = 14
temp <<= 2
Переменная temp равна 56, так как 14 (00001110 двоично) после сдвига двух разрядов влево равно 56 (00111000 двоично). Сдвинутые биты заполняются нулями.

Для получения информации об ошибке run-time error при использовании оператора <<= следует обратиться к таблице поведения операторов.


Составной оператор левого сдвига (<<=)

Оператор <<=
См. также 		Справочник языка

Оператор <<
Оператор >>
Оператор >>>
Поведение операторов
Приоритет операторов
Список операторов


Поразрядный левый сдвиг(<<)

Оператор << 		Справочник языка
Версия 1

См. также

Описание
Поразрядный сдвиг влево.
Синтаксис
result = expression1 << expression2

Синтаксис оператора << состоит из частей:

Часть | Описание
result | Некоторая переменная - variable.
expression1 | Некоторое выражение - expression.
expression2 | Некоторое выражение.

Примечание
Оператор << производит поразрядный сдвиг в expression1 влево на количество битов, указанных в expression2. Пример:
var temp
temp = 14 << 2
Переменная temp принимает значение 56, так как 14 (00001110 в двоичной системе) сдвигается на два разряда влево - 56 (00111000 в двоичной системе).

Для получения информации об ошибке run-time error оператора <<, смотрите таблицу поведения операторов.


Оператор поразрядного левого сдвига (<<)

Оператор <<
См. также 		Справочник языка

Оператор <<=
Оператор >>
Оператор >>>
Поведение операторов
Приоритет операторов
Список операторов


Деление по остатку (%)

Оператор % 		Справочник языка
Версия 1

См. также

Описание
Возвращает остаток от деления двух чисел
Синтаксис
result = number1 % number2

Описание частей оператора %:

Часть | Описание
result | Некоторая переменная - variable.
number1 | Некоторое числовое выражение - numeric expression.
number2 | Некоторое числовое выражение

Примечания
Остаток от деления number1 на number2, определяется как целая часть частного (дробная часть игнорируется), после этого переменной result присваивается значение. Например, в приведенном ниже выражении, A равен 5.
A = 19 % 6.7
Для информации об ошибках типа run-time error оператора %, смотрите таблицу Поведения операторов.


Оператор деления по остатку (%)

Оператор %
См. также 		Справочник языка

Оператор %=
Поведение операторов
Приоритет операторов
Список операторов


Составной оператор деления по остатку (%=)

Оператор %= 		Справочник языка
Версия 1

См. также

Описание
Возвращает остаток от деления двух чисел.
Синтаксис
result %= expression

Синтаксис оператора %= состоит из частей:

Часть | Описание
result | Некоторая переменная (variable).
expression | Некоторое числовое выражение (numeric expression).

Примечание
Использование оператора %= аналогично выражению:
result = result % expression
Для получения информации об ошибке run-time error при применении оператора %= смотрите таблицу поведения операторов.


Составной оператор деления по остатку (%=)

Оператор %=
См. также 		Справочник языка

Оператор %
Поведение операторов
Приоритет операторов
Список операторов


Составной оператор умножения (*=)

Оператор *= 		Справочник языка
Версия 1

См. также

Описание
Применяется для умножения одного числа на другое.
Синтаксис
result *= expression

Синтаксис оператора *= состоит из частей:

Part | Description
result | Некоторая переменная - variable.
expression | Некоторое выражение - expression.

Примечание
Использование оператора *= аналогично следующему выражению:
result = result * expression
Для получения информации об ошибке run-time error при использовании оператора *= следует обратиться к таблице поведения операторов.


Составной оператор умножения (*=)

Оператор *=
См. также 		Справочник языка

Оператор *
Поведение операторов
Приоритет операторов
Список операторов


Оператор умножения (*)

Оператор * 		Справочник языка
Версия 1

См.также

Описание
Применяется для вычисления произведения двух чисел.
Синтаксис
result = number1*number2

Синтаксис оператора * состоит из следующих частей:

Часть | Описание
result | Некоторая переменная - variable.
number1 | Некоторое выражение - expression.
number2 | Некоторое выражение.

Примечание
Для получения информации о возникновении ошибок типа run-time error при использовании оператора *, обратитесь к таблице Поведения операторов.


Оператор умножения (*)

Оператор *
См. также 		Справочник языка

Оператор *=
Поведение операторов
Приоритет операторов
Список операторов


Оператор new

Оператор new
 Справочник языка
Версия 1

См. также

Описание
Создание нового объекта.
Синтаксис

new constructor[(arguments)]

Параметр constructor вызывает конструктор (constructor) объекта. Если конструктор не имеет аргументов, круглые скобки можно опустить.

Примечание
Оператор new выполняет следующее:
  1. Создает новый объект.
  2. Вызывает конструктор объекта, принимает указатель на созданный объект с помощью указателя this.
Конструктор инициализирует объект согласно параметрам.

Примеры возможного применение оператора new:

my_object = new Object;
my_array = new Array();
my_date = new Date("Jan 5 1996");


Оператор new

Оператор new
См.также 		Справочник языка

Инструкция function


Логический оператор НЕ (!)

Оператор ! 		Справочник языка
Версия 1

См. также

Описание
Используется для логического отрицания выражения.
Синтаксис
result = !expression

Синтаксис оператора ! состоит из следующих частей:

Часть | Описание
result | Некоторая переменная - variable.
expression | Некоторое выражение - expression.

Примечание
Порядок определения значения result приведен в следующей таблице.

Значение expression | Значение result
True | False
False | True

Все унарные операторы, подобные оператору !, определяются следующим образом:

  • Если значение не определено (undefined) или равно null, возникает ошибка run-time error.
  • Объекты конвертируются в строки.
  • Строки преобразовываются в числа, если это возможно. Если нет, то возникает ошибка run-time error.
  • Логические значения обрабатываются как числовые (0 при false, 1 при true).
Оператор ! применяется к конечному результату.

Для оператора !, если expression - не нуль, result равен нулю. Если expression - нуль, то result равен 1.


Логический оператор НЕ (!)

Оператор !
См. также 		Справочник языка

Оператор ~
Поведение операторов
Приоритет операторов
Список операторов


Логический оператор ИЛИ (||)

Оператор || 		Справочник языка
Версия 1

См. также

Описание
Логическая дизъюнкция двух выражений.
Синтаксис
result = expression1 || expression2

Синтаксис оператора || состоит из частей:

Часть | Описание
result | Некоторая переменная - variable.
expression1 | Некоторое выражение - expression.
expression2 | Некоторое выражение.

Примечание
Если хотя бы одно из двух выражения равно True, result равен True. В следующей таблице приведены значений result:

Значение expression1 | Значение expression2 | Значение result
True | True | True
True | False | True
False | True | True
False | False | False

Для получения информации об ошибке run-time error при применении оператора || , смотрите таблицу поведения операторов.

JScript следует следующим правилам для преобразования нелогических выражений к логическому значению:

  • Все объекты принимают значение true.
  • Строки равны false, если они пустые.
  • Значения null и undefined рассматриваются как false.
  • Числа обрабатываются как false, если они равны нулю.


Логический оператор ||

Оператор ||
См. также 		Справочник языка

Поведение операторов
Приоритет операторов
Список операторов


Составной оператор правого сдвига (>>=)

Оператор >>= 		Справочник языка
Версия 1

См. также

Описание
Применение разрядного сдвига вправо в выражении с сохранением знака.
Syntax
result >>= expression

Синтаксис оператора >>= состоит из частей:

Часть | Описание
result | Некоторая переменная - variable.
expression | Некоторое выражение - expression.

Примечание
Применение оператора >>= аналогично следующему:
result = result >> expression
Оператор >>= сдвигает биты вправо в result на количество разрядов expression. Бит знака result используется для заполнения цифр слева. Цифры, сдвинутые вправо, теряются. Например, после выполнения следующего кода, temp равен -4: -14 (11110010 двоично) после сдвига двух битов вправо равно -4 (11111100 двоично).
var temp
temp = -14
temp >>= 2
Для получения информации об ошибке run-time error при использовании оператора >>= следует обратиться к таблице поведения операторов.


Составной оператор правого сдвига (>>=)

Оператор >>=
См. также 		Справочник языка

Оператор <<
Оператор >>
Оператор >>>
Поведение операторов
Приоритет операторов
Список операторов


Поразрядный правый сдвиг (>>)

Оператор >> 		Справочник языка
Версия 1

См. также

Описание
Используется для поразрядного сдвига вправо в выражении, при сохранении знака.
Syntax
result = expression1 >> expression2

Синтаксис оператора >> состоит из частей:

Часть | Описание
result | Некоторая переменная - variable.
expression1 | Некоторое выражение - expression.
expression2 | Некоторое выражение.

Примечание
Оператор >> сдвигает разряды в expression1 вправо на количество битов, указанных в expression2. Бит знака expression1 используется для заполнения разрядов слева. Разряды, сдвинутые вправо, игнорируются. Например, после выполнения кода, temp примет значение -4: -14 (11110010 в двоичной системе) после сдвига двух разрядов вправо равно -4 (11111100 в двоичной системе).
var temp
temp = -14 >> 2
Для получения информации об ошибке run-time error при использовании оператора >>, смотрите таблицу поведения операторов.


Оператор поразрядного правого сдвига (>>)

Оператор >>
См. также 		Справочник языка

Оператор <<
Оператор >>=
Оператор >>>
Поведение операторов
Приоритет операторов
Список операторов


Составной оператор вычитания (-=)

Оператор -= 		Справочник языка
Версия 1

См. также

Описание
Вычитание значения из переменной.
Синтаксис
result -= expression

Синтаксис оператора -= состоит из частей:

Часть | Описание
result | Некоторая числовая переменная (variable).
expression | Некоторое числовое выражение (numeric expression).

Примечание
Использование оператора -= аналогично следующему выражению:
result = result - expression

Для информации о возникновении ошибки run-time error при использовании оператора -=, смотрите таблицу поведения операторов.


Знак вычитания (-)

Оператор - 		Справочник языка
Версия 1

См.также

Описание
Применяется для вычисления разности двух чисел или обозначения отрицательного значения числового выражения.

Синтаксис 1
result = number1 - number2
Синтаксис 2
-number

Оператор - состоит из следующих частей:

Часть | Описание
result | Некоторая переменная числового типа - variable.
number | Некоторое числовое выражение - numeric expression.
number1 | Некоторое числовое выражение.
number2 | Некоторое числовое выражение.

Примечание
Синтаксис 1, Оператор - является арифметическим оператором для вычисления разности двух чисел. Синтаксис 2, здесь оператор - применяется как унарный оператор для обозначения отрицательного значения выражения.

Для информации об ошибках типа run-time error при Синтаксисе 1, смотрите таблицу Поведения операторов table.

Для Синтаксиса 2, все унарные операторы и выражения имеют следующие свойства:

  • Если значение не определено (undefined ) или null, то генерируется ошибка run-time error.
  • Объекты конвертируются в строки.
  • Если возможно, строки конвертируются в числа. Иначе - ошибкa run-time error.
  • Логические значения обрабатываются как числовые (0 если false, 1 если true).
Оператор применяется к конечному результату. При Синтаксисе 2, если конечный результат отличен от нуля, result равен конечному результату с противоположным знаком. Если конечный результат равен нулю, result равен нулю.


Оператор вычитания (-)

Оператор -
См. также 		Справочник языка

Оператор -=
Поведение операторов
Приоритет операторов
Список операторов


Оператор определения типа

Оператор typeof 		Справочник языка
Версия 1

См. также

Описание
Используется для определения типа выражения.
Синтаксис
typeof [ ( ] expression [ ) ] ;

Параметр expression - выражение (expression), тип которого необходимо определить.

Примечание
Оператор typeof возвращает информацию о типе как строку. Возможны шесть значений оператора typeof: "number", "string", "boolean", "object", "function" and "undefined".

при использовании оператора typeof, рекомендуется применять круглые скобки.


Оператор typeof

Оператор typeof
См. также 		Справочник языка

Поведение операторов
Приоритет операторов
Список операторов


Составной оператор беззнакового поразрядного правого сдвига (>>>=)

Оператор >>>= 		Справочник языка
Версия 1

См. также

Описание
Применяется для беззнакового поразрядного правого сдвига в переменной.
Синтаксис
result >>>= expression

Синтаксис оператора >>>= состоит из частей:

Часть | Описание
result | Некоторая переменная (variable).
expression | Некоторое выражение (expression).

Применение
Применение оператора >>>= эквивалентно следующему:
result = result >>> expression
Оператор >>>= сдвигает вправо разряды в result на число expression. Слева разряды заполняюся нулями. Цифры в сдвинутых вправо разрядах теряются. Например:
var temp
temp = -14
temp >>>= 2
Переменная temp имеет значение 1073741820 как -14 (11111111 11111111 11111111 11110010 двоично), при правом сдвиге на два бита равно 1073741820 (00111111 11111111 11111111 11111100 двоично).

Для получения информации об ошибке run-time error при использовании оператора >>>=, смотрите таблицу поведения операторов.


Составной оператор беззнакового поразрядного правого сдвига (>>>=)

Оператор >>>=
См. также 		Справочник языка

Оператор >>>
Оператор <<
Оператор >>
Поведение операторов
Приоритет операторов
Список операторов


Беззнаковый поразрядный правый сдвиг (>>>)

Оператор >>> 		Справочник языка
Версия 1

См. также

Описание
Применяется для безнакового поразрядного сдвига вправо в выражении.
Синтаксис
result = expression1 >>> expression2

Синтаксис оператора >>> состоит из следующих частей:

Часть | Описание
result | Некоторая переменная - variable.
expression1 | Некоторое выражение - expression.
expression2 | Некоторое выражение.

Примечание
Оператор >>> применяют для поразрядного сдвига вправо в expression1 на количество битов, указанных в expression2. Слева разряды заполняются нулями. Сдвинутые разряды справа удаляются. Например:
var temp
temp = -14 >>> 2
Переменная temp принимает значение 1073741820, так как -14 (11111111 11111111 11111111 11110010 в двоичной системе) после сдвига двух разрядов вправо равно 1073741820 (00111111 11111111 11111111 11111100 в двоичной системе).

Для получения информации об ошибке run-time error при использовании оператора >>>, смотрите таблицу поведения операторов.


Оператор безнакового правого поразрядного сдвига (>>>)

>Оператор >>
См. также 		Справочник языка

Оператор >>>=
Оператор <<
Оператор >>
Поведение операторов
Приоритет операторов
Список операторов


Оператор void

Оператор void 		Справочник языка
Версия 2

См. также

Описание
Оператор возвращает неопределенное значение - undefined.
Синтаксис
void expression

Аргумент expression - любое разрешенное в JScript выражение (expression).

Примечание
Оператор void оценивает выражение и возвращает неопределенное значение - undefined. Оператор наиболее полезно применять в ситуациях, где необходимо использовать выражение, но не нужно, чтобы его результаты были видимы конечному результату сценария.


Оператор void

Оператор void
См. также 		Справочник языка

Поведение операторов
Приоритет операторов
Список операторов


Оператор поразрядного XOR (^)

Оператор ^ 		Справочник языка
Версия 1

См. также

Описание
Использование поразрядного ИСКЛЮЧАЮЩЕГО ИЛИ над двумя выражениями.
Синтаксис
result = expression1 ^ expression2

Синтаксис оператора ^ состоит из частей:

Часть | Описание
result | Некоторая переменная (variable).
expression1 | Некоторое выражение (expression).
expression2 | Некоторое выражение.

Примечание
Оператор ^ просматривает значения двух выражений в двоичном представлении и производит над ними операцию поразрядного ИСКЛЮЧАЮЩЕГО ИЛИ. Например:
0101    (expression1)
1100    (expression2)
----
1001    (result)
Когда одно, и только одно, из выражений имеет в разряде значение 1, результат равен единице. Иначе результат в разряде равен 0.

Для информации об ошибке run-time error при применении оператора ^, смотрите таблицу поведения операторов.


Оператор поразрядного XOR (^)

Оператор ^
См. также 		Справочник языка

Оператор ^=
Поведение операторов
Приоритет операторов
Список операторов


Составной оператор поразрядного XOR (^=)

Оператор ^= 		Справочник языка
Версия 1

См. также

Описание
Применение поразрядного ИСКЛЮЧАЮЩЕГО ИЛИ над выражением.
Синтаксис
result ^= expression

Синтаксис оператора ^= состоит из частей:

Часть | Описание
result | Некоторая переменная (variable).
expression | Некоторое выражение (expression).

Примечание
Применение оператора ^= аналогично следующему:
result = result ^ expression
Оператор ^= просматривает двоичное представление значений двух выражений и производит над ними поразрядную операцию ИСКЛЮЧАЮЩЕГО ИЛИ. Например:
0101    (result)
1100    (expression)
----
1001    (result)
Когда одно, и только одно, из выражений имеет в разряде значение 1, результат равен единице. Иначе результат в разряде равен 0.

Для получения информации об ошибке run-time error при использовании оператора ^=, смотрите таблицу поведения операторов.


description Property

Microsoft® JScript®
description Property 		Language Reference
Version 5

See Also Applies to

Description
Returns or sets the descriptive string associated with a specific error.
Syntax
object.description [= stringexpression]

The description property syntax has these parts:

Part | Description
object | Any instance of an Error object.
stringexpression | A string expression containing a description of the error.

Remarks
The description property contains the error message string associated with a specific error. Use the value contained in this property to alert a user to an error that you can't or don't want to handle.

The following example illustrates the use of the description property:

try {
  x = y                              // Cause an error.
}
catch(var e {                        // Create local variable e.
  document.write(e)                  // Prints "[object Error]".
  document.write((e.number & 0xFFFF))// Prints 5009.
  document.write(e.description)      // Prints "'y' is undefined".
}


description Property

Microsoft® JScript®
description Property
Applies To 		Language Reference

Error Object


description Property

Microsoft® JScript®
description Property
See Also 		Language Reference

number Property


number Property

Microsoft® JScript®
number Property 		Language Reference
Version 5

See Also Applies to

Description
Returns or sets the numeric value associated with a specific error. The Error object's default property is number.
Syntax
object.number [= errornumber]

The number property syntax has these parts:

Part | Description
object | Any instance of the Error object.
errornumber | An integer representing an error.

Remarks
An error number is a 32-bit value. The upper 16-bit word is the facility code, while the lower word is the actual error code.

The following example illustrates the use of the number property:

try {
  x = y         		             // Cause an error.
}
catch(var e) {                         // Create local variable e.
  document.write(e)                    // Prints "[object Error]".
  document.write(e.number>>16 & 0x1FFF)// Prints 10, the facility code.
  document.write(e.number & 0xFFFF)    // Prints 5009, the error code.
  document.write(e.description)        // Prints "'y' is undefined".
}


number Property

Microsoft® JScript®
number Property
Applies To 		Language Reference

Error Object


number Property

Microsoft® JScript®
number Property
See Also 		Language Reference

description Property


Свойство index

Свойство index 		Справочник языка
Версия 3

См. также Применение

Описание
Указывает на индекс первого успешного соответствия в обрабатываемой строке.
Синтаксис
RegExp.index
Примечание
Свойство index отсчитывается с нуля. Значение изменяется всякий раз при новом успешном соответствии.


Свойство index

Свойство index
Применение 		Справочник языка

Объект RegExp


Свойство index

Свойство index
См. также 		Справочник языка

Свойства объекта RegExp
Синтаксис регулярных выражений


Свойство input

Свойство input 		Справочник языка
Версия 3

См. также Применение

Описание
Содержит строку, по которой выполнен поиск. Только для чтения.
Syntax
RegExp.input
Примечание
Значение свойства input изменяется в любое время при изменении поисковой строки.

В следующем примере приводится применение свойства input:

function inputDemo()
{
  var s;
  var re = new RegExp("d(b+)(d)","ig");
  var str = "cdbBdbsbdbdz";
  var arr = re.exec(str);
  s = "The string used for the match was " + RegExp.input;
  return(s);
}


Свойство input

Свойство input
Применение 		Справочник языка

Объект RegExp


Свойство input

Свойство input
См. также 		Справочник языка

Свойства объекта RegExp
Синтаксис регулярных выражений


Свойство lastIndex

Свойство lastIndex 		Справочник языка
Версия 3

См. также Применение

Описание
Указывает на последнее успешное соответствие в обрабатываемой строке.
Синтаксис
RegExp.lastIndex
Примечание
Свойство lastIndex отсчитывается с нуля, то есть индекс первого символа равен нулю. Его значение изменяется при каждом успешном соответствии.

Свойство lastIndex изменяется методами exec и test объекта RegExp, и методами match, replace и split объекта String.

К lastIndex применяются следующие правила:

  • Если нет соответствий, lastIndex устанавливается равным -1.
  • Если lastIndex больше длины строки, в методах test и exec происходит сбой, а lastIndex устанавливается равным -1.
  • Если lastIndex равно длине строки, соответствие найдено, если регулярное выражение равно пустой строке. Иначе lastIndex устанавливается равным -1.
  • В остальных случаях, lastIndex устанавливается равным следующей позиции последнего совпадения.


Свойство lastIndex

Свойство lastIndex
Применение 		Справочник языка

Объект RegExp


Свойство lastIndex

Свойство lastIndex
См. также 		Справочник языка

Свойства объекта RegExp
Синтаксис регулярных выражений


Свойство lastMatch

Свойство lastMatch ($&) 		Справочник языка
Версия 3

См. также Применение

Описание
Определяет последние соответствующие символы. Только для чтения.
Синтаксис
RegExp.lastMatch
Короткая форма синтаксиса
RegExp.$&
Примечание
Значение свойства lastMatch изменяется всякий раз после успешного соответствия.


Свойство lastMatch

Свойство lastMatch
Применение 		Справочник языка

Объект RegExp


Свойство lastMatch

Свойство lastMatch
См. также 		Справочник языка

Свойства объекта RegExp
Синтаксис регулярных выражений


Свойство lastParen

Свойство lastParen ($+) 		Справочник языка
Версия 3

См. также Применение

Описание
Указазывает на последнее соответствие подстроки (если имеется). Только для чтения.
Синтаксис
RegExp.lastParen
Короткая форма синтаксиса
RegExp.$+
Примечание
Значение свойства lastParen изменяется всякий раз, когда сделано успешное соответствие.


Свойство lastParen

Свойство lastParen
Применение 		Справочник языка

Объект RegExp


Свойство lastParen

Свойство lastParen
См. также 		Справочник языка

Свойства объектаRegExp
Синтаксис регулярных выражений


Свойство leftContext

Свойство leftContext ($`) 		Справочник языка
Версия 3

См. также Применение

Описание
Определяет вводную строку до самого последнего соответствия. Только для чтения.
Синтаксис
RegExp.leftContext
Короткая форма синтаксиса
RegExp.$`
Примечание
Значение свойства leftContext изменяется всякий раз после успешного соответствия.


Свойство leftContext

Свойство leftContext
Применение 		Справочник языка

Объект RegExp


Свойство leftContext

Свойство leftContext
См. также 		Справочник языка

Свойства объекта RegExp
Синтаксис регулярных выражений


Свойства $1...$9

Свойства $1...$9 		Справочник языка
Версия 3

См. также Применение

Применение
Определяет девять последних найденных соответствий. Только для чтения.
Syntax
RegExp.$n

Аргумент n - число от 1 до 9.

Примечание
Значение свойств $1...$9 изменяется после каждого успешного соответствия. Любое количество подстрок может быть найдено в указанном регулярном выражении, но лишь девять последних сохраняются.

В следующем примере показано применение свойств $1...$9:

function matchDemo()
{
  var s;
  var re = new RegExp("d(b+)(d)","ig");
  var str = "cdbBdbsbdbdz";
  var arr = re.exec(str);
  s = "$1 содержит: " + RegExp.$1 + "<BR>";
  s += "$2 содержит: " + RegExp.$2 + "<BR>";
  s += "$3 содержит: " + RegExp.$3;
  return(s);
}


Свойства $1...$9

Свойства $1...$9
Применение 		Справочник языка

Объект RegExp


Свойства $1...$9

Свойства $1...$9
См. также 		Справочник языка

Свойства объекта RegExp
Синтаксис регулярных выражений


Свойство multiline

Свойство multiline ($*) 		Справочник языка
Версия 3

См. также Применение

Описание
Указывает, проводился ли поиск через концы строк. Только для чтения.
Синтаксис
RegExp.multiline
Короткая форма синтаксиса
RegExp.$*
Примечание
Значение свойства multiline изменяется после каждого успешного соответствия. Если значение multiline равно true, то поиск был выполнен через концы строк, иначе multiline возвращает значение false.


Свойство multiline

Свойство multiline
Применение 		Справочник языка

Объект RegExp


Свойство multiline

Свойство multiline
См. также 		Справочник языка

Свойства объекта RegExp
Синтаксис регулярных выражений


Метод compile

Метод compile 		Справочник языка
Версия 3

См. также Применение

Описание
Компилирует регулярное выражение во внутренний формат.
Синтаксис
rgexp.compile(pattern)

Синтаксис метода compile состоит из частей:

Часть | Описание
rgexp | Требуется. Объект Regular Expression. Может быть переменной или константой.
pattern | Требуется. Строковое выражение (string expression), содержащее регулярное выражение для компиляции.

Примечание
Метод compile преобразовывает pattern во внутренний формат для быстрого выполнения. Это позволяет эффективнее применять регулярные выражения, например, в циклах.

В следующем примере используется метод compile:

function CompileDemo()
{
  var s = "AaBbCcDdEeFfGgHhIiJjKkLlMmNnOoPp"
  // Создание регулярного выражения только для верхнего регистра.
  var r = new RegExp("[A-Z]", "g");
  var a = s.match(r) // Найти соответствия.
  document.write(a);
  // Компиляция регулярного выражения только для нижнего регистра.
  r.compile("[a-z]", "g");
  var a = s.match(r) // Найти соответствия.
  document.write(a);
}


Метод compile

Метод compile
Применение 		Справочник языка

Объект Regular Expression


Метод compile

Метод compile
См. также 		Справочник языка

Методы объекта Regular Expression
Свойства объекта Regular Expression
Синтаксис регулярных выражений


Метод exec

Метод exec 		Справочник языка
Версия 3

См. также Применение

Описание
Выполняет поиск на соответствие в указанной строке.
Синтаксис
rgexp.exec(str)

Синтаксис метода exec состоит из частей:

Часть | Описание
rgexp | Требуется. Объект Regular Expression. Может быть именем переменной или строковым литералом.
str | Требуется. Строка, представленная для поиска.

Примечание
Результаты поиска метода exec помещаются в массив.

Если методом exec не найдено соответствие, возвращается null. Если найдено одно или несколько соответствий, то метод exec возвращает массив, a объект RegExp изменяется для отражения результатов поиска.

Следующий пример иллюстрирует применение метода exec:

function ExecDemo()
{
  var s = "AaBbCcDdEeFfGgHhIiJjKkLlMmNnOoPp"
  var r = new RegExp("g", "i");
  var a = r.exec(s);
  document.write(a);
  r.compile("g");
  var a = r.exec(s);
  document.write(a);
}


Метод exec

Метод exec
Применение 		Справочник языка

Объект Regular Expression


Метод exec

Метод exec
См. также 		Справочник языка

Объект RegExp
Методы объекта Regular Expression
Свойства объекта Regular Expression
Синтаксис регулярных выражений


Свойство global

Свойство global 		Справочник языка
Версия 3

См. также Применение

Описание
Показывает, используется ли поиск регулярного выражения глобально (g). Только для чтения.
Синтаксис
rgexp.global

Аргумент rgexp является объектом Regular Expression.

Примечание
Свойство global содержит true при глобальном поиске (g) в регулярном выражении и false, если нет.


Свойство global

Свойство global
Применение 		Справочник языка

Объект Regular Expression


Свойство global

Свойство global
См. также 		Справочник языка

Методы объекта Regular Expression
Свойства объекта Regular Expression
Синтаксис регулярных выражений


Свойство ignoreCase

Свойство ignoreCase 		Справочник языка
Версия 3

См. также Применение

Описание
Указывает, применяется ли использование игнорирования регистра (i). Только для чтения.
Синтаксис
rgexp.ignoreCase

Аргумент rgexp является объектом Regular Expression.

Примечание
Свойство ignoreCase содержит значение true, если включено игнорирование регистра (i) при использовании регулярных выражений, и false - если нет.


Свойство ignoreCase

Свойство ignoreCase
Применение 		Справочник языка

Объект Regular Expression


Свойство ignoreCase

Свойство ignoreCase
См. также 		Справочник языка

Методы объекта Regular Expression
Свойства объекта Regular Expression
Синтаксис регулярных выражений


Свойство lastIndex (Regular Expression)

Свойство lastIndex (Regular Expression) 		Справочник языка
Версия 3

См. также Применение

Описание
Определяет индекс начала поиска следующего соответствия.
Синтаксис
rgexp.lastIndex [= index]

Синтаксис свойства lastIndex состоит из частей:

Часть | Описание
rgexp | Требуется. Объект Regular Expression. Может быть именем переменной или строковым литералом.
index | Индекс, с которого начинается следующий поиск.

Примечание
Свойство lastIndex изменяется методом exec, а также методами match, replace и split объекта String.

Установлены следующие правила значений lastIndex:

  • Если lastIndex больше длины строки, то происходит сбой методов test и exec , a lastIndex устанавливается равным нулю.
  • Если lastIndex равен длине строки, регулярное выражение соответствует, если образец равен пустой строке. Иначе происходит сбой соответствия, а lastIndex устанавливается равным нулю.
  • В других случаях lastIndex устанавливается на следующую позицию за самым последним соответствием.


Свойство lastIndex (Regular Expression)

Свойство lastIndex (Regular Expression)
Применение 		Справочник языка

Объект Regular Expression


Свойство lastIndex (Regular Expression)

Свойство lastIndex (Regular Expression)
См. также 		Справочник языка

Метод match
Методы объекта Regular Expression
Свойства объекта Regular Expression
Синтаксис регулярных выражений
Метод replace
Метод split
Объект String


Свойство source

Свойство source 		Справочник языка
Версия 3

См. также Применение

Описание
Содержит текст регулярного выражения. Только для чтения.
Синтаксис
rgexp.source

Параметр rgexp является объектом Regular expression. Он может быть именем переменной или строковым литералом.

Следующий пример иллюстрирует применение свойства source:

function SourceDemo(re, s)
{
  var s1;
  // Проверка строки для регулярного выражения.
  if (re.test(s))
    s1 = " содержит ";
  else
    s1 = " не содержит ";
  // Получение текста регулярного выражения непосредственно.
  return(s + s1 + re.source);
}


Свойство source

Свойство source
Применение 		Справочник языка

Объект Regular Expression


Свойство source

Свойство source
См. также 		Справочник языка

Методы объекта Regular Expression
Свойства объекта Regular Expression
Синтаксис регулярных выражений


Метод test

Метод test 		Справочник языка
Версия 3

См. также Применение

Описание
Проверяет, существует ли регулярное выражение в строке.
Синтаксис
rgexp.test(str)

Синтаксис метода test состоит из частей:

Часть | Описание
rgexp | Требуется. Объект Regular Expression, может быть именем переменной или строковым литералом.
str | Требуется. Проверяемая для поиска строка.

Примечание
Метод test проверяет, существует ли образец в пределах строки; возвращает значение true в случае совпадения, иначе - false.

Объект RegExp не может быть изменен методом test.

Следующий пример иллюстрирует применение метода test:

function TestDemo(re, s)
{
  var s1;
  // Проверка строки на существование регулярного выражения.
  if (re.test(s))
    s1 = " содержит ";
  else
    s1 = " не содержит ";
  // Получение текста регулярного выражения.
  return(s + s1 + re.source);
}


Метод test

Метод test
Применение 		Справочник языка

Объект Regular Expression


Метод test

Метод test
См. также 		Справочник языка

Объект RegExp
Методы объекта Regular Expression
Свойства объекта Regular Expression
Синтаксис регулярных выражений


Свойство rightContext

Свойство rightContext ($') 		Справочник языка
Версия 3

См. также Применение

Описание
Определяет вводную строку после самого последнего соответствия. Только для чтения.
Синтаксис
RegExp.rightContext
Короткая форма синтаксиса
RegExp.$'
Примечание
Значение свойства rightContext изменяется после каждого успешного соответствия.


Свойство rightContext

Свойство rightContext
Применение 		Справочник языка

Объект RegExp


Свойство rightContext

Свойство rightContext
См. также 		Справочник языка

Свойства $1...$9
Свойство index
Свойство input
Свойство lastIndex
Свойство lastMatch
Свойство lastParen
Свойство leftContext
Свойство multiline


Синтаксис регулярных выражений

Синтаксис регулярных выражений 		Справочник языка
Версия 3

См. также Применение

Описание
Специальные символы и последовательности используются при написании регулярных выражений. Приведенная ниже таблица описывает эти символы и содержит небольшие примеры, показывающие как эти символы применяются.

Символ | Описание
\ Пометка следующего символа как специального. /n/ соответствует символу "n". Последовательность /\n/ соответствует символу конца строки.
^ Соответствует началу ввода или строки.
$ Соответствует концу ввода или строки.
* Соответствует нулю или более совпадений символа. /zo*/ соответствует "z" и "zoo."
+ Соответствует одному или более совпадений символа. /zo+/ соответствует "zoo", но не "z."
? Соответствует нулю или одному совпадению символа. /a?ve?/ соответствует "ve" в слове "never."
. Соответствует любому одиночному буквенно-цифровому символу за исключением символа новой строки.
(pattern) | Соответствие pattern, запоминает соответствие. Соответствующая подстрока может быть извлечена из объекта Array с элементами [1]...[n] или объекта RegExp со свойствами $1...$9. Для соответствия на символы круглых скобок "( )", необходимо использовать "\(" и "\)".
x|y | Соответствие либо x, либо y. /z|food?/ соответствует "zoo" или "food."
{n} | n - неотрицательное целое. Соответствие точно n раз. /o{2}/ не соответствует "o" в "Bob", но соответствует первым двум "o" в "foooood".
{n,} | n - неотрицательное целое. Соответствие по крайней мере n раз. /o{2,}/ не соответствует "o" в "Bob", но соответствует всем "o" в "foooood." /o{1,}/ эквивалентно /o+/.
{n,m} | m и n - неотрицательные целые. Соответствие от n до m раз. /o{1,3}/ соответствует первым трем "o" в "fooooood."
[xyz] | Набор символов. Соответствует любому из приведенных символов. /[abc]/ соответствует "a" в "plain."
[^xyz] | Отрицание символов. Соответствует любому невключенному символу. /[^abc]/ соответствует "p" в "plain."
\b | Соответствие в границах слова. /ea*r\b/ соответствует "er" в "never early."
\B | Соответствие не в границах слова. /ea*r\B/ соответствует "ear" в "never early."
\d | Соответствие цифровым символам. Эквивалентно [0-9].
\D | Соответствие нецифровым символам. Эквивалентно [^0-9].
\f | Соответствие символа конца страницы.
\n | Соответствие символа конца строки.
\r | Соответствие символа возврата.
\s | Соответствие пробельным символам. Эквивалентно [ \f\n\r\t\v]
\S | Соответствие непробельным символам. Эквивалентно [^ \f\n\r\t\v]
\t | Соответствие символу горизонтальной табуляции.
\v | Соответствие символу вертикальной табуляции.
\w | Соответствие цифрово-буквенным символам, включая знак подчеркивания. Эквивалентно [A-Za-z0-9_].
\W | Соответствие всем символам, за исключением цифр, букв и знака подчеркивания. Эквивалентно [^A-Za-z0-9_].
\num | Соответствие num, где num - положительное целое число. Ссылка на сохраненные соответствия. \1 соответствует тому, что сохранено в RegExp.$1.
/n/ | Соответствие n, где n - 8-ричное, 16-ричное или 10-ричное ESC-значение. Позволяет включать коды ASCII в регулярные выражения.


Синтаксис регулярных выражений

Синтаксис регулярных выражений
Применение 		Справочник языка

Объект RegExp
Объект Regular Expression


Синтаксис регулярных выражений

Синтаксис регулярных выражений
См. также 		Справочник языка

Объект String


Alphabetic Keyword List

Microsoft® JScript®
Alphabetic Keyword List 		Scripting Run-Time Library Reference
Version Information

Add Method (Dictionary)
Add Method (Folders)
AtEndOfLine Property
AtEndOfStream Property
Attributes Property
AvailableSpace Property
BuildPath Method
Close Method
Column Property
CompareMode Property
Copy Method
CopyFile Method
CopyFolder Method
Count Property
CreateFolder Method
CreateTextFile Method
DateCreated Property
DateLastAccessed Property
DateLastModified Property
Delete Method
DeleteFile Method
DeleteFolder Method
Dictionary Object
Drive Object
Drive Property
DriveExists Method
DriveLetter Property
Drives Collection
Drives Property
DriveType Property
Exists Method
File Object
FileExists Method
Files Collection
Files Property
FileSystem Property
FileSystemObject Object
Folder Object
FolderExists Method
Folders Collection
FreeSpace Property
GetAbsolutePathName Method
GetBaseName Method
GetDrive Method
GetDriveName Method
GetExtensionName Method
GetFile Method
GetFileName Method
GetFolder Method
GetParentFolderName Method
GetSpecialFolder Method
GetTempName Method
IsReady Property
IsRootFolder Property
Item Property
Items Method
Key Property
Keys Method
Line Property
Move Method
MoveFile Method
MoveFolder Method
Name Property
OpenAsTextStream Method
OpenTextFile Method
ParentFolder Property
Path Property
Read Method
ReadAll Method
ReadLine Method
Remove Method
RemoveAll Method
RootFolder Property
SerialNumber Property
ShareName Property
ShortName Property
ShortPath Property
Size Property
Skip Method
SkipLine Method
SubFolders Property
TextStream Object
TotalSize Property
Type Property
VolumeName Property
Write Method
WriteBlankLines Method
WriteLine Method


Feature Information

Microsoft® JScript®
Feature Information 		Scripting Run-Time Library Reference
Version Information

Microsoft Scripting Run-Time Features


Methods

Microsoft® JScript®
Methods 		Scripting Run-Time Library Reference
Version Information

Add Method (Dictionary)
Add Method (Folders)
BuildPath Method
Close Method
Copy Method
CopyFile Method
CopyFolder Method
CreateFolder Method
CreateTextFile Method
Delete Method
DeleteFile Method
DeleteFolder Method
DriveExists Method
Exists Method
FileExists Method
FolderExists Method
GetAbsolutePathName Method
GetBaseName Method
GetDrive Method
GetDriveName Method
GetExtensionName Method
GetFile Method
GetFileName Method
GetFolder Method
GetParentFolderName Method
GetSpecialFolder Method
GetTempName Method
Items Method
Keys Method
Move Method
MoveFile Method
MoveFolder Method
OpenAsTextStream Method
OpenTextFile Method
Read Method
ReadAll Method
ReadLine Method
Remove Method
RemoveAll Method
Skip Method
SkipLine Method
Write Method
WriteBlankLines Method
WriteLine Method


Objects

Microsoft® JScript®
Objects 		Scripting Run-Time Library Reference
Version Information

Dictionary Object
Drive Object
Drives Collection
File Object
Files Collection
FileSystemObject Object
Folder Object
Folders Collection
TextStream Object


Properties

Microsoft® JScript®
Properties 		Scripting Run-Time Library Reference
Version Information

AtEndOfLine Property
AtEndOfStream Property
Attributes Property
AvailableSpace Property
Column Property
CompareMode Property
Count Property
DateCreated Property
DateLastAccessed Property
DateLastModified Property
Drive Property
DriveLetter Property
Drives Property
DriveType Property
Files Property
FileSystem Property
FreeSpace Property
IsReady Property
IsRootFolder Property
Item Property
Key Property
Line Property
Name Property
ParentFolder Property
Path Property
RootFolder Property
SerialNumber Property
ShareName Property
ShortName Property
ShortPath Property
Size Property
SubFolders Property
TotalSize Property
Type Property
VolumeName Property


Инструкция break

Инструкция break
Справочник языка
Версия 1

См. также

Описание
Завершает текущий цикл, при применении label, завершает связанную инструкцию.
Синтаксис
break [label];

Необязательный параметр label параметр определяет метку инструкции, от которой происходит выход.

Примечание
Инструкция break обычно используется с инструкциями switch и while, а также с циклами for, for...in и do...while. В инструкции switch обычно применяется параметр label, но он также может использоваться и в любой другой инструкции, простой или составной (compound).

При выполнении инструкции break происходит выход из текущего цикла или инструкции, исполнение кода сценария после инструкции продолжается.

В следующем примере приведен образец выполнения инструкции break:

function BreakTest(breakpoint)
{
   var i = 0;
   while (i < 100)
   {
   if (i == breakpoint)
     break;
     i++;
   }
   return(i);
}


Инструкция break

Инструкция break
См. также 		Справочник языка

continue Инструкция
do...while Инструкция
for Инструкция
for...in Инструкция
Labeled Инструкция
while Инструкция


Инструкция @cc_on

Инструкция @cc_on 		Справочник языка
Версия 3

См. также

Описание
Обеспечивает поддержку трансляции условного выражения.
Синтаксис
@cc_on
Применение
Инструкция @cc_on обеспечивает поддержку трансляции условного выражения при выполнении сценария.

Строго рекомендуется использование инструкции @cc_on в комментарии, для того, чтобы не поддерживающие трансляцию условных выражений браузеры принимали код в сценарии как правильный синтаксис:

/*@cc_on*/
...
(остальной сценарий)
Инструкции @if и @set вне комментария также обеспечивают трансляцию условного выражения.


Инструкция @cc_on

Инструкция @cc_on
См. также 		Справочник языка

Трансляция условных выражений
Переменные условных выражений
Инструкция @if
Инструкция @set


Инструкции комментария

Инструкции комментария
 Справочник языка
Версия 1

Описание
Комментарии игнорируются обработчиком JScript.
Синтаксис 1
Однострочный комментарий:
// comment
Синтаксис 2
Многострочный комментарий:
/*
comment
*/

Параметр comment является поясняющим текстом, включенным в сценарий.

Синтаксис 3
//@CondStatement
Синтаксис 4
/*@
CondStatement
@*/

Параметр CondStatement - транслирующий код условного выражения, который применяется, если трансляция условного выражения инициирована. Если используется синтаксис 3, не должно быть пробелов между символами "//" и "@".

Примечание
Использование комментариев необходимо для сохранения тех частей сценария, которые не должны выполняться обработчиком JScript. Например, можно использовать комментарии для включения пояснений или замечаний в программе.

При использовании синтаксиса 1, обработчик игнорирует любой текст от начала комментария до конца строки. При применении синтаксиса 2 будет игнорироваться текст, находящийся между начальным и конечным маркерами.

Синтаксисы 3 и 4 используются для поддержки трансляций условных выражений при сохранении совместимости с браузерами, которые не поддерживают эту особенность. Эти браузеры обрабатывают формы комментариев как синтаксиса 1 и 2 соответственно.

Следующий пример иллюстрирует обычное использование инструкции comment:

function myfunction(arg1, arg2)
{
  /* Это- многострочный комментарий,
 содержит столько строк, сколько необходимо */
  var r;
  // Это - однострочный комментарий
  r = arg1 + arg2; // Сложение двух аргументов.
  return(r);
}


Comment Statements

Microsoft® JScript®
Comment Statements
See Also 		Language Reference

Conditional Compilation


Инструкция @if

Инструкция @if
Справочник языка
Версия 3

См. также

Описание
Условно выполняет группу инструкций в зависимости от значения выражения.
Синтаксис
@if (condition1)
text1
[@elif (condition2)
text2]
[@else
text3]
@end

Синтаксис оператора @if состоит из частей:

Часть | Описание
condition1, condition2 | Выражение, которое может быть преобразовано в логическое (Boolean expression).
text1 | Обрабатываемый текст при condition1, равном true.
text2 | Обрабатываемый текст при condition1, равном false, и condition2, равном true.
text3 | Обрабатываемый текст при condition1 и condition2, равных false.

Примечание
При написании инструкции @if нельзя размещать каждое предложение в отдельной строке. Можно использовать несколько предложений в @elif, однако, все предложения @elif должны быть до предложений @else.

Обычно инструкция @if используется для определения текста для выхода. Например:

alert(@if (@_win32) "используется Windows NT или Windows 95" @else "используется Windows 3.1" @end)


Инструкция @if

Инструкция @if
См. также 		Справочник языка

Трансляция условных выражений
Переменные условных выражений
Инструкция @cc_on
Инструкция @set


Инструкция continue

Инструкция continue
 Справочник языка
Версия 1

См. также

Описание
Завершает текущую итерацию, наачинает новую итерацию.
Синтаксис
continue [label];

Необязательный параметр label определяет инструкцию, к которой применяется continue.

Применение
Инструкция continue применяется только внутри циклов while, do...while, for и for...in. При выполнении инструкции continue завершается текущая итерация цикла, и цикл продолжает работу с новой итерации. Результаты выполнения зависят от типа цикла:
  • Циклы while и do...while проверяют свои условия, и если соответствие, выполняются снова.
  • Циклы for выполняют выражение инкремента, и если выражение истинно, выполняются снова.
  • Циклы for...in переходят к следующему полю указанной переменной и выполняют цикл снова.

Следующий пример показывает применение инструкции continue:

function skip5()
{
  var s = "", i=0;
  while (i < 10)
  {
    i++;
    // Пропуск 5
    if (i==5)
    {
      continue;
    }
   s += i;
  }
  return(s);
}


Инструкция continue

Инструкция continue
См. также 		Справочник языка

Инструкция break
Инструкция do...while
Инструкция for
Инструкция for...in
Инструкция Labeled
Инструкция while


Инструкция do...while

Инструкция do...while 		Справочник языка
Версия 3

См. также

Описание
Выполнение блока инструкций один раз, затем цикл продолжает инсполняться, пока условие не станет false.
Синтаксис
do
statement
while (expression) ;

Синтаксис инструкции do...while состоит из частей:

Часть | Описание
statement | Инструкция, исполняемая при expression равном true. Может быть составной (compound statement).
expression | Выражение (expression), преобразованное к булеву значению true или false. При expression равном true, цикл выполняется снова. Если expression равно false, происходит выход из цикла.

Примечание
Значение expression не проверяется до выполнения первой итерации, это гарантирует, что цикл будет выполнен по крайней мере один раз. Условие проверяется после выполнения каждой итерации.

В следующем примере применена инструкция do...while:

function GetDriveList()
{
  var fso, s, n, e, x;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  e = new Enumerator(fso.Drives);
  s = "";
  do
  {
    x = e.item();
    s = s + x.DriveLetter;
    s += " - ";
    if (x.DriveType == 3)
      n = x.ShareName;
    else if (x.IsReady)
      n = x.VolumeName;
    else
      n = "[Drive not ready]";
    s +=  n + "<br>";
    e.moveNext();
  }
  while (!e.atEnd());
  return(s);
}


Инструкция do...while

Инструкция do...while
См. также 		Справочник языка

Инструкция break
Инструкция continue
Инструкция for
Инструкция for...in
Инструкция while
Инструкция Labeled


Инструкция for

Инструкция for
 Справочник языка
Версия 1

См. также

Описание
Выполнение блока инструкций до тех пор, пока указанное условие верно.
Синтаксис
for (initialization; test; increment)
statement

Синтаксис инструкции for состоит из следующих частей:

Часть | Описание
initialization | Выражение (expression). Выполняется однажды - перед выполнением цикла.
test | Логическое выражение (Boolean expression). Если test равно true, выполняется statement. Если test равно false, цикл заканчивается.
increment | Выражение. Выполняется в конце каждой итерации цикла.
statement | Инструкция, выполняемая при test равном true. Может быть составной (compound statement).

Примечание
Обычно цикл for используется тогда, когда он должен быть выполнен определенное количество раз. Это продемонстрировано в следующем примере.

/* i установлено равным 0 в начале и увеличивается на единицу
в конце каждой итерации. Цикл завершается, когда i становится
не менее 10 до итерации цикла. */
var myarray = new Array();
for (i = 0; i < 10; i++)
{
  myarray[i] = i;
}


Инструкция for

Инструкция for
См. также 		Справочник языка

Инструкция for...in
Инструкция while


Инструкция for...in

Инструкция for...in
Справочник языка
Версия 1

См. также

Описание
Выполнение инструкции для каждого элемента объекта или массива.
Синтаксис
for (variable in [object | array])
statement

Синтаксис инструкции for состоит из частей:

Часть | Описание
variable | Переменная (variable), содержащая любой элемент object.
object, array | Объект или массив для выполнения итераций.
statement | Инструкция, исполняемая для каждого элемента object. Может быть составной (compound statement).

Примечание
До каждой итерации variable присваивается значение следующего элемента object. Можно использовать любою из инструкций внутри цикла точно также как элементobject.

При выполнении итераций в объекте, нельзя никаким способом определять или управлять порядком, в котором элементы объекта назначены для variable.

В следующем примере применяется инструкция for ... in:

function ForStmDemo()
{
  // Создание некоторых переменных.
  var a, d, i, s = "";
  d = new ActiveXObject("Scripting.Dictionary");
  // Добавление ключей и значений
  d.Add ("a", "Athens");
  d.Add ("b", "Belgrade");
  d.Add ("c", "Cairo");
  // Размещение элементов в массиве.
  a = (new VBArray(d.Items())).toArray();
  //Выполнение итераций.
  for (i in a)
  {
     s += a[i] + "\n";
  }
  return(s);
}


Инструкция for...in

Инструкция for...in
См. также 		Справочник языка

Инструкция for
Инструкция while


Инструкция function

Инструкция function
 Справочник языка
Версия 1

См. также

Описание
Объявление новой функции.
Сиснтаксис
function functionname([argument1 [, argument2 [, ...argumentn]]])
{
statements
}

Синтаксис инструкции function состоит из частей:

Часть | Описание
functionname | Имя функции.
argument1...argumentn | Список аргументов(параметров), разделенных запятой.
statements | Инструкции JScript.

Примечание
Инструкция function применяется для использования функции в дальнейшем. При вызове функции исполняется содержание блока statements.

Следующий пример иллюстрирует применение инструкции function:

function myMulti(arg1, arg2)
{
  var r;
  r = arg1 * arg2;
  return(r);
}


Инструкция function

Инструкция function
См. также 		Справочник языка

Оператор new


Инструкция if...else

Инструкция if...else
Справочник языка
Версия 1

См. также

Описание
Выполнение группы инструкций в зависимости от значения выражения.
Синтаксис
if (condition)
statement1
[else
statement2]

Синтаксис инструкции if...else состоит из частей:

Часть | Описание
condition | Логическое выражение (Boolean expression). Если condition имеет значение null или undefined, значением condition считается false.
statement1 | Инструкция, выполняемая при condition равном true. Может быть составной (compound statement).
statement2 | Инструкция, выполняемая при condition равном false. Может быть составной.

Примечание
Считается хорошим тоном заключать statement1 и statement2 в фигурные скобки ({}) для ясности и избежания ошибок. В следующем примере инструкция else предназначается для применения с первой инструкцией if, но используется со второй.
if (x == 5)
  if (y == 6)
     z = 17;
else
  z = 20;
Изменение кода следующим способом устраняет любые неопределенности:
if (x == 5)
  {
  if (y == 6)
     z = 17;
  }
else
  z = 20;
Аналогично, при добавлении инструкции к statement1 (если не использованы фигурные скобки), возникает ошибка :
if (x == 5)
  z = 7;
  q = 42;
else
  z = 19;
Подобное является ошибкой, возникающей при использовании более чем одной инструкции между if и else. В этом случае необходимо использовать фигурные скобки.


Инструкция if...else

Инструкция if...else
См. также 		Справочник языка

Оператор условного выражения (?:)


Инструкция Labeled

Инструкция Labeled 		Справочник языка
Версия 3

См. также

Описание
Устанавливает идентификатор метки.
Синтаксис
label :
statement

Синтаксис инструкции метки состоит из частей:

Часть | Описание
label | Уникальный идентификатор, используется для обращения к помеченной инструкции.
statement | Выражение, ассоциируемое с меткой label. Может быть составным (compound statement).

Примечание
Метки используются в инструкциях break и continue для определения инструкций для выхода.

В следующем примере применяются инструкции continue и labeled для создания массива, в котором третий столбец каждой строки имеет неопределенное значение:

function labelDemo()
{
    var a = new Array();
    var i, j, s = "", s1 = "";
  Outer:
    for (i = 0; i < 5; i++)
    {
      Inner:
        for (j = 0; j < 5; j++)
        {
          if (j == 2)
            continue Inner;
          else
            a[i,j] = j + 1;
        }
    }

    for (i = 0;i < 5; i++)
    {
      s = ""
      for (j = 0; j < 5; j++)
      {
        s += a[i,j];
      }
      s1 += s + "\n";
    }
    return(s1)
}


Инструкция Labeled

Инструкция Labeled
См. также 		Справочник языка

Инструкция break
Инструкция continue


Инструкция return

Инструкция return
Справочник языка
Версия 1

См. также

Описание
Выход из текущей функции и возвращение значений этой функции.
Синтаксис

return [expression];

Параметр expression является значением, возвращаемом функцией. Если инструкция опущена, функция не возвращает значение.

Примечание
Инструкция return используется для остановки выполнения функции, возвращая значение expression. Если expression опущено или инструкция return отсутствует в пределах функции, при вызове expression в текущей функции присваивается значение undefined.

В следующем примере иллюстрируется применение инструкции return:

function myMulti(arg1, arg2)
{
  var r;
  r = arg1 * arg2;
  return(r);
}


Инструкция return

Инструкция return
См.также 		Справочник языка

Инструкция function


Инструкция @set

Инструкция @set 		Справочник языка
Версия 3

См. также

Описание
Позволяет создать переменную, используемую в трансляции условных выражений.
Синтаксис
@set @varname = term

Синтаксис инструкции @set состоит из частей:

Часть | Описание
varname | Допустимое в JScript имя переменной. Должно начинаться с символа "@".
term | Ноль или более унарных операторов, сопровождаемых константой, переменной трансляции условных выражений или вставленным выражением.

Примечание
Числовые и логические переменные поддерживаются в трансляции условных выражений. Строки не поддерживаются. Переменные, созданные при использовании @set, обычно применяются в инструкциях трансляции условных выражений, но могут применяться и в другом месте кода JScript.

Примеры объявления переменных:

@set @myvar1 = 12
@set @myvar2 = (@myvar1 * 20)
@set @myvar3 = @_jscript_version


Инструкция @set

Инструкция @set
См. также 		Справочник языка

Трансляция условных выражений
Переменные условных выражений
Инструкция @cc_on
Инструкция @if


Инструкция switch

Инструкция switch 		Справочник языка
Версия 3

См. также

Описание
Выполнение одной или нескольких инструкций, если значение указанного выражения соответствует метке.
Синтаксис
switch (expression) {
case label :
statementlist
case label :
statementlist
...
default :
statementlist
}

Синтаксис инструкции switch состоит из частей:

Часть | Описание
expression | Оцениваемое выражение.
label | Идентификатор соответствия для expression. Если label === expression, немедленно начинается выполнение statementlist после двоеточия и выполняется либо до инструкции break, которая необязательно, либо до конца инструкции switch .
statementlist | Одна и несколько инструкций к выполнению.

Примечание
Используйте предложение default для инструкций, которые будут выполнены, если ни одна из меток не совпадет с expression. Оно должно размещаться в пределах инструкции switch .

Если никакой label не соответствует expression, a default не указан, ни одна инструкция не будет выполнена.

Выполнение происходит следующим образом:

  1. Оценивает expression и label по порядку до нахождения соответствия.
  2. Если значение label равно expression, выполняется statementlist.
    Выполнение продолжается до инструкции break или до окончания инструкции switch. Это делает возможным выполнение инструкций нескольких label при неиспользовании инструкций break.
  3. Если нет ни одного label, равных expression, выполняется вариант default.
  4. Выполняются инструкции, следующие за окончанием всех блоков в инструкции switch.
В следующем примере объект проверяется на тип:
function MyObject() {
...}
switch (object.constructor){
    case Date:
    ...
    case Number:
    ...
    case String:
    ...
    case MyObject:
    ...
    default:
    ...
}


Инструкция switch

Инструкция switch
См. также 		Справочник языка

Инструкция break
Инструкция if...else


Инструкция this

Инструкция this
 Справочник языка
Версия 1

См. также

Описание
Обращается к текущему объекту.
Синтаксис
this.property
Примечание
Ключевое слово this обычно используется в конструкторах (constructors) объектов для обращения к текущему объекту. В следующем примере, this обращается к новосозданному объекту Car, назначая значения трем свойствам:
function Car(color, make, model)
{
  this.color = color;
  this.make = make;
  this.model = model;
}
Для клиентских версий JScript, this обращается к объекту window, если ключевое слово использовано вне какого-либо объекта.


Инструкция this

Инструкция this
См. также 		Справочник языка

Оператор new


throw Statement

Microsoft® JScript®
throw Statement
 Language Reference
Version 5

See Also

Description
Generates an error condition that can be handled by a try...catch statement.
Syntax
throw exception

The exception argument can be any expression.

Remarks
The following example throws an error based on a passed-in value, then illustrates how that error is handled in a hierarchy of try...catch statements:
function TryCatchDemo(x)
{
  try {
    try {
    if (x == 0)					// Evalute argument.
      throw "x equals zero";			// Throw an error.
    else
      throw "x does not equal zero";		// Throw a different error.
    }
    catch(e) {					// Handle "x = 0" errors here.
      if (e == "x equals zero")			// Check for an error handled here.
        return(e + " handled locally.");	// Return object error message.
      else					// Can't handle error here.
        throw e;					// Rethrow the error for next
    }							// error handler.
  }
  catch(e) {                    	   	// Handle other errors here.
    return(e + " handled higher up.");		// Return error message.
  }
}
document.write(TryCatchDemo(0));
document.write(TryCatchDemo(1));


throw Statement

Microsoft® JScript®
throw Statement
See Also 		Language Reference

try...catch Statement


try...catch Statement

Microsoft® JScript®
try...catch Statement
 Language Reference
Version 5

See Also

Description
Implements error handling for JScript.
Syntax
try
tryStatement
catch(exception)
catchStatement

The try...catch statement syntax has these parts:

Part | Description
tryStatement | Statement where an error can occur. Can be a compound statement.
exception | Any variable name. The initial value of exception is the value of the thrown error.
catchStatement | Statement to handle errors occurring in the associated tryStatement. Can be a compound statement.

Remarks
The try...catch statement provides a way to handle some or all of the possible errors that may occur in a given block of code, while still running code. If errors occur that the programmer has not handled, JScript simply provides its normal error message to a user, as if there was no error handling.

The tryStatement argument contains code where an error can occur, while catchStatement contains the code to handle any error that does occur. If an error occurs in the tryStatement, program control is passed to catchStatement for disposition. The initial value of exception is the value of the error that occurred in tryStatement.

If the error cannot be handled in the catchStatement associated with the tryStatement where the error occurred, use the throw statement to propagate, or rethrow, the error to a higher-level error handler.

The following example throws an error based on a passed-in value. It then illustrates how that error is handled in a hierarchy of try...catch statements:

function TryCatchDemo(x)
{
  try {
    try {
    if (x == 0)					// Evalute argument.
      throw "x equals zero";			// Throw an error.
    else
      throw "x does not equal zero";		// Throw a different error.
    }
    catch(e) {					// Handle "x = 0" errors here.
      if (e == "x equals zero")			// Check for an error handled here.
        return(e + " handled locally.");	// Return object error message.
      else					// Can't handle error here.
        throw e;					// Rethrow the error for next
    }							// error handler.
  }
  catch(e) {						// Handle other errors here.
    return(e + " handled higher up.");		// Return error message.
  }
}
document.write(TryCatchDemo(0));
document.write(TryCatchDemo(1));


try...catch Statement

Microsoft® JScript®
try...catch Statement
See Also 		Language Reference

throw Statement


Инструкция var

Инструкция var
 Справочник языка
Версия 1

См. также

Описание
Объявляет новую переменную (variable).
Синтаксис
var variable [ = value ] [, variable2 [ = value2], ...]

Синтаксис инструкции var состоит из частей:

Часть | Описание
variable, variable2 | Объявленное имя переменной.
value, value2 | Присвоенное переменной значение.

Примечание
Инструкция var используется для объявления переменной. Значение переменной может быть присвоено сразу или позже в сценарии. Примеры объявления:
var index;
var name = "Томас Джефферсон";
var answer = 42, counter, numpages = 10;


Инструкция var

Инструкция var
См. также 		Справочник языка

Инструкция function
Оператор new


Инструкция while

Инструкция while
 Справочник языка
Версия 1

См. также

Описание
Выполнение инструкции до тех пор, пока указанное условие не станет false.
Синтаксис
while (expression)
statement

Синтаксис инструкции while состоит из частей:

Часть | Описание
expression Логическое выражение (Boolean expression), проверяемое до начала выполнения каждой итерации цикла. Если expression равно true, цикл выполняется. Если expression равен false, то происходит выход из цикла.
statement | Выполняемая инструкция при expression равном true. Может быть составной (compound statement).

Примечание
Инструкция while проверяет expression до выполнения цикла. Если expression равно false, цикл никогда не будет выполнен.

В следующем примере применяется инструкция while:

function BreakTest(breakpoint)
{
   var i = 0;
   while (i < 100)
   {
   if (i == breakpoint)
     break;
     i++;
   }
   return(i);
}


Инструкция while

Инструкция while
См. также 		Справочник языка

Инструкция break
Инструкция continue
Инструкция do...while
Инструкция for
Инструкция for...in


Инструкция with

Инструкция with
Справочник языка
Версия 1

См. также

Описание
Устанавливает объект по умолчанию.
Синтаксис
with (object)
statement

Синтаксис инструкции with состоит из частей:

Часть | Описание
object

Новый объект по умолчанию.

statement | Инструкция, для которой object установлен по умолчанию. Может быть составной (compound statement).

Примечание
Инструкция with может применяться для сокращения и наглядности кода. В следующем примере необходимо часто указывать "Math":
x = Math.cos(3 * Math.PI) + Math.sin(Math.LN10)
y = Math.tan(14 * Math.E)
Аналогичный код с применением инструкции with более короткий и простой для чтения:
with (Math)
{
  x = cos(3 * PI) + sin (LN10)
  y = tan(14 * E)
}


Инструкция with

Инструкция with
См. также 		Справочник языка

Инструкция this


Метод anchor

Метод anchor 		Справочник языка
Версия 1

Cм. также Применение

Описание

Размещает якорь HTML с атрибутом NAME вокруг текста.
Синтаксис
strVariable.anchor(anchorstring)
"Строковый литерал".anchor(anchorstring)

Параметр anchorstring - значение аттрибута NAME якоря HTML.

Примечание
Вызов метода anchor создает именованный якорь для текста объекта String. Следующий пример демонстрирует, как выполняется метод anchor:
var strVariable = "This is an anchor" ;
strVariable = strVariable.anchor("Anchor1");
Значение strVariable после выполнения последней инструкции равно:
<A NAME="Anchor1">This is an anchor</A>
Никакой проверки, был ли ранее применен этот тэг, не производится.


Метод anchor

Метод anchor
Применение 		Справочник языка

Объект String


Метод anchor

Метод anchor
См. также 		Справочник языка

Метод link
Методы объекта String
Свойства объекта String


Метод big

Метод big 		Справочник языка
Версия 1

См. также Применение

Описание
Обрамляет HTML-тэгом <BIG> текст объекта String.
Синтаксис
strVariable.big( )
"Строковый литерал".big( )
Примечание
Следующий пример иллюстрирует применение метода big:
var strVariable = "This is a string object";
strVariable = strVariable.big( );
Значение strVariable после выполнения последней инструкции равно:
<BIG>This is a string object</BIG>
Никакой проверки, был ли ранее применен тэг или нет, не производится.


Метод big

Метод big
Применение 		Справочник языка

Объект String


Метод big

Метод big
См. также 		Справочник языка

Метод small
Методы объекта String
Свойства объекта String


Метод blink

Метод blink 		Справочник языка
Версия 1

См. также Применение

Описание
Размещает тэг <BLINK> вокруг текста объекта String.
Синтаксис
strVariable.blink( )
"Строковое значение".blink( )
Примечание
Следующий пример демонстрирует работу метода blink:
var strVariable = "This is a string object";
strVariable = strVariable.blink( );
Значение strVariable после последней инструкции:
<BLINK>This is a string object</BLINK>
Никакая проверка на применение разметки текста ранее не производится.

Тэг <BLINK> не поддерживается браузером Microsoft Internet Explorer.


blink Method

blink Method
Applies To 		Language Reference

String Object


Метод blink

Метод blink
См. также 		Справочник языка

Методы объекта String
Свойства объекта String


Метод bold

Метод bold 		Справочник языка
Версия 1

См. также Применение

Описание
Обрамление HTML-тэгом <B> текста объекта String.
Синтаксис
strVariable.bold( )
"Строковая константа".bold( )
Примечание
Следующий пример демонстрирует работу метода bold:
var strVariable = "Это - строка";
strVariable = strVariable.bold( );
Значение strVariable после последней инструкции:
<B>Это - строка</B>
Никакая дополнительная проверка, для того, чтобы определить, применялся ли уже тэг к строке, не производится.


Метод bold

Метод bold
Применение 		Справочник языка

Объект String


Метод bold

Метод bold
См. также 		Справочник языка

Метод italics
Методы объекта String
Свойства объекта String


Метод charAt

Метод charAt 		Справочник языка
Версия 1

См. также Применение

Описание
Поиск символа по указанному индексу.
Синтаксис
strVariable.charAt(index)
"Строковая константа".charAt(index)

Аргумент index отсчитываемый с нуля индекс желаемого символа. Допустимое значение - между 0 и длиной строки, уменьшенной на единицу.

Примечание
Метод charAt возвращает символ, соответствующий символу с указанным индексом. Первый символ имеет индекс 0, второй соответствует индексу 1, и так далее. При значении индекса вне допустимого диапазона возвращает undefined.

В следующем примере применяется метод charAt :

function charAtTest(n)
{
  var str = "ABCDEFGHIJKLMNOPQRSTUVWXYZ";
  var s;
  s = str.charAt(n - 1);
  return(s);
}


Метод charAt

Метод charAt
Применение 		Справочник языка

Объект String


Метод charAt

Метод charAt
См. также 		Справочник языка

Методы объекта String
Свойства объекта String


Метод charCodeAt

Метод charCodeAt 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает код Unicode указанного символа.
Синтаксис
stringObj.charCodeAt(index)

Синтаксис метода charCodeAt состоит из частей:

Часть | Описание
stringObj | Требуется. Объект String или строковая константа.
index | Требуется. Отсчитаваемый с нуля индекс для символа.

Примечание
Если для указанного index нет символа, возвращается значение NaN.

Применение метода charCodeAt приведено в следующем примере:

function charCodeAtTest(n)
{
  var str = "ABCDEFGHIJKLMNOPQRSTUVWXYZ";
  var s;
  s = str.charCodeAt(n - 1);
  // Возвращает код символа в Unicode.
  return(s);
}


Метод charCodeAt

Метод charCodeAt
Применение 		Справочник языка

Объект String


Метод charCodeAt

Метод charCodeAt
См. также 		Справочник языка

Метод fromCharCode
Методы объекта String


Метод concat (String)

Метод concat (String) 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает объект String, содержащий конкатенацию двух указанных строк.
Синтаксис
string1.concat(string2)

Синтаксис метода concat состоит из частей:

Часть | Описание
string1 | Требуется. Объект String или строковый литерал для конкатенации с string2.
string2 | Требуется. Объект String или строковый литерал, конкатенирующийся к концу string1.

Примечание
Результат применения метода concat эквивалентен: result = string1 + string2.

Следующий пример иллюстрирует применение метода concat:

function concatDemo()
{
  var str1 = "ABCDEFGHIJKLM"
  var str2 = "NOPQRSTUVWXYZ";
  var s = str1.concat(str2);
  // Возвращает строку - результат конкатенации.
  return(s);
}


Метод concat (String)

Метод concat (String)
Применение 		Справочник языка

Объект Array
Объект String


Метод concat (String)

Метод concat (String)
См. также 		Справочник языка

Оператор сложения (+)
Метод concat (Array)
Методы объекта String


Метод fixed

Метод fixed 		Справочник языка
Версия 1

См. также Применение

Описание
Обрамляет HTML-тэгами <TT> текст объекта String.
Синтаксис
strVariable.fixed( )
"Строковая константа".fixed( )
Примечание
В следующем примере показана работа метода fixed:
var strVariable = "This is a string object";
strVariable = strVariable.fixed( );
Значение strVariable после выполнения последней инструкции:
<TT>This is a string object</TT>
Никакой проверки, был ли тэг применен к тексту ранее, не производится.


Метод fixed

Метод fixed
Применение 		Справочник языка

Объект String


Метод fixed

Метод fixed
См. также 		Справочник языка

Методы объекта String
Свойства объекта String


Метод fontcolor

Метод fontcolor 		Справочник языка
Версия 1

См. также Применение

Описание
Обрамление тэгом HTML <FONT> с атрибутом COLOR текста объекта String.
Синтаксис
strVariable.fontcolor(colorval)
"Строковая константа".fontcolor(colorval)

Параметр colorval является значением цвета. Может быть представлен в 16-ричной или именной форме.

Примечание
В следующем примере применен метод fontcolor:
var strVariable = "This is a string";
strVariable = strVariable.fontcolor("red");
Значение strVariable после выполнения последней инструкции:
<FONT COLOR="RED">This is a string</FONT>
Разрешенные названия цветов зависят от хоста JScript (браузера, сервера и т.д.) и его версии. Для уточнения следует обратиться к документации.

Никакой проверки, был ли ранее применен тэг, не производится.


Метод fontcolor

Метод fontcolor
Применение 		Справочник языка

Объект String


Метод fontcolor

Метод fontcolor
См. также 		Справочник языка

Метод fontsize
Методы объекта String
Свойства объекта String


Метод fontsize

Метод fontsize 		Справочник языка
Версия 1

См. также Применение

Описание
Обрамляет HTML-тэгом <FONT> с аттрибутом SIZE текст объекта String.
Синтаксис
strVariable.fontsize(intSize)
"Строковый литерал".fontsize(intSize)

Аргумент intSize является целым значением, определяющим размер текста.

Примечание
Следующий пример иллюстрирует применение метода fontsize:
var strVariable = "This is a string";
strVariable = strVariable.fontsize(-1);
Значение strVariable после выполнения последней инструкции равно:
<FONT SIZE="-1">This is a string</FONT>
Допустимые значения intSize зависят от обработчика Microsoft JScript. Для получения дополнительной информации следует обратиться к соответствующей документации.

Никакой проверки, был ли ранее применен тэг или нет, не производится.


Метод fontsize

Метод fontsize
Применение 		Справочник языка

Объект String


Метод fontsize

Метод fontsize
См. также 		Справочник языка

Метод fontcolor
Методы объекта String
Свойства объекта String


Метод fromCharCode

Метод fromCharCode 		Справочник языка
Версия 3

См. также Применение

Описание
Создание строки из кодов символов Unicode.
Синтаксис
String.fromCharCode(code1, code2, ..., coden)

Параметр code - коды символов Unicode, преобразовываемые в строку.

Примечание
Объект String не должен быть создан до вызова fromCharCode.

В следующем примере test содержит строку "plain":

var test = String.fromCharCode(112, 108, 97, 105, 110);


Метод fromCharCode

Метод fromCharCode
Применение 		Справочник языка

Объект String


Метод fromCharCode

Метод fromCharCode
См. также 		Справочник языка

Метод fromCharCode
Методы объекта String


Метод indexOf

Метод indexOf 		Справочник языка
Версия 1

См. также Применение

Описание
Поиск первого месторасположения подстроки в пределах объекта String.
Синтаксис
strVariable.indexOf(substring, startindex)
"Строковая константа".indexOf(substring, startindex)

Синтаксис метода indexOf состоит из частей:

Часть | Описание
substring | Подстрока для поиска в пределах объектаString.
startindex | Необязательное целое значение, указывающее индекс начала поиска в пределах объекта String. Если опущено, поиск начинается с начала строки.

Примечание
Метод indexOf возвращает целое число, указывающее на начало подстроки в пределах объекта String. Если строка не найдена, возвращается значение -1.

Если startindex - отрицательное число, startindex обрабатывается как нуль. Если значение превышает наибольший допустимый индекс, то обработка происходит по наибольшему допустимому значению индекса.

Поиск происходит слева направо.

Применение метода indexOf приведено в следующем примере:

function IndexDemo(str2)
{
  var str1 = "BABEBIBOBUBABEBIBOBU"
  var s = str1.indexOf(str2);
  return(s);
}


Метод indexOf

Метод indexOf
Применение 		Справочник языка

Объект String


Метод indexOf

Метод indexOf
См. также 		Справочник языка

Метод lastIndexOf
Методы объекта String
Свойства объекта String


Метод italics

Метод italics 		Справочник языка
Версия 1

См. также Применение

Описание
Размещение HTML <I> тэга вокруг текста объекта String.
Синтаксис
strVariable.italics( )
"Строковая константа".italics( )
Примечание
В следующем примере иллюстрируется результат работы метода italics:
var strVariable = "This is a string";
strVariable = strVariable.italics( );
Значение strVariable после выполнения последней инструкции равно:
<I>This is a string</I>
Никакой проверки, был ли тэг применен ранее или нет, не производится.


Метод italics

Метод italics
Применение 		Справочник языка

Объект String


Метод italics

Метод italics
См. также 		Справочник языка

Метод bold
Методы объекта String
Свойства объекта String


Метод lastIndexOf

Метод lastIndexOf 		Справочник языка
Версия 1

См. также Применение

Описание
Поиск последнего местонахождения подстроки в пределах объекта String.
Синтаксис
strVariable.lastIndexOf(substring, startindex)
"Строковая константа".lastIndexOf(substring, startindex)

Синтаксис метода lastIndexOf состоит из частей:

Часть | Описание
substring | Строка для поиска в пределах объекта String .
startindex | Необязательное целое число, указывающее на индекс для начала поиска в пределах объекта String. Если опущено, то поиск начинается с конца строки.

Примечание
Метод lastIndexOf возвращает целое значение, указывающее на начало подстроки в пределах String. Если подстрока не найдена, возвращается значение -1.

Если startindex - отрицательное число, startindex обрабатывается как нуль. Если оно больше наибольшего допустимого значение, то обрабатывается как наибольшее допустимое.

Поиск происходит справа налево.

В следующем примере применен метод lastIndexOf:

function lastIndexDemo(str2)
{
  var str1 = "BABEBIBOBUBABEBIBOBU"
  var s = str1.lastIndexOf(str2);
  return(s);
}


Метод lastIndexOf

Метод lastIndexOf
Применение 		Справочник языка

Объект String


lastIndexOf Method

Microsoft® JScript®
lastIndexOf Method
See Also 		Language Reference

indexOf Method
String Object Methods
String Object Properties


Свойства length (строка)

Свойства length (строка) 		Справочник языка
Версия 1

См. также Применение

Описание
Содержит длину объекта String.
Синтаксис
strVariable.length
"Строковый литерал".length
Примечание
Свойство length содержит целое число, сообщающее о количестве символов объекта String. Первый символ объекта String имеет индекс 0, последний равен (length - 1).


Свойства length (строка)

Свойства length (строка)
См. также 		Справочник языка

Свойство length (массив)
Свойство length (функция)
Методы объекта String
Свойства объекта String


Метод link

Метод link 		Справочник языка
Версия 1

См. также Применение

Описание
Обрамление якорем HTML с атрибутом HREF текста\autoname.htm объекта String.
Синтаксис
strVariable.link(linkstring)
"Строковая константа".link(linkstring)

Аргумент linkstring - текст, обрамляемый атрибутом HREF якоря\autoname.htm HTML.

Примечание
Вызов метода link создает гиперссылку объекта String. В следующем примере это продемонстрировано:
var strVariable = "Это - гиперссылка";
strVariable = strVariable.link("http://www.microsoft.com");
Значение strVariable после выполнения последней инструкции равно:
<A HREF="http://www.microsoft.com">Это - гиперссылка</A>
Никакой проверки, был ли этот тэг применен ранее или нет, не производится.


Метод link

Метод link
Применение 		Справочник языка

Объект String


Метод link

Метод link
См. также 		Справочник языка

Метод anchor
Методы объекта String
Свойства объекта String


Метод match

Метод match 		Справочник языка
Версия 3

См. также Применение

Описание
Выполняет поиск в строке, используя объект Regular Expression.
Синтаксис
stringObj.match(rgExp)

Синтаксис метода match состоит из частей:

Часть | Описание
stringObj | Требуется. Объект String или строковый литерал, в котором выполняется поиск.
rgExp | Требуется. Регулярное выражение для поиска.

Примечание
Метод match ведет себя подобно методу exec, возвращая массив значений. Нулевой элемент массива содержит последние соответствующие символы. Элементы 1 ... n содержат соответствия к любым вставленным подстрокам в регулярном выражении.

Метод обновляет содержание объекта RegExp.

Следующий пример иллюстрирует применение метода match:

function MatchDemo()
{
  var r, re;
  var s = "The quick brown fox jumped over the lazy yellow dog.";
  re = /fox/i;
  r = s.match(re);
  return(r);
}


Метод match

Метод match
Применение 		Справочник языка

Объект String


Свойство match

Свойство match
См. также 		Справочник языка

exec Method
RegExp Object
replace Method
search Method
String Object Methods
test Method


Метод replace

Метод replace 		Справочник языка
Версия 3

См. также Применение

Описание
Заменяет текст, найденный регулярным выражением другим текстом.
Синтаксис
stringObj.replace(rgExp, replaceText)

Синтаксис метода replace состоит из частей:

Часть | Описание
stringObj | Требуется. Объект String или константа, где производится поиск по образцу. Данный объект методом replace не изменяется.
rgExp | Требуется. Объект Regular Expression, описывающий поиск.
replaceText | Требуется. Объект String или строковый литерал, на который изменяются все найденные соответствия rgExp в stringObj.

Примечание
Результатом использования метода replace является копирование stringObj после всех сделанных замен.

Метод обновляет содержимое объекта RegExp.

Следующий пример иллюстрирует применение метода replace:

function ReplaceDemo()
{
  var r, re;
  var s = "The quick brown fox jumped over the lazy yellow dog.";
  re = /fox/i;
  r = s.replace(re, "pig");
  return(r);
}


Метод replace

Метод replace
Применение 		Справочник языка

Объект String


Метод replace

Метод replace
См. также 		Справочник языка

Метод exec
Метод match
Объект RegExp
Метод search
Методы объекта String
Метод test


Метод search

Метод search 		Справочник языка
Версия 3

См. также Применение

Описание
Поиск в строке соответствия регулярного выражения.
Синтаксис
stringObj.search(rgexp)

Синтаксис метода search состоит из частей:

Часть | Описание
stringObj | Требуется. Объект String или константа для поиска.
rgexp | Требуется. Объект Regular Expression, содержащий образец для поиска.

Примечание
Метод search указывает на присутствие или отсутствие соответствия. Если соответствие найдено, то метод search возвращает целое число, указывающее на начало соответствия. Если нет, то возвращаемое значение равно -1.

Метод search используется в следующем примере:

function SearchDemo()
{
  var r, re;
  var s = "The quick brown fox jumped over the lazy yellow dog.";
  re = /fox/i;
  r = s.search(re);
  return(r);
}


Метод search

Метод search
Применение 		Справочник языка

Объект String


Метод search

Метод search
См. также 		Справочник языка

Метод exec
Метод match
Метод replace
Методы объекта String
Метод test


Метод slice (String)

Метод slice (String) 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает секцию строки.
Синтаксис
stringObj.slice(start, [end])

Синтаксис метода slice состоит из частей:

Часть | Описание
stringObj | Требуется. Объект String или строковая константа.
start | Требуется. Отсчитываемый с нуля индекс начала указанной части stringObj.
end | Необязательно. Отсчитываемый с нуля индекс конца указанной части stringObj.

Примечание
Метод slice возвращает объект String, содержащий указанную секцию stringObj.

Если значение end отрицательно, то указывает на смещение с конца stringObj. Если параметр end опущен, извлечение продолжается до конца stringObj.

В следующем примере два способа применения метода slice возвращают один и тот же результат:

str1.slice(0)
str2.slice(0,-1)


Метод slice (String)

Метод slice (String)
Применение 		Справочник языка

Объект Array
Объект String


Метод slice (String)

Метод slice (String)
См. также 		Справочник языка

Метод slice (Array)
Методы объекта String


Метод small

Метод small 		Справочник языка
Версия 1

См. также Применение

Описание
Обрамляет объект String HTML-тэгом <SMALL>.
Синтаксис
strVariable.small( )
"Строковый литерал".small( )
Примечание
Следующий пример демонстрирует работу метода small:
var strVariable = "This is a string";
strVariable = strVariable.small( );
Значение strVariable после выполнения последней инструкции:
<SMALL>This is a string</SMALL>
Никакой проверки, применялся уже тэг или нет, не производится.


Метод small

Метод small
Применение 		Справочник языка

Объект String


Метод small

Метод small
См. также 		Справочник языка

Метод big
Методы объекта String
Свойства объекта String


Метод split

Метод split 		Справочник языка
Версия 3

См. также Применение

Description
Разбивает объект String по разделителю и возвращает массив строк.
Синтаксис
stringObj.split(str)

Синтаксис метода split состоит из частей:

Часть | Описание
stringObj | Требуется. Объект String или строковая константа для разбиения. Данный объект не изменяется методом split.
str | Требуется. Строка или объект Regular Expression для разделения stringObj.

Применение
Результатом метода split является массив подстрок разбитой строки, где str - разделитель stingObj.

В следующем примере используется метод split:

function SplitDemo()
{
  var s, ss;
  var s = "The quick brown fox jumped over the lazy yellow dog.";
  // Разбиение по каждому символу пробела
  ss = s.split(" ");
  return(ss);
}


Метод split

Метод split
См. также 		Справочник языка

Метод concat
Объект RegExp
Синтаксис регулярных выражений
Методы объекта String


Метод strike

Метод strike 		Справочник языка
Версия 1

См. также Применение

Описание
Обрамляет HTML-тэгом <STRIKE> текст объекта String.
Синтаксис
strVariable.strike( )
"Строковый литерал".strike( )
Примечание
Следующий пример демонстрирует применение метода strike:
var strVariable = "This is a string object";
strVariable = strVariable.strike( );
Значение strVariable после последней инструкции равно:
<STRIKE>This is a string object</STRIKE>
Никакой проверки, был ли тэг применен ранее или нет, не производится.


Метод strike

Метод strike
Применение 		Справочник языка

Объект String


Метод strike

Метод strike
См. также 		Справочник языка

Методы объекта String
Свойства объекта String


Метод sub

Метод sub 		Справочник языка
Версия 1

См. также Применение

Описание
Обрамляет HTML-тэгом <SUB> текст объекта String.
Синтаксис
strVariable.sub( )
"Строковый литерал".sub( )
Примечание
Следующий пример иллюстрирует применение метода sub:
var strVariable = "This is a string object"
strVariable = strVariable.sub( );
Значение strVariable после выполнения последней инструкции равно:
<SUB>This is a string object</SUB>
Никакой проверки, был ли тэг применен ранее или нет, не производится.


Метод sub

Метод sub
Применение 		Справочник языка

Объект String


Метод sub

Метод sub
См. также 		Справочник языка

Методы объекта String
Свойства объекта String
Метод sup


Метод substr

Метод substr 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает подстроку, начинающуюся с указанного месторасположения и имеющую указанную длину.
Синтаксис
stringvar.substr(start [, length ])

Синтаксис метод substr состоит из частей:

Часть | Описание
stringvar | Требуется. Строковая константа или объект String, из которых извлекается подстрока.
start | Требуется. Начальное положение в строке. Отсчет индекса начинается с нуля.
length | Необязательно. Количество символов в возвращаемой строке.

Применение
Если length - нуль или отрицательно, то возвращается пустая строка. Если параметр length не указан, подстрока продолжается до конца stringvar.

В следующем примере применен метод substr:

function SubstrDemo()
{
  var s, ss;
  var s = "The quick brown fox jumped over the lazy yellow dog.";
  ss = s.substr(16, 3);
  // Возвращает "fox"
  return(ss);
}


Метод substr

Метод substr
Применение 		Справочник языка

Объект String


Метод substr

Метод substr
См. также 		Справочник языка

Методы объекта String
Свойства объекта String
Метод substring


Метод substring

Метод substring 		Справочник языка
Версия 1

См. также Применение

Описание
Возвращает подстроку объекта String, расположенную в указанных пределах.
Синтаксис
strVariable.substring(start, end)
"Строковая константа".substring(start, end)

Синтаксис метода substring состоит из частей:

Часть | Описание
start | Индекс начала подстроки, отсчитывается с нуля.
end | Индекс конца подстроки, отсчитывается с нуля.

Примечание
Метод substring возвращает объект String, включающий полученную подстроку.

Метод substring применяет наименьшее значение start и end как точку отсчета. Например, strvar.substring(0, 3) и strvar.substring(3, 0) возвращают один и тот же результат.

Единственное исключение - отрицательный параметр. Если параметр меньше нуля, он будет обработан как нуль.

Длина подстроки равна модулю разницы start и end. Например, длина подстрок strvar.substring(0, 3) и strvar.substring(3, 0) равна 3.

Наконец, start и end могут быть строками. При этом строки, если возможно, преобразовываются в целые значения. Если нет, то значение параметра обрабатываются как нуль.

В следующем примере применяется метод substring:

function SubstringDemo()
{
  var s, ss;
  var s = "The quick brown fox jumped over the lazy yellow dog.";
  ss = s.substring(16, 19);
  return(ss);
}


Метод substring

Метод substring
Применение 		Справочник языка

Объект String


Метод substring

Метод substring
См. также 		Справочник языка

Методы объекта String
Свойства объектаString
Метод substr


Метод sup

Метод sup 		Справочник языка
Версия 1

См. также Применение

Описание
Обрамляет HTML-тэгом <SUP> текст объекта String.
Синтаксис
strVariable.sup( )
"Строковый литерал".sup( )
Примечание
Следующий пример иллюстрирует применение метода sup:
var strVariable = "This is a string object";
strVariable = strVariable.sup( );
Значение strVariable после выполнения последней инструкции равно:
<SUP>This is a string object</SUP>
Никакой проверки, был ли тэг применен ранее или нет, не производится.


Метод sup

Метод sup
Применение 		Справочник языка

Объект String


Метод sup

Метод sup
См. также 		Справочник языка

Методы объекта String
Свойства объекта String
Метод sub


Метод toLowerCase

Метод toLowerCase 		Справочник языка
Версия 1

См. также Применение

Описание
Перевод текста объекта String в нижний регистр.
Синтаксис
strVariable.toLowerCase( )
"Строковая константа".toLowerCase( )
Примечание
Метод toLowerCase не меняет неалфавитные символы.

В следующем примере применяется метод toLowerCase:

var strVariable = "This is a STRING object";
strVariable = strVariable.toLowerCase( );
Значение strVariable после выполнения последней инструкции:
this is a string object


Метод toLowerCase

Метод toLowerCase
Применение 		Справочник языка

Объект String


Метод toLowerCase

Метод toLowerCase
См. также 		Справочник языка

Методы объекта String
Свойства объекта String
Метод toUpperCase


Метод toUpperCase

Метод toUpperCase 		Справочник языка
Версия 1

См. также Применение

Описание
Перевод текста объекта String в верхний регистр.
Синтаксис
strVariable.toUpperCase( )
"Строковая константа".toUpperCase( )
Применение
Метод toUpperCase не действует на неалфавитные символы.

В следующем примере применяется метод toUpperCase:

var strVariable = "This is a STRING object";
strVariable = strVariable.toUpperCase( );
Значение strVariable после выполнения последней инструкции:
THIS IS A STRING OBJECT


Метод toUpperCase

Метод toUpperCase
Применение 		Справочник языка

Объект String


Метод toUpperCase

Метод toUpperCase
См. также 		Справочник языка

Методы объекта String
Свойства объекта String
Метод toLowerCase


Свойство AtEndOfLine

Свойство AtEndOfLine 		Справочник языка
Версия 2

См. также Применение

Описание
Возвращает значение true, если указатель находится непосредственно перед символом конца строки файле TextStream, и значение false в иных случаях. Только для чтения.
Синтаксис
object.AtEndOfLine

Аргумент object всегда является именем объекта TextStream.

Примечание
Свойство AtEndOfLine применимо только к файлам TextStream, открытых для чтения; в других случаях возникает ошибка.

Следующий пример иллюстрирует применение свойства AtEndOfLine:

function GetALine(filespec)
{
  var fso, a, s, ForReading;
  ForReading = 1, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  a = fso.OpenTextFile(filespec, ForReading, false);
  while (!a.AtEndOfLine)
  {
    s += a.Read(1);
  }
  a.Close( );
  return(s);
}


Свойство AtEndOfLine

Свойство AtEndOfLine
Применение 		Справочник языка

Объект TextStream


Свойство AtEndOfLine

Свойство AtEndOfLine
См. также 		Справочник языка

Свойство AtEndOfStream


Свойство AtEndOfStream

Свойство AtEndOfStream 		Справочник языка
Версия 2

См. также Применение

Описание
Возвращает true, если указатель находится в конце файла TextStream, и false в остальных случаях. Только для чтения.
Синтаксис
object.AtEndOfStream

Параметр object всегда является именем объекта TextStream.

Примечание
Свойство AtEndOfStream применимо только к файлам TextStream, открытых для чтения, в иных случаях возникает ошибка.

Следующий пример иллюстрирует применение свойства AtEndOfStream:

function GetALine(filespec)
{
  var fso, f, s, ForReading;
  ForReading = 1, s = "";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile(filespec, ForReading, false);
  while (!f.AtEndOfStream)
    s += f.ReadLine( );
  f.Close( );
  return(s);
}


Свойство AtEndOfStream

Свойство AtEndOfStream
Применение 		Справочник языка

Объект TextStream


Свойство AtEndOfStream

Свойство AtEndOfStream
См. также 		Справочник языка

Свойство AtEndOfLine


Метод Close

Метод Close 		Справочник языка
Версия 2

См. также Применение

Описание
Закрывает открытый TextStream-файл.

Синтаксис
object.Close( );

Параметр object является именем объекта TextStream.

Применение
В следующем примере применен метод Close:

var fso;
fso = new ActiveXObject("Scripting.FileSystemObject");
a = fso.CreateTextFile("c:\\testfile.txt", true);
a.WriteLine("This is a test.");
a.Close();


Метод Close

Метод Close
Применение 		Справочник языка

Объект TextStream


Метод Close

Метод Close
Применение 		Справочник языка

Метод Read
Метод Write


Свойство Column

Свойство Column 		Справочник языка
Версия 2

См. также Применение

Описание
Свойство (только для чтения), возвращающее номер столбца текущего символа в файле TextStream.

Синтаксис
object.Column

Параметр object всегда является именем объекта TextStream.

Примечание
После записи символа новой строки, но перед записью других символов, значение Column равно 1.

Следующий пример иллюстрирует применение свойства Column:

function GetColumn()
{
  var fso, f, m;
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true);
  f.Write("Привет, Народ!");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  m = f.ReadLine();
  return(f.Column);
}


Свойство Column

Свойство Column
Применение 		Справочник языка

Объект TextStream


Свойство Column

Свойство Column
См. также 		Справочник языка

Свойство Line


Свойство Line

Свойство Line 		Справочник языка
Версия 2

См. также Применение

Описание
Свойство (только для чтения), возвращающее номер текущей строки в TextStream-файле.

Синтаксис
object.Line

Значение object всегда является именем объекта TextStream.

Remarks
После первоначального открытия файла и до записи в него, Line равно 1.

Следующий пример иллюстрирует применение свойства Line:

function GetLine()
{
  var fso, f, r
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject")
  f = fso.OpenTextFile("c:\\textfile.txt", ForWriting, true)
  f.WriteLine("Hello world!");
  f.WriteLine("JScript is fun");
  f.Close();
  f = fso.OpenTextFile("c:\\textfile.txt", ForReading);
  r =  f.ReadAll();
  return(f.Line);
}


Свойство Line

Свойство Line
Применение 		Справочник языка

Объект TextStream


Свойство Line

Свойство Line
См. также 		Справочник языка

Свойство Column


Метод Read

Метод Read 		Справочник языка
Версия 2

См. также Применение

Описание
Читает указанное количество символов из файла TextStream и возвращает результирующую строку.

Синтаксис
object.Read(characters)

Синтаксис метода Read состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта TextStream .
characters | Требуется. Количество символов для чтения из файла.

Следующий пример иллюстрирует применение метода Read для чтения шести символов из файла и возвращения результирующей строки:

function GetHeader()
{
  var fso, f;
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true);
  f.Write("Header");
  f.Write("1234567890987654321");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  return(f.Read(6));
}


Метод Read

Метод Read
Применение 		Справочник языка

Объект TextStream


Метод ReadAll

Метод ReadAll 		Справочник языка
Версия 2

См. также Применение

Описание
Читает файл TextStream полностью и возвращает результирующую строку.

Синтаксис
object.ReadAll( );

Аргумент object всегда является именем объекта TextStream.

Примечание
При применении метода ReadAll для больших файлов возможна потеря ресурсов памяти. Другой способ чтения файла - построчное чтение файла.

Следующий пример иллюстрирует применение метода ReadAll:

function GetEverything()
{
  var fso, f;
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true);
  f.Write("Header");
  f.Write("1234567890987654321");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  return(f.ReadAll());
}


Метод ReadAll

Метод ReadAll
Применение 		Справочник языка

Объект TextStream


Метод ReadAll

Метод ReadAll
См. также 		Справочник языка

Метод Read
Метод ReadLine
Метод Skip
Метод SkipLine


Метод Read

Метод Read
См. также 		Справочник языка

Метод ReadAll
Метод ReadLine
Метод Skip
Метод SkipLine


Метод ReadLine

Метод ReadLine 		Справочник языка
Версия 2

См. также Применение

Описание
Читает полностью строку (но не включая символ новой строки) из файла TextStream и возвращает результирующую строку.

Синтаксис
object.ReadLine( )

Аргумент object всегда является именем объекта TextStream.

Примечание
Следующий пример иллюстрирует применение свойства Line:

function GetLine()
{
  var fso, f, r;
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true);
  f.WriteLine("Привет, народ!");
  f.WriteLine("JScript - это круто!");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  r =  f.ReadLine();
  return(r);
}


Метод ReadLine

Метод ReadLine
Применение 		Справочник языка

Объект TextStream


Метод ReadLine

Метод ReadLine
См. также 		Справочник языка

Метод Read
Метод ReadAll
Метод Skip
Метод SkipLine


Метод Skip

Метод Skip 		Справочник языка
Версия 2

См. также Применение

Описание
Пропускает указанное количество символов при чтении файла TextStream .

Синтаксис
object.Skip(characters)

Синтаксис метода Skip состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта TextStream .
characters | Требуется. Количество символов для пропуска при чтении файла.

Примечание
Пропущенные символы теряются.

Следующий пример иллюстрирует применение метода Skip:

function SkipDemo()
{
  var fso, f, r;
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject")
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true);
  f.WriteLine("Привет, народ!");
  f.WriteLine("JScript - это круто!");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  f.Skip(6);
  r = f.ReadLine();
  return(r);
}


Метод Skip

Метод Skip
Применение 		Справочник языка

Объект TextStream


Метод Skip

Метод Skip
См. также 		Справочник языка

Метод Close
Метод Read
Метод ReadAll
Метод ReadLine
Метод SkipLine
Метод Write
Метод WriteLine
Метод WriteBlankLines


Метод SkipLine

Метод SkipLine 		Справочник языка
Версия 2

См. также Применение

Описание
Пропускает следующую строку при чтении файла TextStream.

Синтаксис
object.SkipLine( )

Параметр object всегда является именем объекта TextStream.

Примечание
Следующий пример иллюстрирует применение метода SkipLine:

function SkipLineDemo()
{
  var fso, f, r
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject")
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true)
  f.WriteLine("Привет, Мир!");
  f.WriteLine("JScript - это круто!");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  f.SkipLine();
  r = f.ReadLine();
  return(r);
}


Метод SkipLine

Метод SkipLine
Применение 		Справочник языка

Объект TextStream


Метод SkipLine

Метод SkipLine
См. также 		Справочник языка

Метод Read
Метод ReadAll
Метод ReadLine
Метод Skip


Метод Write

Метод Write 		Справочник языка
Версия 2

См. также Применение

Описание
Запись указанной строки в файл TextStream.

Синтаксис
object.Write(string)

Синтаксис метода Write состоит из частей:

Часть | Описание
object | Требуется. Имя объекта TextStream .
string | Требуется. Текст, записываемый в файл.

Примечание
Указанная строка записывается в файл без без разделения на строки. Необходимо использовать метод WriteLine для записи символа конца строки.

Следующий пример демонстрирует применение метода Write:

function WriteDemo()
{
  var fso, f, r
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject")
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true)
  f.Write("Hello world!");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  r = f.ReadLine();
  return(r);
}


Метод Write

Метод Write
Применение 		Справочник языка

Объект TextStream


Метод WriteBlankLines

Метод WriteBlankLines 		Справочник языка
Версия 2

См. также Применение

Описание
Пишет указанное количество символов новой строки в файл TextStream.

Синтаксис
object.WriteBlankLines(lines)

Синтаксис метода WriteBlankLines состоит из частей:

Часть | Описание
object | Требуется. Всегда имя объекта TextStream.
lines | Требуется. Количество символов новой строки.

Примечание
В следующем примере иллюстрируется применение метода WriteBlankLines:

function WriteBlanksDemo()
{
  var fso, f, r;
  var ForReading = 1, ForWriting = 2;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f = fso.OpenTextFile("c:\\testfile.txt", ForWriting, true);
  f.Write("Привет, Мир!");
  f.WriteBlankLines(2);
  f.Write("JScript - это круто!");
  f.Close();
  f = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  r = f.ReadAll();
  return(r);
}


Метод WriteBlankLines

Метод WriteBlankLines
Применение 		Справочник языка

Объект TextStream


Метод WriteBlankLines

Метод WriteBlankLines
См. также 		Справочник языка

Метод Write
Метод WriteLine


Метод Write

Метод Write
См. также 		Справочник языка

Метод WriteBlankLines
Метод WriteLine


Метод WriteLine

Метод WriteLine 		Справочник языка
Версия 2

См. также Применение

Описание
Записывает указанную строку и символ новой строки в файл TextStream.

Синтаксис
object.WriteLine([string])

Синтаксис метода WriteLine состоит из частей:

Часть | Описание
object | Требуется. Всегда является именем объекта TextStream .
string | Необязательно. Текст для записи в файл. Если опущен, в файл записывается только символ новой строки.

Примечание
Следующий пример иллюстрирует применение метода WriteLine:

var fso, f;
fso = new ActiveXObject("Scripting.FileSystemObject");
f = fso.CreateTextFile("c:\\testfile.txt", true);
f.WriteLine("Это тест. Только тест.");
f.Close();


Метод WriteLine

Метод WriteLine
Применение 		Справочник языка

Объект TextStream


Метод WriteLine

Метод WriteLine
См. также 		Справочник языка

Метод Write
Метод WriteBlankLines


Microsoft® JScript Language Reference

Microsoft® JScript®
JScript Language Reference 		JScript Tutorial
Version Information

Feature
Information
Alphabetic
Keyword List
Errors
Functions
Methods
Objects
Operators
Properties
Statements
© 2000 Microsoft Corporation. All rights reserved.


JScript Tutorial

JScript Tutorial
 JScript Language Reference

What Is JScript?
JScript Basics
Writing JScript Code
JScript Variables
JScript Data Types
JScript Operators
Controlling Program Flow
JScript Functions
JScript Objects
JScript Reserved Keywords
Advanced JScript


Преобразование типов данных

Преобразование типов 		Справочник языка
Версия 3

Описание
В Microsoft JScript в зависимости от ситуации преобразование типов происходит автоматически.

В языке имеется шесть типов данных. Значения типов приведены ниже:

undefined
Неопределенный тип принимает только одно значение - undefined.
Null
Этот тип так же имеет одно значение - null.
Boolean
В логическом (булевом) типе два возможных значения: true и false.
String
Строки определяются двойными или одинарными кавычками и состоят из нуля или более символов Unicode. Пустая строка ("") символов не содержит, ее длина равно нулю.
Number
Числа могут быть целые и с плавающей точкой(запятой) согласно спецификации IEEE 754. Есть несколько особых числовых значений:
  • NaN, "not a Number" - НеЧисло
  • Плюс-бесконечность
  • Минус-бесконечность
  • Положительный нуль
  • Отрицательный нуль
Object
Объект, определение которого содержит свойства и методы.
Следующая таблица показывает значения результаты преобразований одного типа данных в другой:

Выходной тип данных | Входной тип данных
Undefined | Null | Boolean | Number | String | Object
boolean false false - false при +0, -0 или NaN; иначе true false при пустой строке (""); иначе true true
number NaN NaN 1 при true; +0 при false - Если нельзя преобразовать в число, возвращает NaN Объект Number
string "undefined" "null" "true" or "false" Абсолютное значение числа со знаком, за исключением случаев:
  • NaN возвращает "NaN"
  • +0 or -0 возвращает "0"
  • + бесконечность возвращает "Infinity"
  • - бесконечность возвращает "-Infinity"
            • - Объект String
    object Ошибка run-time error Ошибка run-time error Новый объект Boolean Новый объект Number Новый объект String -


Метод dimensions

Метод dimensions 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает значение размерности массива VBArray.
Синтаксис
array.dimensions( )

Параметр array является объектом VBArray.

Примечание
Метод dimensions обеспечивает возможность вывода размерности указанного VBArray.

Следующий пример состоит из трех частей. Первая часть - код на VBScript создает safe-массив Visual Basic. Вторая часть - код на JScript определяет число размерностей этого массива и определяет верхнюю границу размерности. Обе эти части расположены в секции <HEAD> HTML-страницы. Третья часть кода на JScript находится в секции <BODY> и вызывает первые две части.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function CreateVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      k = k + 1
    Next
  Next
  CreateVBArray = a
End Function
-->
</SCRIPT>

<SCRIPT LANGUAGE="JScript">
<!--
function VBArrayTest(vba)
{
  var i, s;
  var a = new VBArray(vba);
  for (i = 1; i <= a.dimensions(); i++)
  {
    s = "Верхняя граница размерности ";
    s += i + " равна ";
    s += a.ubound(i)+ ".<BR>";
  }
  return(s);
}
-->
</SCRIPT>
</HEAD>

<BODY>
<SCRIPT language="jscript">
  document.write(VBArrayTest(CreateVBArray()));
</SCRIPT>
</BODY>


Метод dimensions

Метод dimensions
Применение 		Справочник языка

Объект VBArray


Метод dimensions

Метод dimensions
См. также 		Справочник языка

Метод getItem
Метод lbound
Метод toArray
Метод ubound


Метод getItem

Метод getItem 		Справочник языка
Версия 3

См. также Применение

Описание
Отыскивает элемент в указанном объекте.
Синтаксис
safeArray.getItem(dimension1[, dimension2, ...], dimensionn)

Синтаксис метода getItem состоит из частей:

Часть | Описание
safeArray | Требуется. Объект VBArray.
dimension1, ..., dimensionn | Указание точного размещение искомого элемента VBArray; n является размерностью VBArray.

Следующий пример состоит из трех частей. Первая часть на VBScript создает safe-массив Visual Basic. Вторая часть на JScript итерирует этот массив и печатает содержимое каждого элемента. Обе части располагаются в секции <HEAD> HTML-страницы. Третья часть - код на JScript - находится в секции <BODY> и вызывает первые две части.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function CreateVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(i, j) = k
      document.writeln(k)
      k = k + 1
    Next
    document.writeln("<BR>")
  Next
  CreateVBArray = a
End Function
-->
</SCRIPT>
<SCRIPT LANGUAGE="JScript">
<!--
function GetItemTest(vbarray)
{
  var i, j;
  var a = new VBArray(vbarray);
  for (i = 0; i <= 2; i++)
  {
    for (j =0; j <= 2; j++)
    {
      document.writeln(a.getItem(i, j));
    }
  }
}-->
</SCRIPT>
</HEAD>
<BODY>
<SCRIPT LANGUAGE="JScript">
<!--
  GetItemTest(CreateVBArray());
-->
</SCRIPT>
</BODY>
FONT SIZE=2>


Метод getItem

Метод getItem
Применение 		Справочник языка

Объект VBArray


Метод getItem

Метод getItem
См. также 		Справочник языка

Метод dimensions
Метод lbound
Метод toArray
Метод ubound


Метод lbound

Метод lbound 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает значение наименьшего индекса в указанном измерении VBArray.
Синтаксис
safeArray.lbound(dimension)

Синтаксис метода lbound состоит из частей:

Часть | Описание
safeArray | Требуется. Имя объекта VBArray.
dimension | Необязательно. Измерение VBArray для которого запрашивается наименьший индекс. Если значение опущено, то lbound подразумевается равным 1.

Примечание
Если массив VBArray пуст, то метод lbound возвращает значение undefined. Если значение dimension больше размерности VBArray (или отрицательно), то метод генерирует ошибку "Subscript out of range".

Следующий пример состоит из трех частей. Первая часть - код на языке VBScript - создает массив Visual Basic. Вторая часть - код на языке JScript - определяет размерность массива и нижнюю границу каждого измерения. Обе эти части расположены в секции <HEAD> HTML-страницы. Третья часть на языке JScript находится в секции <BODY> и запускает первые две части.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function CreateVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      k = k + 1
    Next
  Next
  CreateVBArray = a
End Function
-->
</SCRIPT>

<SCRIPT LANGUAGE="JScript">
<!--
function VBArrayTest(vba)
{
  var i, s;
  var a = new VBArray(vba);
  for (i = 1; i <= a.dimensions(); i++)
  {
    s = "Нижняя граница размерности ";
    s += i + " равна ";
    s += a.lbound(i)+ ".<BR>";
    return(s);
  }
}
-->
</SCRIPT>
</HEAD>

<BODY>
<SCRIPT language="jscript">
  document.write(VBArrayTest(CreateVBArray()));
</SCRIPT>
</BODY>


Метод lbound

Метод lbound
Применение 		Справочник языка

Объект VBArray


Метод lbound

Метод lbound
См. также 		Справочник языка

Метод dimensions
Метод getItem
Метод toArray
Метод ubound


Метод toArray

Метод toArray 		Справочник языка
Версия 3

См. также Применение

Описание
Преобразует VBArray в стандартный массив JScript.
Syntax
safeArray.toArray( )

Параметр safeArray является объектом VBArray.

Примечание
Преобразование многомерного VBArray в одномерный массив JScript. Каждая последующая мерность добавляется к концу предыдущей. Например, трехмерный VBArray с тремя элементами в каждой мерности преобразовывается в массив JScript следующим образом:

Предположим, VBArray содержит: (1, 2, 3), (4, 5, 6), (7, 8, 9). После преобразования массив JScript будет содержать: 1, 2, 3, 4, 5, 6, 7, 8, 9.

Преобразование массива JScript в VBArray невозможно.

Следующий пример состоит из трех частей. В первой части код на VBScript создает массив Visual Basic. Во второй части код на JScript преобразовывает массив VB в массив JScript. Обе части находятся в секции <HEAD> HTML-страницы. В третьей части код JScript, находящийся в секции <BODY>, выполняет первые две части.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function CreateVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      document.writeln(k)
      k = k + 1
    Next
    document.writeln("<BR>")
  Next
  CreateVBArray = a
End Function
-->
</SCRIPT>
<SCRIPT LANGUAGE="JScript">
<!--
function VBArrayTest(vbarray)
{
  var a = new VBArray(vbarray);
  var b = a.toArray();
  var i;
  for (i = 0; i < 9; i++)
  {
    document.writeln(b[i]);
  }
}
-->
</SCRIPT>
</HEAD>
<BODY>
<SCRIPT LANGUAGE="JScript">
<!--
  VBArrayTest(CreateVBArray());
-->
</SCRIPT>
</BODY>


Метод toArray

Метод toArray
Применение 		Справочник языка

Объект VBArray


Метод toArray

Метод toArray
См. также 		Справочник языка

Метод dimensions
Метод getItem
Метод lbound
Метод ubound


Метод ubound

Метод ubound 		Справочник языка
Версия 3

См. также Применение

Описание
Возвращает значение наибольшего индекса в указанном измерении VBArray.
Синтаксис
safeArray.ubound(dimension)

Синтаксис метода ubound состоит из частей:

Часть | Описание
safeArray | Требуется. Объект VBArray.
dimension | Необязательно. Измерение VBArray для которого запрашивается наибольший индекс. Если опущен, ubound подразумевается равным 1.

Примечание
Если массив VBArray пуст, то метод ubound возвращает значение undefined. Если значение dimension больше числа размерностей VBArray (или отрицательно), то метод генерирует ошибку "Subscript out of range".

Следующий пример состоит из трех частей. Первая часть - код на языке VBScript - создает массив Visual Basic. Вторая часть - код на языке JScript - определяет размерность массива и верхнюю границу каждого измерения. Обе эти части располагаются в секции <HEAD> HTML-страницы. Третья часть на языке JScript находится в секции <BODY> и запускает первые две части.

<HEAD>
<SCRIPT LANGUAGE="VBScript">
<!--
Function CreateVBArray()
  Dim i, j, k
  Dim a(2, 2)
  k = 1
  For i = 0 To 2
    For j = 0 To 2
      a(j, i) = k
      k = k + 1
    Next
  Next
  CreateVBArray = a
End Function
-->
</SCRIPT>

<SCRIPT LANGUAGE="JScript">
<!--
function VBArrayTest(vba)
{
  var i, s;
  var a = new VBArray(vba);
  for (i = 1; i <= a.dimensions(); i++)
  {
    s = "Верхняя граница размерности ";
    s += i + " равна ";
    s += a.ubound(i)+ ".<BR>";
    return(s);
  }
}
-->
</SCRIPT>
</HEAD>

<BODY>
<SCRIPT language="jscript">
  document.write(VBArrayTest(CreateVBArray()));
</SCRIPT>
</BODY>


Информация о версиях языка

Информация о версиях 		Справочник языка

Следующая таблица иллюстрирует реализацию в приложениях версий JScript.

Приложения | JScript Version 1.0 | JScript Version 2.0 | JScript Version 3.0 | JScript Version 4.0
Microsoft Internet Explorer 3.0 | X
Microsoft Internet Information Server 1.0 | X
Microsoft Internet Explorer 4.0 | x
Microsoft Internet Information Server 4.0 | x
Microsoft Windows Scripting Host 1.0 | x
Microsoft Outlook 98 | x
Microsoft Visual Studio 6.0 | x


FileSystemObject Objects

Microsoft® Scripting Library - FileSystemObject
FileSystemObject Objects
 Previous
Next

The FileSystemObject (FSO) object model contains the following objects and collections.

Object/Collection | Description
FileSystemObject | Main object. Contains methods and properties that allow you to create, delete, gain information about, and generally manipulate drives, folders, and files. Many of the methods associated with this object duplicate those in other FSO objects; they are provided for convenience.
Drive | Object. Contains methods and properties that allow you to gather information about a drive attached to the system, such as its share name and how much room is available. Note that a "drive" isn't necessarily a hard disk, but can be a CD-ROM drive, a RAM disk, and so forth. A drive doesn't need to be physically attached to the system; it can be also be logically connected through a network.
Drives | Collection. Provides a list of the drives attached to the system, either physically or logically. The Drives collection includes all drives, regardless of type. Removable-media drives need not have media inserted for them to appear in this collection.
File | Object. Contains methods and properties that allow you to create, delete, or move a file. Also allows you to query the system for a file name, path, and various other properties.
Files | Collection. Provides a list of all files contained within a folder.
Folder | Object. Contains methods and properties that allow you to create, delete, or move folders. Also allows you to query the system for folder names, paths, and various other properties.
Folders | Collection. Provides a list of all the folders within a Folder.
TextStream | Object. Allows you to read and write text files.


FileSystemObject Sample Code

Microsoft® Scripting Library - FileSystemObject
FileSystemObject
Sample Code
 Previous

The sample code described in this section provides a real-world example that demonstrates many of the features available in the FileSystemObject object model. This code shows how all the features of the object model work together, and how to use those features effectively in your own code.

Note that since this code is fairly generic, some additional code and a little tweaking are needed to make this code actually run on your machine. These changes are necessary because of the different ways input and output to the user is handled between Active Server Pages and the Windows Scripting Host.

To run this code on an Active Server Page, use the following steps:

  1. Create a standard Web page with an .asp extension.
  2. Copy the following sample code into that file between the <BODY>...</BODY> tags.
  3. Enclose all the code within <%...%> tags.
  4. Move the Option Explicit statement from its current position in the code to the very top of your HTML page, positioning it even before the opening <HTML> tag.
  5. Place <%...%> tags around the Option Explicit statement to ensure that it's run on the server side.
  6. Add the following code to the end of the sample code:
Sub Print(x)
  Response.Write "<PRE><FONT FACE=""Courier New"" SIZE=""1"">"
  Response.Write x
  Response.Write "</FONT></PRE>"
End Sub
Main
The previous code adds a print procedure that will run on the server side, but display results on the client side. To run this code on the Windows Scripting Host, add the following code to the end of the sample code:
Sub Print(x)
    WScript.Echo x
End Sub
Main
The code is contained in the following section:

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' FileSystemObject Sample Code
'
' Copyright 1998 Microsoft Corporation.  All Rights Reserved.
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Option Explicit

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Regarding code quality:
'
' 1) The following code does a lot of string manipulation by concatenating short
'    strings together with the "&" operator. Since string concatenation
'    is expensive, this is a very inefficient way to write code. However, it is a very
'    maintainable way to write code, and is used here because this program performs extensive
'    disk operations, and because the disk is much slower than the memory operations required to
'    concatenate the strings. Keep in mind that this is demonstration code, not production code.
'
' 2) "Option Explicit" is used, because declared variable access is slightly faster than
'    undeclared variable access. It also prevents bugs from creeping into your code, such as
'    when you misspell DriveTypeCDROM as DriveTypeCDORM.
'
' 3) Error handling is absent from this code, to make the code more readable. Although
'    precautions have been taken to ensure that the code will not error in common cases, file
'    systems can be unpredictable. In production code, use On Error Resume Next and the
'    Err object to trap possible errors.
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Some handy global variables
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Dim TabStop
Dim NewLine

Const TestDrive = "C"
Const TestFilePath = "C:\Test"

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Constants returned by Drive.DriveType
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Const DriveTypeRemovable = 1
Const DriveTypeFixed = 2
Const DriveTypeNetwork = 3
Const DriveTypeCDROM = 4
Const DriveTypeRAMDisk = 5

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Constants returned by File.Attributes
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Const FileAttrNormal  = 0
Const FileAttrReadOnly = 1
Const FileAttrHidden = 2
Const FileAttrSystem = 4
Const FileAttrVolume = 8
Const FileAttrDirectory = 16
Const FileAttrArchive = 32
Const FileAttrAlias = 64
Const FileAttrCompressed = 128

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' Constants for opening files
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Const OpenFileForReading = 1
Const OpenFileForWriting = 2
Const OpenFileForAppending = 8

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ShowDriveType
'
' Purpose:
'
' Generates a string describing the drive type of a given Drive object.
'
' Demonstrates the following
'
' - Drive.DriveType
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function ShowDriveType(Drive)

    Dim S

    Select Case Drive.DriveType
    Case DriveTypeRemovable
        S = "Removable"
    Case DriveTypeFixed
        S = "Fixed"
    Case DriveTypeNetwork
        S = "Network"
    Case DriveTypeCDROM
        S = "CD-ROM"
    Case DriveTypeRAMDisk
        S = "RAM Disk"
    Case Else
        S = "Unknown"
    End Select

    ShowDriveType = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' ShowFileAttr
'
' Purpose:
'
' Generates a string describing the attributes of a file or folder.
'
' Demonstrates the following
'
' - File.Attributes
' - Folder.Attributes
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function ShowFileAttr(File) ' File can be a file or folder

    Dim S
      Dim Attr

    Attr = File.Attributes

    If Attr = 0 Then
        ShowFileAttr = "Normal"
        Exit Function
    End If

    If Attr And FileAttrDirectory  Then S = S & "Directory "
    If Attr And FileAttrReadOnly   Then S = S & "Read-Only "
    If Attr And FileAttrHidden     Then S = S & "Hidden "
    If Attr And FileAttrSystem     Then S = S & "System "
    If Attr And FileAttrVolume     Then S = S & "Volume "
    If Attr And FileAttrArchive    Then S = S & "Archive "
    If Attr And FileAttrAlias      Then S = S & "Alias "
    If Attr And FileAttrCompressed Then S = S & "Compressed "

    ShowFileAttr = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateDriveInformation
'
' Purpose:
'
' Generates a string describing the current state of the available drives.
'
' Demonstrates the following
'
' - FileSystemObject.Drives
' - Iterating the Drives collection
' - Drives.Count
' - Drive.AvailableSpace
' - Drive.DriveLetter
' - Drive.DriveType
' - Drive.FileSystem
' - Drive.FreeSpace
' - Drive.IsReady
' - Drive.Path
' - Drive.SerialNumber
' - Drive.ShareName
' - Drive.TotalSize
' - Drive.VolumeName
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateDriveInformation(FSO)

    Dim Drives
    Dim Drive
    Dim S

    Set Drives = FSO.Drives

    S = "Number of drives:" & TabStop & Drives.Count & NewLine & NewLine

    ' Construct 1st line of report.
    S = S & String(2, TabStop) & "Drive"
    S = S & String(3, TabStop) & "File"
    S = S & TabStop & "Total"
    S = S & TabStop & "Free"
    S = S & TabStop & "Available"
    S = S & TabStop & "Serial" & NewLine

    ' Construct 2nd line of report.
    S = S & "Letter"
    S = S & TabStop & "Path"
    S = S & TabStop & "Type"
    S = S & TabStop & "Ready?"
    S = S & TabStop & "Name"
    S = S & TabStop & "System"
    S = S & TabStop & "Space"
    S = S & TabStop & "Space"
    S = S & TabStop & "Space"
    S = S & TabStop & "Number" & NewLine

    ' Separator line.
    S = S & String(105, "-") & NewLine

    For Each Drive In Drives

        S = S & Drive.DriveLetter
        S = S & TabStop & Drive.Path
        S = S & TabStop & ShowDriveType(Drive)
        S = S & TabStop & Drive.IsReady

        If Drive.IsReady Then
            If DriveTypeNetwork = Drive.DriveType Then
                S = S & TabStop & Drive.ShareName
            Else
                S = S & TabStop & Drive.VolumeName
            End If

            S = S & TabStop & Drive.FileSystem
            S = S & TabStop & Drive.TotalSize
            S = S & TabStop & Drive.FreeSpace
            S = S & TabStop & Drive.AvailableSpace
            S = S & TabStop & Hex(Drive.SerialNumber)

        End If

        S = S & NewLine

    Next

    GenerateDriveInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateFileInformation
'
' Purpose:
'
' Generates a string describing the current state of a file.
'
' Demonstrates the following
'
' - File.Path
' - File.Name
' - File.Type
' - File.DateCreated
' - File.DateLastAccessed
' - File.DateLastModified
' - File.Size
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateFileInformation(File)

    Dim S

    S = NewLine & "Path:" & TabStop & File.Path
    S = S & NewLine & "Name:" & TabStop & File.Name
    S = S & NewLine & "Type:" & TabStop & File.Type
    S = S & NewLine & "Attribs:" & TabStop & ShowFileAttr(File)
    S = S & NewLine & "Created:" & TabStop & File.DateCreated
    S = S & NewLine & "Accessed:" & TabStop & File.DateLastAccessed
    S = S & NewLine & "Modified:" & TabStop & File.DateLastModified
    S = S & NewLine & "Size" & TabStop & File.Size & NewLine

    GenerateFileInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateFolderInformation
'
' Purpose:
'
' Generates a string describing the current state of a folder.
'
' Demonstrates the following
'
' - Folder.Path
' - Folder.Name
' - Folder.DateCreated
' - Folder.DateLastAccessed
' - Folder.DateLastModified
' - Folder.Size
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateFolderInformation(Folder)

    Dim S

    S = "Path:" & TabStop & Folder.Path
    S = S & NewLine & "Name:" & TabStop & Folder.Name
    S = S & NewLine & "Attribs:" & TabStop & ShowFileAttr(Folder)
    S = S & NewLine & "Created:" & TabStop & Folder.DateCreated
    S = S & NewLine & "Accessed:" & TabStop & Folder.DateLastAccessed
    S = S & NewLine & "Modified:" & TabStop & Folder.DateLastModified
    S = S & NewLine & "Size:" & TabStop & Folder.Size & NewLine

    GenerateFolderInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateAllFolderInformation
'
' Purpose:
'
' Generates a string describing the current state of a
' folder and all files and subfolders.
'
' Demonstrates the following
'
' - Folder.Path
' - Folder.SubFolders
' - Folders.Count
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateAllFolderInformation(Folder)

    Dim S
    Dim SubFolders
    Dim SubFolder
    Dim Files
    Dim File

    S = "Folder:" & TabStop & Folder.Path & NewLine & NewLine

    Set Files = Folder.Files

    If 1 = Files.Count Then
        S = S & "There is 1 file" & NewLine
    Else
        S = S & "There are " & Files.Count & " files" & NewLine
    End If

    If Files.Count <> 0 Then

        For Each File In Files
            S = S & GenerateFileInformation(File)
        Next

    End If

    Set SubFolders = Folder.SubFolders

    If 1 = SubFolders.Count Then
        S = S & NewLine & "There is 1 sub folder" & NewLine & NewLine
    Else
        S = S & NewLine & "There are " & SubFolders.Count & " sub folders" & NewLine & NewLine
    End If

    If SubFolders.Count <> 0 Then

        For Each SubFolder In SubFolders
            S = S & GenerateFolderInformation(SubFolder)
        Next

        S = S & NewLine

        For Each SubFolder In SubFolders
            S = S & GenerateAllFolderInformation(SubFolder)
        Next

    End If

    GenerateAllFolderInformation = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GenerateTestInformation
'
' Purpose:
'
' Generates a string describing the current state of the C:\Test
' folder and all files and subfolders.
'
' Demonstrates the following
'
' - FileSystemObject.DriveExists
' - FileSystemObject.FolderExists
' - FileSystemObject.GetFolder
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GenerateTestInformation(FSO)

    Dim TestFolder
    Dim S

    If Not FSO.DriveExists(TestDrive) Then Exit Function
    If Not FSO.FolderExists(TestFilePath) Then Exit Function

    Set TestFolder = FSO.GetFolder(TestFilePath)

    GenerateTestInformation = GenerateAllFolderInformation(TestFolder)

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' DeleteTestDirectory
'
' Purpose:
'
' Cleans up the test directory.
'
' Demonstrates the following
'
' - FileSystemObject.GetFolder
' - FileSystemObject.DeleteFile
' - FileSystemObject.DeleteFolder
' - Folder.Delete
' - File.Delete
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Sub DeleteTestDirectory(FSO)

    Dim TestFolder
    Dim SubFolder
    Dim File

    ' Two ways to delete a file:

    FSO.DeleteFile(TestFilePath & "\Beatles\OctopusGarden.txt")

    Set File = FSO.GetFile(TestFilePath & "\Beatles\BathroomWindow.txt")
    File.Delete

    ' Two ways to delete a folder:

    FSO.DeleteFolder(TestFilePath & "\Beatles")

    FSO.DeleteFile(TestFilePath & "\ReadMe.txt")

    Set TestFolder = FSO.GetFolder(TestFilePath)
    TestFolder.Delete

End Sub

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' CreateLyrics
'
' Purpose:
'
' Builds a couple of text files in a folder.
'
'
' Demonstrates the following
'
' - FileSystemObject.CreateTextFile
' - TextStream.WriteLine
' - TextStream.Write
' - TextStream.WriteBlankLines
' - TextStream.Close
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Sub CreateLyrics(Folder)

    Dim TextStream

    Set TextStream = Folder.CreateTextFile("OctopusGarden.txt")

    TextStream.Write("Octopus' Garden ") ' Note that this does not add a line feed to the file.
    TextStream.WriteLine("(by Ringo Starr)")
    TextStream.WriteBlankLines(1)
    TextStream.WriteLine("I'd like to be under the sea in an octopus' garden in the shade,")
    TextStream.WriteLine("He'd let us in, knows where we've been -- in his octopus' garden in the shade.")
    TextStream.WriteBlankLines(2)

    TextStream.Close

    Set TextStream = Folder.CreateTextFile("BathroomWindow.txt")
    TextStream.WriteLine("She Came In Through The Bathroom Window (by Lennon/McCartney)")
    TextStream.WriteLine("")
    TextStream.WriteLine("She came in through the bathroom window protected by a silver spoon")
    TextStream.WriteLine("But now she sucks her thumb and wanders by the banks of her own lagoon")
    TextStream.WriteBlankLines(2)
    TextStream.Close

End Sub

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' GetLyrics
'
' Purpose:
'
' Displays the contents of the lyrics files.
'
'
' Demonstrates the following
'
' - FileSystemObject.OpenTextFile
' - FileSystemObject.GetFile
' - TextStream.ReadAll
' - TextStream.Close
' - File.OpenAsTextStream
' - TextStream.AtEndOfStream
' - TextStream.ReadLine
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function GetLyrics(FSO)

    Dim TextStream
    Dim S
    Dim File

    ' There are several ways to open a text file, and several ways to read the
    ' data out of a file.  Here's two ways to do each:

    Set TextStream = FSO.OpenTextFile(TestFilePath & "\Beatles\OctopusGarden.txt", OpenFileForReading)

    S = TextStream.ReadAll & NewLine & NewLine
    TextStream.Close

    Set File = FSO.GetFile(TestFilePath & "\Beatles\BathroomWindow.txt")
    Set TextStream = File.OpenAsTextStream(OpenFileForReading)
    Do 	While Not TextStream.AtEndOfStream
        S = S & TextStream.ReadLine & NewLine
    Loop
    TextStream.Close

    GetLyrics = S

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' BuildTestDirectory
'
' Purpose:
'
' Builds a directory hierarchy to demonstrate the FileSystemObject.
'
' We'll build a hierarchy in this order:
'
' C:\Test
' C:\Test\ReadMe.txt
' C:\Test\Beatles
' C:\Test\Beatles\OctopusGarden.txt
' C:\Test\Beatles\BathroomWindow.txt
'
'
' Demonstrates the following
'
' - FileSystemObject.DriveExists
' - FileSystemObject.FolderExists
' - FileSystemObject.CreateFolder
' - FileSystemObject.CreateTextFile
' - Folders.Add
' - Folder.CreateTextFile
' - TextStream.WriteLine
' - TextStream.Close
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Function BuildTestDirectory(FSO)

    Dim TestFolder
    Dim SubFolders
    Dim SubFolder
    Dim TextStream

    ' Bail out if (a) the drive does not exist, or if (b) the directory being built
    ' already exists.

    If Not FSO.DriveExists(TestDrive) Then
        BuildTestDirectory = False
        Exit Function
    End If

    If FSO.FolderExists(TestFilePath) Then
        BuildTestDirectory = False
        Exit Function
    End If

    Set TestFolder = FSO.CreateFolder(TestFilePath)

    Set TextStream = FSO.CreateTextFile(TestFilePath & "\ReadMe.txt")
    TextStream.WriteLine("My song lyrics collection")
    TextStream.Close

    Set SubFolders = TestFolder.SubFolders

    Set SubFolder = SubFolders.Add("Beatles")

    CreateLyrics SubFolder

    BuildTestDirectory = True

End Function

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'
' The main routine
'
' First, it creates a test directory, along with some subfolders and files.
' Then, it dumps some information about the available disk drives and
' about the test directory, and then cleans everything up again.
'
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Sub Main

    Dim FSO

    ' Set up global data.
    TabStop = Chr(9)
    NewLine = Chr(10)

    Set FSO = CreateObject("Scripting.FileSystemObject")

    If Not BuildTestDirectory(FSO) Then
        Print "Test directory already exists or cannot be created.  Cannot continue."
        Exit Sub
    End If

    Print GenerateDriveInformation(FSO) & NewLine & NewLine

    Print GenerateTestInformation(FSO) & NewLine & NewLine

    Print GetLyrics(FSO) & NewLine & NewLine

    DeleteTestDirectory(FSO)

End Sub


Microsoft® Scripting Library - Introduction to the FileSystemObject and the Scripting Run-Time Library Reference

Microsoft® Scripting Library - FileSystemObject
Introduction to the FileSystemObject
and the
Scripting Run-Time Library Reference
 Previous
Next

The FileSystemObject (FSO) object model allows you to use the familiar object.method syntax with a rich set of properties, methods, and events to process folders and files.

Use this object-based tool with:

  • HTML to create Web pages

  • Windows Scripting Host to create batch files for Microsoft Windows

  • Script Control to provide a scripting capability to applications developed in other languages

Because use of the FSO on the client side raises serious security issues about providing potentially unwelcome access to a client's local file system, this documentation assumes use of the FSO object model to create scripts executed by Internet Web pages on the server side. Since the server side is used, the Internet Explorer default security settings do not allow client-side use of the FileSystemObject object. Overriding those defaults could subject a local computer to unwelcome access to the file system, which could result in total destruction of the file system's integrity, causing loss of data, or worse.

The FSO object model gives your server-side applications the ability to create, alter, move, and delete folders, or to detect if particular folders exist, and if so, where. You can also find out information about folders, such as their names, the date they were created or last modified, and so forth.

The FSO object model also makes it easy to process files. When processing files, the primary goal is to store data in a space- and resource-efficient, easy-to-access format. You need to be able to create files, insert and change the data, and output (read) the data. Since storing data in a database, such as Access or SQL Server, adds a significant amount of overhead to your application, storing your data in a binary or text file may be the most efficient solution. You may prefer not to have this overhead, or your data access requirements may not require all the extra features associated with a full-featured database.

The FSO object model, which is contained in the Scripting type library (Scrrun.dll), supports text file creation and manipulation through the TextStream object. Although it does not yet support the creation or manipulation of binary files, future support of binary files is planned.


Programming the FileSystemObject

Microsoft® Scripting Library - FileSystemObject
Programming the FileSystemObject
 Previous
Next

To program with the FileSystemObject (FSO) object model:

  • Use the CreateObject method to create a FileSystemObject object.
  • Use the appropriate method on the newly created object.
  • Access the object's properties.
The FSO object model is contained in the Scripting type library, which is located in the Scrrun.dll file. Therefore, you must have Scrrun.dll in the appropriate system directory on your Web server to use the FSO object model.

Creating a FileSystemObject Object
First, create a FileSystemObject object by using the CreateObject method. In VBScript, use the following code to create an instance of the FileSystemObject:

Dim fso
Set fso = CreateObject("Scripting.FileSystemObject")
This sample code demonstrates how to create an instance of the FileSystemObject.

In JScript, use this code to do the same thing:

var fso;
fso = new ActiveXObject("Scripting.FileSystemObject");
In both of these examples, Scripting is the name of the type library and FileSystemObject is the name of the object that you want to create. You can create only one instance of the FileSystemObject object, regardless of how many times you try to create another.

Using the Appropriate Method
Second, use the appropriate method of the FileSystemObject object. For example, to create a new object, use either CreateTextFile or CreateFolder (the FSO object model doesn't support the creation or deletion of drives).

To delete objects, use the DeleteFile and DeleteFolder methods of the FileSystemObject object, or the Delete method of the File and Folder objects. You can also copy and move files and folders, by using the appropriate methods.

Note Some functionality in the FileSystemObject object model is redundant. For example, you can copy a file using either the CopyFile method of the FileSystemObject object, or you can use the Copy method of the File object. The methods work the same; both exist to offer programming flexibility.

Accessing Existing Drives, Files, and Folders
To gain access to an existing drive, file, or folder, use the appropriate "get" method of the FileSystemObject object:

  • GetDrive
  • GetFolder
  • GetFile
To gain access to an existing file in VBScript:

Dim fso, f1
Set fso = CreateObject("Scripting.FileSystemObject")
Set f1 = fso.GetFile("c:\test.txt")
To do the same thing in JScript, use the following code:

var fso, f1;
fso = new ActiveXObject("Scripting.FileSystemObject");
f1 = fso.GetFile("c:\\test.txt");
Do not use the "get" methods for newly created objects, since the "create" functions already return a handle to that object. For example, if you create a new folder using the CreateFolder method, don't use the GetFolder method to access its properties, such as Name, Path, Size, and so forth. Just set a variable to the CreateFolder function to gain a handle to the newly created folder, then access its properties, methods, and events. To do this in VBScript, use the following code:

Sub CreateFolder
  Dim fso, fldr
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set fldr = fso.CreateFolder("C:\MyTest")
  Response.Write "Created folder: " & fldr.Name
End Sub
To set a variable to the CreateFolder function in JScript, use this syntax:

function CreateFolder()
{
  var fso, fldr;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  fldr = fso.CreateFolder("C:\\MyTest");
  Response.Write("Created folder: " + fldr.Name);
}
Accessing the Object's Properties
Once you have a handle to an object, you can access its properties. For example, to get the name of a particular folder, first create an instance of the object, then get a handle to it with the appropriate method (in this case, the GetFolder method, since the folder already exists).

Use this code to get a handle to the GetFolder method in VBScript:

Set fldr = fso.GetFolder("c:\")

To do the same thing in JScript, use the following code:

var fldr = fso.GetFolder("c:\\");
Now that you have a handle to a Folder object, you can check its Name property. Use the following code to check this in VBScript:

Response.Write "Folder name is: " & fldr.Name
To check a Name property in JScript, use this syntax:

Response.Write("Folder name is: " + fldr.Name);
To find out the last time a file was modified, use the following VBScript syntax:

Dim fso, f1
Set fso = CreateObject("Scripting.FileSystemObject")
' Get a File object to query.
Set f1 = fso.GetFile("c:\detlog.txt")
' Print information.
Response.Write "File last modified: " & f1.DateLastModified
To find out the same thing in JScript, use this code:

var fso, f1;
fso = new ActiveXObject("Scripting.FileSystemObject");
// Get a File object to query.
f1 = fso.GetFile("c:\\detlog.txt");
// Print information.
Response.Write("File last modified: " + f1.DateLastModified);


Microsoft® Scripting Library - The FileSystemObject Object

Microsoft® Scripting Library - FileSystemObject
The FileSystemObject Object Model
 Next

When writing scripts for Active Server Pages, the Windows Scripting Host, or other applications where scripting can be used, it's often important to add, move, change, create, or delete folders (directories) and files on the Web server. It may also be necessary to get information about and manipulate drives attached to the Web server.

Scripting allows you to process drives, folders, and files using the FileSystemObject (FSO) object model, which is explained in the following sections:

  • Introduction to the FileSystemObject
    and the Scripting Run-Time Library Reference

  • FileSystemObject Objects

  • Programming the FileSystemObject

  • Working with Drives and Folders

  • Working with Files

  • FileSystemObject Sample Code


Working with Drives and Folders

Microsoft® Scripting Library - FileSystemObject
Working with Drives and Folders
 Previous
Next

With the FileSystemObject (FSO) object model, you can work with drives and folders programmatically just as you can in the Windows Explorer interactively. You can copy and move folders, get information about drives and folders, and so forth.

Getting Information About Drives
The Drive object allows you to gain information about the various drives attached to a system, either physically or over a network. Its properties allow you to obtain information about:

  • The total size of the drive in bytes (TotalSize property)
  • How much space is available on the drive in bytes (AvailableSpace or FreeSpace properties)
  • What letter is assigned to the drive (DriveLetter property)
  • What type of drive it is, such as removable, fixed, network, CD-ROM, or RAM disk (DriveType property)
  • The drive's serial number (SerialNumber property)
  • The type of file system the drive uses, such as FAT, FAT32, NTFS, and so forth (FileSystem property)
  • Whether a drive is available for use (IsReady property)
  • The name of the share and/or volume (ShareName and VolumeName properties)
  • The path or root folder of the drive (Path and RootFolder properties)
View the sample code to see how these properties are used in FileSystemObject.

Example Usage of the Drive Object
Use the Drive object to gather information about a drive. You won't see a reference to an actual Drive object in the following code; instead, use the GetDrive method to get a reference to an existing Drive object (in this case, drv).

The following example demonstrates how to use the Drive object in VBScript:

Sub ShowDriveInfo(drvPath)
  Dim fso, drv, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set drv = fso.GetDrive(fso.GetDriveName(drvPath))
  s = "Drive " & UCase(drvPath) & " - "
  s = s & drv.VolumeName & "<br>"
  s = s & "Total Space: " & FormatNumber(drv.TotalSize / 1024, 0)
  s = s & " Kb" & "<br>"
  s = s & "Free Space: " & FormatNumber(drv.FreeSpace / 1024, 0)
  s = s & " Kb" & "<br>"
  Response.Write s
End Sub
The following code illustrates the same functionality in JScript:
function ShowDriveInfo1(drvPath)
{
  var fso, drv, s ="";
  fso = new ActiveXObject("Scripting.FileSystemObject");
  drv = fso.GetDrive(fso.GetDriveName(drvPath));
  s += "Drive " + drvPath.toUpperCase()+ " - ";
  s += drv.VolumeName + "<br>";
  s += "Total Space: " + drv.TotalSize / 1024;
  s += " Kb" + "<br>";
  s += "Free Space: " + drv.FreeSpace / 1024;
  s += " Kb" + "<br>";
  Response.Write(s);
}
Working with Folders
Common folder tasks and the methods for performing them are described in the following table.

Task | Method
Create a folder. | FileSystemObject.CreateFolder
Delete a folder. | Folder.Delete or FileSystemObject.DeleteFolder
Move a folder. | Folder.Move or FileSystemObject.MoveFolder
Copy a folder. | Folder.Copy or FileSystemObject.CopyFolder
Retrieve the name of a folder. | Folder.Name
Find out if a folder exists on a drive. | FileSystemObject.FolderExists
Get an instance of an existing Folder object. | FileSystemObject.GetFolder
Find out the name of a folder's parent folder. | FileSystemObject.GetParentFolderName
Find out the path of system folders. | FileSystemObject.GetSpecialFolder

View the sample code to see how many of these methods and properties are used in FileSystemObject.

The following example demonstrates how to use the Folder and FileSystemObject objects to manipulate folders and gain information about them in VBScript:

Sub ShowFolderInfo()
  Dim fso, fldr, s
  ' Get instance of FileSystemObject.
  Set fso = CreateObject("Scripting.FileSystemObject")
  ' Get Drive object.
  Set fldr = fso.GetFolder("c:")
  ' Print parent folder name.
  Response.Write "Parent folder name is: " & fldr & "<br>"
  ' Print drive name.
  Response.Write "Contained on drive " & fldr.Drive & "<br>"
  ' Print root file name.
  If fldr.IsRootFolder = True Then
    Response.Write "This is the root folder." & ""<br>"<br>"
  Else
    Response.Write "This folder isn't a root folder." & "<br><br>"
  End If
  ' Create a new folder with the FileSystemObject object.
  fso.CreateFolder ("C:\Bogus")
  Response.Write "Created folder C:\Bogus" & "<br>"
  ' Print the base name of the folder.
  Response.Write "Basename = " & fso.GetBaseName("c:\bogus") & "<br>"
  ' Delete the newly created folder.
  fso.DeleteFolder ("C:\Bogus")
  Response.Write "Deleted folder C:\Bogus" & "<br>"
End Sub
This example shows how to use the Folder and FileSystemObject objects in JScript:
function ShowFolderInfo()
{
  var fso, fldr, s = "";
  // Get instance of FileSystemObject.
  fso = new ActiveXObject("Scripting.FileSystemObject");
  // Get Drive object.
  fldr = fso.GetFolder("c:");
  // Print parent folder name.
  Response.Write("Parent folder name is: " + fldr + "<br>");
  // Print drive name.
  Response.Write("Contained on drive " + fldr.Drive + "<br>");
  // Print root file name.
  if (fldr.IsRootFolder)
    Response.Write("This is the root folder.");
  else
    Response.Write("This folder isn't a root folder.");
  Response.Write("<br><br>");
  // Create a new folder with the FileSystemObject object.
  fso.CreateFolder ("C:\\Bogus");
  Response.Write("Created folder C:\\Bogus" + "<br>");
  // Print the base name of the folder.
  Response.Write("Basename = " + fso.GetBaseName("c:\\bogus") + "<br>");
  // Delete the newly created folder.
  fso.DeleteFolder ("C:\\Bogus");
  Response.Write("Deleted folder C:\\Bogus" + "<br>");
}


Working with Files

Microsoft® Scripting Library - FileSystemObject
Working with Files
 Previous
Next

There are two major categories of file manipulation:

  • Creating, adding, or removing data, and reading files
  • Moving, copying, and deleting files
Creating Files
There are three ways to create an empty text file (sometimes referred to as a "text stream").

The first way is to use the CreateTextFile method. The following example demonstrates how to create a text file using this method in VBScript:

Dim fso, f1
Set fso = CreateObject("Scripting.FileSystemObject")
Set f1 = fso.CreateTextFile("c:\testfile.txt", True)
To use this method in JScript, use this code:

var fso, f1;
fso = new ActiveXObject("Scripting.FileSystemObject");
f1 = fso.CreateTextFile("c:\\testfile.txt", true);
View this sample code to see how the CreateTextFile method is used in FileSystemObject.

The second way to create a text file is to use the OpenTextFile method of the FileSystemObject object with the ForWriting flag set. In VBScript, the code looks like this example:

Dim fso, ts
Const ForWriting = 2
Set fso = CreateObject("Scripting. FileSystemObject")
Set ts = fso.OpenTextFile("c:\test.txt", ForWriting, True)
To create a text file using this method in JScript, use this code:

var fso, ts;
var ForWriting= 2;
fso = new ActiveXObject("Scripting.FileSystemObject");
ts = fso.OpenTextFile("c:\\test.txt", ForWriting, true);
A third way to create a text file is to use the OpenAsTextStream method with the ForWriting flag set. For this method, use the following code in VBScript:

Dim fso, f1, ts
Const ForWriting = 2
Set fso = CreateObject("Scripting.FileSystemObject")
fso.CreateTextFile ("c:\test1.txt")
Set f1 = fso.GetFile("c:\test1.txt")
Set ts = f1.OpenAsTextStream(ForWriting, True)
In JScript, use the code in the following example:

var fso, f1, ts;
var ForWriting = 2;
fso = new ActiveXObject("Scripting.FileSystemObject");
fso.CreateTextFile ("c:\\test1.txt");
f1 = fso.GetFile("c:\\test1.txt");
ts = f1.OpenAsTextStream(ForWriting, true);
Adding Data to the File
Once the text file is created, add data to the file using the following three steps:

  1. Open the text file.
  2. Write the data.
  3. Close the file.
To open an existing file, use either the OpenTextFile method of the FileSystemObject object or the OpenAsTextStream method of the File object.

To write data to the open text file, use the Write, WriteLine, or WriteBlankLines methods of the TextStream object, according to the tasks outlined in the following table.

Task | Method
Write data to an open text file without a trailing newline character. | Write
Write data to an open text file with a trailing newline character. | WriteLine
Write one or more blank lines to an open text file. | WriteBlankLines

View this sample code to see how the Write, WriteLine, and WriteBlankLines methods are used in FileSystemObject.

To close an open file, use the Close method of the TextStream object.

View this sample code to see how the Close method is used in FileSystemObject.

Note The newline character contains a character or characters (depending on the operating system) to advance the cursor to the beginning of the next line (carriage return/line feed). Be aware that the end of some strings may already have such nonprinting characters.

The following VBScript example demonstrates how to open a file, use all three write methods to add data to the file, and then close the file:

Sub CreateFile()
  Dim fso, tf
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set tf = fso.CreateTextFile("c:\testfile.txt", True)
  ' Write a line with a newline character.
  tf.WriteLine("Testing 1, 2, 3.")
  ' Write three newline characters to the file.
  tf.WriteBlankLines(3)
  ' Write a line.
  tf.Write ("This is a test.")
  tf.Close
End Sub
This example demonstrates how to use the three methods in JScript:

function CreateFile()
{
  var fso, tf;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  tf = fso.CreateTextFile("c:\\testfile.txt", true);
  // Write a line with a newline character.
  tf.WriteLine("Testing 1, 2, 3.") ;
  // Write three newline characters to the file.
  tf.WriteBlankLines(3) ;
  // Write a line.
  tf.Write ("This is a test.");
  tf.Close();
}
Reading Files
To read data from a text file, use the Read, ReadLine, or ReadAll method of the TextStream object. The following table describes which method to use for various tasks.

Task | Method
Read a specified number of characters from a file. | Read
Read an entire line (up to, but not including, the newline character). | ReadLine
Read the entire contents of a text file. | ReadAll

View this sample code to see how the ReadAll and ReadLine methods are used in FileSystemObject.

If you use the Read or ReadLine method and want to skip to a particular portion of data, use the Skip or SkipLine method. The resulting text of the read methods is stored in a string which can be displayed in a control, parsed by string functions (such as Left, Right, and Mid), concatenated, and so forth.

The following VBScript example demonstrates how to open a file, write to it, and then read from it:

Sub ReadFiles
  Dim fso, f1, ts, s
  Const ForReading = 1
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f1 = fso.CreateTextFile("c:\testfile.txt", True)
  ' Write a line.
  Response.Write "Writing file <br>"
  f1.WriteLine "Hello World"
  f1.WriteBlankLines(1)
  f1.Close
  ' Read the contents of the file.
  Response.Write "Reading file <br>"
  Set ts = fso.OpenTextFile("c:\testfile.txt", ForReading)
  s = ts.ReadLine
  Response.Write "File contents = '" & s & "'"
  ts.Close
End Sub
This code demonstrates the same thing in JScript:

function ReadFiles()
{
  var fso, f1, ts, s;
  var ForReading = 1;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f1 = fso.CreateTextFile("c:\\testfile.txt", true);
  // Write a line.
  Response.Write("Writing file <br>");
  f1.WriteLine("Hello World");
  f1.WriteBlankLines(1);
  f1.Close();
  // Read the contents of the file.
  Response.Write("Reading file <br>");
  ts = fso.OpenTextFile("c:\\testfile.txt", ForReading);
  s = ts.ReadLine();
  Response.Write("File contents = '" + s + "'");
  ts.Close();
}
Moving, Copying, and Deleting Files
The FSO object model has two methods each for moving, copying, and deleting files, as described in the following table.

Task | Method
Move a file | File.Move or FileSystemObject.MoveFile
Copy a file | File.Copy or FileSystemObject.CopyFile
Delete a file | File.Delete or FileSystemObject.DeleteFile

View this sample code to see two ways to delete a file in FileSystemObject.

The following VBScript example creates a text file in the root directory of drive C, writes some information to it, moves it to a directory called \tmp, makes a copy of it in a directory called \temp, then deletes the copies from both directories.

To run the following example, create directories named \tmp and \temp in the root directory of drive C:

Sub ManipFiles
  Dim fso, f1, f2, s
  Set fso = CreateObject("Scripting.FileSystemObject")
  Set f1 = fso.CreateTextFile("c:\testfile.txt", True)
  Response.Write "Writing file <br>"
  ' Write a line.
  f1.Write ("This is a test.")
  ' Close the file to writing.
  f1.Close
  Response.Write "Moving file to c:\tmp <br>"
  ' Get a handle to the file in root of C:\.
  Set f2 = fso.GetFile("c:\testfile.txt")
  ' Move the file to \tmp directory.
  f2.Move ("c:\tmp\testfile.txt")
  Response.Write "Copying file to c:\temp <br>"
  ' Copy the file to \temp.
  f2.Copy ("c:\temp\testfile.txt")
  Response.Write "Deleting files <br>"
  ' Get handles to files' current location.
  Set f2 = fso.GetFile("c:\tmp\testfile.txt")
  Set f3 = fso.GetFile("c:\temp\testfile.txt")
  ' Delete the files.
  f2.Delete
  f3.Delete
  Response.Write "All done!"
End Sub
This code shows the same thing in JScript:

function ManipFiles()
{
  var fso, f1, f2, s;
  fso = new ActiveXObject("Scripting.FileSystemObject");
  f1 = fso.CreateTextFile("c:\\testfile.txt", true);
  Response.Write("Writing file <br>");
  // Write a line.
  f1.Write("This is a test.");
  // Close the file to writing.
  f1.Close();
  Response.Write("Moving file to c:\\tmp <br>");
  // Get a handle to the file in root of C:\.
  f2 = fso.GetFile("c:\\testfile.txt");
  // Move the file to \tmp directory.
  f2.Move ("c:\\tmp\\testfile.txt");
  Response.Write("Copying file to c:\\temp <br>");
  // Copy the file to \temp.
  f2.Copy ("c:\\temp\\testfile.txt");
  Response.Write("Deleting files <br>");
  // Get handles to files' current location.
  f2 = fso.GetFile("c:\\tmp\\testfile.txt");
  f3 = fso.GetFile("c:\\temp\\testfile.txt");
  // Delete the files.
  f2.Delete();
  f3.Delete();
  Response.Write("All done!");
}