От переводчика

От Переводчика и составителя

« W3Schools Home Следующая Глава »

Среди многочисленных Online электронных учебников по Web-разработкам, размещенных в Интернете, особое место, по моему мнению, занимают учебники, опубликованные на сайте www.w3schools.com.

Эти учебники особенно хороши для начинающих Web-разработчиков ("чайников").

Основные достоинства этих Учебников:

  • Легко воспринимаемый, лаконичный контент
  • Каждый учебник содержит около 100 примеров, содержание которых обучаемый может редактировать и тотчас видеть результат
  • Обучение построено по принципу: учитесь на примерах
  • Учебники содержат тестирующие модули, позволяющие обучаемым производить самоконтроль знаний
  • Каждый учебник содержит Справочник, позволяющий получить полную информацию по изучаемой теме

Недостатки этих Учебников:

  • Весь их контент (содержание) на английском языке
  • Обучение возможно только в режиме Online
Переводчик и составитель этого учебника:
Джерихов Вадим Вадимович,
доцент кафедры Информационных систем и технологий
Санкт-Петербургского государственного лесотехнического университета имени С.М. Кирова (СПБГЛТУ).

Что сделано:

  • Основной контент учебника переведен с английского языка на русский
  • Основной контент учебника скомпилирован в формате *.chm, с возможностью обучения в режиме Offline

Любые замечания по переводу будут с благодарностью приняты!

E-mail: vadvadd@mail.ru


HTML Теги по алфавиту

HTML 4.01 / XHTML 1.0 Справочник (Reference)

« W3Schools Home Следующий Справочник »

В алфавитном порядке

DTD: указывает, в каком HTML 4.01 / XHTML 1.0 DTD тег разрешен. S=Strict, T=Transitional и F=Frameset

Тег | Описание | DTD
<!--...--> | Определяет комментарий | STF
<!DOCTYPE> | Определяет тип документа (DOСument TYPE - тип документа) | STF
<a> | Определяет якорь (anchor — якорь) | STF
<abbr> | Определяет аббревиатуру (abbreviation — аббревиатура) | STF
<acronym> | Определяет акроним (acronym - акроним) | STF
<address> | Определяет контактную информацию об авторе/владельце документа (address - адрес) | STF
<applet> | Не рекомендуется. Определяет внедренный апплет (applet - апплет) | TF
<area /> | Определяет область внутри изображения-карты (area - область) | STF
<b> | Определяет жирный текст (bold — жирный) | STF
<base /> | Определяет адрес или целевое окно по умолчанию для всех ссылок на странице (base - база, основа) | STF
<basefont /> | Не рекомендуется. Определяет шрифт, цвет или размер текста на странице по умолчанию (base font — базовый шрифт) | TF
<bdo> | Определяет направление текста (BiDi over-ride — переопределение двунаправленного алгоритма) | STF
<big> | Определяет крупный текст (big - большой, крупный) | STF
<blockquote> | Определяет длинную цитату (block quote — блок цитаты) | STF
<body> | Определяет тело документа (body - тело) | STF
<br /> | Определяет один разрыв строки (break — разрыв) | STF
<button> | Определяет кнопку (button - кнопка) | STF
<caption> | Определяет заголовок таблицы (caption - заголовок) | STF
<center> | Не рекомендуется. Определяет центрированный текст (center - центр) | TF
<cite> | Определяет цитату (cite - цитировать) | STF
<code> | Определяет текст, как код программы (code - код) | STF
<col /> | Определяет значения атрибутов для одного или нескольких столбцов в таблице (column — колонка) | STF
<colgroup> | Определяет группу столбцов таблицы для форматирования (column group — группа колонок) | STF
<dd> | Определяет описании термина в списке определений (definition description - описание определения) | STF
<del> | Обозначает текст, как удаленный (delete — удалить) | STF
<dfn> | Определяет определение термина (definition — определение) | STF
<dir> | Не рекомендуется.Определяет список каталогов (directory — каталог) | TF
<div> | Определяет блоковый контейнер в документе (division — разделение) | STF
<dl> | Определяет список определений (definition list — список определений) | STF
<dt> | Определяет термин (пункт) в списке определений (definition term — определение термина, пункта) | STF
<em> | Определяет акцентированный текст (emphasis — акцент) | STF
<fieldset> | Определяет границу вокруг элементов в форме (field set - набор полей) | STF
<font> | Не рекомендуется. Определяет шрифт, цвет и размер текста (font - шрифт) | TF
<form> | Определяет HTML форму для ввода данных пользователем (form - форма) | STF
<frame /> | Определяет окно (фрейм) в наборе фреймов (frame - рамка, кадр, фрейм) | F
<frameset> | Определяет набор фреймов (frame set — набор фреймов) | F
от <h1> до <h6> | Определяют HTML заголовки (heading — заголовок) | STF
<head> | Определяет информацию о документе (head - голова) | STF
<hr /> | Определяет горизонтальную линию (horizontal rule — горизонтальная линия) | STF
<html> | Определяет HTML документ (HyperText Markup Language — язык разметки гипертекста) | STF
<i> | Определяет курсивный текст (italic — курсив) | STF
<iframe> | Определяет встроенный фрейм (inline frame — встроенный фрейм) | TF
<img /> | Определяет изображение (image — изображение) | STF
<input /> | Определяет управляющий элемент формы (input - ввод данных) | STF
<ins> | Обозначает текст, как вставленный (insert — вставка, вставлять) | STF
<isindex> | Не рекомендуется. Определяет поисковый индекс, связанный с документом (is index — это индекс) | TF
<kbd> | Определяет текст, вводимый с клавиатуры (keyboard — клавиатура) | STF
<label> | Определяет метку для элемента input (label - метка) | STF
<legend> | Определяет заголовок элемента fieldset (legend - легенда, надпись) | STF
<li> | Определяет элемент (пункт) списка (list item — элемент, пункт списка) | STF
<link /> | Определяет отношение (связь) между документом и внешним ресурсом (link - ссылка) | STF
<map> | Определяет изображение-карту (map - карта) | STF
<menu> | Не рекомендуется. Определяет список меню (menu - меню) | TF
<meta /> | Определяет метаданные о HTML документе (metainformation — метаинформация) | STF
<noframes> | Определяет альтернативный контент для браузеров, которые не поддерживают фреймы (no frames — нет фреймов) | TF
<noscript> | Определяет альтернативный контент для браузеров, которые не поддерживают сценарии на стороне клиента (no script — нет скрипта) | STF
<object> | Определяет внедренный объект (object - объект) | STF
<ol> | Определяет упорядоченный список (ordered list — упорядоченный список) | STF
<optgroup> | Определяет группу связанных опций в списке выбора (option group — группа опций) | STF
<option> | Определяет опцию в списке выбора (option - опция, вариант, выбор) | STF
<p> | Определяет абзац (paragraph — абзац, параграф) | STF
<param /> | Определяет параметр для объекта (parameter — параметр) | STF
<pre> | Определяет преформатированный текст (preformatted — предварительно отформатированный) | STF
<q> | Определяет короткую цитату (quotation — цитата) | STF
<s> | Не рекомендуется. Определяет перечеркнутый текст (strike-through — перечеркнутый) | TF
<samp> | Определяет пример компьютерного кода (sample — простой) | STF
<script> | Определяет сценарий на стороне клиента (script — сценарий, скрипт) | STF
<select> | Определяет список выбора (выпадающий список) (select — выделение) | STF
<small> | Определяет уменьшенный текст (small — маленький) | STF
<span> | Определяет строковый контейнер в документе (span - промежуток) | STF
<strike> | Не рекомендуется. Определяет перечеркнутый текст (strike-through — перечеркнутый) | TF
<strong> | Определяет акцентированный (полужирный) текст (strong — имеющий преимущество) | STF
<style> | Определяет стилевую информацию для документа (style - стиль, манера) | STF
<sub> | Определяет нижний индекс в тексте (subscript — нижний индекс, подстрочный) | STF
<sup> | Определяет верхний индекс в тексте (supscript — верхний индекс, надстрочный) | STF
<table> | Определяет таблицу (table - таблица) | STF
<tbody> | Объединяет контент тела таблицы (table body — тело таблицы) | STF
<td> | Определяет ячейку в таблице (table data — данные таблицы) | STF
<textarea> | Определяет поле многострочного ввода текста (text area — текстовая область) | STF
<tfoot> | Группирует контент нижнего колонтитула таблицы (table foot — нижняя часть таблицы) | STF
<th> | Определяет заголовочные ячейки таблицы (table header — заголовок таблицы) | STF
<thead> | Группирует контент верхнего колонтитула таблицы (table header — верхняя часть таблицы) | STF
<title> | Определяет заголовок документа (title - заглавие) | STF
<tr> | Определяет строку в таблице (table row — строка таблицы) | STF
<tt> | Определяет телетайпный текст (teletype — телетайп) | STF
<u> | Не рекомендуется. Определяет подчеркнутый текст (underlined — подчеркнутый) | TF
<ul> | Определяет неупорядоченный (маркированный) список (unordered list— неупорядоченный список) | STF
<var> | Определяет переменную, как часть текста (variable — переменная) | STF


HTML Теги по функциям

HTML 4.01 / XHTML 1.0 Справочник (Reference)

« Предыдущий Следующий Справочник »

В функциональном порядке

DTD: указывает, в каком HTML 4.01 / XHTML 1.0 DTD тег разрешен. S=Strict, T=Transitional и F=Frameset

Тег | Описание | DTD
Основные |  |
<!DOCTYPE> | Определяет тип документа (DOСument TYPE - тип документа) | STF
<html> | Определяет документ HTML (HyperText Markup Language — язык разметки гипертекста) | STF
<body> | Определяет тело документа (body - тело) | STF
от <h1> до <h6> | Определяют HTML заголовки (header — заголовок) | STF
<p> | Определяет абзац (paragraph — абзац, параграф) | STF
<br /> | Определяет один разрыв строки (break — разрыв) | STF
<hr /> | Определяет горизонтальную линию (horizontal rule — горизонтальная линия) | STF
<!--...--> | Определяет комментарии | STF
Форматирование |  |
<abbr> | Определяет аббревиатуру (abbreviation — аббревиатура) | STF
<acronym> | Определяет акроним (acronym - акроним) | STF
<address> | Определяет контактную информацию об автора/владельца документа (address - адрес) | STF
<b> | Определяет жирный текст (bold — жирный) | STF
<bdo> | Определяет направление текста (BiDi over-ride — переопределение двунаправленного алгоритма) | STF
<big> | Определяет крупный текст (big - большой) | STF
<blockquote> | Определяет длинную цитату (block quote — блок цитаты) | STF
<center> | Не рекомендуется. Определяет центрированный текст (center - центр) | TF
<cite> | Определяет цитату (cite - цитировать) | STF
<code> | Определяет текст, как код программы (code - код) | STF
<del> | Обозначает текст, как удаленный (delete — удалить) | STF
<dfn> | Определяет определение термина (definition — определение) | STF
<em> | Определяет выделенный (курсивом) текст (emphasis — акцент) | STF
<font> | Не рекомендуется. Определяет шрифт, цвет и размер текста (font - шрифт) | TF
<i> | Определяет курсивный текст (italic — курсив) | STF
<ins> | Определяет маркировку вставленного текста (insert — вставка) | STF
<kbd> | Определяет текст, вводимый с клавиатуры (keyboard — клавиатура) | STF
<pre> | Определяет преформатированный текст (preformatted — предварительно отформатированный) | STF
<q> | Определяет короткую цитату (quotation — цитата) | STF
<s> | Не рекомендуется. Определяет перечеркнутый текст (strike-through — перечеркнутый) | TF
<samp> | Определяет пример компьютерного кода (sample — простой) | STF
<small> | Определяет уменьшенный текст (small — маленький) | STF
<strike> | Не рекомендуется. Определяет перечеркнутый текст (strike-through — перечеркнутый) | TF
<strong> | Определяет акцентированный (полужирный) текст (strong — имеющий преимущество) | STF
<sub> | Определяет нижний индекс в тексте (subscript — нижний индекс, подстрочный) | STF
<sup> | Определяет верхний индекс в тексте (supscript — верхний индекс, надстрочный) | STF
<tt> | Определяет телетайпный текст (teletype — телетайп) | STF
<u> | Не рекомендуется. Определяет подчеркнутый текст (underlined — подчеркнутый) | TF
<var> | Определяет переменную, как часть текста (variable — переменная) | STF
Формы |  |
<form> | Определяет форму HTML для пользовательского ввода (form - форма) | STF
<input /> | Определяет управляющий элемент формы (input - ввод данных) | STF
<textarea> | Определяет поле многострочного ввода текста (text area — текстовая область) | STF
<button> | Определяет кнопку (button - кнопка) | STF
<select> | Определяет список выборки (выпадающий список) (select — выделение) | STF
<optgroup> | Определяет группу связанных опций в списке выбора (option group — группа опций) | STF
<option> | Определяет опцию в списке выбора (option - опция, вариант, выбор) | STF
<label> | Определяет метку для элемента input (label - метка) | STF
<fieldset> | Определяет границы вокруг элементов в форме (field set - набор полей) | STF
<legend> | Определяет заголовок элемента fieldset (legend - легенда, надпись) | STF
<isindex> | Не рекомендуется. Определяет поисковый индекс, связанный с документом (is index — это индекс) | TF
Фреймы |  |
<frame /> | Определяет окно (фрейм) в наборе фреймов (frame - рамка, кадр, фрейм) | F
<frameset> | Определяет установку фреймов (frame set — набор фреймов) | F
<noframes> | Определяет альтернативный контент для браузеров, которые не поддерживают фреймы (no frames — нет фреймов) | TF
<iframe> | Определяет встроенный фрейм (inline frame — встроенный фрейм) | TF
Изображения |  |
<img /> | Определяет изображение (image — изображение) | STF
<map> | Определяет карту изображения (map - карта) | STF
<area /> | Определяет область внутри карты изображения (area - область) | STF
Ссылки |  |
<a> | Определяет якорь (anchor — якорь) | STF
<link /> | Определяет отношение между документом и внешним ресурсом (link - ссылка) | STF
Списки |  |
<ul> | Определяет неупорядоченный (маркированный) список (unordered list— неупорядоченный список) | STF
<ol> | Определяет упорядоченный список (ordered list — упорядоченный список) | STF
<li> | Определяет элемент (пункт) списка (list item — элемент, пункт списка) | STF
<dir> | Не рекомендуется. Определяет список каталогов (directory — каталог) | TF
<dl> | Определяет список определений (definition list — список определений) | STF
<dt> | Определяет термин (пункт) в списке определений (definition term — определение термина, пункта) | STF
<dd> | Определяет описании термина в списке определений (definition description - описание определения) | STF
<menu> | Не рекомендуется. Определяет список меню (menu - меню) | TF
Таблицы |  |
<table> | Определяет таблицу (table - таблица) | STF
<caption> | Определяет заголовок таблицы (caption - заголовок) | STF
<th> | Определяет заголовочные ячейки таблицы (table header — заголовок таблицы) | STF
<tr> | Определяет строку в таблице (table row — строка таблицы) | STF
<td> | Определяет ячейку в таблице (table data — данные таблицы) | STF
<thead> | Группирует контент верхнего колонтитула таблицы (table header — верхняя часть таблицы) | STF
<tbody> | Объединяет контент тела таблицы (Groups the body content in a table) | STF
<tfoot> | Группирует контент нижнего колонтитула таблицы (table foot — нижняя часть таблицы) | STF
<col /> | Определяет значения атрибутов для одного или нескольких столбцов в таблице (column — колонка) | STF
<colgroup> | Определяет группу столбцов таблицы для форматирования (column group — группа колонок) | STF
Стили |  |
<style> | Определяет стилевую информацию для документа (style - стиль, манера) | STF
<div> | Определяет блоковый контейнер в документе (division — разделение) | STF
<span> | Определяет строковый контейнер в документе (span - промежуток) | STF
Метаинформации |  |
<head> | Определяет информацию о документе (head - голова) | STF
<title> | Определяет заголовок документа (title - заглавие) | STF
<meta> | Определяет метаинформацию о документе HTML (metainformation — метаинформация) | STF
<base /> | Определяет адрес или целевое окно по умолчанию для всех ссылок на странице (base - база, основа) | STF
<basefont /> | Не рекомендуется. Определяет шрифт, цвет или размер текста на странице по умолчанию (base font — базовый шрифт) | TF
Программирование |  |
<script> | Определяет сценарий на стороне клиента (script — сценарий, скрипт) | STF
<noscript> | Определяет альтернативный контент для браузеров, которые не поддерживают сценарии на стороне клиента (no script — нет скрипта) | STF
<applet> | Не рекомендуется. Определяет внедренный апплет (applet - апплет) | TF
<object> | Определяет внедренный объект (object - объект) | STF
<param /> | Определяет параметр для объекта (parameter — параметр) | STF


HTML Standard Attributes

HTML / XHTML Стандартные атрибуты

« Предыдущий Следующий справочник »

Атрибуты, перечисленные ниже, являются стандартными и поддерживаются, с некоторыми исключениями, всеми HTML и XHTML тегами.

Основные атрибуты

Не применимы в элементах base, head, html, meta, param, script, style и title.

Атрибут | Значение | Описание
class | имя_класса | Задает имя класса для элемента
id | идентификатор | Задает уникальный идентификатор для элемента
style | определение_стиля | Задает встроенный стиль для элемента
title | текст | Задает дополнительную информацию об элементе

Языковые атрибуты

Не применимы в элементах base, br, frame, frameset, hr, iframe, param и script.

Атрибут | Значение | Описание
dir | ltr rtl | Определяет направление текста для содержания в элементе
lang | код_языка | Указывает код языка для содержания элемента. Справочник кода языка
xml:lang | код_языка | Указывает код языка для содержания элемента в XHTML документах. Справочник кода языка

Клавиатурные атрибуты

Атрибут | Значение | Описание
accesskey | символ | Определяет сочетание клавиш для быстрого доступа к элементу
tabindex | чмсло | Определяет позицию элемента в порядке табуляции в текущем документе


HTML Event Attributes

HTML / XHTML Стандартные Событийные атрибуты

« Предыдущий Следующий справочник »

Стандартные событийные атрибуты

В HTML 4 добавлена возможность обработки событий, вызыванных действиями в браузере, подобно запуску JavaScript, когда пользователь щелкает на элементе.

Чтобы узнать больше о программировании событий, пожалуйста, посетите наш JavaScript учебник и наш DHTML учебник.

Ниже представлены стандартные событийные атрибуты, которые могут быть вставлены в HTML / XHTML элементы для определения действий по событиям.

События для <body> и <frameset>

Только два атрибута указанные ниже, могут быть использованы в <body> или <frameset>:

Атрибут | Значение | Описание
onload | скрипт | Скрипт выполняется, когда браузер закончил загрузку документа в окно или во фрейм
onunload | скрипт | Скрипт выполняется, когда браузер удаляет документ из окна или фрейма

События формы

Атрибуты, показанные ниже, могут быть использованы в элементах формы:

Атрибут | Значение | Описание
onblur | скрипт | Скрипт выполняется, когда элемент теряет фокус
onchange | скрипт | Скрипт выполняется, когда элемент управления формы меняет свое значение
onfocus | скрипт | Скрипт выполняется, когда элемент получает фокус
onreset | скрипт | Скрипт выполняется при "очистке" формы
onselect | скрипт | Скрипт выполняется, когда элемент выбран
onsubmit | скрипт | Скрипт выполняется при отправке формы

События изображения

Атрибуты, показанные ниже, могут быть использованы с элементом img:

Атрибут | Значение | Описание
onabort | скрипт | Скрипт выполняется, когда прерывается загрузка изображения

События клавиатуры

Действительны во всех элементах, кроме base, bdo, br, frame, frameset, head, html, iframe, meta, param, script, style и title.

Атрибут | Значение | Описание
onkeydown | скрипт | Скрипт выполняется, если клавиша нажата над элементом, когда он получил фокус
onkeypress | скрипт | Скрипт выполняется, когда клавиша нажата и отпущена
onkeyup | скрипт | Скрипт выполняется, когда клавиша отпущена

События мыши

Действительны во всех элементах, кроме base, bdo, br, frame, frameset, head, html, iframe, meta, param, script, style и title.

Атрибут | Значение | Описание
onclick | скрипт | Скрипт выполняется, когда пользователь «щелкает» мышью по элементу
ondblclick | скрипт | Скрипт выполняется при двойном щелчке мышью по элементу
onmousedown | скрипт | Скрипт выполняется, когда пользователь нажимает кнопку мыши над элементом
onmousemove | скрипт | Скрипт выполняется, когда пользователь перемещает курсор мыши в пределах данного элемента
onmouseout | скрипт | Скрипт выполняется, когда пользователь уводит курсор мыши за пределы элемента
onmouseover | скрипт | Скрипт выполняется, когда пользователь наводит курсор мыши на элемент
onmouseup | скрипт | Скрипт выполняется, когда пользователь после нажатия отпускает кнопку мыши над элементом


HTML Elements and Valid Doctypes

HTML элементы и допустимые типы документов

« Предыдущий Следующий справочник »

HTML/XHTML элементы и допустимые DTD

В следующей таблице перечислены все HTML/XHTML элементы и определены допустимые декларации типов документов (DTD) для каждого из них.

Тег | HTML 4.01 / XHTML 1.0 |  |  | XHTML 1.1
 | Transitional | Strict | Frameset
<a> | Yes | Yes | Yes | Yes
<abbr> | Yes | Yes | Yes | Yes
<acronym> | Yes | Yes | Yes | Yes
<address> | Yes | Yes | Yes | Yes
<applet> | Yes | No | Yes | No
<area /> | Yes | Yes | Yes | No
<b> | Yes | Yes | Yes | Yes
<base /> | Yes | Yes | Yes | Yes
<basefont /> | Yes | No | Yes | No
<bdo> | Yes | Yes | Yes | No
<big> | Yes | Yes | Yes | Yes
<blockquote> | Yes | Yes | Yes | Yes
<body> | Yes | Yes | Yes | Yes
<br /> | Yes | Yes | Yes | Yes
<button> | Yes | Yes | Yes | Yes
<caption> | Yes | Yes | Yes | Yes
<center> | Yes | No | Yes | No
<cite> | Yes | Yes | Yes | Yes
<code> | Yes | Yes | Yes | Yes
<col /> | Yes | Yes | Yes | No
<colgroup> | Yes | Yes | Yes | No
<dd> | Yes | Yes | Yes | Yes
<del> | Yes | Yes | Yes | No
<dfn> | Yes | Yes | Yes | Yes
<dir> | Yes | No | Yes | No
<div> | Yes | Yes | Yes | Yes
<dl> | Yes | Yes | Yes | Yes
<dt> | Yes | Yes | Yes | Yes
<em> | Yes | Yes | Yes | Yes
<fieldset> | Yes | Yes | Yes | Yes
<font> | Yes | No | Yes | No
<form> | Yes | Yes | Yes | Yes
<frame /> | No | No | Yes | No
<frameset> | No | No | Yes | No
От <h1> до <h6> | Yes | Yes | Yes | Yes
<head> | Yes | Yes | Yes | Yes
<hr /> | Yes | Yes | Yes | Yes
<html> | Yes | Yes | Yes | Yes
<i> | Yes | Yes | Yes | Yes
<iframe> | Yes | No | Yes | No
<img /> | Yes | Yes | Yes | Yes
<input /> | Yes | Yes | Yes | Yes
<ins> | Yes | Yes | Yes | No
<isindex> | Yes | No | Yes | No
<kbd> | Yes | Yes | Yes | Yes
<label> | Yes | Yes | Yes | Yes
<legend> | Yes | Yes | Yes | Yes
<li> | Yes | Yes | Yes | Yes
<link /> | Yes | Yes | Yes | Yes
<map> | Yes | Yes | Yes | No
<menu> | Yes | No | Yes | No
<meta /> | Yes | Yes | Yes | Yes
<noframes> | Yes | No | Yes | No
<noscript> | Yes | Yes | Yes | Yes
<object> | Yes | Yes | Yes | Yes
<ol> | Yes | Yes | Yes | Yes
<optgroup> | Yes | Yes | Yes | Yes
<option> | Yes | Yes | Yes | Yes
<p> | Yes | Yes | Yes | Yes
<param /> | Yes | Yes | Yes | Yes
<pre> | Yes | Yes | Yes | Yes
<q> | Yes | Yes | Yes | Yes
<s> | Yes | No | Yes | No
<samp> | Yes | Yes | Yes | Yes
<script> | Yes | Yes | Yes | Yes
<select> | Yes | Yes | Yes | Yes
<small> | Yes | Yes | Yes | Yes
<span> | Yes | Yes | Yes | Yes
<strike> | Yes | No | Yes | No
<strong> | Yes | Yes | Yes | Yes
<style> | Yes | Yes | Yes | Yes
<sub> | Yes | Yes | Yes | Yes
<sup> | Yes | Yes | Yes | Yes
<table> | Yes | Yes | Yes | Yes
<tbody> | Yes | Yes | Yes | No
<td> | Yes | Yes | Yes | Yes
<textarea> | Yes | Yes | Yes | Yes
<tfoot> | Yes | Yes | Yes | No
<th> | Yes | Yes | Yes | Yes
<thead> | Yes | Yes | Yes | No
<title> | Yes | Yes | Yes | Yes
<tr> | Yes | Yes | Yes | Yes
<tt> | Yes | Yes | Yes | Yes
<u> | Yes | No | Yes | No
<ul> | Yes | Yes | Yes | Yes
<var> | Yes | Yes | Yes | Yes


HTML Названия цветов (Color Names)

« Предыдущий Следующий Справочник »

Названия цветов, поддерживаемые всеми браузерами

Ниже представлен полный список названий цветов, которые поддерживаются всеми основными браузерами.

Вы можете щелкнуть по названию цвета (или HEX значению), чтобы увидеть этот цвет в качестве фона вместе с текстом разных цветов.

Отсортированные по названиям (Sorted by Names)

Ссылка: Тот же список, отсортированный по значениям

Название цвета | HEX | Цвет | Оттенки | Смесь
AliceBlue | #F0F8FF |  | Shades | Mix
AntiqueWhite | #FAEBD7 |  | Shades | Mix
Aqua | #00FFFF |  | Shades | Mix
Aquamarine | #7FFFD4 |  | Shades | Mix
Azure | #F0FFFF |  | Shades | Mix
Beige | #F5F5DC |  | Shades | Mix
Bisque | #FFE4C4 |  | Shades | Mix
Black | #000000 |  | Shades | Mix
BlanchedAlmond | #FFEBCD |  | Shades | Mix
Blue | #0000FF |  | Shades | Mix
BlueViolet | #8A2BE2 |  | Shades | Mix
Brown | #A52A2A |  | Shades | Mix
BurlyWood | #DEB887 |  | Shades | Mix
CadetBlue | #5F9EA0 |  | Shades | Mix
Chartreuse | #7FFF00 |  | Shades | Mix
Chocolate | #D2691E |  | Shades | Mix
Coral | #FF7F50 |  | Shades | Mix
CornflowerBlue | #6495ED |  | Shades | Mix
Cornsilk | #FFF8DC |  | Shades | Mix
Crimson | #DC143C |  | Shades | Mix
Cyan | #00FFFF |  | Shades | Mix
DarkBlue | #00008B |  | Shades | Mix
DarkCyan | #008B8B |  | Shades | Mix
DarkGoldenRod | #B8860B |  | Shades | Mix
DarkGray | #A9A9A9 |  | Shades | Mix
DarkGreen | #006400 |  | Shades | Mix
DarkKhaki | #BDB76B |  | Shades | Mix
DarkMagenta | #8B008B |  | Shades | Mix
DarkOliveGreen | #556B2F |  | Shades | Mix
Darkorange | #FF8C00 |  | Shades | Mix
DarkOrchid | #9932CC |  | Shades | Mix
DarkRed | #8B0000 |  | Shades | Mix
DarkSalmon | #E9967A |  | Shades | Mix
DarkSeaGreen | #8FBC8F |  | Shades | Mix
DarkSlateBlue | #483D8B |  | Shades | Mix
DarkSlateGray | #2F4F4F |  | Shades | Mix
DarkTurquoise | #00CED1 |  | Shades | Mix
DarkViolet | #9400D3 |  | Shades | Mix
DeepPink | #FF1493 |  | Shades | Mix
DeepSkyBlue | #00BFFF |  | Shades | Mix
DimGray | #696969 |  | Shades | Mix
DodgerBlue | #1E90FF |  | Shades | Mix
FireBrick | #B22222 |  | Shades | Mix
FloralWhite | #FFFAF0 |  | Shades | Mix
ForestGreen | #228B22 |  | Shades | Mix
Fuchsia | #FF00FF |  | Shades | Mix
Gainsboro | #DCDCDC |  | Shades | Mix
GhostWhite | #F8F8FF |  | Shades | Mix
Gold | #FFD700 |  | Shades | Mix
GoldenRod | #DAA520 |  | Shades | Mix
Gray | #808080 |  | Shades | Mix
Green | #008000 |  | Shades | Mix
GreenYellow | #ADFF2F |  | Shades | Mix
HoneyDew | #F0FFF0 |  | Shades | Mix
HotPink | #FF69B4 |  | Shades | Mix
IndianRed | #CD5C5C |  | Shades | Mix
Indigo | #4B0082 |  | Shades | Mix
Ivory | #FFFFF0 |  | Shades | Mix
Khaki | #F0E68C |  | Shades | Mix
Lavender | #E6E6FA |  | Shades | Mix
LavenderBlush | #FFF0F5 |  | Shades | Mix
LawnGreen | #7CFC00 |  | Shades | Mix
LemonChiffon | #FFFACD |  | Shades | Mix
LightBlue | #ADD8E6 |  | Shades | Mix
LightCoral | #F08080 |  | Shades | Mix
LightCyan | #E0FFFF |  | Shades | Mix
LightGoldenRodYellow | #FAFAD2 |  | Shades | Mix
LightGrey | #D3D3D3 |  | Shades | Mix
LightGreen | #90EE90 |  | Shades | Mix
LightPink | #FFB6C1 |  | Shades | Mix
LightSalmon | #FFA07A |  | Shades | Mix
LightSeaGreen | #20B2AA |  | Shades | Mix
LightSkyBlue | #87CEFA |  | Shades | Mix
LightSlateGray | #778899 |  | Shades | Mix
LightSteelBlue | #B0C4DE |  | Shades | Mix
LightYellow | #FFFFE0 |  | Shades | Mix
Lime | #00FF00 |  | Shades | Mix
LimeGreen | #32CD32 |  | Shades | Mix
Linen | #FAF0E6 |  | Shades | Mix
Magenta | #FF00FF |  | Shades | Mix
Maroon | #800000 |  | Shades | Mix
MediumAquaMarine | #66CDAA |  | Shades | Mix
MediumBlue | #0000CD |  | Shades | Mix
MediumOrchid | #BA55D3 |  | Shades | Mix
MediumPurple | #9370D8 |  | Shades | Mix
MediumSeaGreen | #3CB371 |  | Shades | Mix
MediumSlateBlue | #7B68EE |  | Shades | Mix
MediumSpringGreen | #00FA9A |  | Shades | Mix
MediumTurquoise | #48D1CC |  | Shades | Mix
MediumVioletRed | #C71585 |  | Shades | Mix
MidnightBlue | #191970 |  | Shades | Mix
MintCream | #F5FFFA |  | Shades | Mix
MistyRose | #FFE4E1 |  | Shades | Mix
Moccasin | #FFE4B5 |  | Shades | Mix
NavajoWhite | #FFDEAD |  | Shades | Mix
Navy | #000080 |  | Shades | Mix
OldLace | #FDF5E6 |  | Shades | Mix
Olive | #808000 |  | Shades | Mix
OliveDrab | #6B8E23 |  | Shades | Mix
Orange | #FFA500 |  | Shades | Mix
OrangeRed | #FF4500 |  | Shades | Mix
Orchid | #DA70D6 |  | Shades | Mix
PaleGoldenRod | #EEE8AA |  | Shades | Mix
PaleGreen | #98FB98 |  | Shades | Mix
PaleTurquoise | #AFEEEE |  | Shades | Mix
PaleVioletRed | #D87093 |  | Shades | Mix
PapayaWhip | #FFEFD5 |  | Shades | Mix
PeachPuff | #FFDAB9 |  | Shades | Mix
Peru | #CD853F |  | Shades | Mix
Pink | #FFC0CB |  | Shades | Mix
Plum | #DDA0DD |  | Shades | Mix
PowderBlue | #B0E0E6 |  | Shades | Mix
Purple | #800080 |  | Shades | Mix
Red | #FF0000 |  | Shades | Mix
RosyBrown | #BC8F8F |  | Shades | Mix
RoyalBlue | #4169E1 |  | Shades | Mix
SaddleBrown | #8B4513 |  | Shades | Mix
Salmon | #FA8072 |  | Shades | Mix
SandyBrown | #F4A460 |  | Shades | Mix
SeaGreen | #2E8B57 |  | Shades | Mix
SeaShell | #FFF5EE |  | Shades | Mix
Sienna | #A0522D |  | Shades | Mix
Silver | #C0C0C0 |  | Shades | Mix
SkyBlue | #87CEEB |  | Shades | Mix
SlateBlue | #6A5ACD |  | Shades | Mix
SlateGray | #708090 |  | Shades | Mix
Snow | #FFFAFA |  | Shades | Mix
SpringGreen | #00FF7F |  | Shades | Mix
SteelBlue | #4682B4 |  | Shades | Mix
Tan | #D2B48C |  | Shades | Mix
Teal | #008080 |  | Shades | Mix
Thistle | #D8BFD8 |  | Shades | Mix
Tomato | #FF6347 |  | Shades | Mix
Turquoise | #40E0D0 |  | Shades | Mix
Violet | #EE82EE |  | Shades | Mix
Wheat | #F5DEB3 |  | Shades | Mix
White | #FFFFFF |  | Shades | Mix
WhiteSmoke | #F5F5F5 |  | Shades | Mix
Yellow | #FFFF00 |  | Shades | Mix
YellowGreen | #9ACD32 |  | Shades | Mix

Примечание: приведенные выше названия, не являются частью W3C веб стандарта.

W3C HTML и CSS стандартами перечислены лишь 16 допустимых названий цветов:
aqua (морской волны), black (черный), blue (синий), fuchsia (фуксия), gray (серый), green (зеленый), lime (лайм), maroon (коричнево-малиновый), navy (темно-синий), olive (оливковый), purple (пурпурный), red (красный), silver (серебряный), teal (сине-зеленый), white (белый ) и yellow (желтый).

If you want valid HTML or CSS use the HEX values instead.


HTML Тег <!--...-->

Пример

HTML комментарий:

<!--Это комментарий. Комментарии не отображаются в браузере-->

<p>Это абзац.</p>

Попробуйте сами »

Определение и использование

Тег комментарий используется для вставки комментарий в исходный код. Комментарии будет игнорироваться браузером. Вы можете использовать комментарии, чтобы объяснить свой код. Это может помочь вам при редактировании исходного кода в дальнейшем.

Вы можете также хранить программную информации внутри комментарий. В этом случае они не будут видимы для пользователя, но будут доступны для программирования. Хорошей практикой является комментирование текст внутри скриптов и элементов стиля, чтобы старые браузеры, которые не поддерживают сценарии и стили, не показывали их как обычный текст.

Стандартные атрибуты

Тег комментарий не поддерживает стандартные атрибуты.

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег комментарий не поддерживает событийные атрибуты.

Более подробная информация о Событийных атрибутах.


Тег !DOCTYPE

HTML Декларация <!DOCTYPE>

Пример

HTML документ с определенным типом XHTML 1.0 Transitional:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html>
<head>
<title>Заголовок документа</title>
</head>

<body>
Содержание документа......
</body>

</html>

Попробуйте сами »

Определение и использование

Декларация типа документа должна находиться в самом начале HTML документа, перед тегом <html>.

Декларация типа документа не является тегом HTML, это инструкция веб-браузеру о версии языка разметки, на котором написана страница.

Декларация типа документа обращается к определению типа документа: Document Type Definition (DTD). DTD задает правила для языка разметки так, чтобы браузеры правильно воспроизводили содержание.

Элементы HTML/XHTML и действующие DTD

Смотрите нашу таблицу всех HTML/XHTML элементов, и в какой DTD показывается каждый элемент.

Типы документов, имеющиеся в нашем распоряжении по рекомендациям W3C

HTML 4.01 Strict

Это DTD охватывает все HTML элементы и атрибуты, но НЕ ВКЛЮЧАЕТ презентационные или устаревшие элементы (например, font). Фреймы не допускается.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

HTML 4.01 Transitional

Это DTD охватывает все HTML элементы и атрибуты,ВКЛЮЧАЯ презентационные или устаревшие элементы (например, font). Фреймы не допускается.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

HTML 4.01 Frameset

Это DTD равносилен HTML 4.01 Transitional, но позволяет использовать содержимое фреймов.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN" "http://www.w3.org/TR/html4/frameset.dtd">

XHTML 1.0 Strict

Это DTD охватывает все HTML элементы и атрибуты, но НЕ ВКЛЮЧАЕТ презентационные или устаревшие элементы (например, font). Фреймы не допускается. Разметка должна быть записана как правильно отформатированный XML.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

XHTML 1.0 Transitional

Это DTD охватывает все HTML элементы и атрибуты, но НЕ ВКЛЮЧАЕТ презентационные или устаревшие элементы (например, font). Фреймы не допускается. Разметка должна быть записана как правильно отформатированный XML.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

XHTML 1.0 Frameset

Это DTD равносилен XHTML 1.0 Transitional, но позволяет использовать содержимое фреймов.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">

XHTML 1.1

Это DTD равносилен XHTML 1.0 Strict, но позволяет добавлять модули (например, чтобы обеспечить ruby поддержку для восточно-азиатских языков) .

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">


HTML Тег <a>

Пример

Ссылка на W3Schools.com:

<a href="http://www.w3schools.com">Посетите W3Schools.com!</a>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Тег <a> определяет якорь. Якорь можно использовать двумя способами:

  1. Чтобы создать ссылку на другой документ, используя атрибут href
  2. Чтобы создать закладку в документе, используя атрибут name

Элемент a обычно называют ссылкой или гиперссылкой.

Наиболее важным атрибутом элемента a является атрибут href, который указывает адресат ссылки.

По умолчанию ссылки во всех браузерах будут выглядеть следующим образом:

  • Непосещенная ссылка - подчеркнута и синяя
  • Посещенная ссылка - подчеркнута и пурпурная
  • Активная ссылка - подчеркнута и красная

Поддержка браузерами

Тег <a> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В XHTML атрибут name тега <a> является не рекомендуемым и будет удален. Используйте вместо него атрибут id.

Советы и примечания

Совет: Используйте CSS для стилизации ссылок!

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
charset | кодировка_символов | Определяет набор символов для связанного документа | STF
coords | координаты | Определяет координаты ссылки | STF
href | URL | Определяет адресат ссылки | STF
hreflang | код_языка | Указывает язык текста ссылочного документа | STF
name | имя_раздела | Определяет имя якоря | STF
rel | текст | Определяет связь между текущим документом и ссылочным документом | STF
rev | текст | Определяет связь между ссылочным документом и текущим документом | STF
shape | default rect circle poly | Определяет форму ссылку | STF
target | _blank _parent _self _top framename | Указывает, где открыть ссылочный документ | TF

Стандартные атрибуты

Тег <a> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
accesskey | символ | Определяет сочетание клавиш для доступа к элементу | STF
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
tabindex | число | Указывает порядке перехода к элементу | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <a> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onblur | скрипт | Скрипт выполняется, когда элемент теряет фокус | STF
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onfocus | скрипт | Скрипт выполняется, когда элемент получает фокус | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.

Examples

Попробуйте сами - Примеры

Создание гиперссылок
Как создать гиперссылки.

Изображение в качестве ссылки
Как использовать изображения в качестве ссылки.

Открыть ссылку в новом окне браузера
Как открыть ссылку в новом окне браузера так, чтобы посетитель не ушел со своего веб-сайта.

Ссылка на место на тот же самой странице
Как сделать ссылку на закладку.

Выход из фрейма
Как выйти из фрейма (если ваш сайт заблокирован во фрейме).

Создать mailto ссылку
Как создать почтовую ссылку (будет работать только если у вас установлена почта).

Создать mailto ссылку 2
Другая почтовая ссылка.


HTML Тег <abbr>

Пример

Аббревиатура размечается подобно следующему:

The <abbr title="HyperText Markup Language (Язык гипертекстовой разметки)">HTML</abbr> был стандартизирован в 1995 году.

Попробуйте сами »

Определение и использование

Тег <abbr> описывает Аббревиатуру - сокращенное написание слова или группы слов (произносится побуквенно).

По разметки сокращений вы можете дать полезную информацию для браузеров, программ проверки правописания, программ экранного доступа, системам машинного перевода и поисковым машинам .

Поддержка браузерами

Тег <abbr> поддерживается всеми основными браузерами.

Примечание: Тег <abbr> не поддерживается в IE 6 или более ранних версиях.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Атрибута title используется, чтобы показать описание сокращения при наведении на него указателя мыши.

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Тег <abbr> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <abbr> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <acronym>

Пример

Акроним размечается подобно следующему:

Я могу получить этот акроним <acronym title="Высшее учебное заведение">Вуз</acronym>?

Попробуйте сами »

Определение и использование

Тег <acronym> определяет Акроним - образование из начальных букв исходного словосочетания (произносится как единое слово).

По разметки сокращений вы можете дать полезную информацию для браузеров, программ проверки правописания, программ экранного доступа, системам машинного перевода и поисковым машинам.

Поддержка браузерами

Тег <acronym> поддерживается всеми основными браузерами.

Note: Тег <acronym> не поддерживается в IE 5.5 или более ранних версиях.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Атрибута title используется, чтобы показать описание сокращения при наведении на него указателя мыши.

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Тег <acronym> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <acronym> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег<address>

Пример

Контактная информация для W3Schools.com:

<address>
Напишите W3Schools.com<br />
<a href="mailto:us@example.org">Email</a><br />
Адрес: Box 564, Disneyland<br />
Телефон: +12 34 56 78
</address>

Попробуйте сами »

Определение и использование

Тег <address> определяет контактную информацию от автора или владельца документа. Таким образом, читатель имеет возможность связаться с владельцем документа.

Элемент address, как правило, добавляется в верхнем или нижнем колонтитуле страницы.

Поддержка браузерами

Тег <address> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Во всех браузерах, содержание элемента address представляется курсивом. Большинство браузеров также добавит разрыв строки до и после элемента address.

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Тег <address> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <address> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <applet>

Элемент applet является не рекомендуемым.

Пример

Встроенный Java-апплет:

<applet code="Bubbles.class" width="350" height="350">
Java-апплет, который рисует анимированные пузыри
</applet>

Определение и использование

Тег <applet> определяет встроенный апплет.

Поддержка браузерами

Примечание: There is still some support for the <applet> tag in some browsers, but it requires additional plug-ins/installations to work.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Чтобы включить апплеты, используйте вместо него элемент <object>!

Обязательные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
code | URL | Определяет имя файла Java-апплета | TF
object | имя | Указывает ссылку на сериализованное представление апплета | TF

Дополнительные атрибуты

Атрибут | Значение | Описание | DTD
align | left right top bottom middle baseline | Задает выравнивание апплета в соответствии с окружающими элементами | TF
alt | текст | Задает альтернативный текст для апплета | TF
archive | URL | Задает местоположение файла архива | TF
codebase | URL | Определяет базовый путь, используемый для разрешения относительных URI attribute | TF
height | пиксели | Указывает высоту апплета | TF
hspace | пиксели | Определяет размер свободного пространства слева и справа от апплета | TF
name | имя | Определяет имя апплета (для использования в скриптах) | TF
vspace | pixels | Определяет размер свободного пространства сверху и снизу от апплета | TF
width | пиксели | Указывает ширину апплета | TF

Стандартные атрибуты

Тег <applet> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <applet> не поддерживает событийные атрибуты:

Более подробная информация о Событийных атрибутах.


HTML Тег <area>

Пример

Карта изображения с интерактивными областями:

<img src ="planets.gif" width="145" height="126" alt="Планеты" usemap ="#planetmap" />

<map name="planetmap">
<area shape="rect" coords="0,0,82,126" href="sun.htm" alt="Солнце" />
<area shape="circle" coords="90,58,3" href="mercur.htm" alt="Меркурий" />
<area shape="circle" coords="124,58,8" href="venus.htm" alt="Венера" />
</map>

Попробуйте сами »

Определение и использование

Тег <area> определяет область внутри карты изображения (карта изображения есть изображение с интерактивными областями).

Элемент area всегда является вложенным в тег <map>.

Примечание: Атрибут usemap в теге <img> связан атрибутом name элемента map исоздает отношение между изображение и картой.

Поддержка браузерами

Тег <area> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В HTML тег <area> не имеет закрывающего тега.

В XHTML тег <area> должен быть правильно закрыт.

Советы и примечания

Примечание: Элемент form является элементом блокового уровня, поэтому создает линии разрыва до и после себя.

Обязательные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
alt | текст | Задает альтернативный текст для области | STF

Дополнительные атрибуты

Атрибут | Значение | Описание | DTD
coords | координаты | Определяет координаты области | STF
href | URL | Определяет адресат ссылки на область | STF
nohref | nohref | Указывает, что область не имеет соответствующей ссылки | STF
shape | default rect circle poly | Определяет форму области | STF
target | _blank _parent _self _top | Определяет, где открыть связанную страницу, указанную в атрибуте href | TF

Стандартные атрибуты

Тег <area> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
accesskey | символ | Определяет сочетание клавиш для доступа к элементу | STF
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
tabindex | число | Указывает порядке перехода к элементу | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <area> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onblur | скрипт | Скрипт выполняется, когда элемент теряет фокус | STF
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onfocus | скрипт | Скрипт выполняется, когда элемент получает фокус | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Теги tt,i,b,big,small

HTML Теги <tt> <i> <b> <big> <small>

Пример

Форматирование текста в документе:

<tt>Телетайпный текст</tt>
<i>Курсивный текст</i>
<b>Жирный (полужирный) текст</b>
<big>Текст увеличенного размера</big>
<small>Текст уменьшенного размера</small>

Попробуйте сами »

Определение и использование

Теги <tt>, <i>, <b>, <big> и <small> являются тегами начертания шрифта. Теги начертания шрифта определены в HTML 4, но настоятельно рекомендуется использовать вместо них CSS стилизованное оформление текста.

Тег | Описание
<i> | Изображается как курсивный текст
<b> | Изображается как полужирный текст
<big> | Изображается как крупный текст
<tt> | Изображается как телетайпный текст
<small> | Изображается как уменьшенный текст

Примечание: Теги <tt> и <big> удаляются из HTML5 версии. Избегайте их использование.

Поддержка браузерами

Теги <tt>, <i>, <b>, <big> и <small> поддерживаются всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Standard Attributes

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Теги <tt>, <i>, <b>, <big> и <small> поддерживают следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Теги <tt>, <i>, <b>, <big> и <small> поддерживают следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <base>

Пример

Укажите URL-адрес и цель (target) по умолчанию для всех ссылок на странице:

<head>
<base href="http://www.w3schools.com/images/" />
<base target="_blank" />
</head>

<body>
<img src="stickman.gif" />
<a href="http://www.w3schools.com">W3Schools</a>
</body>

Попробуйте сами »

Определение и использование

Тег <base> tуказывает адрес или цель (target) по умолчанию для всех ссылок на странице.

Тег <base> должен быть внутри элемента head.

Поддержка браузерами

Тег <base> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В HTML тег <base> не имеет закрывающего тега.

В XHTML тег <base> должен быть правильно закрыт.

Атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
href | URL | Указывает базовый URL для всех относительных URL-адресов на странице. Примечание: Базовый URL должен быть абсолютным URL! | STF
target | _blank _parent _self _top framename | Определяет, где открыть все ссылки на странице | TF

Стандартные атрибуты

Тег <base> не поддерживает стандартные атрибуты.

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <base> не поддерживает событийные атрибуты.

Более подробная информация о Событийных атрибутах.


HTML Тег <basefont>

Элемент basefont является не рекомендуемым.

Пример

Укажите цвет шрифта и размер шрифта по умолчанию для текста на странице:

<head>
<basefont color="red" size="5" />
</head>

<body>
<h1>Это заголовок</h1>
<p>Это абзац</p>
</body>

Попробуйте сами »

Определение и использование

Тег <basefont> указывает цвет шрифта, размер шрифта и семейство шрифтов по умолчанию для всего текста в документе.

Поддержка браузерами

Тег <basefont> поддерживается только в Internet Explorer и его следует избегать!

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Используйте CSS для указания цвета шрифта, размера шрифта и семейства шрифтов по умолчанию для всего текста в документе.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
color | rgb(x,x,x) #xxxxxx название цвета | Не рекомендуется. Вместо него используйте стили. Задает цвет по умолчанию для текста в документе | TF
face | font_family | Не рекомендуется. Вместо него используйте стили. Задает шрифт по умолчанию для текста в документе | TF
size | число | Не рекомендуется. Вместо него используйте стили. Задает размер шрифта по умолчанию для текста в документе | TF

Стандартные атрибуты

Тег <basefont> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <basefont> не поддерживает событийные атрибуты:

Более подробная информация о Событийных атрибутах.


HTML Тег <bdo>

Пример

Укажите направление текста:

<bdo dir="rtl">Вот некоторый текст на иврите!</bdo>

Попробуйте сами »

Определение и использование

bdo - аббревиатура от bidirectional override (двунаправленное переопределение).

Тег <bdo> позволяет указать направление текста и переопределить двунаправленный алгоритм.

Поддержка браузерами

Тег <bdo> поддерживается всеми основными браузерами.

Примечание: Этот тег не поддерживается в Safari версии 2 и более ранних.

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
dir | ltr rtl | Определяет направление текста внутри элемента bdo | STF

Стандартные атрибуты

Тег <bdo> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <bdo> не поддерживает событийные атрибуты.

Более подробная информация о Событийных атрибутах.


HTML Тег <blockquote>

Пример

Длинная (многословная) цитата размечается подобно следующему:

<blockquote>
Вот многословная цитата вот многословная цитата вот многословная цитата вот многословная цитата вот многословная цитата вот многословная цитата вот многословная цитата вот многословная цитата вот многословная цитата.
</blockquote>

Попробуйте сами »

Определение и использование

Тег <blockquote> определяет многословную цитату.

Браузер вставляет интерваля до и после элемента blockquote. Он также вставляет поля для элемента blockquote.

Поддержка браузерами

Тег <blockquote> поддерживается всеми основными браузерами.

Примечание: Ни один из основных браузеров не отображает правильно атрибут cite.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Use the q Используйте элемент q для разметки коротких цитат!

Примечание: Чтобы обосновать элемент blockquote, как strict HTML/XHTML, он должен содержать только другие элементы блочного уровня, подобно следующему:

<blockquote>
<p>Вот многословная цитата вот многословная цитата</p>
</blockquote>

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
cite | URL | Указывает источник цитаты | STF

Стандартные атрибуты

Тег <blockquote> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <blockquote> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <body>

Пример

Простой HTML документ, с минимумом необходимых тегов:

<html>
<head>
<title>Заголовок документа</title>
</head>

<body>
Содержание документа......
</body>

</html>

Попробуйте сами »

Определение и использование

Элемент body определяет тело документа.

Элемент body содержит весь контент документа HTML, такой как текст, гиперссылки, изображения, таблицы, списки и т.д.

Поддержка браузерами

Тег <body> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
alink | rgb(x,x,x) #xxxxxx название цвета | Не рекомендуется. Вместо него используйте стили. Определяет цвет активной ссылки в документе | TF
background | URL | Не рекомендуется. Вместо него используйте стили. Определяет фоновое изображение для документа | TF
bgcolor | rgb(x,x,x) #xxxxxx название цвета | Не рекомендуется. Вместо него используйте стили. Определяет цвет фона документа | TF
link | rgb(x,x,x) #xxxxxx название цвета | Не рекомендуется. Вместо него используйте стили. Определяет цвет непосещенных ссылок в документе по умолчанию | TF
text | rgb(x,x,x) #xxxxxx название цвета | Не рекомендуется. Вместо него используйте стили. Определяет цвет текста в документе | TF
vlink | rgb(x,x,x) #xxxxxx название цвета | Не рекомендуется. Вместо него используйте стили. Определяет цвет посещенных ссылок в документе | TF

Стандартные атрибуты

Тег <body> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <body> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onload | скрипт | Скрипт выполняется, когда закончена загрузка документа в браузер |
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | >Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF
onunload | скрипт | Скрипт выполняется, когда документ выгружен из браузера |

Более подробная информация о Событийных атрибутах.


HTML Тег <br>

Пример

Разрыв строки размечается подобно следующему:

Этот текст содержит<br />разрыв строки.

Попробуйте сами »

Определение и использование

Тег <br> вставляет одиночный разрыв строки.

Тег <br> является пустым тегом. Это означает, что он не имеет закрывающего тега.

Поддержка браузерами

Тег <br> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В HTML тег <br> не имеет конечный тег.

В XHTML тег <br> должен быть закрыт следующим образом: <br />.

Советы и примечания

Примечание: Используйте тег <br> для вставки разрывов строки, но не для создания абзацев.

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F= Frameset.

Тег <br> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <br> не поддерживает событийные атрибуты.

Более подробная информация о Событийных атрибутах.


HTML Тег <button>

Пример

Кнопка размечается подобно следующему:

<button type="button">Щелкни меня!</button>

Попробуйте сами »

Определение и использование

Тег <button> определяет кнопку.

Внутри элемента button можно поместить содержимое, например текст или изображения. Вот в чем разница между этим элементом и кнопками, созданными элементом input.

Всегда указывайте атрибут type для кнопки. Значение атрибута type по умолчанию для Internet Explorer есть "button", в то время как в других браузерах (и в спецификации W3C) это "submit".

Поддержка браузерами

Тег <button> поддерживается всеми основными браузерами.

Примечание: Если вы используете элемент button в HTML форме, различные браузеры будут вставлять различные значения. Internet Explorer будет вставлять текст, расположенный между тегами <button> и </button>, в то время как другие браузеры будут вставлять содержание атрибута value. Используйте элемент input для создания кнопки на HTML форме.

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
disabled | disabled | Указывает, что кнопка будет недоступна | STF
name | name | Определяет имя для кнопки | STF
type | button reset submit | Указывает тип кнопки | STF
value | text | Задает текстовый заголовок для кнопки | STF

Стандартные атрибуты

Тег <xxx> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
accesskey | символ | Определяет сочетание клавиш для доступа к элементу | STF
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
tabindex | число | Указывает порядке перехода к элементу | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <xxx> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onblur | скрипт | Скрипт выполняется, когда элемент теряет фокус | STF
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onfocus | скрипт | Скрипт выполняется, когда элемент получает фокус | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <caption>

Пример

Таблица с заголовком:

<table border="1">
<caption>Ежемесячные накопления</caption>
<tr>
<th>Месяц</th>
<th>Накопление</th>
</tr>
<tr>
<td>Январь</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

Тег <caption> определяет заголовок таблицы.

Тег <caption> должен быть вставлен непосредственно после тега <table>. Вы можете указать только один заголовок в таблице. Обычно заголовок будет отцентрирован над таблицей.

Поддержка браузерами

Тег <caption> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | left right top bottom | Не рекомендуется. Вместо него используйте стили. Определяет выравнивание заголовка | TF

Стандартные атрибуты

Тег <caption> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <caption> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <center>

Элемент center является не рекомендуемым.

Пример

Центрирование текста на HTML странице:

<center>Этот текст будет отцентрирован.</center>

Попробуйте сами »

Определение и использование

Тег <center> используется для центрирования текста.

Поддержка браузерами

Тег <center> поддерживается всеми основными браузерами. Тем не менее, он является не рекомендуемым и его использование следует избегать!

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Используйте CSS для центрирования текста! В нашем учебнике CSS вы можете найти более подробную информацию о центрировании текста.

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Тег <center> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <center> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Теги em,strong,dfn,code,samp,kbd,var,cite

HTML Теги <em> <strong> <dfn> <code> <samp> <kbd> <var> <cite>

Пример

Форматирование текста в документе:

<em>Акцентированный (курсивный) текст</em>
<strong>Акцентированный (полужирный) текст</strong>
<dfn>Определение термина</dfn>
<code>Текст компьютерного кода</code>
<samp>Текст примера программного кода</samp>
<kbd>Текст, вводимый с клавиатуры</kbd>
<var>Переменная</var>
<cite>Цитата</cite>

Попробуйте сами »

Определение и использование

Теги <em>, <strong>, <dfn>, <code>, <samp>, <kbd>, <var> и <cite> выделяют некоторые фрагменты текста. Они не являются не нерекомендуемыми, но больший эффект достигается с использованием CSS.

Тег | Описание
<em> | Воспризводится как акцентированный (курсивный) текст
<strong> | Воспризводится как акцентированный (полужирный) текст
<dfn> | Определяет определение термина
<code> | Определяет текст компьютерного кода
<samp> | Определяет текст примера программного кода
<kbd> | Определяет текст, вводимый с клавиатуры
<var> | Определяет переменную, как часть текста
<cite> | Определяет цитату

Поддержка браузерами

Теги <em>, <strong>, <dfn>, <code>, <samp>, <kbd>, <var> и <cite> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Теги <em>, <strong>, <dfn>, <code>, <samp>, <kbd>, <var> и <cite> поддерживают следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Теги <em>, <strong>, <dfn>, <code>, <samp>, <kbd>, <var> и <cite> поддерживают следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <col>

Пример

Элементы col, определяющие различные выравнивания для трех столбцов в таблице:

<table width="100%" border="1">
<col align="left" />
<col align="left" />
<col align="right" />
<tr>
<th>ISBN</th>
<th>Название</th>
<th>Цена</th>
</tr>
<tr>
<td>3476896</td>
<td>Мой первый HTML</td>
<td>$53</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

Тег <col> определяет значения атрибутов для одного или нескольких столбцов таблицы.

Тег <col> полезен для применения стилей для целых столбцов, вместо повторения стилей для каждой ячейки или для каждой строки.

Тег <col> может быть использован только внутри таблицы или элемента colgroup.

Поддержка браузерами

Тег <col> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В HTML тег <col> не имеет закрывающего тега.

В XHTML тег <col> должен быть правильно закрыт.

Советы и примечания

Совет: Добавьте атрибут style в тег <col>, и пусть CSS заботиться о свойствах background, width и border. Только эти CSS свойства работают с тегом <col>. Попробуйте сами.

Также посмотрите на тег <colgroup>.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | left right center justify char | Определяет выравнивание содержимого, связанного с элементом col | STF
char | символ | Определяет символ внутри содержания элемента col, служащий осью для выравнивания | STF
charoff | число | Устанавливает горизонтальный отступ для первого экземпляра символа, указанного атрибутом char | STF
span | число | Определяет количество столбцов, которые должен охватывать элемент col | STF
valign | top middle bottom baseline | Определяет вертикальное выравнивание содержимого, связанного с элементом col | STF
width | % пиксели relative_length | Определяет ширину элемента col | STF

Стандартные атрибуты

Тег <col> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <col> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <colgroup>

Пример

Два элемента colgroup, которые определяют различные выравнивания для трех столбцов в таблице (обратите внимание, что первый элемент colgroup охватывает две колонки):

<table width="100%" border="1">
<colgroup span="2" align="left"></colgroup>
<colgroup align="right" style="color:#0000FF;"></colgroup>
<tr>
<th>ISBN</th>
<th>Название</th>
<th>Цена</th>
</tr>
<tr>
<td>3476896</td>
<td>Мой первый HTML</td>
<td>$53</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

Тег <colgroup> используется, чтобы группировать столбцы в таблице для форматирования.

Тег <colgroup> полезен для применения стилей для целых столбцов, вместо повторения стилей для каждой ячейки или для каждой строки.

Тег <colgroup> может быть использован только внутри элемента table.

Поддержка браузерами

Тег <colgroup> поддерживается всеми основными браузерами.

Примечание: Только Firefox, Chrome и Safari поддерживают атрибуты span и width элемента colgroup.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Добавьте атрибут style в тег <colgroup>, и пусть CSS заботиться о свойствах background, width и border. Только эти CSS свойства работают с тегом <colgroup>. Попробуйте сами.

Также посмотрите на тег <col>.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | left right center justify char | Выравнивает содержимое в группе столбцов | STF
char | символ | Выравнивает содержимое в группе столбцов по символу | STF
charoff | число | Устанавливает количество символов содержимого, которое будет выровнено в соответствие с символом, заданным атрибутом char | STF
span | число | Определяет количество столбцов группы столбцов, которые должны быть охватчены | STF
valign | top middle bottom baseline | Определяет вертикальное выравнивание содержимого группы столбцов | STF
width | pixels % relative_length | Определяет ширину группы столбцов | STF

Стандартные атрибуты

Тег <colgroup> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <colgroup> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <dd>

Пример

Описание пунктов в списке определений:

<dl>
<dt>Кофе</dt>
<dd>- черный горячий напиток</dd>
<dt>Молоко</dt>
<dd>- белый холодный напиток</dd>
</dl>

Попробуйте сами »

Определение и использование

Тег <dd> используется для описания элемента в списке определений.

Тег <dd> используется в сочетании с тегом <dl> (определяет список определений) и тегом <dt> (определяет пункт в списке).

Внутри тега <dd> вы можете поместить абзацы, разрывы строк, изображения, ссылки, списки и т.д.

Поддержка браузерами

Тег <dd> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Тег <dd> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <dd> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <del>

Пример

Текст с обозначенными удаляемой частью и вставленной частью:

<p>Мой любимый цвет <del>синий</del> <ins>красный</ins>!</p>

Попробуйте сами »

Определение и использование

Тег <xxx> определяет текст, который был удален из документа.

Поддержка браузерами

Тег <del> поддерживается всеми основными браузерами.

Примечание: Ни один из основных браузерах не отображает правильно его атрибуты cite или datetime.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Используйте его вместе с тегом <ins> для описания обновлений и изменений в документе.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
cite | URL | Указывает URL-адрес документа, в котором объясняется, почему текст был удален | STF
datetime | YYYY-MM-DDThh:mm:ssTZD | Указывает дату и время, когда текст был удален | STF

Стандартные атрибуты

Тег <del> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <del> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <dir>

Элемент dir является не рекомендуемым.

Пример

Список каталогов:

<dir>
<li>html</li>
<li>xhtml</li>
<li>css</li>
</dir>

Попробуйте сами »

Определение и использование

Тег <dir> используется для вывода списка названий каталогов.

Поддержка браузерами

Тег <dir> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Используйте CSS для стилизации списков! В нашем учебнике CSS вы можете найти более подробную информацию о стилизации списков.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
compact | compact | Не рекомендуется. Вместо него используйте стили. Указывает, что список должен иметь уменьшенные расстояния между пунктами | TF

Стандартные атрибуты

Тег <dir> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <dir> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <div>

Пример

Блок в документе, который будет отображаться зеленым цветом:

<div style="color:#00FF00">
<h3>Это заголовок</h3>
<p>Это абзац.</p>
</div>

Попробуйте сами »

Определение и использование

Тег <div> определяет логический блок или раздел в документе HTML.

Тег <div> часто используется для группировки блока элементов, чтобы форматировать их с помощью стилей.

Поддержка браузерами

Тег <div> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Элемент div очень часто используется с CSS, чтобы макетировать веб-страницы.

Примечание: Браузеры обычно размещают разрыв строки до и после элемента div.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | left right center justify | Не рекомендуется. Вместо него используйте стили. Задает выравнивание содержимого внутри элемент div | TF

Стандартные атрибуты

Тег <div> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <div> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <dl>

Пример

Список определений:

<dl>
<dt>Кофе</dt>
<dd>- черный горячий напиток</dd>
<dt>Молоко</dt>
<dd>- белый холодный напиток</dd>
</dl>

Попробуйте сами »

Определение и использование

Тег <dl> определяет список определений.

Тег <dl> используется в сочетании с тегом <dt> (определяет пункт в списке) и тегом <dd> (описывает этот пункт в списке).

Поддержка браузерами

Тег <dl> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Тег <dl> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <dl> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <dt>

Пример

Список определений:

<dl>
<dt>Кофе</dt>
<dd>- черный горячий напиток</dd>
<dt>Молоко</dt>
<dd>- белый холодный напиток</dd>
</dl>

Попробуйте сами »

Определение и использование

Тег <dt> определяет пункт в списке определений.

Тег <dt> используется в сочетании с тегом <dl> (определяет список определений) и тегом <dd> (описывает этот пункт в списке).

Поддержка браузерами

Тег <dt> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Тег <dt> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <dt> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <fieldset>

Пример

Группа связанных элементов в форме:

<form>
<fieldset>
<legend>Данные о личности:</legend>
Имя: <input type="text" size="30" /><br />
Email: <input type="text" size="30" /><br />
Дата рождения: <input type="text" size="10" />
</fieldset>
</form>

Попробуйте сами »

Определение и использование

Тег <fieldset> используется для логической группировки элементов в форме.

Тег <fieldset> рисует рамку вокруг элементов, связанных в форме.

Тег <legend> определяет заголовок для элемента fieldset.

Поддержка браузерами

Тег <fieldset> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Тег <fieldset> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <fieldset> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <font>

Элемент font является не рекомендуемым.

Пример

Укажите размер шрифта, гарнитуру и цвет текста:

<font size="3" color="red">Это некоторый текст!</font>
<font size="2" color="blue">Это некоторый текст!</font>
<font face="verdana" color="green">Это некоторый текст!</font>

Попробуйте сами »

Определение и использование

Тег <font> определяет шрифт, размер шрифта и цвет шрифта текста.

Поддержка браузерами

Тег <font> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Используйте CSS, чтобы определить шрифт, размер шрифта и цвет шрифта текста.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
color | rgb(x,x,x) #xxxxxx название_цвета | Не рекомендуется. Вместо него используйте стили. Определяет цвет текста | TF
face | Семейство_шрифтов | Не рекомендуется. Вместо него используйте стили. Определяет шрифт текста | TF
size | число | Не рекомендуется. Вместо него используйте стили. Определяет размер текста | TF

Стандартные атрибуты

Тег <font> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <font> не поддерживает событийные атрибуты.

Более подробная информация о Событийных атрибутах.


HTML Тег <form>

Пример

Простая HTML форма с двумя полями ввода и одной кнопкой отправки (submit):

<form action="form_action.asp" method="get">
Фамилия: <input type="text" name="fname" /><br />
Имя: <input type="text" name="lname" /><br />
<input type="submit" value="Submit" />
</form>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Тег <form> используется для создания HTML формы для пользовательского ввода.

Форма может содержать элементы ввода такие, как текстовые поля, флажки, радио-кнопки, кнопки отправки и другие. Форма может также содержать элементы menus, textarea, fieldset, legend и label.

Формы используются для передачи данных на сервер.

Поддержка браузерами

Тег <form> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В XHTML атрибут name тега <form> является не рекомендуемым и будет удален. Вместо него используйте атрибут id.

Советы и примечания

Примечание: Элемент form является элементом блокового уровня, поэтому создает линии разрыва до и после себя.

Обязательные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
action | URL | Указывает, куда отправить данные формы при ее отправке | STF

Дополнительные атрибуты

Атрибут | Значение | Описание | DTD
accept | MIME_тип | Указывает типы файлов, которые могут быть отправлены через загрузку файлов | STF
accept-charset | кодировка | Указывает символьный набор для обработки сервером данных формы | STF
enctype | application/x-www-form-urlencoded multipart/form-data text/plain | Указывает, как данные формы должны быть закодированы перед их отправкой на сервер | STF
method | get post | Указывает как отправить данные формы | STF
name | имя | Определяет имя формы | TF
target | _blank _self _parent _top framename | Не рекомендуется. Specifies where to open the action URL | TF

Стандартные атрибуты

Тег <form> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <xxx> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF
onreset | скрипт | Скрипт выполняется когда форма сброшена |
onsubmit | скрипт | Скрипт выполняется когда форма отправлена |

Более подробная информация о Событийных атрибутах.

Examples

Попробуйте сами - Примеры

Форма с флажками
Форма с двумя флажками и кнопкой "Отправить".

Форма с переключателями
Форма с двумя переключателями и кнопкой "Отправить".

Отправка по электронной почте из формыы
Как отправить электронную почту из формы.


HTML Тег <frame>

Пример

Простая страница из трех фреймов:

<html>

<frameset cols="25%,50%,25%">
<frame src="frame_a.htm" />
<frame src="frame_b.htm" />
<frame src="frame_c.htm" />
</frameset>

</html>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Тег <frame> определяет одно отдельное окно (фрайм) в наборе фреймов (frameset).

Каждый фрейм в наборе фреймов может иметь различные атрибуты, такие, как границы, прокрутки, возможность изменять размер и т.д.

Поддержка браузерами

Тег <frame> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В HTML тег <frame> не имеет закрывающего тега. В XHTML тег <frame> должен быть закрыт.

В XHTML атрибут name тега <frame> является не рекомендуемым и будет удален. Вместо него используйте атрибут id.

Советы и примечания

Примечание: Если вы хотите проверить страницу, содержащую фреймы, убедитесь, что !DOCTYPE установлен в положение "Frameset DTD". Узнайте больше о !DOCTYPE.

Очень важно: Вы не можете использовать элемент body вместе с элементом frameset. Однако, если вы добавите тег <noframes>, содержащий некоторый текст для браузеров, которые не поддерживает фреймы, вы должны заключить текст в элемента body.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
frameborder | 0 1 | Указывает, следует ли отображать границы вокруг фрейма | F
longdesc | URL | Указывает страницу, содержащую подробное описание содержания фрейма | F
marginheight | пиксели | Задает верхнее и нижнее поля фрейма | F
marginwidth | пиксели | Задает левое и правое поля фрейма | F
name | имя | Определяет имя фрейма | F
noresize | noresize | Указывает, что у фрейма не могут быть изменены размеры | F
scrolling | yes no auto | Указывает, следует ли отображать полосы прокрутки во фрейме | F
src | URL | Указывает URL документа, который будет показан во фрейме | F

Стандартные атрибуты

Тег <frame> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

В соответствии с W3C, тег <frame> не поддерживает ни одного событийного атрибута.

Однако, событие onload поддерживается во всех браузерах.

Более подробная информация о Событийных атрибутах.

Examples

Попробуйте сами - Примеры

Горизонтальный набор фреймов
Как сделать вертикальный набор фреймов с тремя различными документами.

Смешанный набор фреймов
Как сделать набор фреймов с тремя документами и как смешивать их в строках и столбцах.

Как использовать тег <noframes>
Как использовать тег <noframes>.

Набор фреймов с noresize="noresize"
Как использовать атрибут noresize. Фреймы не изменяемого размера. Наведите указатель мыши на границу между фреймами и обратите внимание, что вы не можете передвинуть границы.

Навигационный фрейм
Как сделать навигационный фрейм. Навигационный фрейм содержит список ссылок, со вторым фреймом в качестве целевого. Файл с именем "tryhtml_contents.htm" содержит три ссылки. Исходный код ссылок:
<a href ="frame_a.htm" target ="showframe">Фрейм a</a><br>
<a href ="frame_b.htm" target ="showframe">Фрейм b</a><br>
<a href ="frame_c.htm" target ="showframe">Фрейм c</a>
Второй фрейм покажет связанный документ.

Переход к нужному разделу внутри фрейма
Два фрейма. Один из фреймов имеет исток в указанный раздел файла. Указание раздела производится по <a name="C10"> в файл "link.htm".

Переход к указанному разделу по фреймовой навигации
Два фрейма. Навигационный фрейм (content.htm), расположенный слева, содержит список ссылок на второй фрейм (link.htm), как целевой. Второй фрейм показывает связанный документ. Одна из ссылок в навигационном фрейме связана с указанным разделом в целевом файле. HTML код в файле "content.htm" выглядит следующим образом: <a href ="link.htm" target ="showframe">Ссылка без якоря</a><br><a href ="link.htm#C10" target ="showframe">Ссылка с якорем</a>.


HTML Тег <frameset>

Пример

Простая страница из трех фреймов:

<html>

<frameset cols="25%,*,25%">
<frame src="frame_a.htm" />
<frame src="frame_b.htm" />
<frame src="frame_c.htm" />
</frameset>

</html>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Тег <frameset> определяет набор фреймов.

Элемент frameset содержит один или несколько элементов frame. Каждый элемент frame может содержать отдельный документ.

Элемент frameset определяет, СКОЛЬКО столбцов или строк будет в нем и СКОЛЬКО процентов/пикселей пространства будет занимать каждый столбец или каждая строка.

Поддержка браузерами

Тег <frameset> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Примечание: Если вы хотите проверить страницу, содержащую фреймы, убедитесь, что !DOCTYPE установлен в положение "Frameset DTD". Узнайте больше о !DOCTYPE.

Очень важно: Вы не можете использовать элемент body вместе с элементом frameset. Однако, если вы добавите тег <noframes>, содержащий некоторый текст для браузеров, которые не поддерживает фреймы, вы должны заключить текст в элемента body.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
cols | пиксели % * | Определяет количество и размеры столбцов в наборе фреймов (frameset) | F
rows | пиксели % * | Определяет количество и размеры строк в наборе фреймов (frameset) | F

Стандартные атрибуты

Тег <xxx> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <frameset> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onload | скрипт | Скрипт выполняется, когда документ загружен | F
onunload | скрипт | Скрипт выполняется, когда документ выгружен | F

Более подробная информация о Событийных атрибутах.

Examples

Попробуйте сами - Примеры

Горизонтальный набор фреймов
Как сделать вертикальный набор фреймов с тремя различными документами.

Смешанный набор фреймов
Как сделать набор фреймов с тремя документами и как смешивать их в строках и столбцах.

Как использовать тег <noframes>
Как использовать тег <noframes>.

Набор фреймов с noresize="noresize"
Как использовать атрибут noresize. Фреймы не изменяемого размера. Наведите указатель мыши на границу между фреймами и обратите внимание, что вы не можете передвинуть границы.

Навигационный фрейм
Как сделать навигационный фрейм. Навигационный фрейм содержит список ссылок, со вторым фреймом в качестве целевого. Файл с именем "tryhtml_contents.htm" содержит три ссылки. Исходный код ссылок:
<a href ="frame_a.htm" target ="showframe">Фрейм a</a><br>
<a href ="frame_b.htm" target ="showframe">Фрейм b</a><br>
<a href ="frame_c.htm" target ="showframe">Фрейм c</a>
Второй фрейм покажет связанный документ.

Переход к нужному разделу внутри фрейма
Два фрейма. Один из фреймов имеет исток в указанный раздел файла. Указание раздела производится по <a name="C10"> в файл "link.htm".

Переход к указанному разделу по фреймовой навигации
Два фрейма. Навигационный фрейм (content.htm), расположенный слева, содержит список ссылок на второй фрейм (link.htm), как целевой. Второй фрейм показывает связанный документ. Одна из ссылок в навигационном фрейме связана с указанным разделом в целевом файле. HTML код в файле "content.htm" выглядит следующим образом: <a href ="link.htm" target ="showframe">Ссылка без якоря</a><br><a href ="link.htm#C10" target ="showframe">Ссылка с якорем</a>.


HTML Тег <head>

Пример

Простой HTML документ, с минимумом необходимых тегов:

<html>
<head>
<title>Заголовок документа</title>
</head>

<body>
Содержимое документа......
</body>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Элемент head является контейнером для всех головных элементов. Элементы внутри <head> могут включать в себя сценарии, инструкции браузеру, где он можно найти таблицы стилей, обеспечивать браузер мета-информацией и многое другое.

Следующие теги могут быть добавлены в секцию head: <base>, <link>, <meta>, <script>, <style> и <title>.

Тег <title> определяет заголовок документа и только он является необходимым элементом в секции head!

Поддержка браузерами

Тег <head> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
profile | URL | Указывает URL-адрес документа, который содержит свод правил. Правила могут быть прочитаны браузерами, чтобы четко понимать информацию in the <meta> tag's content attribute | STF

Стандартные атрибуты

Тег <head> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <head> не поддерживает событийные атрибуты:

Более подробная информация о Событийных атрибутах.

Examples

Попробуйте сами - Примеры

Использование тега <base> в <head>
Как использовать тег <base> для указания URL и цели (target) по умолчанию для всех ссылок на странице .

Использование тега <style> в <head>
Как добавить стилевую информацию в секцию <head>.

Использование тега <link> в <head>
Как использовать тег <link> для ссылки на внешнюю таблицу стилей.

Использование тега <meta> в <head>
Как использовать теги <meta> для описания документа.


HTML Теги от <h1> до <h6>

Пример

Шесть различных HTML заголовков:

<h1>Это заголовок 1</h1>
<h2>Это заголовок 2</h2>
<h3>Это заголовок 3</h3>
<h4>Это заголовок 4</h4>
<h5>Это заголовок 5</h5>
<h6>Это заголовок 6</h6>

Попробуйте сами »

Определение и использование

Теги от <h1> до <h6> используются для определения HTML заголовков.

<h1> определяет наиболее важный заголовок. <h6> определяет наименее важный заголовок.

Поддержка браузерами

Теги от <h1> до <h6> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | left center right justify | Не рекомендуется. Вместо него используйте стили. Задает выравнивание заголовка | TF

Стандартные атрибуты

Теги от <h1> до <h6> поддерживают следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Теги от <h1> до <h6> поддерживают следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <hr>

Пример

Два абзаца, разделенные горизонтальной линией:

<p>Это некоторый текст.</p>
<hr />
<p>Это некоторый текст.</p>

Попробуйте сами »

Определение и использование

Тег <hr> создает горизонтальную линию на HTML странице.

Элемент hr может быть использован для разделения содержания HTML страницы.

Поддержка браузерами

Тег <hr> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В HTML тег <hr> не имеет закрывающего тега.

В XHTML тег <hr> должен быть правильно закрыт, вот так: <hr />.

Советы и примечания

Примечание: Элемент hr предоставляет по-разному в различных браузерах.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | left center right | Не рекомендуется. Вместо него используйте стили. Определяет выравнивание элемента hr | TF
noshade | noshade | Не рекомендуется. Вместо него используйте стили. Указывает, что элемент hr должен представляться одним сплошным цветом (no shaded - не затененный) | TF
size | пиксели | Не рекомендуется. Вместо него используйте стили. Определяет высоту элемента hr | TF
width | пиксели % | Не рекомендуется. Вместо него используйте стили. Определяет ширину элемента hr | TF

Стандартные атрибуты

Тег <hr> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <hr> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <html>

Пример

Простой HTML документ, с минимумом необходимых тегов:

<html>
<head>
<title>Заголовок документа</title>
</head>

<body>
Содержание документа......
</body>

</html>

Попробуйте сами »

Определение и использование

Тег <html> говорит браузеру, что это HTML документ.

Элемент html является самым наружным элементом в HTML и XHTML документах. Элемент html также называют корневым элементом.

Поддержка браузерами

Тег <html> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Атрибут xmlns является обязательным в XHTML, но является недействительным в HTML.

Однако, валидатор HTML в w3.org не жалуется, когда атрибут xmlns отсутствует в документе XHTML. Это происходит потому, что пространство имен "xmlns=http://www.w3.org/1999/xhtml" задается по умолчанию, и будет добавлено в <html> тег, даже если вы не включите его.

Советы и примечания

Примечание: Хотя элемент html является корневым элементом, он не содержат деклорацию DOCTYPE. Деклорация DOCTYPE должна быть размещена перед элементом html.

Обязательные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
xmlns | http://www.w3.org/1999/xhtml | Задает пространство имен для использования (только для документов XHTML!) | STF

Стандартные атрибуты

Тег <html> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <html> не поддерживает событийные атрибуты.

Более подробная информация о Событийных атрибутах.


HTML Тег <iframe>

Пример

Встроенный фрейм размечается подобно следующему:

<iframe src="html_intro.asp" width="100%" height="300">
<p>Ваш браузер не поддерживает встроенные фреймы.</p>
</iframe>

Попробуйте сами »

Определение и использование

Тег <iframe> определяет встроенный фрейм, который содержит другой документ.

Поддержка браузерами

Тег <iframe> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В XHTML атрибут name тега <iframe> является не рекомендуемым и будет удален. Использовуйте вместо него атрибут id.

Советы и примечания

Совет: Чтобы иметь дело с браузерами, которые не понимают встроенных фреймов, поместите нужный вам текст между открывающим тегом <iframe> и закрывающим тегом </iframe>.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | left right top middle bottom | Не рекомендуется. Вместо него используйте стили. Задает выравнивание элемента iframe относительно окружающих элементов | TF
frameborder | 1 0 | Указывает, следует ли отображать границы вокруг элемента ifram | TF
height | пикселы % | Указывает высоту элемента iframe | TF
longdesc | URL | Указывает страницу, которая содержит подробное описание содержания элемента iframe | TF
marginheight | пиксели | Указывает верхнее и нижнее поля элемента iframe | TF
marginwidth | pixels | Указывает левое и правое поля элемента iframe | TF
name | имя | Определяет имя элемента iframe | TF
scrolling | yes no auto | Указывает, следует ли отображать полосы прокрутки в элементе iframe | TF
src | URL | Указывает URL документа, который необходимо показать в элементе iframe | TF
width | пиксели % | Указывает ширину элемента iframe | TF

Стандартные атрибуты

Тег <iframe> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

В соответствии с W3C, тег <iframe> не поддерживает ни одного событийного атрибута.

Однако, событие onload поддерживается во всех браузерах.

Более подробная информация о Событийных атрибутах.


HTML Тег <img>

Пример

Изображение размечается подобно следующему:

<img src="images/angry.gif" alt="Сердитое лицо" />

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Тег <img> вставляет изображение в HTML страницу.

Обратите внимание, что изображения технически не вставляются в HTML страницу, изображения связаны с HTML-страницами. Тег <img> создает пространство для хранения ссылки на изображение.

Тег <img> имеет два обязательных атрибута: src и alt.

Поддержка браузерами

Тег <img> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В HTML тег <img> не имеет закрывающего тега.

В XHTML тег <img> должен быть правильно закрыт.

Советы и примечания

Совет: Атрибут alt предназначен для определения альтернативного текста, который будет показан, если изображение не доступно. Чтобы показать текст при наведении указателя мыши на изображение или карту изображения, используйтеь атрибут title, подобно следующему: <img src="angry.gif" alt="Angry face" title="Сердитое лицо" />

Примечание: When a web page is loaded, it is the browser, at that moment, that actually gets the image from a web server and inserts it into the page. Therefore, make sure that the images actually stay in the same spot in relation to the web page, otherwise your visitors will get a broken link icon. The broken link icon is shown if the browser cannot find the image.

Обязательные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
alt | текст | Задает альтернативный текст для изображения | STF
src | URL | Указывает URL-адрес изображения | STF

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | top bottom middle left right | Не рекомендуется. Вместо него используйте стили. Задает выравнивание изображения относительно окружающих элементов | TF
border | пиксели | Не рекомендуется. Вместо него используйте стили. Определяет ширину рамки вокруг изображения | TF
height | пиксели % | Задает высоту изображения | STF
hspace | пиксели | Не рекомендуется. Вместо него используйте стили. Задает пробелы слева и справа от изображения | TF
ismap | ismap | Определяет изображение как карту изображений на стороне сервера | STF
longdesc | URL | Указывает URL-адрес документа, который содержит подробное описание изображения | STF
usemap | #mapname | Определяет изображение как карту изображений на стороне клиента | STF
vspace | пиксели | Не рекомендуется. Вместо него используйте стили. Задает пробелы сверху и снизу изображения | TF
width | пиксели % | Задает ширину изображения | STF

Стандартные атрибуты

Тег <img> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <img> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onabort | скрипт | Скрипт выполняется, когда прервана загрузка изображения | STF
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.

Examples

Попробуйте сами - Примеры

Вставка изображений из различных местонахождений
Как вставлять изображения из другой папки или с другого веб-сайта.

Выравнивание изображений
Как выровнять изображение в тексте.

Пусть изображение плавает
Как разрешать изображению размещаться слева или справа от текста.

Сделать гиперссылку из изображения
Как добавить гиперссылку к изображению.

Создание карты изображения
Как создать карту изображения, с интерактивными регионами. Каждый регион - гиперссылка.


HTML Тег <input>

Пример

Простая HTML форма с двумя полями ввода и одной кнопкой отправки (submit):

<form action="form_action.asp" method="get">
Имя: <input type="text" name="fname" /><br />
Фамилия: <input type="text" name="lname" /><br />
<input type="submit" value="Submit" />
</form>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Тег <input> используется для выборки пользовательской информации.

Элемент input имеет много разновидностей, в зависимости от атрибута type. Элемент input может быть текстовым полем, флажоком, полем пароля, радио-кнопкой, кнопкой и многим другим.

Поддержка браузерами

Тег <input> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В HTML тег <input> не имеет конечного тега.

В XHTML тег <input> должен быть закрыт следующим образом: <input />.

Советы и примечания

Совет: Используйте тег <label> для определения этикеток элементов input.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

accept | MIME_тип | Указывает типы файлов, которые могут быть отправлены через загрузку файлов (только для type="file") | STF
align | left right top middle bottom | Не рекомендуется. Вместо него используйте стили. Задает выравнивание изображения (только для type="image") | TF
alt | текст | Задает альтернативный текст для изображения (только для type="image") | STF
checked | checked | Указывает, что элемент input должен при загрузке страницы быть предварительно выбранным (для type="checkbox" или type="radio") | STF
disabled | disabled | Указывает, что элемент input должен быть отключен при загрузке страницы | STF
maxlength | число | Указывает максимальную длину (в символах) поля ввода (для type="text" или type="password") | STF
name | имя | Определяет имя элемента input | STF
readonly | readonly | Указывает, что поле ввода должны быть доступным только для чтения (для type="text" или type="password") | STF
size | число | Определяет ширину поля ввода | STF
src | URL | Указывает URL-адрес изображения для его отображения в качестве кнопки отправки | STF
type | button checkbox file hidden image password radio reset submit text | Задает тип элемента input | STF
value | значение | Указывает значение для элемента input | STF

Стандартные атрибуты

Тег <input> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
accesskey | символ | Определяет сочетание клавиш для доступа к элементу | STF
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
tabindex | число | Указывает порядке перехода к элементу | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <input> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onblur | скрипт | Скрипт выполняется, когда элемент теряет фокус | STF
onchange | скрипт | Скрипт выполняется, когда элемент изменен | STF
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onfocus | скрипт | Скрипт выполняется, когда элемент получает фокус | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF
onselect | скрипт | Скрипт выполняется, когда элемент выбран | STF

Более подробная информация о Событийных атрибутах.

Examples

Попробуйте сами - Примеры

Поле пароля
Как определить поле для ввода пароля.

Создание кнопки
Как определить кнопку с вашим собственным текстом.

Форма с флажками
Форма с двумя флажками и кнопкой "Отправить".

Форма с переключателями
Форма с двумя переключателями и кнопкой "Отправить".


HTML Тег <ins>

Пример

Текст c удаленным фрагментом и новым, вставленным фрагментом:

<p>Мой любимый цвет <del>синий</del> <ins>красный</ins>!</p>

Попробуйте сами »

Определение и использование

Тег <ins> определяет текст, который был вставлен в документ.

Поддержка браузерами

Тег <ins> поддерживается всеми основными браузерами.

Примечание: Ни один из основных браузерах не отображает правильно атрибуты ins, cite или datetime.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Используйте его вместе с тегом <del> для описания обновлений и изменений в документе.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
cite | URL | Указывает URL-адрес документа, в котором объясняется, почему текст был вставлен/изменен | STF
datetime | YYYY-MM-DDThh:mm:ssTZD | Указывает дату и время, когда текст был вставлен/изменен | STF

Стандартные атрибуты

Тег <ins> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <ins> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <label>

Пример

Простая HTML форма с двумя полями ввода и соответствующими им метками (надписями):

<form>
<label for="male">Мужчина</label>
<input type="radio" name="sex" id="male" />
<br />
<label for="female">Женщина</label>
<input type="radio" name="sex" id="female" />
</form>

Попробуйте сами »

Определение и использование

Тег <label> определяет метку (надпись) для элемента input.

Элемент label не предоставляет что-нибудь особенное для пользователя. Тем не менее, он делает более удобной для пользователей работу с мышью, потому что, если пользователь щелкает мышью на тексте элемента label, он переключает управление.

Значение атрибута for тега <label> должно быть равно значению атрибута id родственного ему элемента, чтобы связать их вместе.

Поддержка браузерами

Тег <label> поддерживается всеми основными браузерами.

Примечание: Не поддерживается в Safari 2 или более ранних версиях.

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
for | элемент_id | Указывает, с каким элементом формы связан элемент label | STF

Стандартные атрибуты

Тег <label> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
accesskey | символ | Определяет сочетание клавиш для доступа к элементу | STF
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <label> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onblur | скрипт | Скрипт выполняется, когда элемент теряет фокус | STF
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onfocus | скрипт | Скрипт выполняется, когда элемент получает фокус | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <legend>

Пример

Группа связанных элементов в форме:

<form>
<fieldset>
<legend>Данные о личности:</legend>
Имя: <input type="text" size="30" /><br />
Email: <input type="text" size="30" /><br />
Дата рождения: <input type="text" size="10" />
</fieldset>
</form>

Попробуйте сами »

Определение и использование

Тег <legend> определяет заголовок для элемента fieldset.

Поддержка браузерами

Тег <legend> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | top bottom left right | Не рекомендуется. Вместо него используйте стили. Определяет выравнивание заголовка в элементе fieldset | TF

Стандартные атрибуты

Тег <legend> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
accesskey | символ | Определяет сочетание клавиш для доступа к элементу | STF
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <legend> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <li>

Пример

Один упорядоченный и один неупорядоченный HTML списки:

<ol>
<li>Кофе</li>
<li>Чай</li>
<li>Молоко</li>
</ol>

<ul>
<li>Кофе</li>
<li>Чай</li>
<li>Молоко</li>
</ul>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Тег <li> определяет пункт списка.

Тег <li> используется как в упорядоченных (<ol>), так и в неупорядоченных (<ul>) списках.

Поддержка браузерами

Тег <li> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Используйте CSS для определения типа списка и пункта списка.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
type | 1 A a I i disc square circle | Не рекомендуется. Вместо него используйте стили. Определяет тип маркера пунктов списка | TF
value | чмсло | Не рекомендуется. Вместо него используйте стили. Определяет номер текущего пункта списка | TF

Стандартные атрибуты

Тег <li> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <li> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.

Examples

Попробуйте сами - Примеры

Вложенный список
Список внутри списка.

Другой вложенный список
Более сложный вложенный список.


HTML Тег <link>

Пример

Ссылка на внешнюю таблицу стилей:

<head>
<link rel="stylesheet" type="text/css" href="theme.css" />
</head>

Попробуйте сами »

Определение и использование

Тег <link> определяет связь между документом и внешним ресурсом.

Тег <link> наиболее часто используются для ссылки на таблицы стилей.

Поддержка браузерами

При использовании таблиц стилей, тег <link> поддерживается всеми основными браузерами.Нет реальной поддержки ни для чего другого.

Различия между HTML и XHTML

В HTML тег <link> не имеет конечного тега.

В XHTML тег <link> должен быть правильно закрыт.

Советы и примечания

Примечание: Элемент link должен быть встроен в секцию head и он может там появиться любое количество раз.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
charset | кодировка_символов | Определяет набор символов для связанного документа | STF
href | URL | Определяет адресат ссылки | STF
hreflang | код_языка | Указывает язык текста ссылочного документа | STF
media | screen tty tv projection handheld print braille aural all | Указывает на каком устройстве связанный документ будет отображаться | STF
rel | alternate appendix bookmark chapter contents copyright glossary help home index next prev section start stylesheet subsection | Определяет связь между текущим документом и ссылочным документом | STF
rev | alternate appendix bookmark chapter contents copyright glossary help home index next prev section start stylesheet subsection | Определяет связь между ссылочным документом и текущим документом | STF
target | _blank _self _top _parent frame_name | Указывает, где открыть ссылочный документ | TF
type | MIME_тип | Определяет MIME-тип связанного документа | STF

Стандартные атрибуты

Тег <link> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

В соответствии со стандартом W3C, тег <link> поддерживает событийные атрибуты. Однако, поскольку элемент link находится в секции head, мы не можем видеть их использование.

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <map>

Пример

Карта изображения с интерактивными областями:

<img src="planets.gif" width="145" height="126" alt="Планеты" usemap="#planetmap" />

<map name="planetmap">
<area shape="rect" coords="0,0,82,126" href="sun.htm" alt="Солнце" />
<area shape="circle" coords="90,58,3" href="mercur.htm" alt="Меркурий" />
<area shape="circle" coords="124,58,8" href="venus.htm" alt="Венера" />
</map>

Попробуйте сами »

Определение и использование

Тег <map> используется для определения карты изображения на стороне клиента. Карта изображения это изображение с активными областям.

Для элемента map требуется атрибут name. This attribute is associated with the <img>'s usemap attribute and creates a relationship between the image and the map.

The map element contains a number of area elements, that defines the clickable areas in the image map.

Поддержка браузерами

Тег <map> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В XHTML атрибут name тега является не рекомендуемым и будет удален. Используйте вместо него атрибут id.

Обязательные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
name | mapname | Определяет имя карты изображения | STF

Стандартные атрибуты

Тег <map> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <map> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <menu>

Элемент menu является не рекомендуемым.

Пример

Список меню:

<menu>
<li>html</li>
<li>xhtml</li>
<li>css</li>
</menu>

Попробуйте сами »

Определение и использование

Тег <menu> используется для создания списка в меню выбора.

Поддержка браузерами

Тег <menu> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Используйте CSS для стилизации списков! В нашем учебнике CSS вы можете найти более подробную информацию о стилизации списков.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
compact | compact | Не рекомендуется. Вместо него используйте стили. Указывает, что список должен иметь уменьшенные расстояния между пунктами | TF

Стандартные атрибуты

Тег <menu> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <menu> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <meta>

Пример

Опишим метаданные в HTML документе:

<head>
<meta name="description" content="Free Web tutorials" />
<meta name="keywords" content="HTML,CSS,XML,JavaScript" />
<meta name="author" content="Hege Refsnes" />
<meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1" />
</head>

Попробуйте сами »

Определение и использование

Метаданные это информация о данных.

Тег <meta> предоставляет метаданные о HTML документе. Метаданных не будет отображаться на странице, but will be machine parsable.

Элементы meta, как правило, используется для указания страницы описания, ключевых слов, автора документа, последнее изменение и другие метаданные.

Тег <meta> всегда располагается в элементе head.

Метаданные могут быть использованы браузерами (например, для отображения содержимого или перезагрузки страницы), поисковыми системами (ключевые слова) или другими веб-службами.

Поддержка браузерами

Тег <meta> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В HTML тег <meta> не имеет закрывающего тега.

В XHTML тег <meta> должен быть правильно закрыт.

Советы и примечания

Примечание: Метаданных всегда передаются парами имя/значение.

Обязательные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
content | текст | Определяет содержание мета-информации | STF

Дополнительные атрибуты

Атрибут | Значение | Описание | DTD
http-equiv | content-type content-style-type expires refresh set-cookie | Служит для указания того, что данное свойство является заголовком сообщения HTTP | STF
name | author description keywords generator revised другие | Предоставляет имя для информации в содержании атрибута | STF
scheme | format/URI | Задает формат значения свойства и предусмотренный для использования совместно со словарями метаданных | STF

Стандартные атрибуты

Тег <meta> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <meta> не поддерживает событийные атрибуты:

Более подробная информация о Событийных атрибутах.


HTML Тег <noframes>

Пример

Простая страница из трех фреймов и тегом <noframes>:

<html>

<frameset cols="25%,50%,25%">
<frame src="frame_a.htm" />
<frame src="frame_b.htm" />
<frame src="frame_c.htm" />
<noframes>
К сожалению Ваш браузер не обрабатывает фреймы!
</noframes>
</frameset>

</html>

Попробуйте сами »

Определение и использование

Тег <noframes> используется для браузеров, которые не обрабатывают фреймы.

Элемент noframes может содержать все элементы, которые вы можете найти внутри элемента body обычной HTML страницы.

Элемент noframes наиболее часто используется для ссылки на не фреймовый вариант веб-сайта или для отображения сообщения пользователям, которым необходимы фреймы.

Элемент noframes располагается внутри элемента frameset.

Поддержка браузерами

Тег <noframes> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Очень важно: В XHTML Frameset DTD, текст в элементе noframes должен быть заключен в элемент body.

Советы и примечания

Совет: Если вы хотите проверить страницу, содержащую фреймы, убедитесь, что !DOCTYPE установлен в положение "Frameset DTD". Узнайте больше о !DOCTYPE.

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Тег <noframes> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <noframes> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <noscript>

Пример

Использование тега <noscript>:

<script type="text/javascript">
document.write("Привет, Мир!")
</script>
<noscript>Ваш браузер не поддерживает JavaScript!</noscript>

Попробуйте сами »

Определение и использование

Тег <noscript> используется для предоставления альтернативного содержания для пользователей, которые отключили сценарии в своих браузерах, или их браузеры не поддерживают сценариев на стороне клиента.

Элемент noscript может содержать все элементы, которые вы можете найти внутри элемента body обычной HTML страницы.

Содержание внутри элемента noscript будет отображаться только, если скрипты не поддерживаются или отключены в браузере пользователя.

Поддержка браузерами

Тег <noscript> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Тег <noscript> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

В соответствии со стандартом W3C, тег <noscript> поддерживает событийные атрибуты. Однако, поскольку элемент noscript используется для предоставления альтернативного содержания для пользователей, которые отключили сценарии, мы не можем видеть любое использование этого.

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <object>

Пример

Добавим объект на HTML страницу:

<object classid="clsid:F08DF954-8592-11D1-B16A-00C0F0283628" id="Slider1" width="100" height="50">
<param name="BorderStyle" value="1" />
<param name="MousePointer" value="0" />
<param name="Enabled" value="1" />
<param name="Min" value="0" />
<param name="Max" value="10" />
</object>

Попробуйте сами »

Определение и использование

Тег <object> используется для добавления объектов, таких как изображения, аудио, видео, Java-апплеты, ActiveX, PDF и Flash.

Элемент object был предназначен для замены элементов img и applet. Однако, из-за ошибок и отсутствия поддержки браузера, этого не произошло.

Поддержка объекта в браузерах зависит от типа объекта. К сожалению, основные браузеры используют различные коды для загрузки одного и того же типа объекта.

К счастью, элемент object обеспечивает решение. Если элемент object не отображается, код между тегами <object> и </object> будет выполнен. Таким образом, мы может иметь несколько вложенных элементов object (по одному для каждого браузера).

Поддержка браузерами

Тег <object> частично поддерживается во всех основных браузерах.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Примечание: Тег <param> определяет для объекта параметры времени выполнения.

Важно: Не используйте тег <object> для изображений, вместо него используйте тег <img>!

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | left right top bottom | Определяет выравнивание текста вокруг объекта | TF
archive | URL | Разделенный пробелами список URL-адресов в архив.Архив содержит ресурсы, имеющие отношение к объекту | STF
border | пиксели | Определяет границу вокруг объекта | TF
classid | класс_ID | Определяет значение класса ID, установленного в реестре Windows или URL | STF
codebase | URL | Определяет, где найти код для объекта | STF
codetype | MIME_тип | The internet media type of the code referred to by the classid attribute | STF
data | URL | Определяет URL, который ссылается на данные объекта | STF
declare | declare | Defines that the object should only be declared, not created or instantiated until needed | STF
height | пикселы | Определяет высоту объекта | STF
hspace | pixels | Определяет размер свободного пространства слева и справа от объекта | TF
name | имя | Определяет имя объекта (для использования в скриптах) | STF
standby | текст | Определяет текст, отображаемый во время загрузки объекта | STF
type | MIME_тип | Определяет MIME-тип данных, указанных в атрибуте data | STF
usemap | URL | Specifies a URL of a client-side image map to be used with the object | STF
vspace | пиксели | Определяет размер свободного пространства сверху и снизу от объекта | TF
width | пиксели | Определяет ширину объекта | STF

Стандартные атрибуты

Тег <object> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
tabindex | number | Specifies the tab order of an element | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <object> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <ol>

Пример

Упорядоченный (нумерованный) HTML список:

<ol>
<li>Coffee</li>
<li>Tea</li>
<li>Milk</li>
</ol>

Попробуйте сами »

Определение и использование

Тег <ol> определяет упорядоченный (нумерованный) список.

Поддержка браузерами

Тег <ol> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Используйте CSS для определения типа списка.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
compact | compact | Не рекомендуется. Вместо него используйте стили. Указывает, что список должен иметь уменьшенные расстояния между пунктами | TF
start | число | Не рекомендуется. Вместо него используйте стили. Указывает номер начального пункта списка | TF
type | 1 A a I i | Не рекомендуется. Вместо него используйте стили. Указывает, какой тип пунктов списка будет использоваться | TF

Стандартные атрибуты

Тег <ol> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <ol> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <optgroup>

Пример

Сгрупперуем вместе родственные элементы выбора, с помощью тегов <optgroup>:

<select>
<optgroup label="Шведские автомобили">
<option value="volvo">Volvo</option>
<option value="saab">Saab</option>
</optgroup>
<optgroup label="Немецкие автомобили">
<option value="mercedes">Mercedes</option>
<option value="audi">Audi</option>
</optgroup>
</select>

Попробуйте сами »

Определение и использование

Тег <optgroup> используется для группировки родственных элементов выбора в элементе select.

Если у вас есть длинный список элементов выбора, группировка родственных элементов делает список более простым для пользователя.

Поддержка браузерами

Тег <optgroup> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Обязательные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
label | текст | Задает описание для группы элементов списка | STF

Дополнительные атрибуты

Атрибут | Значение | Описание | DTD
disabled | disabled | Указывает, что элементы выбора группы должны быть недоступны | STF

Стандартные атрибуты

Тег <optgroup> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <optgroup> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <option>

Пример

Раскрывающейся спискок с четырьмя элементами выбора:

<select>
<option>Volvo</option>
<option>Saab</option>
<option>Mercedes</option>
<option>Audi</option>
</select>

Попробуйте сами »

Определение и использование

Тег <option> определяет элемент выбора в списке выбора.

Поддержка браузерами

Тег <option> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В HTML тег <option> не имеет конечного тега.

В XHTML тег <option> должен быть правильно закрыт.

Советы и примечания

Совет: Если у вас есть длинный список элементов выбора, вы можете сгруппировать родственные элементы с помощью элемента <optgroup> tag.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
disabled | disabled | Указывает, что элемент выбора должна быть недоступен | STF
label | текст | Указывает короткую метку для элемента выбора | STF
selected | selected | Указывает, что элемент выбора должен быть выбран по умолчанию | STF
value | текст | Указывает значение, которое будет отправлено на сервер при отправке формы | STF

Стандартные атрибуты

Тег <option> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <option> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <p>

Пример

Абзац размечается подобно следующему:

<p>Это некоторый текст абзаца.</p>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Тег <p> определяет абзац.

Элемент р автоматически создает некоторые интервалы перед и после себя. Интервалы автоматически создаются браузером, или вы можете задать их в таблицах стилей.

Поддержка браузерами

Тег <p> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | left right center justify | Не рекомендуется. Вместо него используйте стили. Определяет выравнивание текста внутри абзаца | TF

Стандартные атрибуты

Тег <p> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <p> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.

Examples

Попробуйте сами - Примеры

Подробнее об абзацах
Некоторые поведения абзацев по умолчанию.

Проблемы со стихами
Примеры того, как вы НЕ можете писать стихи в HTML.


HTML Тег <param>

Пример

Добавим объект на HTML страницу:

<object classid="clsid:F08DF954-8592-11D1-B16A-00C0F0283628" id="Slider1" width="100" height="50">
<param name="BorderStyle" value="1" />
<param name="MousePointer" value="0" />
<param name="Enabled" value="1" />
<param name="Min" value="0" />
<param name="Max" value="10" />
</object>

Попробуйте сами »

Определение и использование

Тег <param> используется для определения параметров и переменных для элементов object или applet.

Поддержка браузерами

Тег <param> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

В HTML тег <param> не имеет закрывающего тега.

В XHTML тег <param> должен быть правильно закрыт.

Обязательные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
name | name | Определяет имя параметра (для использования в сценарии) | STF

Дополнительные атрибуты

Атрибут | Значение | Описание | DTD
type | MIME_тип | Определяет MIME-тип для параметра | STF
value | значение | Определяет значение параметра | STF
valuetype | data ref object | Указывает тип значения | STF

Стандартные атрибуты

Тег <param> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
id | имя_id | Определяет уникальный идентификатор для элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <param> не поддерживает событийные атрибуты:

Более подробная информация о Событийных атрибутах.


HTML Тег <pre>

Пример

Преформатированный текст:

<pre>
Текст в элементе pre
отображается шрифтом фиксированной
ширины и в нем сохраняются
пробелы и
разрывы строк
</pre>

Попробуйте сами »

Определение и использование

Тег <pre> определяет преформатированный текст.

Текст в элементе pre отображается шрифтом фиксированной ширины (обычно Courier) и в нем сохраняются пробелы и разрывы строк.

Поддержка браузерами

Тег <pre> поддерживается всеми основными браузерами.

Советы и примечания

Совет: Используйте элемент pre для отображения программного кода!

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
width | число | Не рекомендуется. Вместо него используйте стили. Указывает максимальное количество символов в строке | TF

Стандартные атрибуты

Тег <pre> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <pre> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <q>

Пример

Короткая цитата размечается подобно следующему:

<q>
Это короткая цитата это короткая цитата
</q>

Попробуйте сами »

Определение и использование

Тег <q> определяет короткую цитату.

Браузер заключает цитату в кавычки.

Поддержка браузерами

Тег <q> поддерживается всеми основными браузерами.

Примечание: Internet Explorer 8 (и выше) поддерживает элемент q, если указан !DOCTYPE.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Используйте элемент blockquote для разметки длинных цитат!

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
cite | URL | Указывает источник цитаты | STF

Стандартные атрибуты

Тег <q> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <q> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег s,strike

HTML Теги <s> и <strike>

Пример

Перечеркнутый текст размечается подобно следующему:

<p>Версия 2.0 еще <s>не доступна!</s> Сейчас в продаже!</p>

<p>Версия 2.0 еще <strike>не доступна!</strike> Сейчас в продаже!</p>

Попробуйте сами »

Определение и использование

Теги <s> и <strike> определяют перечеркнутый текст.

Поддержка браузерами

Теги <s> и <strike> поддерживаются всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Используйте вместо них элемент del!

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Теги <s> и <strike> поддерживают следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Теги <xxx> и <strike> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <script>

Пример

Вставить JavaScript в HTML страницу:

<script type="text/javascript">
document.write("Привет, Мир!")
</script>

Попробуйте сами »

Определение и использование

Тег <script> используется для определения сценария на стороне клиента как, например, JavaScript.

Элемент script либо содержит инструкции сценария или указывает на внешний файл сценария через атрибут src.

Обязательный атрибут type определяет MIME тип сценария.

Распространенными способами использования JavaScript являются манипуляции с изображениями, проверка формы и динамическое изменение контента.

Поддержка браузерами

Тег <script> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

HTML 4 and XHTML deal different with the content inside scripts:

  • In HTML 4, the content type is declared as CDATA, which means that entities will not be parsed.
  • In XHTML, the content type is declared as (#PCDATA), which means that entities will be parsed.

This means that in XHTML, all special characters should be encoded or all content should be wrapped inside a CDATA section.

To ensure that a script parses correctly in an XHTML document, use the following syntax:

<script type="text/javascript">//<![CDATA[
var i=10;
if (i<5)
{
// some code
}
//]]></script>

Советы и примечания

Совет: Также обратите внимание на элемент noscript. Он полезен пользователям, у которых отключены сценарии в браузере или браузер не поддерживает сценарии на стороне клиента.

Обязательные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
type | MIME-тип | Определяет MIME-тип сценария | STF

Дополнительные атрибуты

Атрибут | Значение | Описание | DTD
charset | кодировка | Задает кодировку символов, используемую во внешнем файле сценария | STF
defer | defer | Указывает, что выполнение сценария должно быть отложено (задержено) до завершения загрузки и отображения документа | STF
htm | URL | Указывает URL внешнего файла сценария | STF
xml:space | preserve | Specifies whether whitespace in code should be preserved |

Стандартные атрибуты

Тег <script> не поддерживает стандартные атрибуты:

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <script> не поддерживает событийные атрибуты:

Более подробная информация о Событийных атрибутах.


HTML Тег <select>

Пример

Создадим список выбора с четырьмя элементами:

<select>
<option value="volvo">Volvo</option>
<option value="saab">Saab</option>
<option value="mercedes">Mercedes</option>
<option value="audi">Audi</option>
</select>

Попробуйте сами »

Определение и использование

Тег <select> используется для создания списка выбора (выпадающего списка).

Теги <option>, внутри элемента select, определяют элементы выбора в списке.

Поддержка браузерами

Тег <select> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Элемент select является элементом управления формы и может быть использован в форме для получения пользовательского ввода.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
disabled | disabled | Указывает, что раскрывающийся спискок должны быть недоступен | STF
multiple | multiple | Указывает, что несколько элементов выбора могут быть выбраны | STF
name | имя | Определяет имя раскрывающегося списка | STF
size | number | Определяет количество видимых элементов в раскрывающемся списке | STF

Стандартные атрибуты

Тег <select> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
tabindex | число | Указывает порядке перехода к элементу | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <select> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onblur | скрипт | Скрипт выполняется, когда элемент теряет фокус | STF
onchange | скрипт | Скрипт выполняется, когда элемент изменен | STF
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onfocus | скрипт | Скрипт выполняется, когда элемент получает фокус | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <span>

Пример

Текст с элементом span, который может быть стилизирован с помощью CSS:

<p>У моей мамы <span class="blue">светло-голубые</span> глаза.</p>

Попробуйте сами »

Определение и использование

Тег <span> используется для оформления встроенных элементов в документе.

Тег <span> не предоставляет визуальных изменений сам по себе.

Тег <span> обеспечивает способ добавить hook to a part of a text or a part of a document.

Когда текст заключен в элемент span, вы можете добавить стили к содержанию или манипулировать содержанием, например, с помощью JavaScript.

Поддержка браузерами

Тег <span> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Тег <span> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <span> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <style>

Пример

Использование элемента style в HTML документе:

<html>
<head>
<style type="text/css">
h1 {color:red}
p {color:blue}
</style>
</head>

<body>
<h1>Заголовок 1</h1>
<p>Абзац.</p>
</body>
</html>

Попробуйте сами »

Определение и использование

Тег <style> задает таблицу стилей для HTML документа.

Внутри элемента style можно указать, как элементы HTML должны предоставляться в браузере.

Требуется атрибут type, определяющий содержание элемента style. Возможно только значение "текст/CSS".

Элемент style всегда располагается в секции head.

Поддержка браузерами

Тег <style> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Чтобы создать ссылку на внешнюю таблицу стилей, используйте тег <link>.

Совет: Чтобы узнать больше о таблицах стилей, ознакомьтесь с нашим CSS Tutorial.

Обязательные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
type | text/css | Определяет MIME тип таблицы стилей | STF

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
media | screen tty tv projection handheld print braille aural all | Определяет стили для различных media типов | STF

Стандартные атрибуты

Тег <style> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <style> не поддерживает событийные атрибуты:

Более подробная информация о Событийных атрибутах.


HTML Теги sub,sup

HTML Теги <sub> и <sup>

Пример

Подстрочный и надстрочный текст:

<p>Этот текст содержит <sub>подстрочный</sub> текст.</p>

<p>Этот текст содержит <sup>надстрочный</sup> текст.</p>

Попробуйте сами »

Определение и использование

Тег <sub> определяет подстрочный текст. Подстрочный текст отображается вдвое меньшими символами ниже базовой линии. Подстрочный текст может быть использован для химических формул, например H2O.

Тег <sup> определяет надстрочный текст. Подстрочный текст отображается вдвое меньшими символами выше базовой линии. Надстрочный текст может быть использован для сносок, например WWW[1].

Поддержка браузерами

Теги <sub> и <sup> поддерживаются всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Теги <sub> и <sup> поддерживают следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Теги <sub> и <sup> поддерживают следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <table>

Пример

Простая HTML таблица, содержащая два столбца и две строки:

<table border="1">
<tr>
<th>Месяц</th>
<th>Накопление</th>
</tr>
<tr>
<td>Январь</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Тег <table> определяет HTML таблицу.

Простая HTML таблица состоит из элемента table и одного или более элементов tr, th и td.

Элемент tr определяет строку таблицы, элемент th определяет заголовочную ячейку таблицы а элемента td определяет ячейку таблицы.

Более сложная HTML таблица может также содержать в себе элементы caption, col, colgroup, thead, tfoot и tbody.

Поддержка браузерами

Тег <table> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | left center right | Не рекомендуется. Вместо него используйте стили. Задает выравнивание таблицы в соответствии с окружающим текстом | TF
bgcolor | rgb(x,x,x) #xxxxxx название_цвета | Не рекомендуется. Вместо него используйте стили. Задает цвет фона для таблицы | TF
border | пиксели | Определяет ширину рамки вокруг таблицы | STF
cellpadding | пиксели | Задает поля между границами и содержимым ячейки | STF
cellspacing | пиксели | Задает поля между ячейками | STF
frame | void above below hsides lhs rhs vsides box border | Определяет, какие стороны окружающей таблицу рамки, будут видны | STF
rules | none groups rows cols all | Specifies which parts of the inside borders that should be visible | STF
summary | текст | Specifies a summary of the content of a table | STF
width | пиксели % | Определяет ширину таблицы | STF

Стандартные атрибуты

Тег <table> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <table> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.

Examples

Попробуйте сами - Примеры

Границы таблицы
HTML таблицы с различными границами.

Заголовочные ячейки таблицы
Как создать заголовочные ячейки таблицы.

Пустые ячейки
Как использовать "&nbsp;" для обработки ячеек, которые не имеют содержимого.

Таблица с заголовком
HTML таблица с заголовком.

Теги внутри таблицы
Как показать элементы внутри других элементов.

Ячейки, которые охватывают более одной строки/колонки
Как определить ячейки таблицы, которые охватывают более одной строки или одного столбца.

Cellpadding
Как использовать атрибут cellpadding для создания большего пустого пространства между содержимым ячейки и ее границами.

Cellspacing
Как использовать атрибут cellspacing,чтобы увеличить расстояние между ячейками.

Добавление цвета фона или фонового изображения для таблицы
Как добавить фон в таблицу.

Атрибут frame
Как использовать атрибут frame для управления границей вокруг таблицы.


HTML Тег <tbody>

Пример

HTML таблица с элементами thead, tfoot и tbody:

<table border="1">
<thead>
<tr>
<th>Месяц</th>
<th>Накопление</th>
</tr>
</thead>
<tfoot>
<tr>
<td>Итого:</td>
<td>$180</td>
</tr>
</tfoot>
<tbody>
<tr>
<td>Январь</td>
<td>$100</td>
</tr>
<tr>
<td>Февраль</td>
<td>$80</td>
</tr>
</tbody>
</table>

Попробуйте сами »

Определение и использование

Тег <tbody> используется для группировки содержимого тела HTML таблицы.

Элемент tbody должен быть использован в сочетании с элементами thead и tfoot.

Элемент thead используется для группировки содержания заголовка в HTML таблице а элемент tfoot используется для группировки содержания колонтитула в таблице HTML.

Примечание: Тег <tfoot> должен находиться в таблице перед тегом <tbody>, чтобы браузер смог его отобразить до получения всех строк данных.

Обратите внимание, что эти элементы не влияют на расположение таблицы по умолчанию. Однако, вы можете использовать CSS, чтобы эти элементы влияли на расположение таблицы.

Поддержка браузерами

Тег <tbody> лишь частично поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | right left center justify char | Выравнивает содержимое элемента tbody | STF
char | символ | Определяет символ внутри содержания элемента tbody, служащий осью для выравнивания | STF
charoff | число | Устанавливает горизонтальный отступ для первого экземпляра символа, указанного атрибутом char | STF
valign | top middle bottom baseline | Определяет вертикальное выравнивание данных в элементе tbody | STF

Стандартные атрибуты

Тег <tbody> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <tbody> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <td>

Пример

Простая HTML таблица, содержащий два столбца и две строки:

<table border="1">
<tr>
<th>Месяц</th>
<th>Накопление</th>
</tr>
<tr>
<td>Январь</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Тег <td> определяет стандартную ячейку в HTML таблице.

HTML таблица имеет два вида ячеек:

  • Заголовочные ячейки - содержат заголовочную информацию (создаются с помощью элемента th)
  • Стандартные ячейки - содержат данные (создаются с помощью элемента td)

Текст в элементе th отображается полужирным шрифтом и центрируется.

Текст в элемент td отображается обычным шрифтом и выравнивается по левому краю.

Поддержка браузерами

Тег <td> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Используйте атрибуты colspan и rowspan, чтобы содержание ячейки охватило нескольких столбцов или строк!

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
abbr | текст | Определяет содержимое ячейки в сокращённой форме | STF
align | left right center justify char | Выравнивает содержимое ячейки | STF
axis | имя_категории | Определяет категорию ячеек | STF
bgcolor | rgb(x,x,x) #xxxxxx название_цвета | Не рекомендуется. Вместо него используйте стили. Задает цвет фона для ячейки | TF
char | символ | Определяет символ содержания ячейки, служащий осью для выравнивания | STF
charoff | число | Устанавливает горизонтальный отступ для первого экземпляра символа, указанного атрибутом char | STF
colspan | число | Устанавливает число столбцов, которые ячейка должна охватывать | STF
headers | headercells'_id | Определяет список ячеек заголовка, содержащих информацию о заголовке текущей ячейки данных | STF
height | пиксели % | Не рекомендуется. Вместо него используйте стили. Устанавливает высоту ячейки | TF
nowrap | nowrap | Не рекомендуется. Вместо него используйте стили. Указывает, что текст внутри ячейки должен отображаться без переносов | TF
rowspan | число | Устанавливает число строк, которые ячейка должна охватывать | STF
scope | col colgroup row rowgroup | Определяет набор ячеек данных, для которых текущая заголовочная ячейка предоставляет заголовочную информацию | STF
valign | top middle bottom baseline | Определяет вертикальное выравнивание данных в ячейке | STF
width | пиксели % | Не рекомендуется. Вместо него используйте стили. Определяет ширину ячейки | TF

Стандартные атрибуты

Тег <td> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <td> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.

Examples

Попробуйте сами - Примеры

Границы таблицы
HTML таблицы с различными границами.

Заголовочные ячейки таблицы
Как создать заголовочные ячейки таблицы.

Пустые ячейки
Как использовать "&nbsp;" для обработки ячеек, которые не имеют содержимого.

Таблица с заголовком
HTML таблица с заголовком.

Теги внутри таблицы
Как показать элементы внутри других элементов.

Ячейки, которые охватывают более одной строки/колонки
Как определить ячейки таблицы, которые охватывают более одной строки или одного столбца.

Cellpadding
Как использовать атрибут cellpadding для создания большего пустого пространства между содержимым ячейки и ее границами.

Cellspacing
Как использовать атрибут cellspacing,чтобы увеличить расстояние между ячейками.

Добавление цвета фона или фонового изображения для таблицы
Как добавить фон в таблицу.

Атрибут frame
Как использовать атрибут frame для управления границей вокруг таблицы.


HTML Тег <textarea>

Пример

Простая текстовая область:

<textarea rows="2" cols="20">
В W3Schools вы найдете все необходимые учебники по Веб-разработкам, начиная с элементарного по HTML до продвинутых по XML, SQL, ASP и PHP.
</textarea>

Попробуйте сами »

Определение и использование

Тег <textarea> определяет управляющий элемент многострочного ввода текст.

Текстовая область может содержать любое количество символов и текст представляется шрифтом фиксированной ширины (обычно Courier).

Размер текстового поля можно задать атрибутами cols и rows, а еще лучше, через CSS свойства height и width.

Поддержка браузерами

Тег <textarea> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Обязательные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
cols | число | Определяет видимую ширину текстовой области | STF
rows | число | Определяет видимое количество строк в текстовом области | STF

Дополнительные атрибуты

Атрибут | Значение | Описание | DTD
disabled | disabled | Указывает, что текстовая область должна быть недоступна | STF
name | имя_textarea | Определяет имя текстового области | STF
readonly | readonly | Указывает, что текстовая область должна быть доступна только для чтения | STF

Стандартные атрибуты

Тег <textarea> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
accesskey | символ | Определяет сочетание клавиш для доступа к элементу | STF
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
tabindex | число | Указывает порядке перехода к элементу | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <xxx> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onblur | скрипт | Скрипт выполняется, когда элемент теряет фокус | STF
onchange | скрипт | Скрипт выполняется, когда элемент изменен | STF
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onfocus | скрипт | Скрипт выполняется, когда элемент получает фокус | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF
onselect | скрипт | Скрипт выполняется, когда элемент выбран | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <tfoot>

Пример

HTML таблица с элементами thead, tfoot и tbody:

<table border="1">
<thead>
<tr>
<th>Месяц</th>
<th>Накопление</th>
</tr>
</thead>
<tfoot>
<tr>
<td>Итого:</td>
<td>$180</td>
</tr>
</tfoot>
<tbody>
<tr>
<td>Январь</td>
<td>$100</td>
</tr>
<tr>
<td>Февраль</td>
<td>$80</td>
</tr>
</tbody>
</table>

Попробуйте сами »

Определение и использование

Тег <tfoot> используется для группировки содержания колонтитула в таблице HTML.

Элемент tfoot должен быть использован в сочетании с элементами thead и tbody.

Элемент thead используется для группировки содержания заголовка в HTML таблице а элемент tbody используется для группировки содержимого тела HTML таблицы.

Примечание: Тег <tfoot> должен находиться в таблице перед тегом <tbody>, чтобы браузер смог его отобразить до получения всех строк данных.

Обратите внимание, что эти элементы не влияют на расположение таблицы по умолчанию. Однако, вы можете использовать CSS, чтобы эти элементы влияли на расположение таблицы.

Поддержка браузерами

Тег <tfoot> лишь частично поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | right left center justify char | Выравнивает содержимое элемента tfoot | STF
char | символ | Определяет символ внутри содержания элемента tfoot, служащий осью для выравнивания | STF
charoff | число | Устанавливает горизонтальный отступ для первого экземпляра символа, указанного атрибутом char | STF
valign | top middle bottom baseline | Определяет вертикальное выравнивание данных в элементе tfoot | STF

Стандартные атрибуты

Тег <tfoot> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <tfoot> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <th>

Пример

Простая HTML таблица, содержащий два столбца и две строки:

<table border="1">
<tr>
<th>Месяц</th>
<th>Накопление</th>
</tr>
<tr>
<td>Январь</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Тег <th> определяет заголовочную ячейку в HTML таблице.

<

HTML таблица имеет два вида ячеек:

  • Заголовочные ячейки - содержат заголовочную информацию (создаются с помощью элемента th)
  • Стандартные ячейки - содержат данные (создаются с помощью элемента td)

Текст в элементе th отображается полужирным шрифтом и центрируется.

Текст в элемент td отображается обычным шрифтом и выравнивается по левому краю.

Поддержка браузерами

Тег <th> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Используйте атрибуты colspan и rowspan, чтобы содержание ячейки охватило нескольких столбцов или строк!

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
abbr | текст | Определяет содержимое ячейки в сокращённой форме | STF
align | left right center justify char | Выравнивает содержимое ячейки | STF
axis | имя_категории | Определяет категорию ячеек | STF
bgcolor | rgb(x,x,x) #xxxxxx название_цвета | Не рекомендуется. Вместо него используйте стили. Задает цвет фона для ячейки | TF
char | символ | Определяет символ содержания ячейки, служащий осью для выравнивания | STF
charoff | число | Устанавливает горизонтальный отступ для первого экземпляра символа, указанного атрибутом char | STF
colspan | число | Устанавливает число столбцов, которые ячейка должна охватывать | STF
height | пиксели % | Не рекомендуется. Вместо него используйте стили. Устанавливает высоту ячейки | TF
nowrap | nowrap | Не рекомендуется. Вместо него используйте стили. Указывает, что текст внутри ячейки должен отображаться без переносов | TF
rowspan | число | Устанавливает число строк, которые ячейка должна охватывать | STF
scope | col colgroup row rowgroup | Определяет набор ячеек данных, для которых текущая заголовочная ячейка предоставляет заголовочную информацию | STF
valign | top middle bottom baseline | Определяет вертикальное выравнивание данных в ячейке | STF
width | пиксели % | Не рекомендуется. Вместо него используйте стили. Определяет ширину ячейки | TF

Стандартные атрибуты

Тег <th> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <th> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.

Examples

Попробуйте сами - Примеры

Границы таблицы
HTML таблицы с различными границами.

Заголовочные ячейки таблицы
Как создать заголовочные ячейки таблицы.

Пустые ячейки
Как использовать "&nbsp;" для обработки ячеек, которые не имеют содержимого.

Таблица с заголовком
HTML таблица с заголовком.

Теги внутри таблицы
Как показать элементы внутри других элементов.

Ячейки, которые охватывают более одной строки/колонки
Как определить ячейки таблицы, которые охватывают более одной строки или одного столбца.

Cellpadding
Как использовать атрибут cellpadding для создания большего пустого пространства между содержимым ячейки и ее границами.

Cellspacing
Как использовать атрибут cellspacing,чтобы увеличить расстояние между ячейками.

Добавление цвета фона или фонового изображения для таблицы
Как добавить фон в таблицу.

Атрибут frame
Как использовать атрибут frame для управления границей вокруг таблицы.


HTML Тег <thead>

Пример

HTML таблица с элементами thead, tfoot и tbody:

<table border="1">
<thead>
<tr>
<th>Месяц</th>
<th>Накопление</th>
</tr>
</thead>
<tfoot>
<tr>
<td>Итого:</td>
<td>$180</td>
</tr>
</tfoot>
<tbody>
<tr>
<td>Январь</td>
<td>$100</td>
</tr>
<tr>
<td>Февраль</td>
<td>$80</td>
</tr>
</tbody>
</table>

Попробуйте сами »

Определение и использование

Тег <thead> используется для определения строки/строк, которые будут отображаться вверху таблицы .

Элемент thead должен быть использован в сочетании с элементами tbody и tfoot.

Элемент tbody используется для группировки содержимого тела HTML таблицы а элемент tfoot используется для группировки содержания колонтитула в таблице HTML.

Примечание: Тег <tfoot> должен находиться в таблице перед тегом <tbody>, чтобы браузер смог его отобразить до получения всех строк данных.

Обратите внимание, что эти элементы не влияют на расположение таблицы по умолчанию. Однако, вы можете использовать CSS, чтобы эти элементы влияли на расположение таблицы.

Поддержка браузерами

Тег <thead> лишь частично поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | right left center justify char | Выравнивает содержимое элемента thead | STF
char | символ | Определяет символ внутри содержания элемента thead, служащий осью для выравнивания | STF
charoff | число | Устанавливает горизонтальный отступ для первого экземпляра символа, указанного атрибутом char | STF
valign | top middle bottom baseline | Определяет вертикальное выравнивание данных в элементе thead | STF

Стандартные атрибуты

Тег <thead> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <thead> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <title>

Пример

Простой HTML документ, с минимумом необходимых тегов:

<html>
<head>
<title>Заголовок документа</title>
</head>

<body>
Содержимое документа......
</body>

Попробуйте сами »

Определение и использование

Тег <title> определяет заголовок документа.

Элемент title требуется во всех HTML/XHTML документах.

Содержимое элемента title отображается:

  • в заголовке окна браузера
  • в названии закладки, при добавлении страницы в избранное
  • в результатах запроса в поисковых системах

Поддержка браузерами

Тег <title> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Тег <title> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <title> не поддерживает событийные атрибуты:

Более подробная информация о Событийных атрибутах.


HTML Тег <tr>

Пример

Простая HTML таблица, содержащий два столбца и две строки:

<table border="1">
<tr>
<th>Месяц</th>
<th>Накопление</th>
</tr>
<tr>
<td>Январь</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Тег <tr> определяет строку в HTML таблице.

Элемент tr содержит один или несколько элементов th или td.

Поддержка браузерами

Тег <tr> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
align | right left center justify char | Выравнивает содержания в строке таблицы | STF
bgcolor | rgb(x,x,x) #xxxxxx название_цвета | Не рекомендуется. Вместо него используйте стили. Задает цвет фона для строки таблицы | TF
char | символ | Выравнивает содержания в строке таблицы по символу | STF
charoff | число | Sets the number of characters the content will be aligned from the character specified by the char attribute | STF
valign | top middle bottom baseline | Вертикальное выравнивание содержания в строке таблицы | STF

Стандартные атрибуты

Тег <tr> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <tr> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.

Examples

Попробуйте сами - Примеры

Границы таблицы
HTML таблицы с различными границами.

Заголовочные ячейки таблицы
Как создать заголовочные ячейки таблицы.

Пустые ячейки
Как использовать "&nbsp;" для обработки ячеек, которые не имеют содержимого.

Таблица с заголовком
HTML таблица с заголовком.

Теги внутри таблицы
Как показать элементы внутри других элементов.

Ячейки, которые охватывают более одной строки/колонки
Как определить ячейки таблицы, которые охватывают более одной строки или одного столбца.

Cellpadding
Как использовать атрибут cellpadding для создания большего пустого пространства между содержимым ячейки и ее границами.

Cellspacing
Как использовать атрибут cellspacing,чтобы увеличить расстояние между ячейками.

Добавление цвета фона или фонового изображения для таблицы
Как добавить фон в таблицу.

Атрибут frame
Как использовать атрибут frame для управления границей вокруг таблицы.


HTML Тег <u>

Элемент u является не рекомендуемым.

Пример

Текст, подчеркнутый с помощью тега <u>:

<p>Не <u>подчеркивайте</u> текст, если это не гиперссылка!</p>

Попробуйте сами »

Определение и использование

Тег <u> определяет подчеркнутый текст.

Поддержка браузерами

Тег <u> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Не подчеркивайте текст! Пользователь может перепутать его с гиперссылкой!

Стандартные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Тег <u> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <u> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.


HTML Тег <ul>

Пример

Неупорядоченный (маркированный) HTML список:

<ul>
<li>Кофе</li>
<li>Чай</li>
<li>Молоко</li>
</ul>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Тег <ul> определяет неупорядоченный (маркированный) список.

Поддержка браузерами

Тег <ul> поддерживается всеми основными браузерами.

Различия между HTML и XHTML

Различий НЕТ

Советы и примечания

Совет: Используйте CSS, чтобы определить тип маркера списка.

Дополнительные атрибуты

DTD указывает в каком HTML 4.01/XHTML 1.0 DTD атрибут допускается. S=Strict, T=Transitional и F=Frameset.

Атрибут | Значение | Описание | DTD
compact | compact | Не рекомендуется. Вместо него используйте стили. Указывает, что список должен иметь уменьшенные расстояния между пунктами | TF
type | disc square circle | Не рекомендуется. Вместо него используйте стили. Определяет тип маркера пунктов списка | TF

Стандартные атрибуты

Тег <ul> поддерживает следующие стандартные атрибуты:

Атрибут | Значение | Описание | DTD
class | имя_класса | Определяет имя класса для элемента | STF
dir | rtl ltr | Определяет направление текста для содержания элемента | STF
id | имя_id | Определяет уникальный идентификатор для элемента | STF
lang | код_языка | Указывает код языка для содержания элемента | STF
style | определение_стиля | Задает встроенный стиль для элемента | STF
title | текст | Указывает дополнительную информацию об элементе | STF
xml:lang | код_языка | Указывает код языка в XHTML документах для содержания элемента | STF

Более подробная информация о Стандартных атрибутах.

Событийные атрибуты

Тег <ul> поддерживает следующие событийные атрибуты:

Атрибут | Значение | Описание | DTD
onclick | скрипт | Скрипт выполняется по щелчку мыши | STF
ondblclick | скрипт | Скрипт выполняется по двойному щелчку мыши | STF
onmousedown | скрипт | Скрипт выполняется при нажатии кнопки мыши | STF
onmousemove | скрипт | Скрипт выполняется при перемещении указателя мыши | STF
onmouseout | скрипт | Скрипт выполняется, когда указатель мыши выходит из элемента | STF
onmouseover | скрипт | Скрипт выполняется при перемещении мыши по элементу | STF
onmouseup | скрипт | Скрипт выполняется при отпускании кнопки мыши | STF
onkeydown | скрипт | Скрипт выполняется при нажатии клавиши | STF
onkeypress | скрипт | Скрипт выполняется при нажатии и отпускании клавиши | STF
onkeyup | скрипт | Скрипт выполняется при отпускании клавиши | STF

Более подробная информация о Событийных атрибутах.

Examples

Попробуйте сами - Примеры

Вложенный список
Список внутри списка.

Другой вложенный список
Более сложный вложенный список.


HTML Атрибут a_charset

HTML Атрибут charset тега <a>

HTML a Tag Reference HTML Тег <a>

Пример

Использование атрибута charset в ссылке:

<a charset="UTF-8" href="http://www.w3schools.com">www.W3Schools.com</a>

Попробуйте сами »

Определение и использование

Атрибут charset определяет набор символов (кодировку) связанного документа (документ ссылается с помощью атрибута href).

Набором символов (кодировкой) по умолчанию для современных браузеров является ISO-8859-1.

Поддержка браузерами

Атрибут charset не поддерживается основными браузерами.

Синтаксис

<a charset="значение">

Значения атрибута

Значение Описание
кодировка

Распространенные наборы символов (кодировки):

  • UTF-8 - Кодировка Unicode
  • ISO-8859-1 - Кодировка символов для латинского алфавита

В теории, может быть использован любой набор символов, но не все из них понимает браузер. Чем более широко используется кодировка, тем выше вероятность того, что она будет понята браузером.

Для просмотра всех доступных наборов символов, перейдите на наш Character sets reference.

HTML a Tag Reference HTML Тег <a>


HTML Атрибут a_coords

HTML Атрибут coords тега <a>

HTML a Tag Reference HTML Тег <a>

Пример

Использование атрибутов shape и coords в элементе, для создания карты изображений:

<object data="planets.gif" alt="Планеты" type="image/gif" usemap="#Map1">
<map name="Map1">
<a href="sun.htm" shape="rect" coords="0,0,82,126">Солнце</a>
<a href="mercur.htm"shape="circle" coords="90,58,3">Меркурий</a>
<a href="venus.htm" shape="circle" coords="124,58,8">Венера</a>
</map>
</object>

Попробуйте сами »

Определение и использование

Атрибут coords используется вместе с атрибутом shape для указания размера, формы и размещения ссылки на объекте или элементе img.

Координатами верхнего левого угла являются 0,0.

Совет: Для создания карт изображений, работающих во всех браузерах, используйте элемент area!

Поддержка браузерами

Атрибут coords поддерживается только в Firefox и Opera.

Синтаксис

<a coords="значение">

Значения атрибута

Значение | Описание
x1,y1,x2,y2 | Если атрибут shape имеет значение "rect", значение определяет координаты верхнего левого угла и нижнего правого угла прямоугольника:
x,y,radius | Если атрибут shape имеет значение "circle", значение определяет координаты центра круга и радиус
x1,y1,x2,y2,..,xn,yn | Если атрибут shape имеет значение "poly", значение указывает координаты краев многоугольника (полигона). Если первая и последняя пары координат не совпадают, браузер должен добавить последнюю пару координат, чтобы закрыть полигон

HTML a Tag Reference HTML Тег <a>


HTML Атрибут a_href

HTML Атрибут href тега <a>

HTML a Tag Reference HTML Тег <a>

Пример

Атрибут href указывает ссылочный адресат:

<a href="http://www.w3schools.com">Посетите W3Schools</a>

Попробуйте сами »

Определение и использование

Атрибут href указывает адресат ссылки.

Атрибут href или атрибут name должен присутствовать в теге <a>.

Поддержка браузерами

Атрибут href поддерживается всеми основными браузерами.

Синтаксис

<a href="значение">

Значения атрибута

Значение Описание
URL URL ссылки.

Возможные значения:

  • Абсолютный URL - указывает на другой веб-сайт (например, href="http://www.example.com/default.htm")
  • Относительный URL - указывает на файл внутри веб-сайта (например, href="default.htm")
  • Якорь URL - указывает на якорь в пределах страницы (например, href="#top")

HTML a Tag Reference HTML Тег <a>


HTML Атрибут a_hreflang

HTML Атрибут hreflang тега <a>

HTML a Tag Reference HTML Тег <a>

Пример

Атрибут hreflang определяет базовый язык документа, обозначенного в ссылке:

<a href="http://www.w3schools.com" hreflang="en">W3Schools</a>

Попробуйте сами »

Определение и использование

Атрибут hreflang определяет язык связанного документа.

Поддержка браузерами

Атрибут hreflang не поддерживается всеми основными браузерами.

Синтаксис

<a hreflang="значение">

Значения атрибута

Значение | Описание
код_языка | Двухбуквенный код языка, определяющий язык связанного документа. Для просмотра всех доступных кодов языка, перейдите на наш Language code reference.

HTML a Tag Reference HTML Тег <a>


HTML Атрибут a_name

HTML Атрибут name тега <a>

HTML a Tag Reference HTML Тег <a>

Пример

Атрибута name определяет имя якоря:

<a name="C4">Глава 4</a>

Попробуйте сами »

Определение и использование

Атрибута name определяет имя якоря.

Атрибута name используется для создания закладки внутри документа.

Атрибут href или атрибут name должен присутствовать в теге <a>

Совет: В XHTML, атрибут name тега <a> является устаревшим, и будет удален. Используйте вместо него атрибут id.

Поддержка браузерами

Атрибут name поддерживается всеми основными браузерами.

Синтаксис

<a name="значение">

Значения атрибута

Значение | Описание
имя_якоря | Имя якоря

HTML a Tag Reference HTML Тег <a>


HTML Атрибут rel

HTML Атрибут rel тега <a>

HTML a Tag Reference HTML Тег <a>

Пример

Ссылка с атрибутом rel:

<a rel="friend" href="http://www.functravel.com/">Дешевые рейсы</a>

Попробуйте сами »

Определение и использование

Атрибут rel указывает отношение между текущим документом и связанным документом.

Поддержка браузерами

Атрибут rel не поддерживается всеми основными браузерами.

Примечание: Браузеры не используют этот атрибут в любом случае. Однако, поисковые машины могут использовать этот атрибут, чтобы получить больше информации о ссылке.

Синтаксис

<a rel="значение">

Значения атрибута

Значение | Описание
alternate | An alternate version of the document (i.e. print page, translated or mirror)
stylesheet | An external style sheet for the document
start | The first document in a selection
next | The next document in a selection
prev | The previous document in a selection
contents | A table of contents for the document
index | An index for the document
glossary | A glossary (explanation) of words used in the document
copyright | A document containing copyright information
chapter | A chapter of the document
section | A section of the document
subsection | A subsection of the document
appendix | An appendix for the document
help | A help document
bookmark | A related document
nofollow | "nofollow" is used by Google, to specify that the Google search spider should not follow that link (mostly used for paid links)
license | Link to copyright information for the document
tag | A tag (keyword) for the current document
friend |

HTML a Tag Reference HTML Тег <a>


HTML Атрибут a_rev

HTML Атрибут rev тега <a>

HTML a Tag Reference HTML Тег <a>

Пример

Ссылка с атрибутом rev:

<a rev="friend" href="http://www.functravel.com/">Дешевые рейсы</a>

Попробуйте сами »

Определение и использование

Атрибут rev указывает отношение между связанным документом и текущим документом.

Атрибут rev является противоположным атрибуту rel.

Поддержка браузерами

Атрибут rev не поддерживается всеми основными браузерами.

Примечание: Браузеры не используют этот атрибут в любом случае. Однако, поисковые машины могут использовать этот атрибут, чтобы получить больше информации о ссылке.

Синтаксис

<a rev="значение">

Значения атрибута

Значение | Описание
alternate | An alternate version of the document (i.e. print page, translated or mirror)
stylesheet | An external style sheet for the document
start | The first document in a selection
next | The next document in a selection
prev | The previous document in a selection
contents | A table of contents for the document
index | An index for the document
glossary | A glossary (explanation) of words used in the document
copyright | A document containing copyright information
chapter | A chapter of the document
section | A section of the document
subsection | A subsection of the document
appendix | An appendix for the document
help | A help document
bookmark | A related document
nofollow | "nofollow" is used by Google, to specify that the Google search spider should not follow that link (mostly used for paid links)
license | Link to copyright information for the document
tag | A tag (keyword) for the current document
friend |

HTML a Tag Reference HTML Тег <a>


HTML Атрибут a_shape

HTML Атрибут shape тега <a>

HTML a Tag Reference HTML Тег <a>

Пример

Использование в элементе атрибутов shape и coords, для создания карты изображения:

<object data="planets.gif" alt="Планеты" type="image/gif" usemap="#Map1">
<map name="Map1">
<a href="sun.htm" shape="rect" coords="0,0,82,126">Солнце</a>
<a href="mercur.htm"shape="circle" coords="90,58,3">Меркурий</a>
<a href="venus.htm" shape="circle" coords="124,58,8">Венера</a>
</map>
</object>

Попробуйте сами »

Определение и использование

Атрибут shape используется вместе с атрибутом coords для указания размера, формы и размещения ссылки на объекте или элементе img.

Совет: Для создания карты изображения, которая работает во всех браузерах, используйте элемент area!

Поддержка браузерами

Атрибут shape поддерживается только Firefox и Opera.

Синтаксис

<a shape="значение">

Значения атрибута

Значение | Описание
default | Указывает всю область
rect | Указывает прямоугольную область
circle | Указывает круглую область
poly | Указывает многоугольную область

HTML a Tag Reference HTML Тег <a>


HTML Атрибут a_target

HTML Атрибут target тега <a>

HTML a Tag Reference HTML Тег <a>

Пример

Атрибут target указывает, где открыть связанный документ:

<a href="http://www.w3schools.com" target="_blank">Посетите W3Schools</a>

Попробуйте сами »

Определение и использование

Атрибут target указывает, где открыть связанный документ:

Поддержка браузерами

Атрибут charset поддерживается всеми основными браузерами.

Синтаксис

<a target="значение">

Значения атрибута

Значение | Описание
_blank | Открыть связанный документ в новом окне или вкладке
_self | Открыть связанный документ в текущем окне (по умолчанию для ссылок)
_parent | Открыть связанный документ в родительском фрейме
_top | Открыть связанный документ в полном окне браузера
имя_фрейма | Открыть связанный документ в указанном фрейме

HTML a Tag Reference HTML Тег <a>


HTML Атрибут area_alt

HTML Атрибут alt тега <area>

HTML a Tag Reference HTML Тег <area>

Пример

Карта изображения с активными областями:

<img src ="planets.gif" width="145" height="126" alt="Планеты" usemap ="#planetmap" />

<map name="planetmap">
<area shape="rect" coords="0,0,82,126" href="sun.htm" alt="Солнце" />
<area shape="circle" coords="90,58,3" href="mercur.htm" alt="Меркурий" />
<area shape="circle" coords="124,58,8" href="venus.htm" alt="Венера" />
</map>

Попробуйте сами »

Определение и использование

TОбязательный атрибут alt задает альтернативный текст для области, если изображение не может быть отображено.

Атрибут alt предоставляет альтернативную информацию для изображения, если пользователь по каким-то причинам не может увидеть его (из-за медленного соединения, ошибки в атрибуте src, или если пользователь использует программу чтения с экрана).

Поддержка браузерами

Атрибут alt не поддерживается всеми основными браузерами.

Синтаксис

<area alt="значение">

Значения атрибута

Значение | Описание
текст | Альтернативный текст для области

HTML a Tag Reference HTML Тег <area>


HTML Атрибут area_coords

HTML Атрибут coords тега <area>

HTML a Tag Reference HTML Тег <area>

Пример

Карта изображения с активными областями:

<img src ="planets.gif" width="145" height="126" alt="Планеты" usemap ="#planetmap" />

<map name="planetmap">
<area shape="rect" coords="0,0,82,126" href="sun.htm" alt="Солнце" />
<area shape="circle" coords="90,58,3" href="mercur.htm" alt="Меркурий" />
<area shape="circle" coords="124,58,8" href="venus.htm" alt="Венера" />
</map>

Попробуйте сами »

Определение и использование

Атрибут coords определяет координаты х и у для области.

Атрибут coords используется вместе с атрибутом shape для указания размера, формы и размещения области.

Координатами верхнего левого угла являются 0,0.

Поддержка браузерами

Атрибут coords поддерживается всеми основными браузерами.

Синтаксис

<area coords="значение">

Значения атрибута

x1,y1,x2,y2 | Если атрибут shape имеет значение "rect", значение определяет координаты верхнего левого угла и нижнего правого угла прямоугольника:
x,y,radius | Если атрибут shape имеет значение "circle", значение определяет координаты центра круга и радиус
x1,y1,x2,y2,..,xn,yn | Если атрибут shape имеет значение "poly", значение указывает координаты краев многоугольника (полигона). Если первая и последняя пары координат не совпадают, браузер должен добавить последнюю пару координат, чтобы закрыть полигон

HTML a Tag Reference HTML Тег <area>


HTML Атрибут area_href

HTML Атрибут href тега <area>

HTML a Tag Reference HTML Тег <area>

Пример

Карта изображения с активными областями:

<img src ="images/planets.gif" width="145" height="126" alt="Планеты" usemap ="#planetmap" />

<map name="planetmap">
<area shape="rect" coords="0,0,82,126" href="sun.htm" alt="Солнце" />
<area shape="circle" coords="90,58,3" href="mercur.htm" alt="Меркурий" />
<area shape="circle" coords="124,58,8" href="venus.htm" alt="Венера" />
</map>

Попробуйте сами »

Определение и использование

Атрибут href указывает адресат ссылки в области.

Поддержка браузерами

Атрибут href поддерживается всеми основными браузерами.

Синтаксис

<area href="значение">

Значения атрибута

Значение Описание
URL URL ссылки.

Возможные значения:

  • Абсолютный URL - указывает на другой веб-сайт (например, href="http://www.example.com/sun.htm")
  • Относительный URL - указывает на файл внутри веб-сайта (например, href="sun.htm")
  • Якорь URL - указывает на якорь в пределах страницы (например, href="#sun")

HTML a Tag Reference HTML Тег <area>


HTML Атрибут area_nohref

HTML Атрибут nohref тега <area>

HTML a Tag Reference HTML Тег <area>

Пример

Карта изображения с активными областями и атрибутом nohref:

<img src ="planets.gif" width="145" height="126" alt="Планеты" usemap ="#planetmap" />

<map name="planetmap">
<area shape="rect" coords="0,0,82,126" nohref="nohref" alt="Солнце" />
<area shape="circle" coords="90,58,3" href="mercur.htm" alt="Меркурий" />
<area shape="circle" coords="124,58,8" href="venus.htm" alt="Венера" />
</map>

Попробуйте сами »

Определение и использование

Атрибут nohref указывает, что область не имеет ассоциированной ссылки.

Совет: Атрибут nohref должен сообщить браузеру, что атрибута href нет. Вы могли бы более легко сделать это, не включая атрибут href.

Поддержка браузерами

Атрибут nohref не поддерживается всеми основными браузерами.

Синтаксис

<area nohref="значение">

Значения атрибута

Значение | Описание
nohref | Указывает, что область не имеет ассоциированной ссылки

HTML a Tag Reference HTML Тег <area>


HTML Атрибут area_shape

HTML Атрибут shape тега <area>

HTML a Tag Reference HTML Тег <area>

Пример

Карта изображения с активными областями:

<img src ="images/planets.gif" width="145" height="126" alt="Планеты" usemap ="#planetmap" />

<map name="planetmap">
<area shape="rect" coords="0,0,82,126" href="sun.htm" alt="Солнце" />
<area shape="circle" coords="90,58,3" href="mercur.htm" alt="Меркурий" />
<area shape="circle" coords="124,58,8" href="venus.htm" alt="Венера" />
</map>

Попробуйте сами »

Определение и использование

Атрибут shape определяет форму области.

Атрибут shape используется вместе с атрибутом coords для указания размера, формы и размещения области.

Поддержка браузерами

Атрибут shape поддерживается всеми основными браузерами.

Синтаксис

<area shape="значение">

Значения атрибута

Значение | Описание
default | Указывает всю область
rect | Указывает прямоугольную область
circle | Указывает круглую область
poly | Указывает многоугольную область

HTML a Tag Reference HTML Тег <area>


HTML Атрибут area_target

HTML Атрибут target тега <area>

HTML a Tag Reference HTML Тег <area>

Пример

Карта изображения с активными областями и атрибутом target:

<img src ="images/planets.gif" width="145" height="126" alt="Планеты" usemap ="#planetmap" />

<map name="planetmap">
<area shape="rect" coords="0,0,82,126" href="sun.htm" alt="Солнце"
target="_blank" />
<area shape="circle" coords="90,58,3" href="mercur.htm" alt="Меркурий" />
<area shape="circle" coords="124,58,8" href="venus.htm" alt="Венера" />
</map>

Попробуйте сами »

Определение и использование

Атрибут target указывает, где открыть связанную страницу, определенную в атрибуте href.

Поддержка браузерами

Атрибут target поддерживается всеми основными браузерами.

Синтаксис

<area target="значение">

Значения атрибута

Значение | Описание
_blank | Открыть связанный документ в новом окне или вкладке
_self | Открыть связанный документ в текущем окне (по умолчанию для ссылок)
_parent | Открыть связанный документ в родительском фрейме
_top | Открыть связанный документ в полном окне браузера
имя_фрейма | Открыть связанный документ в указанном фрейме

HTML a Tag Reference HTML Тег <area>


HTML Атрибут base_href

HTML Атрибут href тега <base>

HTML a Tag Reference HTML Тег <base>

Пример

Укажем базовый URL для всех относительных URL-адресов на странице:

<head>
<base href="http://www.w3schools.com/images/" />
</head>

<body>
<img src="stickman.gif" />
</body>

Попробуйте сами »

Определение и использование

Атрибут href указывает базовый URL для всех относительных URL-адресов на странице.

Поддержка браузерами

Атрибут href поддерживается всеми основными браузерами.

Синтаксис

<base href="значение">

Значения атрибута

Значение | Описание
URL | Абсолютный URL, который действует в качестве базового URL (например, "http://www.example.com/")

HTML a Tag Reference HTML Тег <base>


HTML Атрибут base_target

HTML Атрибут target тега <base>

HTML a Tag Reference HTML Тег <base>

Пример

Определим, где открывать все ссылки на странице по умолчанию:

<head>
<base target="_blank" />
</head>

<body>
<a href="http://www.w3schools.com">W3Schools</a>
</body>

Попробуйте сами »

Определение и использование

Атрибут target указывает, где открывать все ссылки на странице по умолчанию.

Поддержка браузерами

Атрибут target поддерживается всеми основными браузерами.

Синтаксис

<base target="значение">

Значения атрибута

Значение | Описание
_blank | Открыть связанный документ в новом окне или вкладке
_self | Открыть связанный документ в текущем окне (по умолчанию для ссылок)
_parent | Открыть связанный документ в родительском фрейме
_top | Открыть связанный документ в полном окне браузера
имя_фрейма | Открыть связанный документ в указанном фрейме

HTML a Tag Reference HTML Тег <base>


HTML Атрибут basefont_color

HTML Атрибут color тега <basefont>

HTML a Tag Reference HTML Тег <basefont>

Пример

Указать цвет шрифта по умолчанию для текста на странице:

<head>
<basefont color="red" />
</head>

<body>
<h1>Это заголовок</h1>
<p>Это абзац</p>
</body>

Попробуйте сами »

Определение и использование

Атрибут color задает цвет шрифта по умолчанию для текста в документе.

Поддержка браузерами

Атрибут color не поддерживается ни в одном из основных браузерах, кроме Internet Explorer.

Примечания относительно совместимости

Атрибут color тега <basefont> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS (в секции <head>): <style>body{color:red}</style>

Пример CSS: Укажите цвет шрифта по умолчанию для страницы

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве color текста.

Синтаксис

<basefont color="значение">

Значения атрибута

Значение | Описание
название_цвета | Задает цвет шрифта с помощью названия цвета (например, "red")
шестнадцатиричное_число | Задает цвет шрифта шестнадцатеричным кодом (например, "#ff0000")
rgb_число | Задает цвет шрифта с помощью rgb кода (например, "rgb(255,0,0)")

HTML a Tag Reference HTML Тег <basefont>


HTML Атрибут basefont_face

HTML Атрибут face тега <basefont>

HTML a Tag Reference HTML Тег <basefont>

Пример

Укажите шрифт по умолчанию для текста на странице:

<head>
<basefont face="courier, serif" />
</head>

<body>
<h1>Это заголовок</h1>
<p>Это абзац</p>
</body>

Попробуйте сами »

Определение и использование

Атрибут face определяет шрифт по умолчанию для текста в документе.

Совет: Значение атрибута face может иметь несколько имен шрифтов, как "резервная" система. Список шрифтов, которые вы хотите использовать первыми, затем все шрифты, которые могут заменить первые, если они недоступны. У вас должен получиться список общих шрифтов (serif, sans-serif, monospace, cursive или fantasy), чтобы браузер сам мог выбрать шрифт, находящийся в общей семье, если другие шрифты недоступны.

Поддержка браузерами

Атрибут color не поддерживается ни в одном из основных браузерах, кроме Internet Explorer.

Примечания относительно совместимости

Атрибут face тега <basefont> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS (в секции <head>): <style>body{font-family: courier, serif}</style>

Пример CSS: Укажите шрифт по умолчанию для страницы

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве font-family.

Синтаксис

<basefont face="значение">

Значения атрибута

Значение | Описание
семейство_шрифтов | Шрифт текста. Чтобы задать приоритетный список из нескольких шрифтов, разделяйте отдельные имена запятой (например, <basefont face="verdana,arial,sans-serif" />

HTML a Tag Reference HTML Тег <basefont>


HTML Атрибут basefont_size

HTML Атрибут size тега <basefont>

HTML a Tag Reference HTML Тег <basefont>

Пример

Укажите размер шрифта по умолчанию для текста на странице:

<head>
<basefont size="7" />
</head>

<body>
<h1>Это заголовок</h1>
<p>Это абзац</p>
</body>

Попробуйте сами »

Определение и использование

Атрибут size задает размер шрифта по умолчанию для текста в документе.

Поддержка браузерами

Атрибут color не поддерживается ни в одном из основных браузерах, кроме Internet Explorer.

Примечания относительно совместимости

Атрибут size тега <basefont> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS (в секции <head>): <style>body{font-size: 10px}</style>

Пример CSS: Укажите размер шрифт по умолчанию для страницы

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве font-size.

Синтаксис

<basefont size="значение">

Значения атрибута

Значение | Описание
число | Размер текста. Возможные значения: число от 1 до 7. Браузер по умолчанию 3.

HTML a Tag Reference HTML Тег <basefont>


HTML Атрибут bdo_dir

HTML Атрибут dir тега <bdo>

HTML a Tag Reference HTML Тег <bdo>

Пример

Укажите направление текста:

<bdo dir="rtl">Вот некоторый текст на иврите!</bdo>

Попробуйте сами »

Определение и использование

Обязательный атрибут dir указывает направление текста в текст внутри элемента bdo.

Поддержка браузерами

Атрибут dir поддерживается всеми основными браузерами.

Примечание: Не поддерживается в Safari 2 или более ранних версиях.

Синтаксис

<bdo dir="значение">

Значения атрибута

Значение | Описание
ltr | Направление текста слева направо
rtl | Направление текста справа налево

HTML a Tag Reference HTML Тег <bdo>


HTML Атрибут blockquot_cite

HTML Атрибут cite тега <blockquote>

HTML a Tag Reference HTML Тег <blockquote>

Пример

Цитата с атрибутом cite, который определяет источник цитаты:

<blockquote cite="http://en.wikiquote.org/wiki/Quotations">
Жизнь сама по себе является цитатой, цитата - не жизнь.
</blockquote>

Попробуйте сами »

Определение и использование

Атрибут cite указывает источник цитаты.

Поддержка браузерами

Атрибут cite не поддерживается всеми основными браузерами. Однако, поисковые системы могут использовать его для получения более подробной информации о цитате.

Синтаксис

<blockquote cite="значение">

Значения атрибута

Значение Описание
URL Источник цитаты.

Возможные значения:

  • Абсолютный URL - указывает на другой веб-сайт (например, cite="http://www.example.com")
  • Относительный URL - указывает на файл внутри веб-сайта (например, cite="example.htm")

HTML a Tag Reference HTML Тег <blockquote>


HTML Атрибут body_alink

HTML Атрибут alink тега <body>

HTML a Tag Reference HTML Тег <body>

Пример

Установить в документе HTML цвет активной ссылки в "green":

<html>
<body alink="green">
<p><a href="http://www.w3schools.com">W3Schools.com</a></p>
<p><a href="http://www.w3schools.com/html/">HTML Tutorial</a></p>
</body>
</html>

Попробуйте сами »

Определение и использование

Атрибут alink задает цвет активной ссылки в документе (ссылка активируется при нажатии на нее).

Поддержка браузерами

Атрибут alink поддерживается всеми основными браузерами.

Примечания относительно совместимости

Атрибут alink тега <body> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS (в секции <head>): <style>a:active {color: #0000FF}</style>

Пример CSS: Добавить фоновое изображение в документ

В нашем учебнике CSS вы можете найти более подробную информацию о :active pseudo-class.

Синтаксис

<body alink="значение">

Значения атрибута

Значение | Описание
название_цвета | Определяет цвет ссылки названием цвета (например, "red")
шестнадцатиричное_число | Определяет цвет ссылки шестнадцатеричным кодом (например, "#ff0000")
rgb_число | Определяет цвет ссылки rgb кодом (например, "rgb(255,0,0)")

HTML a Tag Reference HTML Тег <body>


HTML Атрибут body_background

HTML Атрибут background тега <body>

HTML a Tag Reference HTML Тег <body>

Пример

Укажите фоновое изображение для HTML документа:

<html>
<body background="bgimage.jpg">
<h1>Привет, Мир!</h1>
<p><a href="http://www.w3schools.com">Посетите W3Schools.com!</a></p>
</body>
</html>

Попробуйте сами »

Определение и использование

Атрибут background задает фоновое изображение для документа.

Поддержка браузерами

Атрибут background поддерживается всеми основными браузерами.

Примечания относительно совместимости

Атрибут background тега <body> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <body style="background-image:url(bgimage.jpg)">

Пример CSS: Укажите цвет активной ссылки

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве background-image.

Синтаксис

<body background="значение">

Значения атрибута

Значение Описание
URL URL фонового изображения.

Возможные значения:

  • Абсолютный URL - указывает на другой веб-сайт (например, href="http://www.example.com/bgimage.gif")
  • Относительный URL - указывает на файл внутри веб-сайта (например, href="/images/bgimage.gif")

HTML a Tag Reference HTML Тег <body>


HTML Атрибут body_bgcolor

HTML Атрибут bgcolor тега <body>

HTML a Tag Reference HTML Тег <body>

Пример

Укажите цвет фона для HTML документа:

<html>
<body bgcolor="#E6E6FA">
<h1>Привет, Мир!</h1>
<p><a href="http://www.w3schools.com">Посетите W3Schools.com!</a></p>
</body>
</html>

Попробуйте сами »

Определение и использование

Атрибут bgcolor задает цвет фона документа.

Поддержка браузерами

Атрибут charset поддерживается всеми основными браузерами.

Примечания относительно совместимости

Атрибут bgcolor тега <body> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <body style="background-color:#E6E6FA">

Пример CSS: Установить цвет фона документа

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве background-color.

Синтаксис

<body bgcolor="значение">

Значения атрибута

Значение | Описание
название_цвета | Определяет цвет ссылки названием цвета (например, "red")
шестнадцатиричное_число | Определяет цвет ссылки шестнадцатеричным кодом (например, "#ff0000")
rgb_число | Определяет цвет ссылки rgb кодом (например, "rgb(255,0,0)")

HTML a Tag Reference HTML Тег <body>


HTML Атрибут body_link

HTML Атрибут link тега <body>

HTML a Tag Reference HTML Тег <body>

Пример

Установить в HTML документе цвет ссылки по умолчанию в значение "blue":

<html>
<body link="blue">
<p><a href="http://www.w3schools.com">W3Schools.com</a></p>
<p><a href="http://www.w3schools.com/html/">HTML Tutorial</a></p>
</body>
</html>

Попробуйте сами »

Определение и использование

Атрибут link задает цвет по умолчанию посещенной ссылки в документе.

Поддержка браузерами

Атрибут charset поддерживается всеми основными браузерами.

Примечания относительно совместимости

Атрибут link тега <body> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS (в секции <head>): <style>a:link {color: #FF0000}</style>

Пример CSS: Установить цвет посещенной ссылки в документе

В нашем учебнике CSS вы можете найти более подробную информацию о :link pseudo-class.

Синтаксис

<body link="значение">

Значения атрибута

Значение | Описание
название_цвета | Задает цвет шрифта с помощью названия цвета (например, "red")
шестнадцатиричное_число | Задает цвет шрифта шестнадцатеричным кодом (например, "#ff0000")
rgb_число | Задает цвет шрифта с помощью rgb кода (например, "rgb(255,0,0)")

HTML a Tag Reference HTML Тег <body>


HTML Атрибут body_text

HTML Атрибут text тега <body>

HTML a Tag Reference HTML Тег <body>

Пример

Установить цвет текста в HTML документе:

<html>
<body text="green">
<h1>Hello world!</h1>
<p><a href="http://www.w3schools.com">Посетите W3Schools.com!</a></p>
</body>
</html>

Попробуйте сами »

Определение и использование

Атрибут text задает цвет текста в документе.

Поддержка браузерами

Атрибут text поддерживается всеми основными браузерами.

Примечания относительно совместимости

Атрибут text тега <body> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS (в секции <head>): <style>body{color:green}</style>

Пример CSS: Установить цвет текста в документе

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве text-color.

Синтаксис

<body text="значение">

Значения атрибута

название_цвета | Задает цвет шрифта с помощью названия цвета (например, "red")
шестнадцатиричное_число | Задает цвет шрифта шестнадцатеричным кодом (например, "#ff0000")
rgb_число | Задает цвет шрифта с помощью rgb кода (например, "rgb(255,0,0)")

HTML a Tag Reference HTML Тег <body>


HTML Атрибут body_vlink

HTML Атрибут vlink тега <body>

HTML a Tag Reference HTML Тег <body>

Пример

Установить в HTML документе цвет посещенной ссылки в "red":

<html>
<body vlink="red">
<p><a href="http://www.w3schools.com">W3Schools.com</a></p>
<p><a href="http://www.w3schools.com/html/">HTML Tutorial</a></p>
</body>
</html>

Попробуйте сами »

Определение и использование

Атрибут vlink задает в документе цвет посещенных ссылок.

Поддержка браузерами

Атрибут vlink поддерживается всеми основными браузерами.

Примечания относительно совместимости

Атрибут vlink тега <body> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS (в секции <head>): <style>a:visited {color: #FF0000}</style>

Пример CSS: Установить цвет посещенной ссылки

В нашем учебнике CSS вы можете найти более подробную информацию о :visited pseudo-class.

Синтаксис

<body vlink="значение">

Значения атрибута

Значение | Описание
название_цвета | Задает цвет шрифта с помощью названия цвета (например, "red")
шестнадцатиричное_число | Задает цвет шрифта шестнадцатеричным кодом (например, "#ff0000")
rgb_число | Задает цвет шрифта с помощью rgb кода (например, "rgb(255,0,0)")

HTML a Tag Reference HTML Тег <body>


HTML Атрибут button_disabled

HTML Атрибут disabled тега <button>

HTML a Tag Reference HTML Тег <button>

Пример

Недоступная кнопка размечается следущим образом:

<button type="button" disabled="disabled">Click Me!</button>

Попробуйте сами »

Определение и использование

Атрибут disabled указывает, что кнопка должна быть недоступной для пользователя.

Недоступную кнопку нельзя нажать.

Атрибут disabled может быть использован, чтобы удержать пользователя от щелчка по кнопки, пока некоторые другие условия не будут выполнены (например, выбрать флажок, и т.д.). Тогда, требуется JavaScript, чтобы удалить значение disabled и сделать кнопку доступной.

Поддержка браузерами

Атрибут disabled поддерживается всеми основными браузерами.

Синтаксис

<button disabled="значение">

Значения атрибута

Значение | Описание
disabled | Делает кнопку недоступной

HTML a Tag Reference HTML Тег <button>


HTML Атрибут button_name

HTML Атрибут name тега <button>

HTML a Tag Reference HTML Тег <button>

Пример

Две кнопки с одинаковыми именами, которые представляют различные значения при нажатии:

<form action="demo_button_name.asp" method="get">
Выберите свою любимую тему:
<button name="subject" type="submit" value="HTML">HTML</button>
<button name="subject" type="submit" value="CSS">CSS</button>
</form>

Попробуйте сами »

Определение и использование

Атрибут name определяет имя кнопки.

Атрибут name элемента button используется to reference form data after it has been submitted, или для ссылки на элемент в JavaScript.

Совет: Несколько элементов button могут разделять одно и то же имя. Это позволяет вам иметь несколько кнопок с одинаковыми именами, которые могут submit different values when used in a form.

Поддержка браузерами

Атрибут name поддерживается всеми основными браузерами.

Синтаксис

<button name="значение">

Значения атрибута

Значение | Описание
name | Имя кнопки

HTML a Tag Reference HTML Тег <button>


HTML Атрибут button_type

HTML Атрибут type тега <button>

HTML a Tag Reference HTML Тег <button>

Пример

Два элемента button, один из которые действует как кнопка submit, а другой как кнопка reset (в форме):

<form action="form_action.asp" method="get">
Имя: <input type="text" name="fname" /><br />
Фамилия: <input type="text" name="lname" /><br />
<button type="submit" value="Submit">Submit</button>
<button type="reset" value="Reset">Reset</button>
</form>

Попробуйте сами »

Определение и использование

Атрибут type определяет тип кнопки.

Совет: Всегда указывайте атрибут type для кнопки. Для Internet Explorer значением type по умолчанию является "button", в то время как в других браузерах (и в спецификации W3C) - "submit".

Поддержка браузерами

Атрибут type поддерживается всеми основными браузерами.

Синтаксис

<button type="значение">

Значения атрибута

Значение | Описание
submit | Кнопка является кнопкой отправки (это по умолчанию для всех браузеров, кроме Internet Explorer)
button | Кнопка является интерактивной кнопкой (это по умолчанию для Internet Explorer)
reset | Кнопка является кнопкой сброса (очищает данные формы)

HTML a Tag Reference HTML Тег <button>


HTML Атрибут button_value

HTML Атрибут value тега <button>

HTML a Tag Reference HTML Тег <button>

Пример

Две кнопки с одинаковыми именами, которые при нажатии передают различные значения:

<form action="demo_button_name.asp" method="get">
Выберите свою любимую тему:
<button name="subject" type="submit" value="HTML">HTML</button>
<button name="subject" type="submit" value="CSS">CSS</button>
</form>

Попробуйте сами »

Определение и использование

Атрибут value указывается базовое значение, связанное с кнопкой.

Важно: Если вы используете элемент button в HTML форме, различные браузеры будут отправлять различные значения. Internet Explorer будет отправлять текст между тегами <button> and </button>, в то время как другие браузеры будут отправлять содержание атрибута value. Используйте элемент input для создания кнопки в HTML форме.

Поддержка браузерами

Атрибут value поддерживается всеми основными браузерами.

Синтаксис

<button value="значение">

Значения атрибута

Значение | Описание
значение | Значение, которое будет отправлено

HTML a Tag Reference HTML Тег <button>


HTML Атрибут caption_align

HTML Атрибут align тега <caption>

HTML a Tag Reference HTML Тег <caption>

Пример

Таблица с элементом caption, расположеном ниже таблицы:

<table border="1">
<caption align="bottom">Ежемесячные накопления</caption>
<tr>
<th>Месяц</th>
<th>Накопления</th>
</tr>
<tr>
<td>Январь</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

Атрибут align определяет выравнивание элемента caption.

Этот атрибут должен выровнять заголовок как блоковый элемент слева, справа, выше или ниже таблицы.

Поддержка браузерами

Атрибут align не поддерживается должным образом ни в одном из основных браузерах, кроме Firefox.

Примечание: Значения "top" и "bottom" поддерживаются во всех браузерах, указанных выше выше. Значения "left" и "right" не поддерживается в Chrome или Safari, а Internet Explorer и Opera только выравнивают текст внутри заголовка (не весь элемент caption).

Примечания относительно совместимости

Атрибут align тега <caption> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Синтаксис CSS: <caption style="caption-side:left">

Примечание: CSS свойство caption-side не очень хорошо поддерживается в основных браузерах!

Пример CSS: Позиционирование заголовка таблицы

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве caption-side.

Синтаксис

<caption align="значение">

Значения атрибута

Значение | Описание
left | Заголовок в левой части таблицы
right | Заголовок в правой части таблицы
top | Заголовок в верхней части таблицы (это по умолчанию)
bottom | Заголовок в нижней части таблицы

HTML a Tag Reference HTML Тег <caption>


HTML Атрибут col_align

HTML Атрибут align тега <col>

HTML a Tag Reference HTML Тег <col>

Пример

В приведенном ниже примере, элементы col определяет выравнивание для трех столбцов в таблице:

<table width="100%" border="1">
<col align="left" />
<col align="left" />
<col align="right" />
<tr>
<th>ISBN</th>
<th>Заглавие</th>
<th>Цена</th>
</tr>
<tr>
<td>3476896</td>
<td>Мой первый HTML</td>
<td>$53</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

Атрибут align определяет горизонтальное выравнивание содержимого, связанного с элементом col.

Поддержка браузерами

Атрибут align поддерживается только в Internet Explorer и Opera.

Примечание: IE не обрабатывает правильно значение "justify" атрибута align в таблицах, вместо этого IE будет центрировать контент.

Примечание: Ни один из основных браузеров не обрабатывает правильно значение "char".

Синтаксис

<col align="значение">

Значения атрибута

Значение | Описание
left | Выравнивание содержания по левому краю
right | Выравнивание содержания по правому краю
center | Выравнивание содержания по центру
justify | Выравнивание содержания по ширине
char | Выравнивание содержания по конкретному символу

HTML a Tag Reference HTML Тег <col>


HTML Атрибут col_char

HTML Атрибут char тега <col>

HTML a Tag Reference HTML Тег <col>

Пример

В приведенном ниже примере, содержимое второй колонке следует выровнять по символу ".":

<table width="100%" border="1">
<col align="left" />
<col align="char" char="." />
<tr>
<th>Месяц</th>
<th>Накопления</th>
</tr>
<tr>
<td>Январь</td>
<td>$100.00</td>
</tr>
<tr>
<td>Февраль</td>
<td>$10.00</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

Атрибут char задает выравнивание по символу контента, связанного с элементом col.

Атрибут char может быть использован только, если атрибут align установлен в значение "char".

Значением по умолчанию атрибута char является символ десятичной точки.

Поддержка браузерами

Атрибут char не поддерживается всеми основными браузерами.

Синтаксис

<col char="значение">

Значения атрибута

Значение | Описание
символ | Определяет символ для выравнивания содержимого

HTML a Tag Reference HTML Тег <col>


HTML Атрибут col_charoff

HTML Атрибут charoff тега <col>

HTML a Tag Reference HTML Тег <col>

Пример

In the example below, the content of the second column is aligned two characters to the right from the "." character:

<table width="100%" border="1">
<col align="left" />
<col align="char" char="." charoff="2" />
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100.00</td>
</tr>
<tr>
<td>February</td>
<td>$10.00</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The charoff attribute sets the number of characters the content will be aligned from the character specified by the char attribute.

The charoff attribute can only be used if the char attribute is specified and the align attribute is set to "char".

Поддержка браузерами

Атрибут charoff не поддерживается всеми основными браузерами.

Синтаксис

<col charoff="значение">

Значения атрибута

Значение | Описание
число | Specifies the alignment. Positive numbers specifies alignment to the right of the character. Negative numbers specifies alignment to the left of the character.

HTML a Tag Reference HTML Тег <col>


HTML Атрибут col_span

HTML Атрибут span тега <col>

HTML a Tag Reference HTML Тег <col>

Пример

Here, all three columns will be center-aligned, because the col element spans three columns:

<table width="100%" border="1">
<col span="3" align="center" />
<tr>
<th>ISBN</th>
<th>Title</th>
<th>Price</th>
</tr>
<tr>
<td>3476896</td>
<td>My first HTML</td>
<td>$53</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The span attribute defines the number of columns a col element should span.

Поддержка браузерами

Атрибут span поддерживается всеми основными браузерами.

Синтаксис

<col span="значение">

Значения атрибута

Значение | Описание
число | Sets the number of columns a col element should span

HTML a Tag Reference HTML Тег <col>


HTML Атрибут col_valign

HTML Атрибут valign тега <col>

HTML a Tag Reference HTML Тег <col>

Пример

An HTML table with different vertical-aligned columns:

<table border="1" style="height:200px">
<col valign="top" />
<col valign="bottom" />
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The valign attribute specifies the vertical alignment of the content related to a col element.

Поддержка браузерами

Атрибут valign поддерживается всеми основными браузерами.

Note: None of the major browsers support the "baseline" value.

Синтаксис

<col valign="значение">

Значения атрибута

Значение | Описание
top | Top-align content
middle | Center-align content
bottom | Bottom-align content
baseline | The baseline is the "imaginary line" which most letters "sit" on, in a line of text. The baseline value sets the row so that all the table data share the same baseline. Often this has the same effect as the bottom value. However, if the fonts are in different sizes, baseline looks better. Look at the illustration below

Illustration of bottom vs. baseline if fonts are in different sizes:

valign="bottom"

valign="baseline"

HTML a Tag Reference HTML Тег <col>


HTML Атрибут col_width

HTML Атрибут width тега <col>

HTML a Tag Reference HTML Тег <col>

Пример

Two col elements with a predefined width:

<table border="1" width="100%">
<col width="100" />
<col width="50" />
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The width attribute specifies the width of a col element.

Normally, a col element takes up the space it needs to display the content. The width attribute is used to set a predefined width of a col element.

Note: This attribute will overwrite any width set in the colgroup element.

Поддержка браузерами

Атрибут width поддерживается всеми основными браузерами.

Note: None of the browsers support the relative_length value of this attribute.

Синтаксис

<col width="значение">

Значения атрибута

Значение | Описание
pixels | Sets the width in pixels (example: width="50")
percent | Sets the width in percent of the surrounding element (example: width="50%")
relative_length | Shares the available pixels into parts. (e.g. A table is 100 px, the first column is 20 px, the second is 50%, the available pixels will then be 30px). One part is set like this: "1*". Example: If 30 px of space are available, you can have one "1*" and one "2*", which will be interpreted as 10 and 20 px (think of 1* as one part, and 2* as two parts).

HTML a Tag Reference HTML Тег <col>


HTML Атрибут colgroup_align

HTML Атрибут align тега <colgroup>

HTML a Tag Reference HTML Тег <colgroup>

Пример

Two colgroup elements that specify different alignment for the three columns in the table (notice that the first colgroup element spans two columns):

<table width="100%" border="1">
<colgroup span="2" align="left"></colgroup>
<colgroup align="right"></colgroup>
<tr>
<th>ISBN</th>
<th>Title</th>
<th>Price</th>
</tr>
<tr>
<td>3476896</td>
<td>My first HTML</td>
<td>$53</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The align attribute specifies the horizontal alignment of the content in a column group.

Поддержка браузерами

Атрибут align поддерживают только Internet Explorer и Opera.

Note: IE does not handle the "justify" value properly in tables, IE will center the content instead.

Note: None of the major browsers handle the "char" value correctly.

Синтаксис

<colgroup align="значение">

Значения атрибута

Значение | Описание
left | Left-align content
right | Right-align content
center | Center-align content
justify | Stretches the lines so that each line has equal width (like in newspapers and magazines)
char | Align the content to a specific character

HTML a Tag Reference HTML Тег <colgroup>


HTML Атрибут colgroup_char

HTML Атрибут char тега <colgroup>

HTML a Tag Reference HTML Тег <colgroup>

Пример

In the example below, the content of the second column should be aligned to the "." character:

<table width="100%" border="1">
<colgroup align="left"></colgroup>
<colgroup align="char" char="."></colgroup>
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100.00</td>
</tr>
<tr>
<td>February</td>
<td>$10.00</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The char attribute specifies the alignment of the content in a column group to a character.

The char attribute can only be used if the align attribute is set to "char".

The default value of char is the decimal-point character of the page language.

Поддержка браузерами

Атрибут char не поддерживается всеми основными браузерами.

Синтаксис

<colgroup char="значение">

Значения атрибута

Значение | Описание
character | Specifies the character to align the content to

HTML a Tag Reference HTML Тег <colgroup>


HTML Атрибут colgroup_charoff

HTML Атрибут charoff тега <colgroup>

HTML a Tag Reference HTML Тег <colgroup>

Пример

In the example below, the content of the second column is aligned two characters to the right from the "." character:

<table width="100%" border="1">
<colgroup align="left"></colgroup>
<colgroup align="char" char="." charoff="2"></colgroup>
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100.00</td>
</tr>
<tr>
<td>February</td>
<td>$10.00</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The charoff attribute sets the number of characters the content will be aligned from the character specified by the char attribute.

The charoff attribute can only be used if the char attribute is specified and the align attribute is set to "char".

Поддержка браузерами

Атрибут charoff не поддерживается всеми основными браузерами.

Синтаксис

<colgroup charoff="значение">

Значения атрибута

Значение | Описание
число | Specifies the alignment. Positive numbers specifies alignment to the right of the character. Negative numbers specifies alignment to the left of the character.

HTML a Tag Reference HTML Тег <colgroup>


HTML Атрибут colgroup_span

HTML Атрибут span тега <colgroup>

HTML a Tag Reference HTML Тег <colgroup>

Пример

Two colgroup elements that specify different alignment for the three columns in the table (notice that the first colgroup element spans two columns):

<table width="100%" border="1">
<colgroup span="2" align="left"></colgroup>
<colgroup align="right"></colgroup>
<tr>
<th>ISBN</th>
<th>Title</th>
<th>Price</th>
</tr>
<tr>
<td>3476896</td>
<td>My first HTML</td>
<td>$53</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The span attribute defines the number of columns a column group should span.

Поддержка браузерами

Атрибут span поддерживается всеми основными браузерами.

Синтаксис

<colgroup span="значение">

Значения атрибута

Значение | Описание
число | Sets the number of columns a column group should span

HTML a Tag Reference HTML Тег <colgroup>


HTML Атрибут colgroup_valign

HTML Атрибут valign тега <colgroup>

HTML a Tag Reference HTML Тег <colgroup>

Пример

An HTML table with different vertical-aligned columns:

<table border="1" style="height:200px">
<colgroup valign="top" />
<colgroup valign="bottom" />
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The valign attribute specifies the vertical alignment of the content in a column group.

Поддержка браузерами

Атрибут valign поддерживается только в Internet Explorer и Opera.

Note: None of the major browsers support the "baseline" value.

Синтаксис

<colgroup valign="значение">

Значения атрибута

Значение | Описание
top | Top-align content
middle | Center-align content
bottom | Bottom-align content
baseline | The baseline is the "imaginary line" which most letters "sit" on, in a line of text. The baseline value sets the row so that all the table data share the same baseline. Often this has the same effect as the bottom value. However, if the fonts are in different sizes, baseline looks better. Look at the illustration below

Illustration of bottom vs. baseline if fonts are in different sizes:

valign="bottom"

valign="baseline"

HTML a Tag Reference HTML Тег <colgroup>


HTML Атрибут colgroup_width

HTML Атрибут width тега <colgroup>

HTML a Tag Reference HTML Тег <colgroup>

Пример

A column group that specifies that the two columns should have a predefined width of 100 pixels:

<table border="1">
<colgroup span="2" width="100" />
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

Атрибут charset определяет набор символов (кодировку) связанного документа (документ ссылается с помощью атрибута href).

Набором символов (кодировкой) по умолчанию для современных браузеров является ISO-8859-1.

Поддержка браузерами

Атрибут charset поддерживается всеми основными браузерами.

Синтаксис

<a charset="значение">

Значения атрибута

Значение | Описание
кодировка |

HTML a Tag Reference HTML Тег <colgroup>


HTML Атрибут del_cite

HTML Атрибут cite тега <del>

HTML a Tag Reference HTML Тег <del>

Пример

Использование атрибута cite в элементе del:

<p>My favorite color is <del cite="why_deleted.htm">blue</del> <ins>red</ins>!</p>

Попробуйте сами »

Определение и использование

The cite attribute specifies a URL to a document which explains why the text was deleted.

Поддержка браузерами

Note: None of the major browsers use the cite attribute in any way.

Синтаксис

<del cite="значение">

Значения атрибута

Значение Описание
URL The address to the document that explains why the text was deleted.

Possible values:

  • An absolute URL - Points to another web site (like cite="http://www.example.com")
  • A relative URL - Points to a page within a web site (like cite="example.html")
  • An anchor URL - Points to a named anchor (like cite="#bottom")

HTML a Tag Reference HTML Тег <del>


HTML Атрибут del_datetime

HTML Атрибут datetime тега <del>

HTML a Tag Reference HTML Тег <del>

Пример

Использование атрибута datetime в элементе del:

<p>My favorite color is <del datetime="2009-01-08T22:55:03Z">blue</del>
<ins>red</ins>!</p>

Попробуйте сами »

Определение и использование

Атрибут charset определяет набор символов (кодировку) связанного документа (документ ссылается с помощью атрибута href).

Набором символов (кодировкой) по умолчанию для современных браузеров является ISO-8859-1.

Поддержка браузерами

Атрибут charset поддерживается всеми основными браузерами.

Синтаксис

<a charset="значение">

Значения атрибута

Значение | Описание
кодировка |

HTML a Tag Reference HTML Тег <del>


HTML Атрибут dir_compact

HTML Атрибут compact тега <dir>

HTML a Tag Reference HTML Тег <dir>

Пример

Use of the compact attribute in a directory list:

<dir compact="compact">
<li>html</li>
<li>xhtml</li>
<li>css</li>
</dir>

Попробуйте сами »

Определение и использование

The compact attribute specifies that the list should render smaller than normal, by reducing the space between lines and the indentation of the list.

Поддержка браузерами

Атрибут compact не поддерживается всеми основными браузерами.

Примечания относительно совместимости

Атрибут compact тега <dir> является не рекомендуемым и не поддерживается в HTML 4.01 Strict/XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <dir style="line-height: 80%">

Пример CSS: reduce line-height in a list

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве line-height.

Синтаксис

<dir compact="значение">

Значения атрибута

Значение | Описание
compact | Specifies that the list should render smaller than normal

HTML a Tag Reference HTML Тег <dir>


HTML Атрибут div_align

HTML Атрибут align тега <div>

HTML a Tag Reference HTML Тег <div>

Пример

A section in a document that will be center-aligned:

<div align="center">
This is some text!
</div>

Попробуйте сами »

Определение и использование

The align attribute specifies the horizontal alignment of the content inside a div element.

Поддержка браузерами

Атрибут align поддерживается всеми основными браузерами.

Примечания относительно совместимости

Атрибут align тега <div> является не рекомендуемым и не поддерживается в HTML 4.01 Strict/XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <div style="text-align:center">

Пример CSS: Align text in a div element

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве text-align.

Синтаксис

<td align="значение">

Значения атрибута

Значение | Описание
left | Left-align content
right | Right-align content
center | Center-align content
justify | Stretches the lines so that each line has equal width (like in newspapers and magazines)

HTML a Tag Reference HTML Тег <div>


HTML Атрибут font_color

HTML Атрибут color тега <font>

HTML a Tag Reference HTML Тег <font>

Пример

Specify the color of text:

<font color="red">This is some text!</font>

Попробуйте сами »

Определение и использование

The color attribute specifies the color of the text inside a font element.

Поддержка браузерами

Атрибут color поддерживается всеми основными браузерами.

Примечания относительно совместимости

Атрибут color тега <font> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <p style="color:red">

Пример CSS: set the color of text

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве текста color.

Синтаксис

<font color="значение">

Значения атрибута

Значение | Описание
название_цвета | Задает цвет шрифта с помощью названия цвета (например, "red")
шестнадцатиричное_число | Задает цвет шрифта шестнадцатеричным кодом (например, "#ff0000")
rgb_число | Задает цвет шрифта с помощью rgb кода (например, "rgb(255,0,0)")

HTML a Tag Reference HTML Тег <font>


HTML Атрибут font_face

HTML Атрибут face тега <font>

HTML a Tag Reference HTML Тег <font>

Пример

Specify the font of text:

<font face="verdana">This is some text!</font>

Попробуйте сами »

Определение и использование

The face attribute specifies the font of the text inside a font element.

Tip: The value of the face attribute can hold several font names as a "fallback" system. List the font that you want first, followed by any fonts that can fill in for the first, if it is unavailable. You should end the list with a generic font (serif, sans-serif, monospace, cursive or fantasy), to let the browser pick a font that is in the generic family, if no other fonts are available.

Поддержка браузерами

Атрибут face поддерживается всеми основными браузерами.

Примечания относительно совместимости

Атрибут face тега <font> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <p style="font-family: verdana">

Пример CSS: set the font of text

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве font-family.

Синтаксис

<font face="значение">

Значения атрибута

Значение | Описание
font_family | The font of the text. To specify a prioritized list of several fonts, separate the names with a comma (like this <font face="verdana,arial,sans-serif">

HTML a Tag Reference HTML Тег <font>


HTML Атрибут font_size

HTML Атрибут size тега <font>

HTML a Tag Reference HTML Тег <font>

Пример

Specify the size of text:

<font size="6">This is some text!</font>

Попробуйте сами »

Определение и использование

The size attribute specifies the size of the text inside a font element.

Поддержка браузерами

Атрибут size поддерживается всеми основными браузерами.

Примечания относительно совместимости

Атрибут size тега <font> является не рекомендуемым и не поддерживается в HTML 4.01 Strict/XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <p style="font-size:20px">

Пример CSS: set the size of text

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве font-size.

Синтаксис

<a charset="значение">

Значения атрибута

Значение | Описание
кодировка |

HTML a Tag Reference HTML Тег <font>


HTML Атрибут form_charset

HTML Атрибут accept тега <form>

HTML a Tag Reference HTML Тег <form>

Пример

Use of the accept attribute in a form (allow two types of files in the file upload - gif and jpeg):

<form action="form_action.asp" accept="image/gif, image/jpeg">
First name: <input type="text" name="fname" /><br />
Last name: <input type="text" name="lname" /><br />
Your image: <input type="file" name="pic" id="pic" /><br />
<input type="submit" value="Submit" />
</form>

Попробуйте сами »

Определение и использование

The accept attribute specifies the type of files that can be submitted through a file upload.

Tip: Avoid using this attribute. File uploads should be validated on the server.

Поддержка браузерами

Примечание: Атрибут accept не поддерживается всеми основными браузерами.

Синтаксис

<form accept="значение">

Значения атрибута

Значение | Описание
MIME_тип | One or more MIME types that can be submitted/uploaded. To specify more than one MIME type, separate the types with a comma. Look at IANA MIME types for a complete list of standard MIME types.

HTML a Tag Reference HTML Тег <form>


HTML Атрибут form_accept-charset

HTML Атрибут accept-charset тега <form>

HTML a Tag Reference HTML Тег <form>

Пример

Использование атрибута accept-charset в форме:

<form action="form_action.asp" accept-charset="ISO-8859-1">
First name: <input type="text" name="fname" /><br />
Last name: <input type="text" name="lname" /><br />
<input type="submit" value="Submit" />
</form>

Попробуйте сами »

Определение и использование

The accept-charset attribute specifies the character-sets the server can handle for form-data.

Поддержка браузерами

Атрибут accept-charset поддерживается всеми основными браузерами, кроме Internet Explorer.

Note: The accept-charset attribute does not work properly in Internet Explorer. If accept-charset="ISO-8859-1", IE will send data encoded as "Windows-1252".

Синтаксис

<form accept-charset="значение">

Значения атрибута

Значение Описание
character_set One or more character-sets that the server can handle. To specify more than one character set, separate the sets with a comma.

Common values:

  • UTF-8 - Character encoding for Unicode
  • ISO-8859-1 - Character encoding for the Latin alphabet

In theory, any character encoding can be used, but no browser understands all of them. The more widely a character encoding is used, the better the chance that a browser will understand it.

To view all available character encodings, go to our Character sets reference.

HTML a Tag Reference HTML Тег <form>


HTML Атрибут form_action

HTML Атрибут action тега <form>

HTML a Tag Reference HTML Тег <form>

Пример

An HTML form with two input fields and one submit button. The form-data will be sent to a page called "form_action.asp" when the form is submitted:

<form action="form_action.asp" method="get">
First name: <input type="text" name="fname" /><br />
Last name: <input type="text" name="lname" /><br />
<input type="submit" value="Submit" />
</form>

Попробуйте сами »

Определение и использование

The required action attribute specifies where to send the form-data when a form is submitted.

Поддержка браузерами

Атрибут action поддерживается всеми основными браузерами.

Синтаксис

<form action="значение">

Значения атрибута

Значение Описание
URL Where to send the form data.

Possible values:

  • An absolute URL - points to another web site (like action="http://www.example.com/example.htm")
  • A relative URL - points to a file within a web site (like action="example.htm")

HTML a Tag Reference HTML Тег <form>


HTML Атрибут form_enctype

HTML Атрибут enctype тега <form>

HTML a Tag Reference HTML Тег <form>

Пример

In the following example, the form-data will be sent unencoded:

<form action="form_action.asp" method="get" enctype="text/plain">
First name: <input type="text" name="fname" /><br />
Last name: <input type="text" name="lname" /><br />
<input type="submit" value="Submit" />
</form>

Попробуйте сами »

Определение и использование

The enctype attribute specifies how form-data should be encoded before sending it to the server.

The form-data is encoded to "application/x-www-form-urlencoded" by default. This means that all characters are encoded before they are sent to the server (spaces are converted to "+" symbols, and special characters are converted to ASCII HEX values).

Поддержка браузерами

Атрибут enctype поддерживается всеми основными браузерами.

Синтаксис

<form enctype="значение">

Значения атрибута

Значение | Описание
application/x-www-form-urlencoded | All characters are encoded before sent (this is default)
multipart/form-data | No characters are encoded. This value is required when you are using forms that have a file upload control
text/plain | Spaces are converted to "+" symbols, but no special characters are encoded

HTML a Tag Reference HTML Тег <form>


HTML Атрибут form_method

HTML Атрибут method тега <form>

HTML a Tag Reference HTML Тег <form>

Пример

In the following example, the form-data will be appended to the URL via the "get" method:

<form action="form_action.asp" method="get">
First name: <input type="text" name="fname" /><br />
Last name: <input type="text" name="lname" /><br />
<input type="submit" value="Submit" />
</form>

Попробуйте сами »
(more examples at the bottom of this page)

Определение и использование

The method attribute specifies how to send form-data (the form-data is sent to the page specified in the action attribute).

The form-data can be sent as URL variables (with method="get") or as HTTP post (with method="post").

Notes on the "get" method:

  • This method appends the form-data to the URL in name/value pairs
  • This method is useful for form submissions where a user want to bookmark the result
  • There is a limit to how much data you can place in a URL (varies between browsers), therefore, you cannot be sure that all of the form-data will be correctly transferred
  • Never use the "get" method to pass sensitive information! (password or other sensitive information will be visible in the browser's address bar)

Notes on the "post" method:

  • This method sends the form-data as an HTTP post transaction
  • Form submissions with the "post" method cannot be bookmarked
  • The "post" method is more robust and secure than "get", and "post" does not have size limitations

Поддержка браузерами

Атрибут method поддерживается всеми основными браузерами.

Синтаксис

<form method="значение">

Значения атрибута

Значение | Описание
get | Appends the form-data to the URL: URL?name=value&name=value
post | Sends the form-data as an HTTP post transaction

Examples

Попробуйте сами - Примеры

form method attribute example using "post"
Send form data with the "post" method.

HTML a Tag Reference HTML Тег <form>


HTML Атрибут form_name

HTML Атрибут name тега <form>

HTML a Tag Reference HTML Тег <form>

Пример

An HTML form with a name attribute:

<form action="form_action.asp" method="get" name="myForm">
First name: <input type="text" name="fname" /><br />
Last name: <input type="text" name="lname" /><br />
<input type="button" onclick="formSubmit()" value="Send form data!" />
</form>

Попробуйте сами »

Определение и использование

The name attribute specifies the name of a form.

The name attribute of the form element provides a way to reference the form in a script.

Tip: In XHTML, the name attribute of the <form> tag is deprecated, and will be removed. Use the id attribute instead.

Поддержка браузерами

Атрибут name поддерживается всеми основными браузерами.

Синтаксис

<form name="значение">

Значения атрибута

Значение | Описание
name | The name of a form

HTML a Tag Reference HTML Тег <form>


HTML Атрибут form_target

HTML Атрибут target тега <form>

HTML a Tag Reference HTML Тег <form>

Пример

In the following example, the page specified in the action attribute will open in a new window:

<form action="form_action.asp" method="get" target="_blank">
First name: <input type="text" name="fname" /><br />
Last name: <input type="text" name="lname" /><br />
<input type="submit" value="Submit" />
</form>

Попробуйте сами »

Определение и использование

The target attribute specifies where to open the action URL.

Поддержка браузерами

Атрибут target поддерживается всеми основными браузерами.

Примечания относительно совместимости

Атрибут target тега <form> является не рекомендуемым и не поддерживается в HTML 4.01 Strict/XHTML 1.0 Strict DTD.

Синтаксис

<form target="значение">

Значения атрибута

Значение | Описание
_blank | Open in a new window or tab
_self | Open in the same frame as it was clicked
_parent | Open in the parent frameset
_top | Open in the full body of the window
framename | Open in a named frame

HTML a Tag Reference HTML Тег <form>


HTML Атрибут frame_frameborder

HTML Атрибут frameborder тега <frame>

HTML a Tag Reference HTML Тег <frame>

Пример

A two-framed page, with no frameborders:

<html>

<frameset cols="50%,50%">
<frame src="frame_a.htm" frameborder="0" />
<frame src="frame_b.htm" frameborder="0" />
</frameset>

</html>

Попробуйте сами »

Определение и использование

The frameborder attribute specifies whether or not to display a border around a frame.

Tip: For practical reasons, it may be better not to specify borders, and use CSS to apply border styles and color instead.

CSS Example: frame borders

Поддержка браузерами

Атрибут frameborder поддерживается всеми основными браузерами.

Синтаксис

<frame frameborder="значение">

Значения атрибута

Значение | Описание
1 | Border on (this is default)
0 | Border off

HTML a Tag Reference HTML Тег <frame>


HTML Атрибут frame_longdesc

HTML Атрибут longdesc тега <frame>

HTML a Tag Reference HTML Тег <frame>

Пример

The longdesc attribute points to a page with a long description of the content of a frame:

<html>

<frameset cols="50%,50%">
<frame src="frame_a.htm" longdesc="w3s.txt" />
<frame src="frame_b.htm" />
</frameset>

</html>

Попробуйте сами »

Определение и использование

The longdesc attribute specifies an URL to a page that contains a long description of the content of a frame.

Note: The longdesc attribute is so poorly supported that it should not be used.

Tip: To offer a long description of a frame (if necessary), simply create a link (that is visible to anyone) to a page with the description.

Поддержка браузерами

Атрибут longdesc не поддерживается всеми основными браузерами.

Синтаксис

<frame longdesc="значение">

Значения атрибута

Значение Описание
URL An URL to a page that describes the content of a frame.

Possible values:

  • An absolute URL - points to another web site (like longdesc="http://www.example.com/description.txt")
  • A relative URL - points to a file within a web site (like longdesc="description.txt")

HTML a Tag Reference HTML Тег <frame>


HTML Атрибут frame_marginheight

HTML Атрибут marginheight тега <frame>

HTML a Tag Reference HTML Тег <frame>

Пример

The first frame with a top and bottom margin of 50 pixels, and the second frame with a top and bottom margin of 0 pixels:

<html>

<frameset cols="50%,50%">
<frame src="frame_a.htm" marginheight="50" />
<frame src="frame_b.htm" marginheight="0" />
</frameset>

</html>

Попробуйте сами »

Определение и использование

The marginheight attribute specifies the height between the content and the top and bottom of the frame, in pixels.

Поддержка браузерами

Атрибут marginheight поддерживается всеми основными браузерами.

Синтаксис

<frame marginheight="значение">

Значения атрибута

Значение | Описание
pixels | Specifies the top and bottom margins of a frame

HTML a Tag Reference HTML Тег <frame>


HTML Атрибут frame_marginwidth

HTML Атрибут marginwidth тега <frame>

HTML a Tag Reference HTML Тег <frame>

Пример

The first frame with a left and right margin of 50 pixels, and the second frame with a left and right margin of 0 pixels:

<html>

<frameset cols="50%,50%">
<frame src="frame_a.htm" marginwidth="50" />
<frame src="frame_b.htm" marginwidth="0" />
</frameset>

</html>

Попробуйте сами »

Определение и использование

The marginwidth attribute specifies the width between the content and the left and right sides of the frame, in pixels.

Поддержка браузерами

Атрибут marginwidth поддерживается всеми основными браузерами.

Синтаксис

<frame marginwidth="значение">

Значения атрибута

Значение | Описание
pixels | Specifies the left and right margins of a frame

HTML a Tag Reference HTML Тег <frame>


HTML Атрибут frame_name

HTML Атрибут name тега <frame>

HTML a Tag Reference HTML Тег <frame>

Пример

A named frame:

<html>

<frameset cols="50%,50%">
<frame src="frame_a.htm" name="frame_a" />
<frame src="frame_b.htm" />
</frameset>

</html>

Попробуйте сами »

Определение и использование

The name attribute specifies the name of a frame.

The name attribute of the frame element is used to reference the element in a JavaScript, or to act as a target for a link.

Tip: In XHTML, the name attribute of the <frame> tag is deprecated, and will be removed. Use the id attribute instead.

Поддержка браузерами

Атрибут name поддерживается всеми основными браузерами.

Синтаксис

<frame name="значение">

Значения атрибута

Значение | Описание
name | The name of a frame

HTML a Tag Reference HTML Тег <frame>


HTML Атрибут frame_noresize

HTML Атрибут noresize тега <frame>

HTML a Tag Reference HTML Тег <frame>

Пример

Frame A cannot be resized:

<html>

<frameset cols="50%,50%">
<frame src="frame_a.htm" noresize="noresize" />
<frame src="frame_b.htm" />
</frameset>

</html>

Попробуйте сами »

Определение и использование

The noresize attribute specifies that a frame cannot be resized by the user.

By default, each frame in a frameset can be resized by dragging the "walls" between the frames. However, this attribute locks the size of a frame.

Поддержка браузерами

Атрибут noresize поддерживается всеми основными браузерами.

Синтаксис

<frame noresize="значение">

Значения атрибута

Значение | Описание
noresize | The frame cannot be resized by the user

HTML a Tag Reference HTML Тег <frame>


HTML Атрибут frame_scrolling

HTML Атрибут scrolling тега <frame>

HTML a Tag Reference HTML Тег <frame>

Пример

Frame A always contain scrollbars:

<html>

<frameset cols="50%,50%">
<frame src="frame_a.htm" scrolling="yes" />
<frame src="frame_b.htm" />
</frameset>

</html>

Попробуйте сами »

Определение и использование

The scrolling attribute specifies whether or not to display scrollbars in a frame.

By default, scrollbars appear in a frame if the content is larger than the frame.

Поддержка браузерами

Атрибут scrolling поддерживается всеми основными браузерами.

Синтаксис

<frame scrolling="значение">

Значения атрибута

Значение | Описание
auto | Scrollbars appear if needed (this is default)
yes | Scrollbars are always shown (even if they are not needed)
no | Scrollbars are never shown (even if they are needed)

HTML a Tag Reference HTML Тег <frame>


HTML Атрибут frame_src

HTML Атрибут src тега <frame>

HTML a Tag Reference HTML Тег <frame>

Пример

The src attribute specifies the location of the document to show in a frame:

<html>

<frameset cols="50%,50%">
<frame src="frame_a.htm" />
<frame src="frame_b.htm" />
</frameset>

</html>

Попробуйте сами »

Определение и использование

The src attribute specifies the URL of the document to show in a frame.

Поддержка браузерами

Атрибут src поддерживается всеми основными браузерами.

Синтаксис

<frame src="значение">

Значения атрибута

Значение Описание
URL The address to the document to show in the frame.

Possible values:

  • An absolute URL - points to another web site (like src="http://www.example.com/default.htm")
  • A relative URL - points to a file within a web site (like src="default.htm")

HTML a Tag Reference HTML Тег <frame>


HTML Атрибут frameset_cols

HTML Атрибут cols тега <frameset>

HTML a Tag Reference HTML Тег <frameset>

Пример

A frameset with three columns:

<html>

<frameset cols="25%,*,25%">
<frame src="frame_a.htm" />
<frame src="frame_b.htm" />
<frame src="frame_c.htm" />
</frameset>

</html>

Попробуйте сами »

Определение и использование

The cols attribute specifies the size of, and the number of columns in a frameset.

Each frame’s width is specified in the cols attribute in a comma-separated list.

Note: The number of cols attribute values specified, defines the number of columns in the frameset.

Поддержка браузерами

Атрибут cols поддерживается всеми основными браузерами.

Синтаксис

<frameset cols="значение">

Значения атрибута

Значение | Описание
pixels | The column size in pixels (like "100px" or just "100")
% | The column size in percent of the available space (like "50%")
* | The rest of the available space should be assigned this column

HTML a Tag Reference HTML Тег <frameset>


HTML Атрибут frameset_rows

HTML Атрибут rows тега <frameset>

HTML a Tag Reference HTML Тег <frameset>

Пример

A frameset with three rows:

<html>

<frameset rows="25%,*,25%">
<frame src="frame_a.htm" />
<frame src="frame_b.htm" />
<frame src="frame_c.htm" />
</frameset>

</html>

Попробуйте сами »

Определение и использование

The rows attribute specifies the size of, and the number of rows in a frameset.

Each frame’s height is specified in the rows attribute in a comma-separated list.

Note: The number of rows attribute values specified, defines the number of rows in the frameset.

Поддержка браузерами

Атрибут rows поддерживается всеми основными браузерами.

Синтаксис

<frameset rows="значение">

Значения атрибута

Значение | Описание
pixels | The row height in pixels (like "100px" or just "100")
% | The row height in percent of the available space (like "50%")
* | The rest of the available space should be assigned this row

HTML a Tag Reference HTML Тег <frameset>


HTML Атрибут hn_align

HTML Атрибут align тегов от <h1> до <h6>

HTML a Tag Reference HTML Теги от <h1> до <h6>

Пример

A center-aligned HTML heading:

<h1 align="center">This is heading 1</h1>

Попробуйте сами »

Определение и использование

The align attribute specifies the horizontal alignment of a heading.

Поддержка браузерами

The align attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут align тегов от <h1> до <h6> является не рекомендуемым и не поддерживается в HTML 4.01 Strict/XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <h1 style="text-align:right">

Пример CSS: Set the alignment of headings

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве text-align.

Синтаксис

<h1 align="значение">

Значения атрибута

Значение | Описание
left | Left-aligns the heading
right | Right-aligns the heading
center | Center-aligns the heading
justify | The heading is justified to both margins

HTML a Tag Reference HTML Теги от <h1> до <h6>


HTML Атрибут hr_align

HTML Атрибут align тега <hr>

HTML a Tag Reference HTML Тег <hr>

Пример

A left-aligned horizontal line:

<hr align="left" width="50%" />

Попробуйте сами »

Определение и использование

The align attribute specifies the alignment of a horizontal line.

Note: The align attribute has no effect unless the width attribute is set to less than 100%.

Поддержка браузерами

The align attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут align тега <hr> является не рекомендуемым и не поддерживается в HTML 4.01 Strict/XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS для IE и Opera: <hr style="text-align:right" />

Синтаксис CSS для Firefox, Chrome и Safari: <hr style="margin-right:0" />

For cross-browser syntax use both: <hr style="text-align:right;margin-right:0" />

Пример CSS: align a hr element

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве text-align.

Синтаксис

<hr align="значение">

Значения атрибута

Значение | Описание
left | Left-aligns the horizontal line
center | Center-aligns the horizontal line (this is default)
right | Right-aligns the horizontal line

HTML a Tag Reference HTML Тег <hr>


HTML Атрибут hr_noshade

HTML Атрибут noshade тега <hr>

HTML a Tag Reference HTML Тег <hr>

Пример

A noshaded horizontal line:

<hr noshade="noshade" />

Попробуйте сами »

Определение и использование

The noshade attribute specifies that a horizontal line should render in one solid color (noshaded), instead of a shaded color.

Поддержка браузерами

The noshade attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут noshade тега <hr> является не рекомендуемым и не поддерживается в HTML 4.01 Strict/XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS для Internet Explorer: <hr style="height:2px;color:gray" />

Синтаксис CSS для Firefox, Opera, Chrome и Safari: <hr style="height:2px;border-width:0;background-color:gray" />

For cross-browser syntax use both: <hr style="height:2px;border-width:0;color:gray;background-color:gray" />

Пример CSS: A noshaded hr

В нашем учебнике CSS вы можете найти более подробную информацию о свойствах color и background-color.

Синтаксис

<hr noshade="значение">

Значения атрибута

Значение | Описание
noshade | The horizontal line will render in one solid color (noshaded)

HTML a Tag Reference HTML Тег <hr>


HTML Атрибут hr_size

HTML Атрибут size тега <hr>

HTML a Tag Reference HTML Тег <hr>

Пример

A horizontal line with a height of 30 pixels:

<hr size="30" />

Попробуйте сами »

Определение и использование

The size attribute specifies the height of a horizontal line, in pixels.

Поддержка браузерами

The size attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут size тега <hr> является не рекомендуемым и не поддерживается в HTML 4.01 Strict/XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <hr style="height:30px" />

Пример CSS: Set the height of a hr element

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве height.

Синтаксис

<hr size="значение">

Значения атрибута

Значение | Описание
пиксели | The height of the hr element

<

HTML a Tag Reference HTML Тег <hr>


HTML Атрибут hr_width

HTML Атрибут width тега <hr>

<

HTML a Tag Reference HTML Тег <hr>

Пример

A horizontal line with a width of 50%:

<hr width="50%" />

Попробуйте сами »

Определение и использование

The width attribute specifies the width of a horizontal line, in pixels or percent.

Поддержка браузерами

The width attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут width тега <hr> является не рекомендуемым и не поддерживается в HTML 4.01 Strict/XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <hr style="width:50%" />

Пример CSS: Set the width of a hr element

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве width.

Синтаксис

<hr width="значение">

Значения атрибута

Значение | Описание
pixels | The width in pixels (like "100px" or just "100")
% | The width in percent of the available space (like "50%")

<

HTML a Tag Reference HTML Тег <hr>


HTML Атрибут html_xmlns

HTML Атрибут xmlns тега <html>

HTML a Tag Reference HTML Тег <html>

Пример

A simple XHTML document, with the minimum of required tags:

<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>Title of the document</title>
</head>

<body>
The content of the document......
</body>

</html>

Попробуйте сами »

Определение и использование

The xmlns attribute specifies the xml namespace for a document.

Note: The xmlns attribute is required in XHTML but it is invalid in HTML!

However, the HTML validator at w3.org does not complain when the xmlns attribute is missing in an XHTML document. This is because the namespace "xmlns=http://www.w3.org/1999/xhtml" is default, and will be added to the <html> tag even if you do not include it.

Поддержка браузерами

Атрибут xmlns поддерживается всеми основными браузерами.

Синтаксис

<html xmlns="значение">

Значения атрибута

Значение | Описание
http://www.w3.org/1999/xhtml | The namespace to use (for XHTML documents)

HTML a Tag Reference HTML Тег <html>


HTML Атрибут iframe_align

HTML Атрибут align тега <iframe>

HTML a Tag Reference HTML Тег <iframe>

Пример

A right-aligned iframe:

<iframe src="/default.asp" width="200" height="200" align="right">
<p>Your browser does not support iframes.</p>
</iframe>

Попробуйте сами »

Определение и использование

The align attribute specifies the horizontal and vertical alignment of an iframe according to the surrounding element.

The iframe element is an inline element (it does not insert a new line on a page), meaning that text and other elements can wrap around it. Therefore, it can be useful to specify the alignment of the iframe according to surrounding elements.

Поддержка браузерами

The align attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут align тега <iframe> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <iframe style="float:right">

Пример CSS: Float an iframe to the right

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве float.

Синтаксис

<iframe align="значение">

Значения атрибута

Значение | Описание
left | Align the iframe to the left
right | Align the iframe to the right
middle | Align the iframe in the middle
top | Align the iframe at the top
bottom | Align the iframe at the bottom

HTML a Tag Reference HTML Тег <iframe>


HTML Атрибут iframe_frameborder

HTML Атрибут frameborder тега <iframe>

HTML a Tag Reference HTML Тег <iframe>

Пример

An iframe with no border:

<iframe src="/default.asp" width="200" height="200" frameborder="0">
<p>Your browser does not support iframes.</p>
</iframe>

Попробуйте сами »

Определение и использование

The frameborder attribute specifies whether or not to display a border around an iframe.

Tip: For practical reasons, it may be better not to specify borders, and use CSS to apply border styles and color instead.

CSS Example: iframe borders

Поддержка браузерами

Атрибут frameborder поддерживается всеми основными браузерами.

Синтаксис

<iframe frameborder="значение">

Значения атрибута

Значение | Описание
1 | Border on (this is default)
0 | Border off

HTML a Tag Reference HTML Тег <iframe>


HTML Атрибут iframe_height

HTML Атрибут height тега <iframe>

HTML a Tag Reference HTML Тег <iframe>

Пример

An iframe with a specified height and width:

<iframe src="/default.asp" width="200" height="200">
<p>Your browser does not support iframes.</p>
</iframe>

Попробуйте сами »

Определение и использование

The height attribute specifies the height of an iframe.

Поддержка браузерами

Атрибут height поддерживается всеми основными браузерами.

Синтаксис

<iframe height="значение">

Значения атрибута

Значение | Описание
pixels | The height in pixels (like "100px" or just "100")
percent | The height in percent of the containing element (like "20%")

HTML a Tag Reference HTML Тег <iframe>


HTML Атрибут iframe_longdesc

HTML Атрибут longdesc тега <iframe>

HTML a Tag Reference HTML Тег <iframe>

Пример

The longdesc attribute points to a page with a long description of the content of an iframe:

<iframe src="/default.asp" width="200" height="200" longdesc="w3s.txt">
<p>Your browser does not support iframes.</p>
</iframe>

Попробуйте сами »

Определение и использование

The longdesc attribute specifies an URL to a page that contains a long description of the content of an iframe.

Note: The longdesc attribute is so poorly supported that it should not be used.

Tip: To offer a long description of an iframe (if necessary), simply create a link (that is visible to anyone) to a page with the description.

Поддержка браузерами

Атрибут longdesc не поддерживается всеми основными браузерами.

Синтаксис

<iframe longdesc="значение">

Значения атрибута

Значение Описание
URL An URL to a page that describes the content of an iframe.

Possible values:

  • An absolute URL - points to another web site (like longdesc="http://www.example.com/description.txt")
  • A relative URL - points to a file within a web site (like longdesc="description.txt")

HTML a Tag Reference HTML Тег <iframe>


HTML Атрибут iframe_marginheight

HTML Атрибут marginheight тега <iframe>

P> HTML a Tag Reference HTML Тег <iframe>

Пример

An iframe with a top and bottom margin of 50 pixels:

<iframe src="demo_iframe.htm" marginheight="50px">
<p>Your browser does not support iframes.</p>
</iframe>

Попробуйте сами »

Определение и использование

The marginheight attribute specifies the top and bottom margins of an iframe, in pixels.

Поддержка браузерами

Атрибут marginheight поддерживается всеми основными браузерами.

Синтаксис

<iframe marginheight="значение">

Значения атрибута

Значение | Описание
pixels | Specifies the top and bottom margins of an iframe

P> HTML a Tag Reference HTML Тег <iframe>


HTML Атрибут iframe_marginwidth

HTML Атрибут marginwidth тега <iframe>

P> HTML a Tag Reference HTML Тег <iframe>

Пример

An iframe with a left and right margin of 50 pixels:

<iframe src="demo_iframe.htm" marginwidth="50px">
<p>Your browser does not support iframes.</p>
</iframe>

Попробуйте сами »

Определение и использование

The marginwidth attribute specifies the left and right margins of an iframe, in pixels.

Поддержка браузерами

Атрибут marginwidth поддерживается всеми основными браузерами.

Синтаксис

<iframe marginwidth="значение">

Значения атрибута

Значение | Описание
pixels | Specifies the left and right margins of an iframe

P> HTML a Tag Reference HTML Тег <iframe>


HTML Атрибут iframe_name

HTML Атрибут name тега <iframe>

HTML a Tag Reference HTML Тег <iframe>

Пример

<

An iframe that act as a target for a link:

<iframe src="demo_iframe.htm" name="iframe_a">
<p>Your browser does not support iframes.</p>
</iframe>
<a href="http://www.w3schools.com" target="iframe_a">W3Schools.com</a>

Попробуйте сами »

Определение и использование

The name attribute specifies the name of an iframe.

The name attribute of the iframe element is used to reference the element in a JavaScript, or to act as a target for a link.

Tip: In XHTML, the name attribute of the <iframe> tag is deprecated, and will be removed. Use the id attribute instead.

Поддержка браузерами

Атрибут name поддерживается всеми основными браузерами.

Синтаксис

<iframe name="значение">

Значения атрибута

Значение | Описание
name | The name of an iframe

HTML a Tag Reference HTML Тег <iframe>


HTML Атрибут iframe_scrolling

HTML Атрибут scrolling тега <iframe>

HTML a Tag Reference HTML Тег <iframe>

Пример

An iframe with scrollbars:

<iframe src="/default.asp" width="200" height="200" scrolling="yes">
<p>Your browser does not support iframes.</p>
</iframe>

Попробуйте сами »

Определение и использование

The scrolling attribute specifies whether or not to display scrollbars in an iframe.

By default, scrollbars appear in an iframe if the content is larger than the iframe.

Поддержка браузерами

Атрибут scrolling поддерживается всеми основными браузерами.

Синтаксис

<iframe scrolling="значение">

Значения атрибута

Значение | Описание
auto | Scrollbars appear if needed (this is default)
yes | Scrollbars are always shown (even if they are not needed)
no | Scrollbars are never shown (even if they are needed)

HTML a Tag Reference HTML Тег <iframe>


HTML Атрибут iframe_src

HTML Атрибут src тега <iframe>

HTML a Tag Reference HTML Тег <iframe>

Пример

An iframe in its simplest use:

<iframe src="/default.asp">
<p>Your browser does not support iframes.</p>
</iframe>

Попробуйте сами »

Определение и использование

The src attribute specifies the URL of the document to show in an iframe.

Поддержка браузерами

Атрибут src поддерживается всеми основными браузерами.

Синтаксис

<iframe src="значение">

Значения атрибута

Значение Описание
URL The address to the document to show in the iframe.

Possible values:

  • An absolute URL - points to another web site (like src="http://www.example.com/default.htm")
  • A relative URL - points to a file within a web site (like src="default.htm")

HTML a Tag Reference HTML Тег <iframe>


HTML Атрибут iframe_width

HTML Атрибут width тега <iframe>

HTML a Tag Reference HTML Тег <iframe>

Пример

An iframe with a specified height and width:

<iframe src="/default.asp" width="200" height="200">
<p>Your browser does not support iframes.</p>
</iframe>

Попробуйте сами »

Определение и использование

The width attribute specifies the width of an iframe.

Поддержка браузерами

Атрибут width поддерживается всеми основными браузерами.

Синтаксис

<iframe width="значение">

Значения атрибута

Значение | Описание
пиксели | The width in pixels (like "100px" or just "100")
проценты | The width in percent of the containing element (like "20%")

HTML a Tag Reference HTML Тег <iframe>


HTML Атрибут img_align

HTML Атрибут align тега <img>

HTML a Tag Reference HTML Тег <img>

Пример

Align the image in the middle of a text:

<p><img src="logo_w3s.gif" alt="W3Schools.com" align="middle" />This is some text. This is some text. This is some text.</p>

Попробуйте сами »

Определение и использование

The align attribute specifies the horizontal and vertical alignment of an image according to the surrounding element.

The img element is an inline element (it does not insert a new line on a page), meaning that text and other elements can wrap around it. Therefore, it can be useful to specify the alignment of the image according to surrounding elements.

Поддержка браузерами

The align attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут align тега <img> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS:<img style="float:right" />

Пример CSS: Float an image to the right

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве float.

Синтаксис

<img align="значение">

Значения атрибута

Значение | Описание
left | Align the image to the left
right | Align the image to the right
middle | Align the image in the middle
top | Align the image at the top
bottom | Align the image at the bottom

HTML a Tag Reference HTML Тег <img>


HTML Атрибут img_alt

HTML Атрибут alt тега <img>

HTML a Tag Reference HTML Тег <img>

Пример

An image is marked up as follows:

<img src="angry.gif" alt="Angry face" />

Попробуйте сами »

Определение и использование

The required alt attribute specifies an alternate text for an image, if the image cannot be displayed.

The alt attribute provides alternative information for an image if a user for some reason cannot view it (because of slow connection, an error in the src attribute, or if the user uses a screen reader).

Note: Internet Explorer also displays the value of the alt attribute as a tooltip when mousing over the image. This is NOT the correct behavior, according to the HTML specification.

Tip: To create a tooltip for an image, use the title attribute!

Поддержка браузерами

Атрибут alt поддерживается всеми основными браузерами.

Синтаксис

<img alt="значение">

Значения атрибута

Значение Описание
текст An alternate text for an image.

Guidelines for the alt text:

  • If the image contains information - use alt to describe the image
  • If the image is inside an a element - use alt to explain where the link goes
  • If the image is only for decoration - use alt=""

HTML a Tag Reference HTML Тег <img>


HTML Атрибут img_border

HTML Атрибут border тега <img>

HTML a Tag Reference HTML Тег <img>

Пример

An image with a border of 5 pixels:

<img src="logo_w3s.gif" alt="W3Schools.com" border="5" />

Попробуйте сами »

Определение и использование

The border attribute specifies the width of the border around an image.

Note: An image has no border by default (unless the image is inside an a element).

Поддержка браузерами

The border attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут border тега <img> является не рекомендуемым и не поддерживается в HTML 4.01 Strict/XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS:<img style="border:5px solid black" />

Пример CSS: image border

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве border.

Синтаксис

<img border="значение">

Значения атрибута

Значение | Описание
пиксели | The width of the border, in pixels

HTML a Tag Reference HTML Тег <img>


HTML Атрибут img_height

HTML Атрибут height тега <img>

HTML a Tag Reference HTML Тег <img>

Пример

An image with a height and a width of 100 pixels:

<img src="logo_w3s.gif" alt="W3Schools.com" height="100" width="100" />

Попробуйте сами »

Определение и использование

The height attribute specifies the height of an image.

Tip: It is a good practice to specify both the height and width attributes for an image. If these attributes are set, the space required for the image is reserved when the page is loaded. However, without these attributes, the browser does not know the size of the image, and cannot reserve the appropriate space to it. The effect will be that the page layout will change during loading (while the images load).

Tip: Downsizing a large image with the height and width attributes forces a user to download the large image (even if it looks small on the page). To avoid this, rescale the image with a program before using it on a page.

Поддержка браузерами

Атрибут height поддерживается всеми основными браузерами.

Синтаксис

<img height="значение">

Значения атрибута

Значение | Описание
пиксели | The height in pixels (like "100px" or just "100")
проценты | The height in percent of the containing element (like "20%")

HTML a Tag Reference HTML Тег <img>


HTML Атрибут img_hspace

HTML Атрибут hspace тега <img>

HTML a Tag Reference HTML Тег <img>

Пример

An image with a 20 pixels margin on both left and right sides:

<p><img src="logo_w3s.gif" alt="W3Schools.com" align="middle" hspace="20" />This is some text. This is some text. This is some text.</p>

Попробуйте сами »

Определение и использование

The hspace attribute specifies the whitespace on left and right side of an image.

Поддержка браузерами

The hspace attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут hspace тега <img> является не рекомендуемым и не поддерживается в HTML 4.01 Strict/XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS:<img style="margin: 0px 20px" />

Пример CSS: image with margins

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве margin.

Синтаксис

<img hspace="значение">

Значения атрибута

Значение | Описание
пиксели | The whitespace on left and right side of an image, in pixels

HTML a Tag Reference HTML Тег <img>


HTML Атрибут img_ismap

HTML Атрибут ismap тега <img>

HTML a Tag Reference HTML Тег <img>

Пример

A server-side image-map:

<a href="demo_form.asp">
<img src="img_logo.gif" ismap="ismap" />
</a>

Попробуйте сами »

Определение и использование

The ismap attribute specifies an image as a server-side image-map.

An image-map is an image with clickable areas.

When clicking a sever-side image map, the click coordinates are sent to the server as a URL query string.

Поддержка браузерами

Атрибут ismap поддерживается всеми основными браузерами.

Синтаксис

<img ismap="ismap" />

HTML a Tag Reference HTML Тег <img>


HTML Атрибут img_longdesc

HTML Атрибут longdesc тега <img>

HTML a Tag Reference HTML Тег <img>

Пример

Use of the longdesc attribute, to point to a page with a long description of an image:

<img src="logo_w3s.gif" alt="W3Schools.com" longdesc="w3s.txt" />

Попробуйте сами »

Определение и использование

Use of the longdesc attribute, to point to a page with a long description of an image:

Note: The longdesc attribute is so poorly supported that it should not be used.

Tip: To offer a long description of an image, simply create a link (that is visible to anyone) to a page with the description.

Поддержка браузерами

Атрибут longdesc не поддерживается всеми основными браузерами.

Синтаксис

<img longdesc="URL" />

Значения атрибута

Значение Описание
URL An URL to a page that describes the image.

Possible values:

  • An absolute URL - points to another web site (like longdesc="http://www.example.com/description.txt")
  • A relative URL - points to a file within a web site (like longdesc="description.txt

HTML a Tag Reference HTML Тег <img>


HTML Атрибут img_src

HTML Атрибут src тега <img>

HTML a Tag Reference HTML Тег <img>

Пример

An image is marked up as follows:

<img src="angry.gif" alt="Angry face" />

Попробуйте сами »

Определение и использование

<

The required src attribute specifies the URL of an image.

Поддержка браузерами

Атрибут src поддерживается всеми основными браузерами.

Синтаксис

<img src="значение">

Значения атрибута

Значение Описание
URL The URL of the image.

Possible values:

  • An absolute URL - points to another web site (like src="http://www.example.com/image.gif")
  • A relative URL - points to a file within a web site (like src="image.gif")

HTML a Tag Reference HTML Тег <img>


HTML Атрибут img_usemap

HTML Атрибут usemap тега <img>

HTML a Tag Reference HTML Тег <img>

Пример

An image-map, with clickable areas:

<img src="planets.gif" width="145" height="126" alt="Planets" usemap="#planetmap" />

<map name="planetmap">
<area shape="rect" coords="0,0,82,126" href="sun.htm" alt="Sun" />
<area shape="circle" coords="90,58,3" href="mercur.htm" alt="Mercury" />
<area shape="circle" coords="124,58,8" href="venus.htm" alt="Venus" />
</map>

Попробуйте сами »

Определение и использование

The usemap attribute specifies an image as a client-side image-map.

An image-map is an image with clickable areas.

The usemap attribute is associated with a map element's name or id attribute, and creates a relationship between the image and the map.

Поддержка браузерами

Атрибут usemap поддерживается всеми основными браузерами.

Синтаксис

<img usemap="значение">

Значения атрибута

Значение | Описание
#mapname | A hash character ("#") plus the name or id of the map element to use

HTML a Tag Reference HTML Тег <img>


HTML Атрибут img_vspace

HTML Атрибут vspace тега <img>

HTML a Tag Reference HTML Тег <img>

Пример

An image with a 20 pixels margin on top and bottom:

<p><img src="logo_w3s.gif" alt="W3Schools.com" align="middle" vspace="20" />This is some text. This is some text. This is some text.</p>

Попробуйте сами »

Определение и использование

The vspace attribute specifies the whitespace on top and bottom of an image.

Поддержка браузерами

The vspace attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут vspace тега <img> является не рекомендуемым и не поддерживается в HTML 4.01 Strict/XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS:<img style="margin: 20px 0px" />

Пример CSS: image with margins

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве margin.

Синтаксис

<img vspace="значение">

Значения атрибута

Значение | Описание
пиксели | The whitespace on top and bottom of an image, in pixels

HTML a Tag Reference HTML Тег <img>


HTML Атрибут img_width

HTML Атрибут width тега <img>

HTML a Tag Reference HTML Тег <img>

Пример

An image with a height and a width of 100 pixels:

<img src="logo_w3s.gif" alt="W3Schools.com" height="100" width="100" />

Попробуйте сами »

Определение и использование

The width attribute specifies the width of an image.

Tip: It is a good practice to specify both the height and width attributes for an image. If these attributes are set, the space required for the image is reserved when the page is loaded. However, without these attributes, the browser does not know the size of the image, and cannot reserve the appropriate space to it. The effect will be that the page layout will change during loading (while the images load).

Tip: Downsizing a large image with the height and width attributes forces a user to download the large image (even if it looks small on the page). To avoid this, rescale the image with a program before using it on a page.

Поддержка браузерами

Атрибут width поддерживается всеми основными браузерами.

Синтаксис

<img width="значение">

Значения атрибута

Значение | Описание
пиксели | The width in pixels (like "100px" or just "100")
проценты | The width in percent of the containing element (like "20%")

HTML a Tag Reference HTML Тег <img>


HTML Атрибут input_accept

HTML Атрибут accept тега <input>

HTML a Tag Reference HTML Тег <input>

Пример

Use of the accept attribute in a file upload (allow two types of files in the upload - gif and jpeg):

<form>
<input type="file" name="pic" id="pic" accept="image/gif, image/jpeg" />
</form>

Определение и использование

The accept attribute is only used with <input type="file"> and it specifies the types of files that can be submitted through a file upload.

Tip: Avoid using this attribute. File uploads should be validated on the server.

Поддержка браузерами

Note: The accept attribute is not properly supported by any of the major browsers.

Синтаксис

<input accept="значение">

Значения атрибута

Значение | Описание
MIME_тип | One or more MIME types that can be submitted/uploaded. To specify more than one MIME type, separate the types with a comma. Look at IANA MIME types for a complete list of standard MIME types

HTML a Tag Reference HTML Тег <input>


HTML Атрибут input_align

HTML Атрибут align тега <input>

HTML a Tag Reference HTML Тег <input>

Пример

An HTML form with two input fields and one image as a submit button:

<form action="form_action.asp" method="get">
First name: <input type="text" name="fname" /><br />
Last name: <input type="text" name="lname" /><br />
<input type="image" src="submit.gif" alt="Submit" align="right"/>
<p>This is some text This is some text This is some text.</p>
</form>

Попробуйте сами »

Определение и использование

The align attribute is only used with <input type="image"> and it specifies the alignment of the image input according to surrounding elements.

Поддержка браузерами

Note: Only the "left" and "right" values of the align attribute work properly in all major browsers.

Примечания относительно совместимости

Атрибут align тега <input> является не рекомендуемым и не поддерживается в HTML 4.01 Strict/XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <input type="image" style="float:right"/>

Пример CSS: align input image

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве float.

Синтаксис

<input align="значение">

Значения атрибута

Значение | Описание
left | Left-aligns the image (this is default)
right | Right-aligns the image
top | Top-aligns the image
middle | Middle-aligns the image
bottom | Bottom-aligns the image

HTML a Tag Reference HTML Тег <input>


HTML Атрибут input_alt

HTML Атрибут alt тега <input>

HTML a Tag Reference HTML Тег <input>

Пример

An HTML form with two input fields and one image as a submit button:

<form action="form_action.asp" method="get">
First name: <input type="text" name="fname" /><br />
Last name: <input type="text" name="lname" /><br />
<input type="image" src="submit.gif" alt="Submit" width="48" height="48"/>
</form>

Попробуйте сами »

Определение и использование

The alt attribute is only used with <input type="image"> and it specifies an alternate text for an image input.

The alt attribute provides alternative information if the user for some reason cannot view the image (because of slow connection, an error in the src attribute, or if the user uses a screen reader).

Note: Even though the alt attribute is not specified as required, it should always be set when <input type="image">. Not using this attribute will cause problems for text-only browsers or non-visual browsers.

Поддержка браузерами

Атрибут charset поддерживается всеми основными браузерами, кроме Safari.

Синтаксис

<input alt="текст" />

Значения атрибута

Значение | Описание
текст | An alternate text for the image input

HTML a Tag Reference HTML Тег <input>


HTML Атрибут input_checked

HTML Атрибут checked тега <input>

HTML a Tag Reference HTML Тег <input>

Пример

An HTML form with a preselected checkbox:

<form action="form_action.asp" method="get">
<input type="checkbox" name="vehicle" value="Car" checked="checked" /> I have a car <br />
</form>

Попробуйте сами »

Определение и использование

The checked attribute specifies that an input element should be preselected when the page loads.

The checked attribute is used with <input type="checkbox"> or <input type="radio">.

The checked attribute can also be set after the page load, with a JavaScript.

Поддержка браузерами

Атрибут checked поддерживается всеми основными браузерами.

Синтаксис

<input checked="значение">

Значения атрибута

Значение | Описание
checked | Preselects the checkbox or radio button

HTML a Tag Reference HTML Тег <input>


HTML Атрибут input_disabled

HTML Атрибут disabled тега <input>

HTML a Tag Reference HTML Тег <input>

Пример

An HTML form with a disabled input field:

<form action="form_action.asp" method="get">
First name: <input type="text" name="fname" /><br />
Last name: <input type="text" name="lname" disabled="disabled" /><br />
<input type="submit" value="Submit" />
</form>

Попробуйте сами »

Определение и использование

The disabled attribute specifies that an input element should be disabled.

A disabled input element is unusable and un-clickable.

The disabled attribute can be set to keep a user from using an input field until some other condition has been met (like selecting a checkbox, etc.). Then, a JavaScript is required to remove the disabled value, and make the input element usable.

Note: The disabled attribute will not work with <input type="hidden">.

Поддержка браузерами

Атрибут disabled поддерживается всеми основными браузерами.

Синтаксис

<input disabled="значение">

Значения атрибута

Значение | Описание
disabled | Disables an input element

HTML a Tag Reference HTML Тег <input>


HTML Атрибут input_maxlength

HTML Атрибут maxlength тега <input>

HTML a Tag Reference HTML Тег <input>

Пример

An HTML form with two input fields with a maximum length of 75 and 35 characters:

<form action="form_action.asp" method="get">
Name: <input type="text" name="fullname" maxlength="75" /><br />
Email: <input type="text" name="email" maxlength="35" /><br />
<input type="submit" value="Submit" />
</form>

Попробуйте сами »

Определение и использование

The maxlength attribute specifies the maximum length (in characters) of an input field.

The maxlength attribute is used with <input type="text"> or <input type="password">.

Поддержка браузерами

Атрибут maxlength поддерживается всеми основными браузерами.

Синтаксис

<input maxlength="значение">

Значения атрибута

Значение | Описание
characters | The maximum number of characters allowed in an input field

HTML a Tag Reference HTML Тег <input>


HTML Атрибут input_name

HTML Атрибут name тега <input>

HTML a Tag Reference HTML Тег <input>

Пример

An HTML form with two text fields and one submit button:

<form action="form_action.asp" method="get">
Name: <input type="text" name="fullname" /><br />
Email: <input type="text" name="email" /><br />
<input type="submit" value="Submit" />
</form>

Попробуйте сами »

Определение и использование

The name attribute specifies a name for an input element.

The name attribute is used to identify form data after it has been submitted to the server, or to reference form data using JavaScript on the client side.

Note: Only form elements with a name attribute will have their values passed when submitting a form.

Поддержка браузерами

Атрибут name поддерживается всеми основными браузерами.

Синтаксис

<input name="значение">

Значения атрибута

Значение | Описание
name | The name of an input element

HTML a Tag Reference HTML Тег <input>


HTML Атрибут input_readonly

HTML Атрибут readonly тега <input>

HTML a Tag Reference HTML Тег <input>

Пример

An HTML form with two input fields (one read-only) and one submit button:

<form action="form_action.asp" method="get">
Email: <input type="text" name="email" /><br />
Country: <input type="text" name="country" value="Norway"
readonly="readonly" /><br />
<input type="submit" value="Submit" />
</form>

Попробуйте сами »

Определение и использование

The readonly attribute specifies that an input field should be read-only.

A read-only field cannot be modified. However, a user can tab to it, highlight it, and copy the text from it.

The readonly attribute can be set to keep a user from changing the value until some other condition has been met (like selecting a checkbox, etc.). Then, a JavaScript is required to remove the readonly value, and make the input field editable.

The readonly attribute can be used with <input type="text"> or <input type="password">.

Поддержка браузерами

Атрибут readonly поддерживается всеми основными браузерами.

Синтаксис

<input readonly="значение">

Значения атрибута

Значение | Описание
readonly | Specifies that an input field is read-only

HTML a Tag Reference HTML Тег <input>


HTML Атрибут input_size

HTML Атрибут size тега <input>

HTML a Tag Reference HTML Тег <input>

Пример

An HTML form with two input fields with a width of 35 and 4 characters:

<form action="form_action.asp" method="get">
Email: <input type="text" name="email" size="35" /><br />
PIN: <input type="text" name="pin" maxlength="4" size="4" /><br />
<input type="submit" value="Submit" />
</form>

Попробуйте сами »

Определение и использование

The size attribute specifies the width of an input field.

For <input type="text"> and <input type="password">, the size attribute defines the number of characters that should be visible. For all other input types, size defines the width of the input field in pixels.

Поддержка браузерами

Атрибут size поддерживается всеми основными браузерами.

Примечания относительно совместимости

Since the size attribute is a visual design attribute, it is recommended to use CSS instead.

CSS syntax: <input style="width:100px" />

Пример CSS: Set the width of an input field.

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве width.

Синтаксис

<input size="значение">

Значения атрибута

Значение | Описание
characters/pixels | The width of an input element

HTML a Tag Reference HTML Тег <input>


HTML Атрибут input_src

HTML Атрибут src тега <input>

HTML a Tag Reference HTML Тег <input>

Пример

An HTML form with two input fields and an image as a submit button:

<form action="form_action.asp" method="get">
First name: <input type="text" name="fname" /><br />
Last name: <input type="text" name="lname" /><br />
<input type="image" src="submit.gif" alt="Submit" />
</form>

Попробуйте сами »

Определение и использование

The src attribute is only used with <input type="image"> and it specifies the URL to an image to display as a submit button.

The src attribute is required with <input type="image">.

Поддержка браузерами

Атрибут src поддерживается всеми основными браузерами.

Синтаксис

<input src="значение">

Значения атрибута

Значение Описание
URL The URL of an image to use as a submit button.

Possible values:

  • An absolute URL - points to another web site (like src="http://www.example.com/submit.gif")
  • A relative URL - points to a file within a web site (like src="submit.gif")

HTML a Tag Reference HTML Тег <input>


HTML Атрибут input_type

HTML Атрибут type тега <input>

HTML a Tag Reference HTML Тег <input>

Пример

A simple HTML form with two input fields and one submit button:

<form action="form_action.asp" method="get">
First name: <input type="text" name="fname" /><br />
Last name: <input type="text" name="lname" /><br />
<input type="submit" value="Submit" />
</form>

Попробуйте сами »

(more examples below)

Определение и использование

The type attribute specifies the type of an input element.

Поддержка браузерами

Атрибут type поддерживается всеми основными браузерами.

Синтаксис

<input type="значение">

Значения атрибута

Значение | Описание
button | Defines a clickable button (mostly used with a JavaScript to activate a script)
checkbox | Defines a checkbox
file | Defines an input field and a "Browse..." button, for file uploads
hidden | Defines a hidden input field
image | Defines an image as a submit button
password | Defines a password field. The characters in this field are masked
radio | Defines a radio button
reset | Defines a reset button. A reset button resets all form fields to their initial values
submit | Defines a submit button. A submit button sends form data to a server
text | Defines a one-line input field that a user can enter text into. Default width is 20 characters

Text

<input type="text" /> defines a one-line input field that a user can enter text into.

Пример

Email: <input type="text" name="email" /><br />
Pin: <input type="text" name="pin" />

Try it yourself »

Button

<input type="button" /> defines a clickable button, that does not do anything. The button type is most often used to activate a JavaScript when a user clicks on the button.

Пример

<input type="button" value="Click me" onclick="msg()" />

Try it yourself »

Checkbox

<input type="checkbox" /> defines a checkbox. Checkboxes let a user select one or more options of a limited number of choices.

Пример

<input type="checkbox" name="vehicle" value="Bike" /> I have a bike<br />
<input type="checkbox" name="vehicle" value="Car" /> I have a car

Try it yourself »

File

<input type="file" /> is used for file uploads.

Пример

<input type="file" />

Try it yourself »

Hidden

<input type="hidden" /> defines a hidden field. A hidden field is not visible for the user. Hidden fields often store a default value, or have their value changed by a JavaScript.

Пример

<input type="hidden" name="country" value="Norway" />

Try it yourself »

Image

<input type="image" /> defines an image as a submit button.

The src and alt attribute are required with <input type="image">.

Пример

<input type="image" src="submit.gif" alt="Submit" />

Try it yourself »

Password

<input type="password" /> defines a password field. The characters in a password field are masked (shown as asterisks or circles).

Пример

<input type="password" name="pwd" />

Try it yourself »

Radio

<input type="radio" /> defines a radio button. Radio buttons let a user select only one of a limited number of choices.

Пример

<input type="radio" name="sex" value="male" /> Male<br />
<input type="radio" name="sex" value="female" /> Female

Try it yourself »

Reset Button

<input type="reset" /> defines a reset button. A reset button resets all form fields to their initial values.

Tip: Use the reset button carefully! It can be annoying for users who accidentally activate the reset button.

Пример

<input type="reset" />

Try it yourself »

Submit

<input type="submit" /> defines a submit button. A submit button is used to send form data to a server. The data is sent to the page specified in the form's action attribute.

Пример

<form action="form_action.asp" method="get">
Email: <input type="text" name="email" /><br />
<input type="submit" />
</form>

Try it yourself »

HTML a Tag Reference HTML Тег <input>


HTML Атрибут input_value

HTML Атрибут value тега <input>

HTML a Tag Reference HTML Тег <input>

Пример

An HTML form with two text fields and a submit button - all with a predefined value:

<form action="form_action.asp" method="get">
First name: <input type="text" name="fname" value="John" /><br />
Last name: <input type="text" name="lname" value="Doe" /><br />
<input type="submit" value="Submit form" />
</form>

Попробуйте сами »

Определение и использование

Атрибут charset определяет набор символов (кодировку) связанного документа (документ ссылается с помощью атрибута href).

Набором символов (кодировкой) по умолчанию для современных браузеров является ISO-8859-1.

Поддержка браузерами

Атрибут charset поддерживается всеми основными браузерами.

Синтаксис

<a charset="значение">

Значения атрибута

Значение | Описание
кодировка |

HTML a Tag Reference HTML Тег <input>


HTML Атрибут ins_cite

HTML Атрибут cite тега <ins>

HTML a Tag Reference HTML Тег <ins>

Пример

Use of the cite attribute in the ins element:

<p>My favorite color is <del>blue</del> <ins cite="why_inserted.htm">red</ins>!</p>

Попробуйте сами »

Определение и использование

The cite attribute specifies a URL to a document which explains why the text was inserted/changed.

Поддержка браузерами

Note: None of the major browsers use the cite attribute in any way.

Синтаксис

<ins cite="значение">

Значения атрибута

Значение Описание
URL The address to the document that explains why the text was inserted/changed.

Possible values:

  • An absolute URL - Points to another web site (like cite="http://www.example.com")
  • A relative URL - Points to a page within a web site (like cite="example.html")
  • An anchor URL - Points to a named anchor (like cite="#bottom")

HTML a Tag Reference HTML Тег <ins>


HTML Атрибут ins_datetime

HTML Атрибут datetime тега <ins>

HTML a Tag Reference HTML Тег <ins>

Пример

Use of the datetime attribute in the ins element:

<p>My favorite color is <del>blue</del>
<ins datetime="2009-01-08T22:55:03Z">red</ins>!</p>

Попробуйте сами »

Определение и использование

The datetime attribute specifies the date and time when the text was inserted/changed.

Поддержка браузерами

Note: None of the major browsers use the datetime attribute in any way.

Синтаксис

<ins datetime="значение">

Значения атрибута

Значение Описание
YYYY-MM-DDThh:mm:ssTZD The date and time the text was inserted/changed.

Explanation of components:

  • YYYY - year (e.g. 2009)
  • MM - month (e.g. 01 for January)
  • DD - day of the month (e.g. 08)
  • T - a required separator
  • hh - hour (e.g. 22 for 10.00pm)
  • mm - minutes (e.g. 55)
  • ss - seconds (e.g. 03)
  • TZD - Time Zone Designator (Z denotes Zulu, also known as Greenwich Mean Time)

HTML a Tag Reference HTML Тег <ins>


HTML Атрибут label_for

HTML Атрибут for тега <label>

HTML a Tag Reference HTML Тег <label>

Пример

An simple HTML form with two input fields and related labels :

<form>
<label for="male">Male</label>
<input type="radio" name="sex" id="male" />
<br />
<label for="female">Female</label>
<input type="radio" name="sex" id="female" />
</form>

Попробуйте сами »

Определение и использование

The for attribute specifies which form element a label is bound to.

Поддержка браузерами

Атрибут for поддерживается всеми основными браузерами.

Note: Not supported in Safari 2.0 or earlier versions.

Синтаксис

<label for="значение">

Значения атрибута

Значение | Описание
element_id | The id of the element the label is bound to

HTML a Tag Reference HTML Тег <label>


HTML Атрибут legend_align

HTML Атрибут align тега <legend>

HTML a Tag Reference HTML Тег <legend>

Пример

Align the fieldset caption to the right:

<form>
<fieldset>
<legend align="right">Personalia:</legend>
Name: <input type="text" size="30" /><br />
Email: <input type="text" size="30" /><br />
Date of birth: <input type="text" size="10" />
</fieldset>
</form>

Попробуйте сами »

Определение и использование

The align attribute specifies the alignment of the caption in a fieldset.

Поддержка браузерами

The "left" and "right" values of the align attribute is supported in all major browsers, except opera. The "bottom" value does not work in any of the major browsers.

Примечания относительно совместимости

Атрибут align тега <legend> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Синтаксис

<legend align="значение">

Значения атрибута

Значение | Описание
left | Aligns the caption to the left (this is default)
right | Aligns the caption to the right
top | Aligns the caption at the top
bottom | Aligns the caption at the bottom

HTML a Tag Reference HTML Тег <legend>


HTML Атрибут li_type

HTML Атрибут type тега <li>

HTML a Tag Reference HTML Тег <li>

Пример

Use of the type attribute in an ordered and an unordered HTML list:

<ol>
<li>Coffee</li>
<li type="a">Tea</li>
<li>Milk</li>
</ol>

<ul>
<li>Coffee</li>
<li type="square">Tea</li>
<li>Milk</li>
</ul>

Попробуйте сами »

Определение и использование

The type attribute specifies the style of the bullet point of a list item in a list.

Поддержка браузерами

The type attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут type тега <li> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <li style="list-style-type:square">

Пример CSS: list style type

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве list-style-type.

Синтаксис

<li type="значение">

Значения атрибута

For ordered lists (<ol>):

Значение | Описание
1 | Numerical ordered list (this is default) (1, 2, 3, 4)
a | Alphabetically ordered list, lowercase (a, b, c, d)
A | Alphabetically ordered list, uppercase (A, B, C, D)
i | Roman numbers, lowercase (i, ii, iii, iv)
I | Roman numbers, uppercase (I, II, III, IV)

For unordered lists (<ul>):

Значение | Описание
disc | Default. A filled circle
circle | An unfilled circle
square | A filled square

HTML a Tag Reference HTML Тег <li>


HTML Атрибут li_value

HTML Атрибут value тега <li>

HTML a Tag Reference HTML Тег <li>

Пример

Use of the value attribute in an ordered HTML list:

<ol>
<li>Coffee</li>
<li>Tea</li>
<li>Milk</li>
<li value="100">Water</li>
<li>Juice</li>
<li>Beer</li>
</ol>

Попробуйте сами »

Определение и использование

The value attribute sets the number of a list item. The following list items will increment from that number.

Поддержка браузерами

The value attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут value тега <li> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Note: At the moment, there is no CSS alternative for the value attribute.

Синтаксис

<li value="значение">

Значения атрибута

Значение | Описание
number | The number of the current list item

HTML a Tag Reference HTML Тег <li>


HTML Атрибут link_media

HTML Атрибут media тега <link>

HTML a Tag Reference HTML Тег <link>

Пример

Two different style sheets for two different media types (computer screen and print):

<head>
<link rel="stylesheet" type="text/css" href="theme.css" />
<link rel="stylesheet" type="text/css" href="print.css" media="print"/>
</head>

Попробуйте сами »

Определение и использование

The media attribute is used to specify different styles for different media types.

Поддержка браузерами

The media attribute with the value of "screen", "print", and "all" is supported in all major browsers.

Tip: Opera also supports "projection" in full screen mode.

Синтаксис

<link media="значение">

Значения атрибута

Значение | Описание
screen | Computer screens (this is default)
tty | Teletypes and similar media using a fixed-pitch character grid
tv | Television type devices (low resolution, limited scroll ability)
projection | Projectors
handheld | Handheld devices (small screen, limited bandwidth)
print | Print preview mode/printed pages
braille | Braille feedback devices
aural | Speech synthesizers
all | Suitable for all devices

HTML a Tag Reference HTML Тег <link>


HTML Атрибут link_rel

HTML Атрибут rel тега <link>

HTML a Tag Reference HTML Тег <link>

Пример

In the following example, the rel attribute indicates that the linked document is a style sheet:

<head>
<link rel="stylesheet" type="text/css" href="theme.css" />
</head>

Попробуйте сами »

Определение и использование

The rel attribute specifies the relationship between the current document and the linked document.

Поддержка браузерами

Note: Only the "stylesheet" value of the rel attribute is fully supported in all major browsers. The other values are only partially supported.

Синтаксис

<link rel="значение">

Значения атрибута

Значение | Описание
alternate | An alternate version of the document (i.e. print page, translated or mirror)
stylesheet | An external style sheet for the document
start | The first document in a selection
next | The next document in a selection
prev | The previous document in a selection
contents | A table of contents for the document
index | An index for the document
glossary | A glossary (explanation) of words used in the document
copyright | A document containing copyright information
chapter | A chapter of the document
section | A section of the document
subsection | A subsection of the document
appendix | An appendix for the document
help | A help document
bookmark | A related document

HTML a Tag Reference HTML Тег <link>


HTML Атрибут link_rev

HTML Атрибут rev тега <link>

HTML a Tag Reference HTML Тег <link>

Пример

In the following example, the rev attribute indicates that the current document is the parent of the "wildcats.htm" page:

<head>
<link rev="parent" href="wildcats.htm" />
</head>

Определение и использование

The rev attribute specifies the relationship between the linked document and the current document.

The rev attribute is the reverse of the rel attribute.

Поддержка браузерами

Атрибут rev не поддерживается всеми основными браузерами.

Синтаксис

<link rev="значение">

Значения атрибута

Значение | Описание
alternate | An alternate version of the document (i.e. print page, translated or mirror)
stylesheet | An external style sheet for the document
start | The first document in a selection
next | The next document in a selection
prev | The previous document in a selection
contents | A table of contents for the document
index | An index for the document
glossary | A glossary (explanation) of words used in the document
copyright | A document containing copyright information
chapter | A chapter of the document
section | A section of the document
subsection | A subsection of the document
appendix | An appendix for the document
help | A help document
bookmark | A related document

HTML a Tag Reference HTML Тег <link>


HTML Атрибут link_target

HTML Атрибут target тега <link>

HTML a Tag Reference HTML Тег <link>

Пример

In the following example, the linked document is loaded in a new window:

<head>
<link rel="parent" href="wildcats.htm" target="_blank" />
</head>

Определение и использование

The target attribute specifies a window or a frame where the linked document is loaded.

Поддержка браузерами

Note: Атрибут target не поддерживается всеми основными браузерами.

Синтаксис

<link target="значение">

Значения атрибута

Значение | Описание
_blank | Load in a new window
_self | Load in the same frame as it was clicked
_parent | Load in the parent frameset
_top | Load in the full body of the window
framename | Load in a named frame

HTML a Tag Reference HTML Тег <link>


HTML Атрибут link_type

HTML Атрибут type тега <link>

<

HTML a Tag Reference HTML Тег <link>

Пример

In the following example, the type attribute indicates that the linked document is a style sheet:

<head>
<link rel="stylesheet" type="text/css" href="theme.css" />
</head>

Попробуйте сами »

Определение и использование

The type attribute specifies the MIME type of the linked document.

The most common MIME type for this attribute is "text/css", which describes a style sheet.

Поддержка браузерами

Атрибут type поддерживается всеми основными браузерами.

Синтаксис

<link type="значение">

Значения атрибута

Значение | Описание
MIME_type | The MIME type of the linked document. Look at IANA MIME types for a complete list of standard MIME types.

HTML a Tag Reference HTML Тег <link>


HTML Атрибут map_name

HTML Атрибут name тега <map>

HTML a Tag Reference HTML Тег <map>

Пример

An image-map, with clickable areas:

<img src="planets.gif" width="145" height="126" alt="Planets" usemap="#planetmap" />

<map name="planetmap">
<area shape="rect" coords="0,0,82,126" href="sun.htm" alt="Sun" />
<area shape="circle" coords="90,58,3" href="mercur.htm" alt="Mercury" />
<area shape="circle" coords="124,58,8" href="venus.htm" alt="Venus" />
</map>

Попробуйте сами »

Определение и использование

The required name attribute specifies the name of an image-map.

The name attribute is associated with the <img>'s usemap attribute and creates a relationship between the image and the map.

Note: In XHTML 1.0, the name attribute of the <map> tag is deprecated, and will be removed. Use the id attribute instead.

Поддержка браузерами

Атрибут name поддерживается всеми основными браузерами.

Синтаксис

<map name="значение">

Значения атрибута

Значение | Описание
mapname | The name of an image-map

HTML a Tag Reference HTML Тег <map>


HTML Атрибут menu_compact

HTML Атрибут compact тега <menu>

HTML a Tag Reference HTML Тег <menu>

Пример

Use of the compact attribute in a menu list:

<menu compact="compact">
<li>html</li>
<li>xhtml</li>
<li>css</li>
</menu>

Попробуйте сами »

Определение и использование

The compact attribute specifies that the list should render smaller than normal, by reducing the space between lines and the indentation of the list.

Поддержка браузерами

Note: Атрибут compact не поддерживается всеми основными браузерами.

Примечания относительно совместимости

Элемент menu является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Look at ordered (<ol>) and unordered (<ul>) HTML lists instead.

Синтаксис

<menu compact="значение">

Значения атрибута

Значение | Описание
compact | Specifies that the list should render smaller than normal

HTML a Tag Reference HTML Тег <menu>


HTML Атрибут meta_content

HTML Атрибут content тега <meta>

HTML a Tag Reference HTML Тег <meta>

Пример

Describe metadata within an HTML document:

<head>
<meta name="description" content="Free Web tutorials" />
<meta name="keywords" content="HTML,CSS,XML,JavaScript" />
<meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1" />
</head>

Попробуйте сами »

Определение и использование

The required content attribute specifies the content of the meta information.

The value of the content attribute depends on the value of the name or http-equiv attribute.

Поддержка браузерами

Атрибут content поддерживается всеми основными браузерами.

Синтаксис

<meta content="значение">

Значения атрибута

Значение | Описание
text | The content of the meta information

HTML a Tag Reference HTML Тег <meta>


HTML Атрибут meta_http-equiv

HTML Атрибут http-equiv тега <meta>

HTML a Tag Reference HTML Тег <meta>

Пример

Use the http-equiv attribute to define the character set for an HTML document:

<head>
<meta http-equiv="content-type" content="text/html;charset=UTF-8" />
</head>

Попробуйте сами »

Определение и использование

The http-equiv attribute provides an HTTP header for the information in the content attribute.

The http-equiv attribute can be used to simulate an HTTP response header.

The value of the http-equiv attribute depends on the value of the content attribute.

If the name attribute is set, the http-equiv attribute should not be set.

Поддержка браузерами

Атрибут http-equiv поддерживается всеми основными браузерами.

Синтаксис

<meta http-equiv="значение">

Значения атрибута

Some commonly used HTTP-header values are:

Значение | Описание
cache-control Controls the caching mechanism to use for the document.

Available values:

  • public - cached in public shared caches
  • private - cached in private cache
  • no-cache - not cached
  • no-store - cached but not archived

Example:

<meta http-equiv="cache-control" content="no-cache" />
content-language Specifies the natural language(s) of the document (used by search engines to categorize pages by language).

Example:

<meta http-equiv="content-language" content="en-US" />
content-type Specifies the character set for the contents of the document.

Tip: It is recommended to always specify the character set.

Example:

<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
date Specifies the date and time when the page was created.

Example:

<meta http-equiv="date" content="Wed, 16 Feb 2011 22:34:13 GMT" />
expires Specifies the date and time when the page will expire.

Example:

<meta http-equiv="expires" content="Fri, 30 Dec 2011 12:00:00 GMT" />
last-modified Specifies the last modification date.

Example:

<meta http-equiv="last-modified" content="Mon, 03 Jan 2011 17:45:57 GMT" />
location Redirects the visitor to another location.

Example:

<meta http-equiv="location" content="URL=http://www.w3schools.com" />
refresh Defines a time interval for the document to refresh itself.

Example:

<meta http-equiv="refresh" content="300" />

Note: The value "refresh" should be used carefully, as it takes the control of a page away from the user. Using "refresh" will cause a failure in W3C's Web Content Accessibility Guidelines.
set-cookie Creates a cookie with specified name,expires date and value.

Example:

<meta http-equiv="set-cookie" content="w3scookie=myContent;expires=Fri, 30 Dec 2011 12:00:00 GMT; path=http://www.w3schools.com">
window-target | Specifies the name of the frame where the current document must be loaded

HTML a Tag Reference HTML Тег <meta>


HTML Атрибут meta_name

HTML Атрибут name тега <meta>

HTML a Tag Reference HTML Тег <meta>

Пример

Use the name attribute to define a description, keywords, and the author of an HTML document:

<head>
<meta name="description" content="Free Web tutorials" />
<meta name="keywords" content="HTML,CSS,XML,JavaScript" />
<meta name="author" content="Hege Refsnes" />
</head>

Попробуйте сами »

Определение и использование

The name attribute provides a name for the information in the content attribute.

The value of the name attribute depends on the value of the content attribute.

If the http-equiv attribute is set, the name attribute should not be set.

Поддержка браузерами

Атрибут name поддерживается всеми основными браузерами.

Синтаксис

<meta name="значение">

Значения атрибута

Значение | Описание
abstract | Defines a secondary description
author Defines the author of the document.

Example:
<meta name="author" content="Hege Refsnes" />
classification | Classifies the site into the correct category
copyright Defines copyright information of the document.

Example:
<meta name="copyright" content="2011© W3Schools.com" />
description Search engines can pick up this description to show with the results of searches.

Example:
<meta name="description" content="Free web tutorials" />
distribution Declares whether the document is available to the web or on an intranet.
  • web - for the full internet
  • intranet - only for intranet

Example:
<meta name="distribution" content="web" />
doc-class | Specifies completion status of the document
doc-rights | Specifies copyright status of the document
doc-type | Specifies the type of the document
DownloadOptions | The associated content property determines what buttons are visible on the File Download dialog box
expires Specifies the date and time when the page expires.

Example:
<meta name="expires" content="Fri, 10 Jun 2011 12:00:00 GMT" />
generator | Specifies the name of the program that generated the document
googlebot Informs the Google search engine about indexing, archiving and link-following rules.
  • noarchive - Prevent Google search engine from archiving the page
  • nofollow - The page can be indexed, but links should not be followed
  • noindex - Google robots should follow links, but not index the page
  • nosnippet - Prevent Google search engine from saving snippets and archiving the document

Example:
<meta http-equiv="googlebot" content="noarchive" />
keywords Informs search engines what your site is about.

Tip: Always specify keywords (needed by search engines to catalogize the page).

Example:
<meta http-equiv="keywords" content="HTML, HTML DOM, JavaScript" />
MSSmartTagsPreventParsing | Prevents any Microsoft product from automatically generating smart tags
name | Specifies the name of the document
owner | Defines the owner of the page or site
progid | Defines the id of a program used to generate the document
rating | Defines webpage rating
refresh The document will display for a specified amount of time before refreshing or switch to a new URL.

Example:
<meta name="refresh" content="10" />
<meta name="refresh" content="10;URL=http://www.w3schools.com" />
reply-to | Defines an email address of a contact for the document
resource-type | Defines the type of web resource
revisit-after | Defines how often search engine spiders should revisit the site
robots Defines page indexing mechanisms for robots, search engine indexing and link-following rules.

The content attribute should contain a comma separated list of the following values:
  • ALL - Robots should follow links, index and archive this page
  • FOLLOW - Search engine robots should follow links from this page
  • INDEX - Robots should include and index this page
  • NOARCHIVE - Prevent search engines from archiving the page
  • NOINDEX - Robots should follow links, but should not index the page
  • NOFOLLOW - The page can be indexed, but links should not be followed
  • NONE - Search engine robots can ignore the page

Example:
<meta name="robots" content="ALL" />
<meta name="robots" content="INDEX,NOFOLLOW" />
Template | The content attribute should specify the location of the template used to edit the document
others | You can define your own names in a schema

HTML a Tag Reference HTML Тег <meta>


HTML Атрибут meta_scheme

HTML Атрибут scheme тега <meta>

HTML a Tag Reference HTML Тег <meta>

Пример

Use the scheme attribute to define formats for the content attribute:

<head>
<meta name="date" content="2009-01-02" scheme="YYYY-MM-DD" />
<meta name="identifier" content="0-2345-6634-6" scheme="ISBN" />
</head>

Попробуйте сами »

Определение и использование

The scheme attribute specifies a scheme (format or URI) to be used to interpret the value of the content attribute.

Поддержка браузерами

Атрибут scheme поддерживается всеми основными браузерами.

Синтаксис

<meta scheme="значение">

Значения атрибута

Значение | Описание
format/URI | Defines the format (or points to an URI that contains the information) of the value inside the content attribute

HTML a Tag Reference HTML Тег <meta>


HTML Атрибут ol_start

HTML Атрибут start тега <ol>

HTML a Tag Reference HTML Тег <ol>

Пример

Set the start point to "4" in an ordered list:

<ol start="4">
<li>Coffee</li>
<li>Tea</li>
<li>Milk</li>
</ol>

Попробуйте сами »

Определение и использование

The start attribute specifies the start point of an ordered list.

Поддержка браузерами

The start attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут start тега <ol> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Note: At the moment, there is no CSS alternative for the start attribute.

Синтаксис

<ol start="значение">

Значения атрибута

Значение | Описание
число | The start point of an ordered list

HTML a Tag Reference HTML Тег <ol>


HTML Атрибут ol_type

HTML Атрибут type тега <ol>

HTML a Tag Reference HTML Тег <ol>

Пример

Set the bullet points to roman numbers in an ordered list:

<ol type="I">
<li>Coffee</li>
<li>Tea</li>
<li>Milk</li>
</ol>

Попробуйте сами »

Определение и использование

The type attribute specifies which kind of bullet points will be used in an ordered list.

Поддержка браузерами

The type attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут type тега <ol> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <ol style="list-style-type:upper-roman">

Пример CSS: Set the list style type

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве list-style-type.

Синтаксис

<ol type="значение">

Значения атрибута

Значение | Описание
1 | Numerical ordered list (this is default) (1, 2, 3, 4)
a | Alphabetically ordered list, lowercase (a, b, c, d)
A | Alphabetically ordered list, uppercase (A, B, C, D)
i | Roman numbers, lowercase (i, ii, iii, iv)
I | Roman numbers, uppercase (I, II, III, IV)

HTML a Tag Reference HTML Тег <ol>


HTML Атрибут optgroup_disabled

HTML Атрибут disabled тега <optgroup>

HTML a Tag Reference HTML Тег <optgroup>

Пример

A disabled option group:

<select>
<optgroup label="German Cars" disabled="disabled">
<option value="mercedes">Mercedes</option>
<option value="audi">Audi</option>
</optgroup>
</select>

Попробуйте сами »

Определение и использование

The disabled attribute specifies that an option group should be disabled.

A disabled option group is unusable and un-clickable.

The disabled attribute can be set to keep a user from selecting from the option group until some other condition has been met (like selecting a checkbox, etc.). Then, a JavaScript is required to remove the disabled value, and make the option group selectable.

Поддержка браузерами

The disabled attribute is supported by all major browsers, except Internet Explorer.

Note: Not supported in Safari 2.0 or earlier versions. Supported in IE 8 (beta) and newer versions.

Синтаксис

<optgroup disabled="значение">

Значения атрибута

Значение | Описание
disabled | Disables the option group

HTML a Tag Reference HTML Тег <optgroup>


HTML Атрибут optgroup_label

HTML Атрибут label тега <optgroup>

HTML a Tag Reference HTML Тег <optgroup>

Пример

Group together related options with <optgroup> tags:

<select>
<optgroup label="Swedish Cars">
<option value="volvo">Volvo</option>
<option value="saab">Saab</option>
</optgroup>
<optgroup label="German Cars">
<option value="mercedes">Mercedes</option>
<option value="audi">Audi</option>
</optgroup>
</select>

Попробуйте сами »

Определение и использование

The required label attribute specifies a description for a group of options.

Поддержка браузерами

Атрибут label поддерживается всеми основными браузерами.

Синтаксис

<optgroup label="значение">

Значения атрибута

Значение | Описание
текст | Description of the contained options

HTML a Tag Reference HTML Тег <optgroup>


HTML Атрибут option_disabled

HTML Атрибут disabled тега <option>

HTML a Tag Reference HTML Тег <option>

Пример

A select list with four options - one disabled:

<select>
<option>Volvo</option>
<option>Saab</option>
<option disabled="disabled">Mercedes</option>
<option>Audi</option>
</select>

Попробуйте сами »

Определение и использование

The disabled attribute specifies that an option should be disabled.

A disabled option is unusable and un-clickable.

The disabled attribute can be set to keep a user from selecting the option until some other condition has been met (like selecting a checkbox, etc.). Then, a JavaScript is required to remove the disabled value, and make the option selectable.

Поддержка браузерами

The disabled attribute is supported in all major browsers, except Internet Explorer.

Note: Not supported in Safari 2.0 or earlier versions. Supported in IE 8 (beta) and newer versions.

Синтаксис

<option disabled="значение">

Значения атрибута

Значение | Описание
disabled | Disables an option

HTML a Tag Reference HTML Тег <option>


HTML Атрибут option_label

HTML Атрибут label тега <option>

HTML a Tag Reference HTML Тег <option>

Пример

Use of the label attribute in option elements:

<select>
<option label="Volvo">Volvo (Latin for "I roll")</option>
<option label="Saab">Saab (Swedish Aeroplane AB)</option>
</select>

Попробуйте сами »

Определение и использование

The label attribute specifies a shorter version of an option.

The shorter version will be displayed in the drop-down list.

Поддержка браузерами

Атрибут label поддерживается only supported by IE 7+.

Синтаксис

<option label="значение">

Значения атрибута

Значение | Описание
текст | A shorter version for an option

HTML a Tag Reference HTML Тег <option>


HTML Атрибут option_selected

HTML Атрибут selected тега <option>

HTML a Tag Reference HTML Тег <option>

Пример

A drop-down list with a preselected option:

<select>
<option>Volvo</option>
<option selected="selected">Saab</option>
<option>Mercedes</option>
<option>Audi</option>
</select>

Попробуйте сами »

Определение и использование

The selected attribute specifies that an option should be preselected when the page loads.

The selected option will be displayed first in the drop-down list.

The selected attribute can also be set after the page load, with a JavaScript.

Поддержка браузерами

Атрибут selected поддерживается всеми основными браузерами.

Синтаксис

<option selected="значение">

Значения атрибута

Значение | Описание
selected | Selects an option

HTML a Tag Reference HTML Тег <option>


HTML Атрибут option_value

HTML Атрибут value тега <option>

HTML a Tag Reference HTML Тег <option>

Пример

A drop-down list with values to be sent to a server:

<select>
<option value="volvo">Volvo XC90</option>
<option value="saab">Saab 95</option>
<option value="mercedes">Mercedes SLK</option>
<option value="audi">Audi TT</option>
</select>

Попробуйте сами »

Определение и использование

The value attribute specifies the value to be sent to a server when a form is submitted.

The content between the opening <option> and closing </option> tags is what the browsers will display in a drop-down list. However, the value in the value attribute is what will be sent to the server when a form is submitted.

Note: If the value attribute is not specified, the content will be passed as a value instead.

Поддержка браузерами

Атрибут value поддерживается всеми основными браузерами.

Синтаксис

<option value="значение">

Значения атрибута

Значение | Описание
value | The value to be sent to the server

HTML a Tag Reference HTML Тег <option>


HTML Атрибут p_align

HTML Атрибут align тега <p>

HTML a Tag Reference HTML Тег <p>

Пример

A right-aligned paragraph:

<p align="right">This is some text in a paragraph.</p>

Попробуйте сами »

Определение и использование

The align attribute specifies the alignment of the text within a paragraph.

Поддержка браузерами

Атрибут align поддерживается всеми основными браузерами.

Примечания относительно совместимости

Атрибут align тега <p> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <p style="text-align:right">

Пример CSS: Align text in a paragraph

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве text-align.

Синтаксис

<p align="значение">

Значения атрибута

Значение | Описание
left | Left-align text
right | Right-align text
center | Center-align text
justify | Stretches the lines so that each line has equal width (like in newspapers and magazines)

HTML a Tag Reference HTML Тег <p>


HTML Атрибут pre_width

HTML Атрибут width тега <pre>

HTML a Tag Reference HTML Тег <pre>

Пример

Preformatted text with a width of 30 characters:

<pre width="30">
Text in a pre element is displayed in a fixed-width
font, and it preserves both spaces and
line breaks
</pre>

Попробуйте сами »

Определение и использование

The width attribute specifies the maximum number of characters per line.

Поддержка браузерами

The width attribute is only supported by Firefox.

Примечания относительно совместимости

Атрибут width тега <pre> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <div style="width:200px;overflow:auto"><pre>Some text</pre></div>

Пример CSS: preformatted text with a fixed width

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве width.

Tip: The overflow property adds a scrollbar if the width of the text exceeds the width of the surrounding element.

Синтаксис

<pre width="значение">

Значения атрибута

Значение | Описание
число | Sets the width in number of characters

HTML a Tag Reference HTML Тег <pre>


HTML Атрибут q_cite

HTML Атрибут cite тега <q>

HTML a Tag Reference HTML Тег <q>

Пример

A quotation with a cite attribute that specifies the source of the quotation:

<q cite="http://en.wikiquote.org/wiki/Quotations">
Life itself is a quotation, quotation is not life.
</q>

Попробуйте сами »

Определение и использование

The cite attribute specifies the source of a quotation.

Поддержка браузерами

The cite attribute is not supported by any of the major browsers. However, search engines may use it to get more information about the quotation.

Синтаксис

<q cite="значение">

Значения атрибута

Значение Описание
URL The source of the quotation.

Possible values:

  • An absolute URL - points to another web site (like cite="http://www.example.com")
  • A relative URL - points to a file within a web site (like cite="example.htm")

HTML a Tag Reference HTML Тег <q>


HTML Атрибут script_charset

HTML Атрибут charset тега <script>

HTML a Tag Reference HTML Тег <script>

Пример

Define the character encoding used in a linked script file:

<script type="text/javascript" src="myscripts.js" charset="UTF-8"></script>

Попробуйте сами »

Определение и использование

The charset attribute specifies the character encoding used in an external script file (referred to by the src attribute).

The charset attribute is used when the character encoding in an external script file differs from the encoding in the main file.

The default character encoding is ISO-8859-1.

Поддержка браузерами

Атрибут charset поддерживается всеми основными браузерами.

Синтаксис

<script charset="значение">

Значения атрибута

Значение Описание
character_encoding The character encoding of an external script file.

Some common values:

  • "ISO-8859-1" - Standard encoding for the Latin alphabet
  • "UTF-8" - Character encoding for Unicode. Compatible with ASCII

Look at our Character-sets reference for a complete list of character sets.

HTML a Tag Reference HTML Тег <script>


HTML Атрибут script_defer

HTML Атрибут defer тега <script>

HTML a Tag Reference HTML Тег <script>

Пример

Use of the defer attribute:

<script type="text/javascript" defer="defer">
alert(document.getElementById("p1").firstChild.nodeValue);
</script>

Попробуйте сами »

Определение и использование

The defer attribute specifies that the execution of a script should be deferred (delayed) until after the page has been loaded.

Поддержка браузерами

The defer attribute is only supported by Internet Explorer.

Синтаксис

<script defer="значение">

Значения атрибута

Значение | Описание
defer | Delays the execution of a script

HTML a Tag Reference HTML Тег <script>


HTML Атрибут script_src

HTML Атрибут src тега <script>

HTML a Tag Reference HTML Тег <script>

Пример

Link to an external script file:

<script type="text/javascript" src="myscripts.js"></script>

Попробуйте сами »

Определение и использование

The src attribute specifies the URL of an external script file.

Sometimes you want to run the same JavaScript on several pages in a web site. Instead of writing the same script over and over again, create your JavaScript in a standalone file, save it with a .js extension, and then refer to it using the src attribute in the <script> tag.

Note: The external script file cannot contain the <script> tag!

Note: Remember to place the script exactly where you normally would write the script!

Поддержка браузерами

Атрибут src поддерживается всеми основными браузерами.

Синтаксис

<script src="значение">

Значения атрибута

Значение Описание
URL The URL of the external script.

Possible values:

  • An absolute URL - points to another web site (like src="http://www.example.com/example.js")
  • A relative URL - points to a file within a web site (like src="/scripts/example.js")

HTML a Tag Reference HTML Тег <script>


HTML Атрибут script_type

HTML Атрибут type тега <script>

HTML a Tag Reference HTML Тег <script>

Пример

Insert a JavaScript in an HTML page:

<script type="text/javascript">
document.write("Hello World!");
</script>

Попробуйте сами »

Определение и использование

The required type attribute specifies the MIME type of a script.

The type attribute identifies the content between the <script> and </script> tags.

The MIME type consists of two parts: one media type and one subtype. For JavaScript, the MIME type is "text/javascript".

Поддержка браузерами

Атрибут type поддерживается всеми основными браузерами.

Синтаксис

<script type="значение">

Значения атрибута

Значение Описание
MIME_type The MIME type. Some values:
  • text/javascript
  • text/ecmascript
  • application/ecmascript
  • application/javascript
  • text/vbscript

Look at IANA MIME types for a complete list of standard MIME types.

Note: According to IANA, the "text/javascript" MIME type is obsolete. The new standard is "application/javascript". However, "application/javascript" is not supported by Internet Explorer.

HTML a Tag Reference HTML Тег <script>


HTML Атрибут select_disabled

HTML Атрибут disabled тега <select>

HTML a Tag Reference HTML Тег <select>

Пример

Disable a drop-down list:

<select disabled="disabled">
<option value="volvo">Volvo</option>
<option value="saab">Saab</option>
<option value="mercedes">Mercedes</option>
<option value="audi">Audi</option>
</select>

Попробуйте сами »

Определение и использование

The disabled attribute specifies that a drop-down list should be disabled.

A disabled drop-down list is unusable and un-clickable.

The disabled attribute can be set to keep a user from using the drop-down list until some other condition has been met (like selecting a checkbox, etc.). Then, a JavaScript is required to remove the disabled value, and make the drop-down list usable.

Поддержка браузерами

Атрибут disabled поддерживается всеми основными браузерами.

Синтаксис

<select disabled="значение">

Значения атрибута

Значение | Описание
disabled | Disables a drop-down list

HTML a Tag Reference HTML Тег <select>


HTML Атрибут select_multiple

HTML Атрибут multiple тега <select>

HTML a Tag Reference HTML Тег <select>

Пример

Allow multiple selection in a drop-down list:

<select multiple="multiple" size="2">
<option value="volvo">Volvo</option>
<option value="saab">Saab</option>
<option value="mercedes">Mercedes</option>
<option value="audi">Audi</option>
</select>

Попробуйте сами »

Определение и использование

The multiple attribute specifies that multiple options can be selected at the same time.

Selecting multiple options vary in different operating systems and browsers:

  • For windows: Hold down the control (ctrl) button to select multiple options
  • For Mac: Hold down the command button to select multiple options

Because of the different ways of doing this, and because you have to inform the user that multiple selection is available, it is more user-friendly to use checkboxes instead.

Tip: The multiple attribute can be used together with the size attribute to define the number of options to be displayed.

Поддержка браузерами

Атрибут multiple поддерживается всеми основными браузерами.

Синтаксис

<select multiple="значение">

Значения атрибута

Значение | Описание
multiple | Specifies that multiple options can be selected

HTML a Tag Reference HTML Тег <select>


HTML Атрибут select_name

HTML Атрибут name тега <select>

HTML a Tag Reference HTML Тег <select>

Пример

A drop-down list with a name attribute:

<select name="carlist">
<option value="volvo">Volvo</option>
<option value="saab">Saab</option>
<option value="mercedes">Mercedes</option>
<option value="audi">Audi</option>
</select>

Попробуйте сами »

Определение и использование

The name attribute specifies the name for a drop-down list.

The name attribute is used to reference elements in a JavaScript, or to reference form data after a form is submitted.

Поддержка браузерами

Атрибут name поддерживается всеми основными браузерами.

Синтаксис

<select name="значение">

Значения атрибута

Значение | Описание
name | The name of the drop-down list

HTML a Tag Reference HTML Тег <select>


HTML Атрибут select_size

HTML Атрибут size тега <select>

HTML a Tag Reference HTML Тег <select>

Пример

The size attribute displays two options in the drop-down list:

<select size="2">
<option value="volvo">Volvo</option>
<option value="saab">Saab</option>
<option value="mercedes">Mercedes</option>
<option value="audi">Audi</option>
</select>

Попробуйте сами »

Определение и использование

The size attribute specifies the number of visible options in a drop-down list.

If the value of the size attribute is greater than "1", but lower than the total number of options in the list, the browser will add a scroll bar to indicate that there are more options to view.

Поддержка браузерами

The size attribute is supported in all major browsers, except Google Chrome and Safari.

Синтаксис

<select size="значение">

Значения атрибута

Значение | Описание
number | The number of visible options in the drop-down list

HTML a Tag Reference HTML Тег <select>


HTML Атрибут <class>

HTML Standard Attributes Reference HTML Стандартные атрибуты

Пример

Использование атрибута class в HTML документе:

<html>
<head>
<style type="text/css">
h1.intro {color:blue;}
p.important {color:green;}
</style>
</head>

<body>
<h1 class="intro">Заголовок 1</h1>
<p>Абзац.</p>
<p class="important">Отметим, что это важный абзац.</p>
</body>
</html>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Атрибут class определяет имя класса для элемента.

Атрибут class в основном используется для указания на класс в таблице стилей. Однако, он также может быть использован JavaScript (через HTML DOM), чтобы вносить изменения в HTML элементы с указанным классом.

Советы и примечания

Примечание: Атрибута class не может быть использован в следующих элементах HTML: base, head, html, meta, param, script, style и title.

Совет: Можно назначить несколько классов одному элементу HTML, например, <span class="left_menu important">. Это позволяет объединить несколько CSS классов для одного элемента HTML.

Совет: НЕ начинайте имя класса с числа! Это поддерживается только в Internet Explorer .

Поддержка

W3C: В "W3C" колонка указывается рекомендован ли атрибут W3C HTML/XHTML.

IE | Firefox | Opera | Safari | W3C
ДА | ДА | ДА | ДА | ДА

Синтаксис

<элемент class="значение">

Значения атрибута

Значение | Описание
имя класса | Определяет имя класса для элемента. Чтобы указать несколько классов для одного элемента, отдельные имена классов разделяются пробелами

Examples

Попробуйте сами - Примеры

Добавление несколько классов для одного элемента
Как добавить несколько классов для одного HTML элемент.

HTML Standard Attributes Reference HTML Стандартные атрибуты


HTML Атрибут <id>

HTML Standard Attributes Reference HTML Стандартные атрибуты

Пример

Использование атрибута id для изменения текста с помощью JavaScript:

<html>
<head>
<script type="text/javascript">
function change_header()
{
document.getElementById("myHeader").innerHTML="Хороший день!";
}
</script>
</head>

<body>
<h1 id="myHeader">Привет, Мир!</h1>
<button onclick="change_header()">Изменить текст</button>
</body>

</html>

Попробуйте сами »
(дополнительные примеры в нижней части этой страницы)

Определение и использование

Атрибут id определяет уникальный идентификатор для элемента HTML.

Идентификатор должен быть уникальным в пределах HTML документа.

Атрибут id может быть использован JavaScript (через HTML DOM) или CSS для внесения изменений или стиль элемента с указанным id.

Поддержка

W3C: В "W3C" колонка указывается рекомендован ли атрибут W3C HTML/XHTML.

IE | Firefox | Opera | Safari | W3C
ДА | ДА | ДА | ДА | ДА

Синтаксис

<элемент id="значение">

Значения атрибута

Значение Описание
идентификатор Определяет уникальный идентификатор для элемента.

Правила именования:

  • Должен начинаться с буквы A-Z или a-z
  • Далее могут следовать: буквы (A-Za-z), цифры (0-9), дефисы ("-"), подчеркивания ("_"), двоеточия (":") и периоды (".")
  • Значения чувствительны к регистру

Examples

Попробуйте сами - Примеры

Добавление уникального идентификатора для HTML элемента
Как добавить атрибут id к элементу HTML.

Использование атрибута id в CSS
Как использовать атрибут id в CSS.

HTML Standard Attributes Reference HTML Стандартные атрибуты


HTML Атрибут <style>

HTML Standard Attributes Reference HTML Стандартные атрибуты

Пример

Использование атрибута style в HTML документе:

<h1 style="color:blue;text-align:center">Это заголовок</h1>
<p style="color:green">Это абзац.</p>

Попробуйте сами »

Определение и использование

Атрибут style указывает встроенный стиль для элемента.

TАтрибут style заменит любой стиль установленный глобально, например, стили, указанные в теге <style> или внешней таблицы стилей.

Поддержка

W3C: В "W3C" колонка указывается рекомендован ли атрибут W3C HTML/XHTML.

IE | Firefox | Opera | Safari | W3C
ДА | ДА | ДА | ДА | ДА

Синтаксис

<элемент style="значение">

Значения атрибута

Значение | Описание
определение_стиля | Одно или несколько CSS свойств и значений, разделенных точкой с запятой

HTML Standard Attributes Reference HTML Стандартные атрибуты


HTML Атрибут <title>

HTML Standard Attributes Reference HTML Стандартные атрибуты

Пример

Использование атрибута title в HTML документе:

<abbr title="Всемирная Организация Здравоохранения">ВОЗ</abbr> была основана в 1948.
<p title="Бесплатный веб-учебники">W3Schools.com</p>

Попробуйте сами »

Определение и использование

Атрибут title определяет дополнительную информацию об элементе.

Эта информация наиболее часто показывается, как текст всплывающей подсказки при перемещении мыши над элементом.

Совет: TАтрибут title часто используется с формой и ее элементами, чтобы предоставить информацию о входных форматах и ссылочных адресатах. Кроме того, title является обязательным атрибутом для элементов abbr и acronym.

Поддержка

W3C: В "W3C" колонка указывается рекомендован ли атрибут W3C HTML/XHTML.

IE | Firefox | Opera | Safari | W3C
ДА | ДА | ДА | ДА | ДА

Синтаксис

<элемент title="значение">

Значения атрибута

Значение | Описание
текст | Текст всплывающей подсказки для элемента

HTML Standard Attributes Reference HTML Стандартные атрибуты


HTML Атрибут style_media

HTML Атрибут media тега <style>

HTML a Tag Reference HTML Тег <style>

Пример

Two different styles for two different media types (computer screen and print):

<html>
<head>
<style type="text/css">
h1 {color:#FF0000;}
p {color:#0000FF;}
body {background-color:#FFEFD6;}
</style>

<style type="text/css" media="print">
h1 {color:#000000;}
p {color:#000000;}
body {background-color:#FFFFFF;}
</style>
</head>

<body>
<h1>Header 1</h1>
<p>A paragraph.</p>
</body>
</html>

Попробуйте сами »

Определение и использование

The media attribute is used to specify different styles for different media types.

Tip: To define more than one media type per style element, use a comma-separated list (example: <style type="text/css" media="screen,projection">).

Поддержка браузерами

Атрибут media со значениями "screen", "print", and "all" поддерживается во всех основных браузерах.

Совет: Opera также поддерживает значение "handheld".

Синтаксис

<style media="значение">

Значения атрибута

Значение | Описание
screen | Экраны компьютеров (это по умолчанию)
tty | Teletypes and similar media using a fixed-pitch character grid
tv | Television type devices (low resolution, limited scroll ability)
projection | Projectors
handheld | Handheld devices (small screen, limited bandwidth)
print | Print preview mode/printed pages
braille | Braille feedback devices
aural | Speech synthesizers
all | Suitable for all devices

HTML a Tag Reference HTML Тег <style>


HTML Атрибут style_type

HTML Атрибут type тега <style>

HTML a Tag Reference HTML Тег <style>

Пример

Использование атрибута type в теге <style>:

<html>
<head>
<style type="text/css">
h1 {color:red}
p {color:blue}
</style>
</head>

<body>
<h1>Заголовок 1</h1>
<p>Абзац.</p>
</body>
</html>

Попробуйте сами »

Определение и использование

The required type attribute specifies the MIME type of the style sheet.

The type attribute identifies the content between the <style> and </style> tags.

The value "text/css" indicates that the content is standard CSS.

Поддержка браузерами

Атрибут type поддерживается всеми основными браузерами.

Синтаксис

<style type="значение">

Значения атрибута

Значение | Описание
MIME_type | The MIME type of the style sheet. For now, the only possible value is "text/css"

HTML a Tag Reference HTML Тег <style>


HTML Атрибут table_align

HTML Атрибут align тега <table>

HTML a Tag Reference HTML Тег <table>

Пример

A right-aligned HTML table:

<table border="1" align="right">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The align attribute specifies the alignment of a table according to surrounding text.

Normally, an HTML table will have a break before and after it. The align attribute allows other HTML elements to wrap around the table.

Поддержка браузерами

The align attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут align тега <table> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <table style="float:right">

Пример CSS: table alignment

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве float.

Синтаксис

<table align="значение">

Значения атрибута

Значение | Описание
left | Left-aligns the table
right | Right-aligns the table
center | Center-aligns the table

HTML a Tag Reference HTML Тег <table>


HTML Атрибут table_bgcolor

HTML Атрибут bgcolor тега <table>

HTML a Tag Reference HTML Тег <table>

Пример

An HTML table with a background color:

<table border="1" bgcolor="#00FF00">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The bgcolor attribute specifies a background color of a table.

Поддержка браузерами

The bgcolor attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут bgcolor тега <table> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <table style="background-color:red">

Пример CSS: table background-color

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве background-color.

Синтаксис

<table bgcolor="значение">

Значения атрибута

Значение | Описание
color_name | Specifies the background color with a color name (like "red")
hex_number | Specifies the background color with a hex code (like "#ff0000")
rgb_number | Specifies the background color with an rgb code (like "rgb(255,0,0)")

HTML a Tag Reference HTML Тег <table>


HTML Атрибут table_border

HTML Атрибут border тега <table>

HTML a Tag Reference HTML Тег <table>

Пример

The following example sets the width of the borders around a table to five pixels:

<table border="5">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The border attribute specifies the width of the borders around a table.

The border attribute applies a border to each cell, and around the table. If the value of the border attribute is changed, only the size of the border around the table will change. The border inside the table will be 1 pixel.

Tip: Set border="0" to display tables with no borders.

For practical reasons, it may be better not to specify borders, and use CSS to apply border styles and color instead.

Поддержка браузерами

Атрибут border поддерживается всеми основными браузерами.

Синтаксис

<table bordert="значение">

Значения атрибута

Значение | Описание
пиксели | Specifies the border width

HTML a Tag Reference HTML Тег <table>


HTML Атрибут table_cellpadding

HTML Атрибут cellpadding тега <table>

HTML a Tag Reference HTML Тег <table>

Пример

The following example sets the space between the cell wall and the cell content to ten pixels:

<table border="1" cellpadding="10">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The cellpadding attribute specifies the space between the cell wall and the cell content.

Note: Do not confuse this with the cellspacing attribute, which specifies the space between cells.

For practical reasons, it may be better not to specify cellpadding, and use CSS to apply padding instead.

Поддержка браузерами

Атрибут cellpadding поддерживается всеми основными браузерами.

Синтаксис

<table cellpadding="значение">

Значения атрибута

Значение | Описание
пиксели | The space between the cell wall and the cell content

HTML a Tag Reference HTML Тег <table>


HTML Атрибут table_cellspacing

HTML Атрибут cellspacing тега <table>

HTML a Tag Reference HTML Тег <table>

Пример

The following example sets the space between the cells to ten pixels:

<table border="1" cellspacing="10">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The cellspacing attribute specifies the space between cells.

Note: Do not confuse this with the cellpadding attribute, which specifies the space between the cell wall and the cell content.

Поддержка браузерами

Атрибут cellspacing поддерживается всеми основными браузерами.

Синтаксис

<table cellspacing="значение">

Значения атрибута

Значение | Описание
пиксели | The space between cells

HTML a Tag Reference HTML Тег <table>


HTML Атрибут table_frame

HTML Атрибут frame тега <table>

HTML a Tag Reference HTML Тег <table>

Пример

The following example specifies that only the borders around the table should be visible:

<table frame="box">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The frame attribute specifies which parts of the outside table borders that should be visible.

For practical reasons, it may be better not to specify frames, and use CSS to apply border styles instead.

Поддержка браузерами

The frame attribute is supported in all major browsers, except Internet Explorer.

Note: Internet Explorer displays this attribute incorrectly. IE displays the borders on the cells within the table too (instead of on only the outside borders).

Note: Not supported in Safari 2.0 or earlier versions.

Синтаксис

<table frame="значение">

Значения атрибута

Значение | Описание
void | The outside borders are not shown
above | The top outside border is shown
below | The bottom outside border is shown
hsides | The top and bottom outside borders are shown
vsides | The left and right outside borders are shown
lhs | The left outside border is shown
rhs | The right outside border is shown
box | The outside borders are shown on all four sides
border | The outside borders are shown on all four sides

HTML a Tag Reference HTML Тег <table>


HTML Атрибут table_rules

HTML Атрибут rules тега <table>

HTML a Tag Reference HTML Тег <table>

Пример

The following example specifies that only the borders between the rows should be visible:

<table rules="rows">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The rules attribute specifies which parts of the inside borders that should be visible.

For practical reasons, it may be better to not specify any rules, and use CSS instead.

Поддержка браузерами

The rules attribute is properly displayed in Firefox and Opera.

Internet Explorer, Chrome, and Safari 3 displays this attribute incorrectly.

  • IE: Adds the four outside borders in addition to the inside borders
  • Chrome and Safari: Adds the affected outside borders in addition to the inside borders

Note: This attribute is not supported in Safari 2.0 or earlier versions.

Синтаксис

<table rules="значение">

Значения атрибута

Значение | Описание
none | No lines
groups | Lines between row groups and column groups
rows | Lines between rows
cols | Lines between columns
all | Lines between rows and columns

HTML a Tag Reference HTML Тег <table>


HTML Атрибут table_summary

HTML Атрибут summary тега <table>

HTML a Tag Reference HTML Тег <table>

Пример

The following HTML table defines a summary of the content of the table:

<table border="1" summary="Monthly savings for the Flintstones family">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The summary attribute specifies a summary of the content of a table.

The summary attribute makes no visual difference in ordinary web browsers.

This attribute can be used by screen readers.

Поддержка браузерами

Since there is no visual difference in ordinary web browsers, it’s difficult to say whether or not they support the summary attribute.

Синтаксис

<table summary="значение">

Значения атрибута

Значение | Описание
текст | A summary of the content of the table

HTML a Tag Reference HTML Тег <table>


HTML Атрибут table_width

HTML Атрибут width тега <table>

HTML a Tag Reference HTML Тег <table>

Пример

An HTML table with a width of 400 pixels:

<table border="1" width="400">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The width attribute specifies the width of a table.

If the width attribute is not set, a table takes up the space it needs to display the table data.

For practical reasons, it may be better not to specify the width, and use CSS to apply the width instead.

Поддержка браузерами

Атрибут width поддерживается всеми основными браузерами.

Синтаксис

<table width="значение">

Значения атрибута

Значение | Описание
pixels | Sets the width in pixels (example: width="50")
% | Sets the width in percent of the surrounding element (example: width="50%")

HTML a Tag Reference HTML Тег <table>


HTML Атрибут tbody_align

HTML Атрибут align тега <tbody>

HTML a Tag Reference HTML Тег <tbody>

Пример

The following HTML table aligns the content inside the tbody element to the right:

<table border="1" width="100%">
<thead>
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
</thead>
<tbody align="right">
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
</tbody>
</table>

Попробуйте сами »

Определение и использование

The align attribute specifies the horizontal alignment of the content inside the tbody element.

Поддержка браузерами

Атрибут align поддерживается всеми основными браузерами.

Note: IE does not handle the "justify" value properly in tables, IE will center the content instead.

Note: None of the major browsers supports the "char" value.

Синтаксис

<tbody align="значение">

Значения атрибута

Значение | Описание
left | Left-align content (default for table data)
right | Right-align content
center | Center-align content
justify | Stretches the lines so that each line has equal width (like in newspapers and magazines)
char | Align the content to a specific character

HTML a Tag Reference HTML Тег <tbody>


HTML Атрибут tbody_char

HTML Атрибут char тега <tbody>

HTML a Tag Reference HTML Тег <tbody>

Пример

The following HTML table aligns the content inside the tbody element to the "." character:

<table border="1" width="100%">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tbody align="char" char=".">
<tr>
<td>January</td>
<td>$100.00</td>
</tr>
<tr>
<td>February</td>
<td>$80.00</td>
</tr>
</tbody>
</table>

Попробуйте сами »

Определение и использование

The char attribute specifies the alignment of the content inside the tbody element to a character.

The char attribute can only be used if the align attribute is set to "char".

The default value of char is the decimal-point character of the current language.

Поддержка браузерами

Примечание: Атрибут char не поддерживается всеми основными браузерами.

Синтаксис

<tbody char="значение">

Значения атрибута

Значение | Описание
символ | Specifies the character to align the content to

HTML a Tag Reference HTML Тег <tbody>


HTML Атрибут tbody_charoff

HTML Атрибут charoff тега <tbody>

HTML a Tag Reference HTML Тег <tbody>

Пример

In the example below, the content inside the tbody element is aligned two characters to the right from the "." character:

<table border="1" width="100%">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tbody align="char" char="." charoff="2">
<tr>
<td>January</td>
<td>$100.00</td>
</tr>
<tr>
<td>February</td>
<td>$80.00</td>
</tr>
</tbody>
</table>

Попробуйте сами »

Определение и использование

The charoff attribute sets the number of characters the content inside the tbody element will be aligned from the character specified by the char attribute.

The charoff attribute can only be used if the char attribute is specified and the align attribute is set to "char".

Поддержка браузерами

Примечание: Атрибут charoff не поддерживается всеми основными браузерами.

Синтаксис

<tbody charoff="значение">

Значения атрибута

Значение | Описание
число | Specifies the alignment. Positive numbers specifies alignment to the right of the character. Negative numbers specifies alignment to the left of the character.

HTML a Tag Reference HTML Тег <tbody>


HTML Атрибут tbody_valign

HTML Атрибут valign тега <tbody>

HTML a Tag Reference HTML Тег <tbody>

Пример

The following HTML table vertical aligns the content inside the tbody element to the bottom:

<table border="1" width="100%">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tbody valign="bottom">
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
</tbody>
</table>

Попробуйте сами »

Определение и использование

The valign attribute specifies the vertical alignment of the content in a tbody element.

Поддержка браузерами

Атрибут valign поддерживается всеми основными браузерами.

Синтаксис

<tbody valign="значение">

Значения атрибута

Значение | Описание
top | Top-align content
middle | Center-align content
bottom | Bottom-align content
baseline | The baseline is the imaginary line which most letters "sit" on, in a line of text. The baseline value sets the row so that all the table data share the same baseline. Often this has the same effect as the bottom value. However, if the fonts are in different sizes, baseline looks better. Look at the illustration below

Illustration of bottom vs. baseline if fonts are in different sizes:

valign="bottom"

valign="baseline"

HTML a Tag Reference HTML Тег <tbody>


HTML Атрибут textarea_cols

HTML Атрибут cols тега <textarea>

HTML a Tag Reference HTML Тег <textarea>

Пример

A text area with 3 rows and a width of 25 characters:

<textarea rows="3" cols="25">
At W3Schools you will find all the Web-building tutorials you need, from basic HTML to advanced XML, SQL, ASP, and PHP.
</textarea>

Попробуйте сами »

Определение и использование

The cols attribute specifies the visible width of a text area.

Поддержка браузерами

Атрибут cols поддерживается всеми основными браузерами.

Синтаксис

<textarea cols="значение">

Значения атрибута

Значение | Описание
number | Sets the width of the text area (in average character widths)

HTML a Tag Reference HTML Тег <textarea>


HTML Атрибут textarea_disabled

HTML Атрибут disabled тега <textarea>

HTML a Tag Reference HTML Тег <textarea>

Пример

A disabled text area:

<textarea rows="3" cols="25" disabled="disabled">
At W3Schools you will find all the Web-building tutorials you need, from basic HTML to advanced XML, SQL, ASP, and PHP.
</textarea>

Попробуйте сами »

Определение и использование

The disabled attribute specifies that a text area should be disabled. A disabled text area is unusable and un-clickable.

The disabled attribute can be set to keep a user from using a text area until some other condition has been met (like selecting a checkbox, etc.). Then, a JavaScript is required to remove the disabled value, and make the text area usable.

Поддержка браузерами

Атрибут disabled поддерживается всеми основными браузерами.

Синтаксис

<texarea disabled="значение">

Значения атрибута

Значение | Описание
disabled | Specifies that the text area should be disabled

HTML a Tag Reference HTML Тег <textarea>


HTML Атрибут textarea_name

HTML Атрибут name тега <textarea>

HTML a Tag Reference HTML Тег <textarea>

Пример

A text area with a name attribute:

<textarea rows="3" cols="25" name="w3s_text">
At W3Schools you will find all the Web-building tutorials you need, from basic HTML to advanced XML, SQL, ASP, and PHP.
</textarea>

Попробуйте сами »

Определение и использование

The name attribute specifies a name for a text area.

The name attribute is used to reference elements in a JavaScript, or to reference form data after a form is submitted.

Поддержка браузерами

Атрибут name поддерживается всеми основными браузерами.

Синтаксис

<textarea name="значение">

Значения атрибута

Значение | Описание
name_of_textarea | Specifies the name of a text area

HTML a Tag Reference HTML Тег <textarea>


HTML Атрибут textarea_readonly

HTML Атрибут readonly тега <textarea>

HTML a Tag Reference HTML Тег <textarea>

Пример

A text area that is read-only:

<textarea rows="3" cols="25" readonly="readonly">
At W3Schools you will find all the Web-building tutorials you need, from basic HTML to advanced XML, SQL, ASP, and PHP.
</textarea>

Попробуйте сами »

Определение и использование

The readonly attribute specifies that a text area should be read-only.

In a read-only text area, the content cannot be changed, but a user can tab to it, or highlight and copy the content from it.

The readonly attribute can be set to keep a user from using a text area until some other condition has been met (like selecting a checkbox, etc.). Then, a JavaScript is required to remove the readonly value, and make the text area editable.

Поддержка браузерами

Атрибут readonly поддерживается всеми основными браузерами.

Синтаксис

<texarea readonly="значение">

Значения атрибута

Значение | Описание
readonly | Specifies that the text area should be read-only

HTML a Tag Reference HTML Тег <textarea>


HTML Атрибут textarea_rows

HTML Атрибут rows тега <textarea>

HTML a Tag Reference HTML Тег <textarea>

Пример

A text area with 3 rows and a width of 25 characters:

<textarea rows="3" cols="25">
At W3Schools you will find all the Web-building tutorials you need, from basic HTML to advanced XML, SQL, ASP, and PHP.
</textarea>

Попробуйте сами »

Определение и использование

The rows attribute specifies the visible height of a text area.

Поддержка браузерами

Атрибут rows поддерживается всеми основными браузерами.

Синтаксис

<textarea rows="значение">

Значения атрибута

Значение | Описание
number | Sets the height of the text area (in rows)

HTML a Tag Reference HTML Тег <textarea>


HTML Атрибут tfoot_align

HTML Атрибут align тега <tfoot>

HTML a Tag Reference HTML Тег <tfoot>

Пример

The following HTML table center-aligns the content inside the tfoot element:

<table border="1" width="100%">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
<tfoot align="center">
<tr>
<td>Sum</td>
<td>$180</td>
</tr>
</tfoot>
</table>

Попробуйте сами »

Определение и использование

The align attribute specifies the horizontal alignment of the content inside the tfoot element.

Поддержка браузерами

Атрибут align поддерживается всеми основными браузерами.

Note: IE does not handle the "justify" value properly in tables, IE will center the content instead.

Note: None of the major browsers supports the "char" value.

Синтаксис

<tfoot align="="значение">

Значения атрибута

Значение | Описание
left | Left-align content (default for td elements)
right | Right-align content
center | Center-align content
justify | Stretches the lines so that each line has equal width (like in newspapers and magazines)
char | Align the content to a specific character

HTML a Tag Reference HTML Тег <tfoot>


HTML Атрибут tfoot_char

HTML Атрибут char тега <tfoot>

HTML a Tag Reference HTML Тег <tfoot>

Пример

The following HTML table aligns the content inside the tfoot element to the "." character:

<table border="1" width="100%">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
<tfoot align="char" char=".">
<tr>
<td>Sum</td>
<td>$180.00</td>
</tr>
</tfoot>
</table>

Попробуйте сами »

Определение и использование

The char attribute specifies the alignment of the content inside the tfoot element to a character.

The char attribute can only be used if the align attribute is set to "char".

The default value of char is the decimal-point character of the current language.

Поддержка браузерами

Note: Атрибут char не поддерживается всеми основными браузерами.

Синтаксис

<tfoot char="значение">

Значения атрибута

Значение | Описание
символ | Specifies the character to align the content to

HTML a Tag Reference HTML Тег <tfoot>


HTML Атрибут tfoot_charoff

HTML Атрибут charoff тега <tfoot>

HTML a Tag Reference HTML Тег <tfoot>

Пример

In the example below, the content inside the tfoot element is aligned two characters to the right from the "." character:

<table border="1" width="100%">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
<tfoot align="char" char="." charoff="2">
<tr>
<td>Sum</td>
<td>$180.00</td>
</tr>
</tfoot>
</table>

Попробуйте сами »

Определение и использование

The charoff attribute sets the number of characters the content inside the tfoot element will be aligned from the character specified by the char attribute.

The charoff attribute can only be used if the char attribute is specified and the align attribute is set to "char".

Поддержка браузерами

Note: Атрибут charoff не поддерживается всеми основными браузерами.

Синтаксис

<tfoot charoff="значение">

Значения атрибута

Значение | Описание
число | Specifies the alignment. Positive numbers specifies alignment to the right of the character. Negative numbers specifies alignment to the left of the character.

HTML a Tag Reference HTML Тег <tfoot>


HTML Атрибут tfoot_valign

HTML Атрибут valign тега <tfoot>

HTML a Tag Reference HTML Тег <tfoot>

Пример

The following HTML table vertical aligns the content inside the tfoot element to the bottom:

<table border="1" width="100%">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
<tfoot valign="bottom">
<tr>
<td>Sum</td>
<td>$180</td>
</tr>
</tfoot>
</table>

Попробуйте сами »

Определение и использование

The valign attribute specifies the vertical alignment of the content in a tfoot element.

Поддержка браузерами

Атрибут valign поддерживается всеми основными браузерами.

Синтаксис

<tfoot valign="значение">

Значения атрибута

top | Top-align content
middle | Center-align content
bottom | Bottom-align content
baseline | The baseline is the imaginary line which most letters "sit" on, in a line of text. The baseline value sets the row so that all the table data share the same baseline. Often this has the same effect as the bottom value. However, if the fonts are in different sizes, baseline looks better. Look at the illustration below

Illustration of bottom vs. baseline if fonts are in different sizes:

valign="bottom"

valign="baseline"

HTML a Tag Reference HTML Тег <tfoot>


HTML Атрибут th_abbr

HTML Атрибут abbr тега <th>

HTML a Tag Reference HTML Тег <th>

Пример

Use of the abbr attribute in an HTML table:

<table border="1">
<tr>
<th abbr="Make">Toy manufacturer</th>
<th abbr="Model">Vehicle model</th>
</tr>
<tr>
<td>Bruder Toys</td>
<td>Cross Country Vehicle</td>
</tr>
<tr>
<td>Bruder Toys</td>
<td>DHL Lorry</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The abbr attribute specifies a shorter version of the content in a header cell.

The abbr attribute makes no visual difference in ordinary web browsers.

This attribute can be used by screen readers.

Поддержка браузерами

Since there is no visual difference in ordinary web browsers, it’s difficult to say whether or not they support the abbr attribute.

Синтаксис

<th abbr="значение">

Значения атрибута

Значение | Описание
текст | A short description of a header cell

HTML a Tag Reference HTML Тег <th>


HTML Атрибут th_align

HTML Атрибут align тега <th>

HTML a Tag Reference HTML Тег <th>

Пример

An HTML table with left-aligned table header cells:

<table width="100%" border="1">
<tr>
<th align="left">Month</th>
<th align="left">Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The align attribute specifies the horizontal alignment of the content in a table header cell.

Поддержка браузерами

Атрибут align поддерживается всеми основными браузерами.

Note: IE does not handle the "justify" value properly in tables, IE will center the content instead.

Note: None of the major browsers handles the "char" value correctly.

Синтаксис

<th align="значение">

Значения атрибута

Значение | Описание
left | Left-align content (default for td elements)
right | Right-align content
center | Center-align content
justify | Stretches the lines so that each line has equal width (like in newspapers and magazines)
char | Align the content to a specific character

HTML a Tag Reference HTML Тег <th>


HTML Атрибут th_axis

HTML Атрибут axis тега <th>

HTML a Tag Reference HTML Тег <th>

Пример

An HTML table with categorized header cells:

<table border="1" width="100%">
<tr>
<th axis="name">Name</td>
<th axis="contact">Email</td>
<th axis="contact">Phone</td>
<th axis="contact">Address</td>
</tr>
<tr>
<td>John Doe</td>
<td>someone@example.com</td>
<td>+45342323</td>
<td>Rosevn 56,4300 Sandnes,Norway</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The axis attribute is used to categorize header cells.

The axis attribute can be used to group related columns of information.

Поддержка браузерами

Note: Атрибут axis не поддерживается всеми основными браузерами.

Синтаксис

<th axis="значение">

Значения атрибута

Значение | Описание
category_name | Specifies a category name

HTML a Tag Reference HTML Тег <th>


HTML Атрибут th_bgcolor

HTML Атрибут bgcolor тега <th>

HTML a Tag Reference HTML Тег <th>

Пример

Table header cells with a background color:

<table border="1">
<tr>
<th bgcolor="#FF0000">Month</th>
<th bgcolor="#00FF00">Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The bgcolor attribute specifies a background color of a table header cell.

Поддержка браузерами

The bgcolor attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут bgcolor тега <th> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <th style="background-color:red">

Пример CSS: table header background-color

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве background-color.

Синтаксис

<th bgcolor="значение">

Значения атрибута

Значение | Описание
название_цвета | Определяет цвет ссылки названием цвета (например, "red")
шестнадцатиричное_число | Определяет цвет ссылки шестнадцатеричным кодом (например, "#ff0000")
rgb_число | Определяет цвет ссылки rgb кодом (например, "rgb(255,0,0)")

HTML a Tag Reference HTML Тег <th>


HTML Атрибут th_char

HTML Атрибут char тега <th>

HTML a Tag Reference HTML Тег <th>

Пример

In the example below, the content of the first header cell should align to the "M" character:

<table border="1">
<tr>
<th align="char" char="M">Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100.00</td>
</tr>
<tr>
<td>February</td>
<td>$10.00</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The char attribute specifies the alignment of the content in a header cell to a character.

The char attribute can only be used if the align attribute is set to "char".

The default value of char is the decimal-point character of the page language.

Поддержка браузерами

Note: Атрибут char не поддерживается всеми основными браузерами.

Синтаксис

<th char="значение">

Значения атрибута

Значение | Описание
символ | Specifies the character to align the content to

HTML a Tag Reference HTML Тег <th>


HTML Атрибут th_charoff

HTML Атрибут charoff тега <th>

HTML a Tag Reference HTML Тег <th>

Пример

In the example below, the content of the first header cell is aligned two characters to the right from the "M" character:

<table border="1">
<tr>
<th align="char" char="M" charoff="2">Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100.00</td>
</tr>
<tr>
<td>February</td>
<td>$10.00</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The charoff attribute sets the number of characters the content will be aligned from the character specified by the char attribute.

The charoff attribute can only be used if the char attribute is specified and the align attribute is set to "char".

Поддержка браузерами

Note: Атрибут charoff не поддерживается всеми основными браузерами.

Синтаксис

<th charoff="значение">

Значения атрибута

Значение | Описание
число | Specifies the alignment. Positive numbers specifies alignment to the right of the character. Negative numbers specifies alignment to the left of the character.

HTML a Tag Reference HTML Тег <th>


HTML Атрибут th_colspan

HTML Атрибут colspan тега <th>

HTML a Tag Reference HTML Тег <th>

Пример

An HTML table with a header cell that spans two columns:

<table width="100%" border="1">
<tr>
<th colspan="2">Monthly Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The colspan attribute defines the number of columns a header cell should span.

Поддержка браузерами

Атрибут colspan поддерживается всеми основными браузерами.

Note: None of the major browsers supports colspan="0", which have a special meaning (look below in the "Attribute Values" table).

Синтаксис

<th colspan="значение">

Значения атрибута

Значение | Описание
число | Sets the number of columns a header cell should span. Note: colspan="0" tells the browser to span the cell to the last column of the column group (colgroup)

HTML a Tag Reference HTML Тег <th>


HTML Атрибут th_height

HTML Атрибут height тега <th>

HTML a Tag Reference HTML Тег <th>

Пример

Table header cells with a predefined height:

<table border="1">
<tr>
<th height="100px">Month</th>
<th height="100px">Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The height attribute specifies the height of a table header cell.

If no height attribute is set, a header cell takes up the space it needs to display the content. The height attribute is used to set a predefined height of a header cell.

Поддержка браузерами

The height attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут height тега <th> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <th style="height:100px">

Пример CSS: Set the height of a table header

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве height.

Синтаксис

<th height="значение">

Значения атрибута

Значение | Описание
pixels | Sets the height in pixels (example: height="50")
% | Sets the height in percent of the surrounding element (example: height="50%")

HTML a Tag Reference HTML Тег <th>


HTML Атрибут th_nowrap

HTML Атрибут nowrap тега <th>

HTML a Tag Reference HTML Тег <th>

Пример

A table header cell with a nowrap attribute:

<table border="1">
<tr>
<th>Month</th>
<th nowrap="nowrap">My Savings for a new car</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The nowrap attribute specifies that the content inside a header cell should stay on one line (not wrap).

Поддержка браузерами

The nowrap attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут nowrap тега <th> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <th style="white-space: nowrap">

Пример CSS: no word wrapping in th

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве white-space.

Синтаксис

<th nowrap="значение">

Значения атрибута

Значение | Описание
nowrap | Specifies that the content inside a header cell should not wrap

HTML a Tag Reference HTML Тег <th>


HTML Атрибут th_rowspan

HTML Атрибут rowspan тега <th>

HTML a Tag Reference HTML Тег <th>

Пример

An HTML table with a header cell that spans three rows:

<table width="100%" border="1">
<tr>
<th>Month</th>
<th>Savings</th>
<th rowspan="3">Savings for holiday!</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
</table>

Попробуйте сами »
(more examples at the bottom of this page)

Определение и использование

The rowspan attribute defines the number of rows a header cell should span.

Поддержка браузерами

Атрибут rowspan поддерживается всеми основными браузерами.

Note: Only Opera supports rowspan="0", which have a special meaning (look below in the "Attribute Values" table).

Синтаксис

<th rowspan="значение">

Значения атрибута

Значение | Описание
число | Sets the number of rows a header cell should span. Note: rowspan="0" tells the browser to span the cell to the last row of the table section (thead, tbody, or tfoot)

HTML a Tag Reference HTML Тег <th>


HTML Атрибут th_scope

HTML Атрибут scope тега <th>

HTML a Tag Reference HTML Тег <th>

Пример

The following example identifies two of the th elements as headers for columns, and two of the td elements as headers for rows:

<table border="1">
<tr>
<th></th>
<th scope="col">Month</th>
<th scope="col">Savings</th>
</tr>
<tr>
<td scope="row">1</td>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td scope="row">2</td>
<td>February</td>
<td>$80</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The scope attribute defines a way to associate header cells and data cells in a table.

The scope attribute identifies whether a cell is a header for a column, row, or group of columns or rows.

The scope attribute makes no visual difference in ordinary web browsers.

This attribute can be used by screen readers.

Поддержка браузерами

Since there is no visual difference in ordinary web browsers, it’s difficult to say whether or not they support the scope attribute.

Синтаксис

<th scope="значение">

Значения атрибута

Значение | Описание
col | Specifies that the cell is a header for a column
row | Specifies that the cell is a header for a row
colgroup | Specifies that the cell is a header for a group of columns
rowgroup | Specifies that the cell is a header for a group of rows

HTML a Tag Reference HTML Тег <th>


HTML Атрибут th_valign

HTML Атрибут valign тега <th>

HTML a Tag Reference HTML Тег <th>

Пример

An HTML table with different vertical-aligned table header cells:

<table border="1" style="height:200px">
<tr>
<th valign="middle">Month</th>
<th valign="bottom">Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The valign attribute specifies the vertical alignment of the content in a table header cell.

Поддержка браузерами

Атрибут valign поддерживается всеми основными браузерами.

Синтаксис

<th valign="значение">

Значения атрибута

Значение | Описание
top | Top-align content
middle | Center-align content
bottom | Bottom-align content
baseline | The baseline is the imaginary line which most letters "sit" on, in a line of text. The baseline value sets the row so that all the table data share the same baseline. Often this has the same effect as the bottom value. However, if the fonts are in different sizes, baseline looks better. Look at the illustration below

Illustration of bottom vs. baseline if fonts are in different sizes:

valign="bottom"

valign="baseline"

HTML a Tag Reference HTML Тег <th>


HTML Атрибут th_width

HTML Атрибут width тега <th>

HTML a Tag Reference HTML Тег <th>

Пример

Table header cells with a predefined width:

<table border="1" width="100%">
<tr>
<th width="70%">Month</th>
<th width="30%">Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The width attribute specifies the width of a table header cell.

If no width attribute is set, a header cell takes up the space it needs to display the content. The width attribute is used to set a predefined width of a header cell.

Поддержка браузерами

The width attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут width тега <th> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <th style="width:100px">

Пример CSS: Set the width of a table header

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве width.

H2>Синтаксис
<th width="значение">

Значения атрибута

Значение | Описание
pixels | Sets the width in pixels (example: width="50")
% | Sets the width in percent of the surrounding element (example: width="50%")

HTML a Tag Reference HTML Тег <th>


HTML Атрибут thead_align

HTML Атрибут align тега <thead>

HTML a Tag Reference HTML Тег <thead>

Пример

The following HTML table aligns the content inside the thead element to the left:

<table border="1" width="100%">
<thead align="left">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
</thead>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The align attribute specifies the horizontal alignment of the content inside the thead element.

Поддержка браузерами

Атрибут align поддерживается всеми основными браузерами.

Note: IE does not handle the "justify" value properly in tables, IE will center the content instead.

Note: None of the major browsers supports the "char" value.

Синтаксис

<thead align="значение">

Значения атрибута

Значение | Описание
left | Left-align content (default for td elements)
right | Right-align content
center | Center-align content
justify | Stretches the lines so that each line has equal width (like in newspapers and magazines)
char | Align the content to a specific character

HTML a Tag Reference HTML Тег <thead>


HTML Атрибут thead_char

HTML Атрибут char тега <thead>

HTML a Tag Reference HTML Тег <thead>

Пример

The following HTML table aligns the content inside the thead element to the "M" character:

<a charset="UTF-8" href="http://www.w3schools.com">www.W3Schools.com</a>

Попробуйте сами »

Определение и использование

The char attribute specifies the alignment of the content inside the thead element to a character.

The char attribute can only be used if the align attribute is set to "char".

The default value of char is the decimal-point character of the current language.

Поддержка браузерами

Note: Атрибут char не поддерживается всеми основными браузерами.

Синтаксис

<thead char="значение">

Значения атрибута

Значение | Описание
символ | Specifies the character to align the content to

HTML a Tag Reference HTML Тег <thead>


HTML Атрибут thead_charoff

HTML Атрибут charoff тега <thead>

HTML a Tag Reference HTML Тег <thead>

Пример

In the example below, the content inside the thead element is aligned two characters to the right from the "M" character:

<table border="1" width="100%">
<thead align="char" char="M" charoff="2">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
</thead>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The charoff attribute sets the number of characters the content inside the thead element will be aligned from the character specified by the char attribute.

The charoff attribute can only be used if the char attribute is specified and the align attribute is set to "char".

Поддержка браузерами

Note: Атрибут charoff не поддерживается всеми основными браузерами.

Синтаксис

<thead charoff="значение">

Значения атрибута

Значение | Описание
число | Specifies the alignment. Positive numbers specifies alignment to the right of the character. Negative numbers specifies alignment to the left of the character.

HTML a Tag Reference HTML Тег <thead>


HTML Атрибут thead_valign

HTML Атрибут valign тега <thead>

HTML a Tag Reference HTML Тег <thead>

Пример

The following HTML table vertical aligns the content inside the thead element to the middle:

<table border="1" width="100%">
<thead valign="middle">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
</thead>
<tr>
<td>January</td>
<td>$100</td>
</tr>
<tr>
<td>February</td>
<td>$80</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The valign attribute specifies the vertical alignment of the content in a thead element.

Поддержка браузерами

Атрибут valign поддерживается всеми основными браузерами.

Синтаксис

<thead valign="значение">

Значения атрибута

Значение | Описание
top | Top-align content
middle | Center-align content
bottom | Bottom-align content
baseline | The baseline is the imaginary line which most letters "sit" on, in a line of text. The baseline value sets the row so that all the table data share the same baseline. Often this has the same effect as the bottom value. However, if the fonts are in different sizes, baseline looks better. Look at the illustration below

Illustration of bottom vs. baseline if fonts are in different sizes:

valign="bottom"

valign="baseline"

HTML a Tag Reference HTML Тег <thead>


HTML Атрибут tr_align

HTML Атрибут align тега <tr>

HTML a Tag Reference HTML Тег <tr>

Пример

An HTML table with center-aligned rows:

<table width="100%" border="1">
<tr align="center">
<th>Month</th>
<th>Savings</th>
</tr>
<tr align="center">
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The align attribute specifies the horizontal alignment of the content in a table row.

Поддержка браузерами

Атрибут align поддерживается всеми основными браузерами.

Note: IE does not handle the "justify" value properly in tables, IE will center the content instead.

Note: None of the major browsers handles the "char" value correctly.

Синтаксис

<tr align="значение">

Значения атрибута

Значение | Описание
left | Left-align content (default for td elements)
right | Right-align content
center | Center-align content
justify | Stretches the lines so that each line has equal width (like in newspapers and magazines)
char | Align the content to a specific character

HTML a Tag Reference HTML Тег <tr>


HTML Атрибут tr_bgcolor

HTML Атрибут bgcolor тега <tr>

HTML a Tag Reference HTML Тег <tr>

Пример

An HTML table with a background color on the first table row:

<table border="1">
<tr bgcolor="#FF0000">
<th>Month</th>
<th>Savings</th>
</tr>
<tr>
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The bgcolor attribute specifies a background color of a table row.

Поддержка браузерами

The bgcolor attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут bgcolor тега <tr> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <tr style="background-color:red">

Пример CSS: table row background-color

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве background-color.

Синтаксис

<tr bgcolor="значение">

Значения атрибута

Значение | Описание
название_цвета | Определяет цвет ссылки названием цвета (например, "red")
шестнадцатиричное_число | Определяет цвет ссылки шестнадцатеричным кодом (например, "#ff0000")
rgb_число | Определяет цвет ссылки rgb кодом (например, "rgb(255,0,0)")

HTML a Tag Reference HTML Тег <tr>


HTML Атрибут tr_char

HTML Атрибут char тега <tr>

HTML a Tag Reference HTML Тег <tr>

Пример

In the example below, the content of the second and the third row should align to the "." character:

<table border="1">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr align="char" char=".">
<td>January</td>
<td>$100.00</td>
</tr>
<tr align="char" char=".">
<td>February</td>
<td>$10.00</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The char attribute specifies the alignment of the content in a table row to a character.

The char attribute can only be used if the align attribute is set to "char".

The default value of char is the decimal-point character of the page language.

Поддержка браузерами

Note: Атрибут char не поддерживается всеми основными браузерами.

Синтаксис

<tr char="значение">

Значения атрибута

Значение | Описание
символ | Specifies the character to align the content to

HTML a Tag Reference HTML Тег <tr>


HTML Атрибут tr_charoff

HTML Атрибут charoff тега <tr>

HTML a Tag Reference HTML Тег <tr>

Пример

In the example below, the content of the second and the third row is aligned two characters to the right from the "." character:

<table border="1">
<tr>
<th>Month</th>
<th>Savings</th>
</tr>
<tr align="char" char="." charoff="2">
<td>January</td>
<td>$100.00</td>
</tr>
<tr align="char" char="." charoff="2">
<td>February</td>
<td>$10.00</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The charoff attribute sets the number of characters the content will be aligned from the character specified by the char attribute.

The charoff attribute can only be used if the char attribute is specified and the align attribute is set to "char".

Поддержка браузерами

Note: Атрибут charoff не поддерживается всеми основными браузерами.

Синтаксис

<tr charoff="значение">

Значения атрибута

Значение | Описание
число | Specifies the alignment. Positive numbers specifies alignment to the right of the character. Negative numbers specifies alignment to the left of the character.

HTML a Tag Reference HTML Тег <tr>


HTML Атрибут tr_valign

HTML Атрибут valign тега <tr>

HTML a Tag Reference HTML Тег <tr>

Пример

An HTML table with different vertical-aligned rows:

<table border="1" style="height:200px">
<tr valign="middle">
<th>Month</th>
<th>Savings</th>
</tr>
<tr valign="bottom">
<td>January</td>
<td>$100</td>
</tr>
</table>

Попробуйте сами »

Определение и использование

The valign attribute specifies the vertical alignment of the content in a table row.

Поддержка браузерами

Атрибут valign поддерживается всеми основными браузерами.

Синтаксис

<tr valign="значение">

Значения атрибута

Значение | Описание
top | Top-align content
middle | Center-align content
bottom | Bottom-align content
baseline | The baseline is the imaginary line which most letters "sit" on, in a line of text. The baseline value sets the row so that all the table data share the same baseline. Often this has the same effect as the bottom value. However, if the fonts are in different sizes, baseline looks better. Look at the illustration below

Illustration of bottom vs. baseline if fonts are in different sizes:

valign="bottom"

valign="baseline"

HTML a Tag Reference HTML Тег <tr>


HTML Атрибут ul_compact

HTML Атрибут compact тега <ul>

HTML a Tag Reference HTML Тег <ul>

Пример

Use of the compact attribute in an unordered HTML list:

<ul compact="compact">
<li>Coffee</li>
<li>Tea</li>
<li>Milk</li>
</ul>

Попробуйте сами »

Определение и использование

The compact attribute specifies that the list should render smaller than normal, by reducing the space between lines and the indentation of the list.

Поддержка браузерами

Note: Атрибут compact не поддерживается всеми основными браузерами.

Примечания относительно совместимости

Атрибут compact тега <ul> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <ul style="line-height: 80%">

Пример CSS: reduce line-height in a list

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве line-height.

Синтаксис

<ul compact="значение">

Значения атрибута

Значение | Описание
compact | Specifies that the list should render smaller than normal

HTML a Tag Reference HTML Тег <ul>


HTML Атрибут ul_type

HTML Атрибут type тега <ul>

HTML a Tag Reference HTML Тег <ul>

Пример

Use of the type attribute in an unordered HTML list:

<ul type="square">
<li>Coffee</li>
<li>Tea</li>
<li>Milk</li>
</ul>

Попробуйте сами »

Определение и использование

The type attribute specifies the style of the bullet points in an unordered list.

Поддержка браузерами

The type attribute is deprecated, but still supported in all major browsers.

Примечания относительно совместимости

Атрибут type тега <ul> является не рекомендуемым и не поддерживается в HTML 4.01 Strict / XHTML 1.0 Strict DTD.

Вместо его используйте CSS.

Синтаксис CSS: <ul style="list-style-type:square">

Пример CSS: list style type

В нашем учебнике CSS вы можете найти более подробную информацию о свойстве list-style-type.

Синтаксис

<ul type="значение">

Значения атрибута

Значение | Описание
disc | Default. A filled circle
circle | An unfilled circle
square | A filled square

HTML a Tag Reference HTML Тег <ul>


Фрейм A


Фрейм B


Фрейм C


Tryit Editor v1.4

Результат после редактирования:

Отредактируйте код и щелкните кнопку, чтобы увидеть результат W3Schools.com - Попробуйте сами